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Preface 
This manual will show you how to use the advanced features of the Electronic 
News Production System (ENPS). It is written for Group Managers and users 
who want to take advantage of the more sophisticated features in ENPS. This 
guide is divided into the following sections: 

Section Topics 

Section I: Group 
Administration  

Creating and managing program groups for 
Group Managers. 

Section II: Newsgathering 
Grids and Rundowns 

Working with planning grids and Rundowns. 

Section III: Hardware Control Controlling CGs, prompters, and MOS 
devices. 

Section IV: Macros Advanced keyboard control 

Section V: Hints and Tips Hints to help you get the most out of ENPS. 

Refer to the ENPS Basic User’s Guide for information about the fundamentals of 
using ENPS. System Administrators should refer to the ENPS Operations Guide 
for information on how to set up, maintain, and troubleshoot ENPS.  

If you need help while you are using ENPS, press F1 for online help. If you 
require further assistance, contact your System Administrator.  

You can find the ENPS website at http://www.enps.com. 

Typographic Conventions in this Guide 
The following table lists the typographic conventions you will find in this guide: 

Typeface Meaning Example 

SAMPLE TEXT Filenames, directories, 
and commands 

You can edit user settings in 
ENPS.INI.  

Sample → 
Text 

Navigation through 
menus, where one menu 
option leads to another 

Select New → Contact→ 
Personal. 

Sample text Button names Click OK to save your changes 
and close the window. 

http://www.enps.com/�
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Chapter 1 

Working with Groups 
Groups in ENPS allow you to separate different task areas at your station. This 
can be as simple as having one group for News and another for the Assignment 
Desk. Large enterprises may have dozens or even hundreds of groups. 

Creating Groups 
Each group has its own saved searches, macros, CG templates, Rundowns, 
planners as well as story and Rundown print report layouts. Folder Managers 
should keep these functions in mind when planning for which groups will be 
created. Your System Administrator is responsible for creating new groups.  

Navigating through Groups 
To navigate from one group location to another, select either the third or fourth 
folder rover; whichever folder rover you use will determine which folder becomes 
a shortcut to the contents of that group. Select Locations then select the Server 
name and Group name.  

The Server name usually corresponds to the physical location of the server on 
which the groups are placed.  

 

Group Users Default Settings 
To become a Group Manager, you must have the System Administrator or 
another Group Manager in the group give you Manager privileges. The System 
Administrator should also ensure that the Default Settings option is enabled for 
Group Managers. Once this is done, open your ENPS.INI file using a text editor 
and add the following setting to the [ENPS] section: 

DefSettings=1 

Restart ENPS after you modify the ENPS.INI. To set the default security profiles 
for users of your group select Third Folder rover → Group Maintenance → 
Default Settings Profiles. Setting defaults will not prevent users from later 
altering any of their own personal settings.  
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To set your preferences highlight a profile, such as "Guest," and then click 
Select. Make any changes to the preferences, including fonts, fourth folder 
choice, default ActiveX control, macros, forward searches, or regular searches. 
Click Save when you are finished making your selections. 

Once you make changes to one profile, you can copy that profile’s settings to 
other profiles. Press Ctrl and click on each of the destination profiles to 
highlight them. The options will be written to each of the selected profiles when 
you click Save. 

Managing Group Members 
From either the Third or Fourth folder rover select Locations and select the 
server where the group is located. Then select the Third or Fourth folder rover 
→ Group Maintenance → Staff privileges. To add a new user click New then 
type the name of the user.  
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In the pane at the right you can select the server where the groups are located. 
When you are viewing the correct server highlight the name of the user. If you 
want to add multiple users hold down the Ctrl key and click each of the user 
names you want to add. Then click the names of the groups where you want to 
add the users. A checkmark will appear beside each of the group names you 
select. Click Copy to select programs to make the users members of those 
program groups. 

You can remove multiple users by holding down the Ctrl key and clicking each 
of the user names you want to remove then clicking Remove from selected 
programs. 
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Chapter 2  

Creating Story Templates 
Group Managers create custom layouts for stories and Rundowns for the group. 
story layouts can include pre-determined fields which cannot be modified by 
other users. To create a story template for your group complete the following 
steps: 

1. Create a new story in your group folder by selecting Group Folder rover → 
New → Story.  

 

If you create the story in your Personal Folder, you must copy it to the Group 
Folder before you can save it as a template. You can also use an existing story 
as a template. 

2. Enter text that you want to appear in the story template. This can include 
information that appears in stories frequently such as production commands. 
Refer to the ENPS Basic User’s Guide for instructions on how to add production 
commands to your story. 

If you want to prevent users from changing or deleting text in the story template 
first highlight the text that you want to protect, then select Story rover → Layout 
→ Protect selected text. Protected text is displayed in blue. You cannot protect 
production commands. 

If you want to change or delete protected text you must first highlight it, then 
unprotect it by selecting Story rover → Layout → Unprotect selected text.  

3. Select Story rover → Layout → Add/remove/move fields. Under the Story 
Fields tab you will see a list of defined field names that you can use for the story 
properties.  
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To add a field name to your story template, drag the field name above the black 
bar and release the mouse button. The field name will then appear in red. All of 
the fields above the black bar will appear in the properties of your story. You can 
change the display order of these fields by dragging and dropping the field 
names. 

 

The Header Fields tab allows you to add fields which appear at the top on the 
front of the story. The Front Fields tab allows you to add fields which appear just 
below the Header Fields. These fields can provide information which can be 
displayed by columns in a Rundown. They may also be used with the news ticker 
functionality. 

Your System Administrator can customize the fields under any of these tabs for 
the specific needs of your station.  

4. Click the magnifying glass icon  to switch between the text of the story and 
the property fields. Any text you enter into the fields or pull-down menu options 
you select will appear whenever someone creates a story using this template.  

5. To save your story as a template, select Story rover → Layout → Save as 
template. Any group user can use the new template by selecting Group folder 
rover → New → Story. The template will be displayed as one of the choices in 
the list box.  

You can modify or delete story templates by selecting Group folder rover → 
Group maintenance → Story templates. Open the story template in an Editing 
Window to make changes or delete the template by moving it into the Group 
Waste Bin.  

You can also insert the story templates you have chosen into an ENPS Rundown 
or select which story template should be used as the default template in a 
Rundown. 
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Chapter 3  

Creating Printing Layouts for Stories 
Group Managers can create templates for how stories will be laid out when they 
are printed. 

1. To access printed report layout options, select Group Folder rover → Group 
maintenance → Report Layouts. 

 

2. To create a new story layout, click the New Story Layout button. The Story 
Layout window appears. 

 

3. Enter the story name in the field labeled Untitled at the top of the window. 
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4. When it is first displayed, the layout will appear with a default set of fields in 
each of the header, body, and footer areas. The header and footer each have 
three areas which correspond to the left-justified, centered, and right-justified 
areas of the page.  

Page numbers will not appear in stories unless they are part of a Rundown and 
you freeze page numbers before you print by selecting Rundown rover → 
Freeze page numbers. 

5. Remove fields by dragging any bracketed {field} outside of the window 
screen or by highlighting the field and pressing the Delete key. Add fields by 
dragging and dropping them from the Available Fields section. The 
{SourceText} field represents information below the story divider in the Source 
Content area, while the {Text} field represents regular story text.  

You can enter text that will appear along with the fields. For example, you might 
enter: “This story was written by {Writer} and was printed on {Date 
Printed}.” If you want to include the Rundown’s title and date you can add the 
{Parent} field. 

6. Customize the font appearance by selecting a font style and point size from 
using the pull-down menus. Click the B, I, or U buttons to turn on boldface, italics 
or underlining. Fields above the dashed line are for the header and footer; fields 
below the dashed line are for the main body of the text.  

7. You can independently change the font sizes used for MOS items and 
production commands. 

8. In the Page Orientation section indicate whether the report will print in portrait 
or landscape mode (orient the page vertically or horizontally). Below the Body 
Text area you can define whether you want the text to print in one or two 
columns. This setting does not affect the appearance of the Header or Footer. 

9. Use the Page Margins section to define the margins on your reports. In the 
Top, Bottom, Left, and Right fields, define your margins based on the chosen unit 
of measurement. Use the Up/Down arrows beside each field to toggle by tenths 
of a unit. System-defined minimums and maximums will prevent you from 
exceeding the margin limits.  

10. If you are not in your home group, you can still use your home group’s report 
layouts. If you want to use the other by selecting Group Folder rover → Use 
this group’s report layouts. 

For information on how to create print layouts for Rundowns, refer to Chapter 11, 
“Printing Rundown Report Layouts.” 
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Chapter 4  

Managing Group Folders  
Your group folder can contain up to 20 sub-folders which can be used to 
organize stories.  

To create a subfolder, select Group folder rover → New → Folder.  

 

Enter the name of the new folder.  

To access the new folder, select Group folder rover and then click on the folder 
name to open it.  

To rename the folder, select Group Folder rover → Group Maintenance → 
Rename folder and then select the name of the folder you want to rename.  

To delete a folder, select Group Folder rover → Group Maintenance → 
Remove folder and then select the name of the folder you want to remove. 

By default, items in conventional group folders will automatically be deleted after 
30 days. You can prevent this by making the first word in the folder name HOLD 
such as “HOLD Desk.” However, make sure folder contents do not get too large; 
the maximum allowable number of items in any folder is 5000 items. 
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Chapter 5  

Creating Read-Ins 
Group Managers can create messages called Read-ins that all of the users in the 
group see when they open ENPS.  

To create a Read-In, select Group Folder rover → New → Read-in and enter 
the text of the message you want the group to read. 

 

Group users will find this message highlighted in red at the top of their List 
Window when they open ENPS. 

Users with sufficient privileges can also send Read-ins to all of the users at that 
server by selecting Personal Folder rover → New → Read-in for (Server). 
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Chapter 6 

Creating a Rundown 
This section will show you how to create a new Rundown or how to make 
changes to an existing Rundown template. Once a Rundown is saved as a 
template only users with sufficient privileges, such as Producers, will be able to 
change it. 

 

You can create a Rundown in ENPS if you have appropriate privileges. To create 
a new Rundown, select Group Folder rover → New → Rundown. This screen 
displays a list of available templates along with various Rundown property fields. 

When you create a new template you can start by using any existing template 
from the list on the left-hand side of the Rundown properties window. When you 
select a template, the Program name, the Timing and other Property fields 
change to reflect the appropriate settings.  

The table below lists the default Rundown properties and their descriptions. 
Some fields will not appear in your configuration if they have not been enabled by 
your station’s System Administrator. Likewise, the System Administrator may 
have created custom fields for your station that do not appear in the list below. 

Property Description 

Add MOS 
Durations 

If you choose 0-default or do not make any selection, 
the option that your System Administrator selected as a 
global default will be used. Choose 1-Yes to add MOS 
object durations in this Rundown. Choose 2-No not to add 
MOS object durations. See 0, “Rundown Timing” for more 
information on using MOS durations for timing. 

Allow External 
Modification 

Allow MOS devices to place temporary holds on stories for 
modification. This feature will only work when the MOS 
Control Active box is selected and the MOS device is 
using MOS protocol version 2.82 or higher. 
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Approved Stories 
Only 

Prevent users from adding non-approved stories into a 
Rundown. If this option is selected it will not be possible to 
create new entries; the only way to add entries to the 
Rundown will be by dragging and dropping in approved 
stories. This option is used most often with Rundowns for 
publishing or in read-only Rundowns. 

Auto Archive Automatically archive the Rundown. The System 
Administrator configures the frequency. 

AutoCreate Days 
in Advance 

Create this Rundown every day for the number of days 
specified up to one year in advance of the Program Start 
Date. To create a Rundown on the same date leave this 
field blank. To create the Rundown one day in advance of 
the Program Start Date you would enter “1” in this field. 
You will need to set the AutoCreate Time field for this 
feature to work. 

AutoCreate Time 
& Days  

Once you save a Rundown as a template it is possible to 
use it to automatically create Rundowns for particular days 
of the week at specific times using the AutoCreate Days  
and AutoCreate Time fields. You can use these fields to 
automatically create Rundowns up to one year in advance 
of the Program Start Date.  

It is important to make sure the Time field contains a 
value. If it is not set, the Rundowns will not be created. 
This design prevents large numbers of Rundowns being 
created simultaneously if many child Rundowns are set to 
be AutoCreated. 

For each "child" Rundown that is AutoCreated from the 
parent template if a property is changed that change will 
remain in place even if that same property changes in the 
parent Rundown template. However, if the parent template 
and the child Rundown have the same values for a 
property and it is changed in the parent Rundown, 
changing the parent property also changes that property in 
the child Rundown. This design lets Folder Managers 
change the properties for a number of Rundowns 
simultaneously while maintaining the changes that have 
been made in individual Rundowns. 

You can see a list of Rundown templates which are set to 
AutoCreate by selecting Group Folder rover → Group 
Maintenance → Rundown Templates then select List 
Window rover → AutoCreate Templates. The scheduled 
AutoCreate times will also be displayed. 

Continuous 
Content 

When you select this checkbox, the Rundown will not be 
purged by ENPS maintenance routines. However, stories 
from the Rundown will be automatically archived based on 
the Continuous Content Interval setting. 

Continuous 
Content Interval 

If the Continuous Content box is selected, then setting a 
value in this field will determine the number of days before 
a story is archived. For example, setting this value to 5 
means that all stories that are older than five days will be 
archived. A copy of the Rundown itself will also be 
archived without the stories that are still current. 
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Director Used as a label. 

Duplicate Slugs Allow identical slugs in the Rundown. If this option is 
enabled, you may paste a story into the Rundown multiple 
times. 

Duplicate Slug 
Options 

If duplicate slugs are not allowed, selecting this option will 
display an option menu to users who attempt to drag in 
story with the same name as another story in the 
Rundown. If you enable this option, those users will be 
presented with the following choices: enter the story with 
the duplicate slug unchanged, enter the story with a new 
slug or cancel the operation. 

By default, ENPS will suggest as a new title the original 
slug plus "-1," and incrementing the number as additional 
duplicate items are entered.  

Enable CTOS Archives a copy of the Rundown to a specially designated 
server, the Central Text Object Storage. 

MOS Block Prevent the Rundown from sending outbound MOS 
messages.  

MOS Channel Send the MOS channel on which the Rundown will be 
produced to the MOS device or the production control 
room. 

MOS Control 
Active 

Link Rundowns to the MOS Logic in the ENPS News 
Object Manager (NOM), which will connect the Rundown 
to other MOS devices. Once a Rundown is MOS Active, 
its icon in the List Window will change to reflect that is 
MOS-enabled. 

MOS Editorial 
Duration 

Send the duration of the Rundown to the MOS device. 

MOS Editorial 
Start 

Set a time for a MOS device to start receiving MOS 
messages from the Rundown. Select a device name in the 
MOS Story Send field, then enter a start time in MOS 
Editorial Start. Depending on how your System 
Administrator has configured timing, the Rundown will not 
be visible as an active MOS Rundown until the MOS 
Editorial Start time is reached. The default time for this 
entry is the Rundown’s start time. 

To update this time to match the Rundown’s scheduled 
airtime, highlight MOS Editorial Start then press 
Ctrl+Shift+U.  

MOS Macro In, 
Out 

Refer to your Media Object Server documentation. 
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MOS Redirection Allow ENPS to send all references to specific families of 
Media Object Servers to a specific, usually local, server in 
the same family. To use this feature, Media Object 
Servers must have a fully-qualified name according to the 
following convention: 
<familyname>.<machine>.<location>.<enterprise>.mos 

For example: 
video_vendor_x.product.w???.bcastenterprise.mos 

MOS Story Send Designates the MOS device, such as a prompter, to which 
roStorySend messages will be sent. Multiple entries are 
allowed. Check the box next to each device to which you 
will connect. This will send the body of all stories and 
associated metadata to those devices.  

If you want the Rundown to begin sending MOS 
messages to a device at a particular time, enter the start 
time in MOS Editorial Start field. Depending on the 
settings your System Administrator has selected, the 
Rundown may not be visible as an active MOS Rundown 
before then. 

On Air Select this box to start the Rundown timing bar when the 
show is ready to go to air.  

If you wish to lock the On Air timing bar, select Rundown 
rover → Lock Timing Bar. Only you will be able to 
advance the bar manually. Others opening a Rundown will 
see the timing bar in place and moving, but they will not 
be able to advance it. 

If the Rundown is in On Air mode, a stopwatch will appear 
in the lower left corner. If the On Air bar is locked, the 
stopwatch will be yellow. Users with Approval privileges 
will be able to unlock the On Air bar by double-clicking on 
the stopwatch icon.  

You can hold the mouse cursor over the stopwatch to 
display the time the On Air bar was locked and the name 
of the user who locked it. 

Overwrite 
Properties 

Allow story property fields to be copied into another 
Rundown. If this option is not enabled, when you copy a 
story from one Rundown to another, you will lose the story 
properties, which you can access by clicking on the story’s 
magnifying glass  icon.  

Prevent Approval 
Reset 

Prevent the story approval flag from being reset by 
changes or updates to embedded MOS Item References. 
This is useful if you frequently make late changes to the 
duration of a media clip which, although it triggers an 
update to an embedded MOS object, will not require a 
reset of the Approval flag.  

With this setting, the approval flag will not reset even if a 
MOS object is added to the story or the MOS item 
reference is changed by an ActiveX plug-in.  

Prevent Manual 
Bar Movement 

Allow the Rundown timing bar to be automatically 
advanced based on cues from an automation system. 
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Producer, 
Program Name 

Used as labels. 

Publishing Active Click this entry once you are satisfied with all of the stories 
and the Rundown is ready to be published. If you have 
selected Publishing Days, the Rundown will be published 
automatically on those days, even if your ENPS client is 
not running at that time. Refer to the ENPS Publishing 
Installation and User’s Guide for more information. 

Publishing Days Select the days of the week for the Rundown to be 
published. Refer to the ENPS Publishing Installation and 
User’s Guide for more information. 

Publishing Target Select one of the Output Locations you where you want to 
publish the Rundown. Refer to the ENPS Publishing 
Installation and User’s Guide for more information. 

Rundown 
Numeric Pages 

If the System Administrator has configured Rundown 
pages to be automatically numbered with alphabetic 
prefixes such as A1, A2, A3 you can override that 
configuration for a particular Rundown by selecting this 
option to have simple numeric numbering instead. 

Show Story 
Templates on 
Insert 

Select this option to allow users to select from a list of 
story templates when they insert a new line in a Rundown. 
Users will also be able to title the story before it is 
inserted.  

Ticker Content 
and Ticker Story 
Delimiter 

Use these fields to create a Rundown that can send news 
tickers to your CG. Refer to Chapter 10, “Creating a News 
Ticker” for more information. 

Time Format Express time in various formats for frame-accurate 
automation systems. You can set this value to one of the 
following values: PAL, NTSCDF, NTSCNDF, or 
THOUSANDTHS. 

Use Summary 
Item 

When active for sites using the MOS Object AutoCreate 
feature, a story that will be recorded into a "Summary" 
item will have the Summary MOS item at the top, followed 
by story text and other MOS items. If the Rundown 
property Use Summary Item is checked, the Rundown will 
total only summary items for timing purposes. Stories that 
do not contain summary items will be timed normally, e.g. 
the total of text and any media items. 

Among the settings you may store with a Rundown template is the default story 
template that will be used by default when new rows are added to the Rundown. 
Select this template from the dropdown list on the left-hand side of the Rundown 
properties box. Rundown templates will be saved with an associated story 
template. See Chapter 2, Creating Story Template for more information. 

Any settings you enter into the Rundown properties will be the default settings for 
users who open the Rundown template. Only users with sufficient privileges will 
be able to change these settings.  

If you specify the Start and End time of your Rundown, the program will be 
timed based on the time of day (for example, 11:00:00 until 11:30:00).  If the 
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Duration based option box is checked, the timing will be based on the length of 
the program, such as 30 minutes. When the program is timed live, it will be 
based on the duration of the program, regardless of start time. When the 
Duration based checkbox is unchecked, timing counts down to the previously 
entered end time of the program, regardless of when the newscast was started. 
Rundown timing information can be modified at any time from Rundown 
Properties. Click Go to open the new Rundown. 

Viewing Rundowns by Date 
To view the Rundowns created on a particular date, click Group Folder rover → 
Calendar.  

Check the Rundown box under Item Type and then click on the date in the 
calendar area. Under location, select whether you want to search current Work in 
Progress or Archives. 
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Chapter 7 

Rundown Basics 
Different users will want to display different types of information in a Rundown 
depending on their job role. Users can customize the types of information they 
see when they are using a Rundown by creating a Rundown layout and then 
saving that layout as their personal view.  

Views 
Rundowns, like Editing Windows, can be displayed in different ways, which are 
useful depending on what you are working on. You might want a half-screen 
Rundown view when you are adding stories and a full-screen view during the 
broadcast. The icons for changing Rundown views are in the upper right-hand 
corner of the Rundown window. 

Icon Meaning 

 Display the Rundown in its own window. This is the same as clicking 
on the  icon on the Rundown’s title bar.  

Once this option is selected each subsequent Rundowns will be 
displayed in its own window. By default, there is a limit of 10 detached 
Rundowns and/or Newsgathering Grids allowed, although this value 
may be changed by your System Administrator. 

Click the  icon in a detached Rundown or Newsgathering Grid 
window to return the detached windows to the ENPS desktop. 

 Switch between a tabbed view and separated Rundown views. In a 
tabbed view, you will see the names of all open Rundowns above the 
current Rundown. Press Alt + > or Alt + < to move to the next 
Rundown or click on another Rundown name to open it. In the 
separated Rundown view, each Rundown occupies a different window. 
You can open Rundown properties by clicking on a Rundown title in 
either mode.  

 
Full Screen view. You can find other full screen view configurations by 
selecting Rundown rover → Layout → Full Screen. From this menu, 
you can choose a full screen single Rundown view, Rundowns split 
horizontally or vertically on the screen, or a Rundown vertically split 
with the story from the top Editing Window. 

 Switch between a vertical and horizontal Rundown view. 

 Close the Rundown. 

Moving and Resizing Columns 
To move a column to a new position, place the mouse pointer anywhere in the 
column’s title box. Hold down the left mouse button and drag the column. 
Release the mouse button when the column is in the desired location. The 
column will appear to the left of where it was dropped. 

To resize a column move the mouse pointer to the right border of the column's 
title box until it becomes a double-sided arrow. Hold down the left mouse button 
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and drag the border to make it wider or narrower. Release the mouse button 
when the column is the desired width.  

Rover Options 
Click the rover at the top left corner of the Rundown to display the following 
options: 

Option Description 

Proportional 
View/Uniform 
View 

Proportional View displays row heights proportional to 
their length as a percentage of the broadcast, which is 
useful for getting a quick idea of for lengths of the show’s 
segments. Uniform View displays all rows with the same 
height. 

Insert Row Create a new row in the Rundown (Ctrl+I) . Double-click 
the new row’s story slug to edit the story. 

Freeze page 
numbers 

Page numbers will not appear in stories unless they are 
part of a Rundown and you freeze page numbers before 
you print by selecting this option. 

Layout To add a column to a Rundown highlight any cell in the 
column to the right of where you want the new column to 
appear. In the example below, a new column will be 
inserted between the Segment and Camera columns:  

 

Select Layout → Add column and click on the column 
you want to add. The new column will appear in your 
layout to the left of the column that was previously 
selected.  

To define a row as a break, for 
example, add the Break column to your 
layout. Then click in that column of the 
row you want to make a break. A 
checkmark appears in the Break field, 
and the entire row will have a blue background. Once you 
have made the row into a break, you can delete the 
column so you do not accidentally change break lines. 

The columns Page, Story Slug, and Segment must be the 
first three columns in the Rundown. They can be hidden 
but they cannot be moved or deleted. 

To remove a column, first highlight any cell in that column 
and select Layout → Remove column. You can also 
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remove a column by clicking on the column header and 
dragging it to the Waste Bin. When you remove a column 
from your layout, you do not lose any of the information 
contained in that column; if you add the column back later, 
it will still contain all of the same information. 

To retain dual story windows while viewing a horizontally-
maximized Rundown select Layout → Dual story 
viewers. 

After you have modified columns, including their sizes and 
positions, save your personal Rundown view by selecting 
Layout → Make this my layout.  

To customize the Rundown so that the same features 
appear every time a Rundown is created, save the 
Rundown as a template by selecting Layout → Save as 
template. If the Rundown is in the group folder other 
members of your group will also be able to use it. 

After you define a personal layout every time you open 
Rundown it will be displayed in your personal layout. You 
can change this behavior in your personal settings by 
selecting Personal Folder → Settings where you can 
choose the template or system layout as your default.  

Detach Display the Rundown in its own window. This is the same 
as clicking on the  icon on the Rundown’s title bar.  

Once this option is selected all subsequent Rundowns will 
be displayed in their window. By default, there is a limit of 
10 detached Rundowns and/or Newsgathering Grids 
allowed although this option may be changed by your 
System Administrator. 

Click the  icon in the detached Rundown or 
Newsgathering Grid window to return them to the main 
ENPS window. 

Font Select the typeface style and size used to display the 
Rundown. 

Print Print the Rundown. This option lets you select which part 
of the Rundown you want to print. You can also select 
Print Setup to select the printer you want to use, how you 
want the printout to appear and other options. 

You can add page breaks to long Rundowns by adding 
the “Page Break” column to the layout. The Rundown will 
have a page break in rows where this column is checked, 
but this feature will only work if the RTL print engine is 
enabled. Check with your System Administrator for more 
information. 

Ticker Active If the Rundown is enabled for tickers use this option to 
start the Rundown ticker. 
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MOS Ready to 
Air 

Before the Media Object Server playlist can be executed 
on-air the Producer may need to set the MOS Ready to 
Air flag. The exact behavior of this switch depends on the 
configuration used by your MOS vendor.  

This setting reflects the Producer’s approval to signal the 
Media Object Sever to air the contents of the Rundown, 
such as the audio, video and still store. 

Properties Set Rundown properties. Refer to “Creating a Rundown” 
on page 18 for more information on Rundown properties. 
You can also access the Rundown properties by double-
clicking on the title at the top of the Rundown. 

Export Rundown Save the Rundown as a plain text file. 

Export as HTML, 
HTML Encoding 

Save the Rundown as an HTML file and set the format for 
the exported HTML. Refer to Chapter 12, “Exporting 
Rundowns to HTML” for more information. 

Archive After a Rundown is used in production it should be moved 
to a permanent archive location for future reference. 
Archiving ensures that there can be no further modification 
or deletion of content and that it will not be subject to 
automatic deletion along with older items in Group 
Folders.  

To archive a Rundown select Rundown rover → Archive 
this Rundown. You may choose to archive the Rundown, 
a copy, and/or only lines above the Rundown’s black bar. 
Once a Rundown is archived it is no longer available in its 
original work area unless you specify that you want to 
archive a copy of the Rundown. You cannot archive 
copies if you are using the AutoArchive feature discussed 
below. 

When you create an archive, stories marked Not to be 
broadcast will be included in the archived Rundown but 
the Not to be broadcast message will remain. 

System Administrators can configure ENPS to archive 
Rundowns and Newsgathering Grids automatically using a 
global configuration setting. This setting allows the System 
Administrator the number of days after the Rundown’s air 
date when the Rundown should be archived. More 
information about setting this option can be found in the 
ENPS Operations Guide.  

ENPS purges Rundowns that are not archived within 30 
days of their creation date. To have a Rundown archive 
automatically, select Rundown rover → Properties or 
double-click on the Rundown’s title bar. Select the 
AutoArchive property. If the System Administrator has 
configured AutoArchiving to be triggered by the system 
automatically then you may want to save the Rundown 
template with this option enabled. 
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Lock Rundown, 
Lock all stories, 
Unlock all stories 

When airing a program Producers with approval privileges 
have the option to lock a Rundown, lock all stories, or lock 
the timing bar. To lock a Rundown, select Rundown rover 
→ Lock Rundown. If the Rundown is locked, authorized 
users may continue to make changes to stories in the 
Rundown and associated fields, although no user may 
add, delete, insert or move items in the Rundown itself. To 
prevent changes to stories, select Rundown rover → 
Lock all stories. Any user with Approval permission can 
continue to make changes to a locked Rundown. 

A Lock icon appears at the bottom of the 
Rundown. Rundowns which have been 
locked by a Producer cannot have their page numbers 
"unfrozen" and the Rundown cannot be deleted. 

Move your mouse cursor over the Lock icon to identify 
who holds the lock and from what workstation. An 
Approver may also unlock the Rundown from the 
Rundown rover (or it may be unlocked by double-clicking 
the Lock icon). A warning will be displayed if you try to 
drag either a Rundown or a Newsgathering Grid to the 
trash.  

When a user edits a story, ENPS places a lock Approver 
status on the story. Users with approver status can break 
that lock. If a story is locked and you break the lock to edit 
that story, when you save your work it will be saved in the 
Rundown. The user who had been working in the story will 
receive a message telling them that you broke the lock on 
their story. When that user saves their work, it will be 
saved in the user’s personal folder and not in the 
Rundown. 

Lock timing bar Once the show is on air select the producer that select this 
option will be the only person able to advance the timing 
bar manually. Others opening a Rundown will see the 
timing bar in place and moving, but they will not be able to 
advance it. 

Refresh grid Refresh the information in the Rundown. This option is 
used to check that the Rundown reflects the most up-to-
date information. 

Close Close the Rundown. This is the same as clicking on the X 
in the top right corner of the Rundown. 



 

The Associated Press  29 
 

Chapter 8 

Adding Content to Rundowns 
This section covers some of the basic procedures for working with Rundowns 
including adding and editing stories and segments, floating stories, and saving 
the Rundown. You must have sufficient privileges to add, delete, or move stories 
in a Rundown  

There are some simple techniques for working in the Rundown using the mouse 
and keyboard. If you want to replace the contents of a text field in a Rundown, 
highlight the cell and type the new text. If you want to edit text, press the 
Backspace key and then use the mouse or arrow  keys to move the cursor to 
different areas of the text. You can move to the next cell by pressing Tab. 
Press Shift+Tab to move to the previous cell. 

Creating and Deleting Stories 
You have a number of options for adding stories to a Rundown: 

• Create a new row in the Rundown by selecting Rundown rover → Insert 
Row or press Ctrl+I. Double-click the new row’s story slug to edit the 
story. 

• Drag a wire story from the List Window into a row in the Rundown.  

• Drag a story from a Personal or Group folder into the Rundown. 

• Drag a planning item from a Newsgathering Grid into the Rundown.  

To add or change the name of an item, click the appropriate Story Slug field. 
Type the desired name, and press Enter. You can also change the name of an 
open item by double-clicking on the tab for that item. Save changes by hitting 
Enter. 

To delete a story from a Rundown drag it to the Waste Bin or highlight it and 
press Alt+D. 

Each row in a Rundown represents an item or story. In each row, the color 
indicators adjacent to the story slug serve as indicators for whether the story 
contains text and whether it has been approved:  

A yellow marker indicates that an item does not have any text. 

A red marker indicates that an item contains text, but it has not been approved. 

A green marker indicates that an item contains text and has been approved.  

Only users with sufficient privileges will have the ability to approve items. 

Copying Text into a Rundown or Story 
Once you create an entry in the Rundown, double-click the story slug to open or 
edit the story in that row. When you add text to the story and save it, the color 
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code of that line in the Rundown will turn red. You can type directly into the story 
or you can copy text from other documents into your Rundown story.  

From Another Rundown 

Drag the Story slug from one Rundown to another Rundown. If you are dragging 
a story that contains multiple segments, those segments will also be copied into 
the target Rundown. 

From the List Window 

Open any folder that contains items that you want to add to the Rundown; this 
may include wire copy, a group folder, or a personal folder. Select an item in the 
List Window to copy by clicking on it or select multiple items by holding down the 
Ctrl key and clicking on each item you want to select.  

If you have a Rundown open, you can drag the item or items into the Rundown. 
Multiple items will become segments of the same story. Alternately, you can 
paste the objects directly into the Rundown if you already have a Rundown open. 
Select List Window rover → Copy to Target → Opened Rundown and select 
the name of the Rundown where you want to paste the data.  

If you do not have a Rundown open, select List Window rover → Place 
selections in ENPS clipboard. The ENPS clipboard is a temporary space you 
can hold items until you are ready to paste them into your Rundown. When you 
are ready to add the items to the Rundown select Rundown rover → Paste 
items to add the rows.  

From Another Editing Window 

Select Editing Window rover → Copy to Target → Opened Rundown and 
select the Rundown name. The new row will appear below the Rundown’s black 
bar. 

To drag a story that is currently in an Editing Window into a 
Rundown, you may drag and drop it by the folder tab from the 
Editing Window into the Rundown. 

Creating Segments 
Single story slugs may contain multiple segments. To define a segment, add a 
hyphen and segment name when entering information in the Story Slug field.  

 

Typing “Weather-Weekend” in the Story Slug column will divide the terms so that 
Weather appears in the Story Slug field, and Weekend appears in the Segment 
field.  

 

Other Rundown columns may be edited directly on the Rundown by typing in the 
column. Additional segments may be added, such as Weather-Overnight, 
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Weather-Morning, etc. To define a segment, type the desired label in the 
segment column. The item’s Story Slug field increases in height if it includes 
multiple segments. A character other than a hyphen may be defined as the 
delimiter on non-English language systems. 

Moving Stories 
To move a Rundown item, drag its story slug to a new position. This will also 
work for items that contain multiple segments. 

 

Individual segments may also be dragged to new positions by clicking on the 
“segment” portion of the Rundown. 

To move multiple stories within a Rundown at the same time, mark them by 
holding the Ctrl key and clicking on each slug you want to select or press 
Alt+B. Selected stories are marked with a dark gray background. To clear all 
selected rows press Alt+A.  

To move multiple stories, highlight them, then drag and drop them at the point 
above which you wish to move them. Items are repositioned in the order that they 
were selected, so it is important that you mark them in the desired order before 
dragging them to a new position.  

Items may be copied from one Rundown to another using the same drag and 
drop techniques outlined above. Approval indicators are removed when items are 
copied into new Rundowns. Items may be moved between Rundowns by holding 
down the Shift key while dragging and dropping items. The original is deleted. 

 

Floating Stories 
The Rundown is divided into two main areas separated by a black bar that 
extends all the way across the Rundown. Items above the black bar are 
considered part of the show and are including in timing, prompting, and MOS 
functionality. If you drag an item below the black bar, it will not be included in the 
timing of the show, but it can still be edited. 
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An alternative to dragging items below the black bar 
is to use the float feature. This will keep the story in 
its allocated row, but it will not be included with the 
regular timing, prompting, and MOS functionality.  

To float a story, the column labeled "float" must be in 
the Rundown. Clicking on that column in the story 
row will place a check mark in the row, and the color of the row will change. To 
re-activate the story, click on the check mark in the float column. 

If you are moving a story in your Rundown 
while your newscast is on the air, you 
should first float the story, move it, and 
then unfloat it. However, be aware that 
unfloating a story too close to the time it is 
scheduled to go to air may mean peripheral 
devices will not be able to load the story for air as quickly as you will need them. 
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Chapter 9 

Rundown Timing 
This section will show you how the Rundown’s timing features work when you 
bring a show to air. 

To start Rundown timing, the Producer selects Rundown rover → Properties 
and checks the On Air checkbox to enable the timing function. You can also 
access Rundown properties by double-clicking on the Rundown’s title bar. You 
must have Approver status to change the On Air setting. A Rundown cannot be 
deleted while this setting is enabled. Click Go. 

The Over/Under time appears at the lower left corner of the Rundown. This time 
indicates how the total program time compares with the expected program 
duration, as defined in the Rundown properties.  

Start the clock by pressing the Space bar. A yellow timing bar appears. 
Continue to press the Space bar as each item is passed. 

• Press Ctrl+Space bar to move the timing bar to the selected line. 

• Press Shift+Space bar to move the timing bar back one line.  

• Press Alt+Space bar to turn off t iming. 

The time in the lower left corner is based on either the Actual or Estimated timing 
fields, depending on how it has been configured by your System Administrator. 
By default, ENPS uses Estimated time. Four clocks appear at the bottom of the 
Rundown. These clocks indicate, from left to right: 

• Time remaining in the current story segment. 

• Time elapsed in the current story segment. 

• Time remaining in the current story including all segments. 

• Time remaining in the program. 

Each time you press the Space bar, the Segment, Story, and Over/Under clock 
calculate from the beginning of the next segment. A yellow highlight bar marks 
the item currently being timed.  

Remember that if the Duration based checkbox is highlighted in the Rundown 
Properties, the timing of the show will be based on the length of the program 
(e.g., 30:00) and when the program is timed live, timing will be based on the 
duration of the program, regardless of the start time. If this box is not checked, 
timing counts down to the previously entered end time of the program, regardless 
of when the newscast was started.  

Basic Time Fields 
The following table summarizes basic timing columns available in Rundowns: 

Time fields Description 

Estimated Time Entered in the Rundown by the show Producer.  
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Text Time Entered automatically by ENPS. Reflects the time of textual 
elements as calculated by either the global read rate or by 
the manually entered read rates in stories. 

Media Time Reflects media durations manually entered into the stories.  

Check with your System Administrator to see if the Global 
Configuration option AddMOSObjDuration=1. If it is, then 
this value will also include all MOS Object durations 
included in the story. Refer to the MOS Timing section 
below for more information about the 
AddMOSObjDuration setting. 

Actual Time Reflects Text Time + Media Time. See definitions 
above. By default, ENPS Rundowns calculate overall 
timing based upon actual time. 

Again, check with your System Administrator to see if the 
Global Configuration option AddMOSObjDuration=1. If 
there is a MOS Editorial time present refer to MOS Timing 
below.  

Actual Time = Text Time + MOS Editorial Time 
+ Durations manually entered into the story 
from Media Time 

Check with your System Administrator to find out whether the configuration 
setting RundownTimeEstimated is enabled or disabled. It is disabled by 
default, which means that ENPS will calculate the timing based on the Actual 
Time. If you change the time in the Estimated Time column, it does not affect 
Rundown timing. However if RundownTimeEstimated is enabled, Rundowns 
will calculate the timing based on Estimated Time rather than Actual Time. If 
there is no value for Actual Time, ENPS will use Estimated Time until an Actual 
Time is entered. 

Additional Time Fields 
Here are some other fields you can use for Rundown timing: 

Time Fields Description 

Back Time Calculates time backward from the ending time of the 
Rundown, based on the length of individual items. 

Front Time Calculates time forward from the start time of the 
newscast based on the length of individual items. 

Cume Time Adds up the time of all items in a Rundown working 
forward. 

Back Cume Time Adds together the time of all elements in a Rundown, 
working backward from the end time. 

Elapsed Time This column shows the amount of time that the yellow 
bar, engaged when the Air box is checked, spends on 
each row as it moves through the Rundown.  

Check with your System Administrator to see if the 
Global Configuration option RundownTimeElapsed = 
1. When this option is enabled, the newscast timing will 
be recalculated as the yellow bar moves down. 
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MOS Timing 
For information on using the MOS protocol in Rundowns refer to the Using MOS 
and Media Controls section in this guide. 

When a MOS Object message is sent to ENPS, it may include an Object 
Duration, and it may also include an item’s Editorial Duration. The following MOS 
timing columns can be included in a Rundown: 

MOS Timing Description 

MOS Object Time 

 

Length of the MOS object as reported from the MOS 
Server. By default, MOS Object Time is not calculated 
into the overall Rundown time.  

MOS Editorial Time A user-defined variable time also reported from the 
MOS Server set on either the vendor's software or in the 
ActiveX. 

Check with your System Administrator to find out the value of the Global 
Configuration Setting AddMOSObjDuration. 

If AddMOSObjDuration=0 then Actual Time = Text Time + Manually 
entered durations 

If AddMOSObjDuration=1 then Actual Time = Text Time + MOS 
Object Durations + Manually entered durations 

MOS Editorial times are not added to Media Time. If MOS Editorial Time is 
present, it will override the MOS Object Duration in the calculation of Actual Time 
so that: 

Actual Time = Text Time + MOS Editorial Time + Manually 
entered durations 

In other words, if AddMOSObjDuration=1, ENPS calculates the MOS Object 
Duration as part of the Actual time (along with the story text time). However, if a 
MOS Editorial Duration is present in the MOS Item Reference, then ENPS uses 
the MOS Object Editorial Duration over the Object Duration. 

You can enable the AddMOSObjDuration=1 behavior for individual Rundowns. 
Select Rundown rover → Properties and select the Add MOS Durations field. 
There are three choices: 0 is the default behavior, 1 enables the option and will 
add MOS object durations to the Rundown, 2 disables it and will not add MOS 
object durations. 

It is also possible to make these choices on a per item basis by adding the "MOS 
User Duration" column to your Rundown. Refer to Chapter 18 Enabling Objects 
for MOS, “Step 1: Creating a MOS-Enabled Rundown Template” for more 
information. 

Segment or Hard Hit Timing 
It is possible to enter a manual segment or hit time during a newscast which can 
be used, for example, to time into shared live shots or lottery drawings. Hard hit 
timing may be configured for either back time or front time.  It is useful for doing 
the calculations of whether stories put you over or under the hard hit time, 
however it will not update values automatically during a broadcast.   
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To use hard hit timing with back time, select Rundown rover → Layout → Add 
columns → Hard Hit Back then add the column Hard Hit Back +/-. You may 
also do this using the columns Hard Hit Front and Hard Hit Front +/-. 

Go to the row for the story that you want to time into and enter the exact time that 
it should go to air in the Hard Hit Back or Hard Hit Front columns, including AM 
or PM.  

If you are using the Hard Hit Front time column, enter the front time at which you 
want to hit the segment, and ENPS will figure the over/under time to that point. 
When the newscast is on the air, ENPS will consider the hard hit time as a forced 
time and will recalculate all timings based on that entry. 

For example, say you need to hit a live shot four minutes into a newscast 
scheduled to start at 6:00:00 pm, as follows: 

Now you "force" a hit time of 6:03 at Story 4. The timing is alright until you add 
Story 1a for 30 seconds which will put you 30 seconds past your live shot start:  

Scheduled Start time: 6:00:00 

 Actual Time or 
Estimated 
Duration 

Hard Hit Front Time Hard Hit Front +/- 

Story 1 1:00 6:00  

Story 1a :30 6:01:30  

Story 2 1:00 6:02:30  

Story 3 1:00 6:03:30  

Story 4 1:00 6:04:00  

Live 
Shot 

 6:04 :30 over 

Again, note that you have "forced" the 6:04 hit time, so the Front Time column 
remains at 6:04. Once you start the ENPS timing bar, the over and under 
calculation will vary according to the actual start time. So if you do not actually 
begin the newscast until 6:00:15, you will be another 15 seconds over your 6:04 
forced hit time.  
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Chapter 10 

Creating a News Ticker  
You can use the Rundown in ENPS to create a headline ticker that sends output 
to a CG via serial cable. Your Rundown can extract headlines directly from an AP 
wire feed that streams the latest news headlines. You can then combine 
headlines with local news copy.  

To use this feature, make sure your System Administrator has completed the 
steps for enabling a Rundown ticker in the ENPS Operations Guide. Then 
complete the following steps: 

1. Create a new Rundown. In the Rundown properties box, select the Ticker 
Content checkbox to enable the ticker functionality. Enable the Continuous 
Content property if you want to prevent the Rundown from being purged by 
ENPS maintenance routines.  

 

2. If you want to separate the headlines in the ticker with a 
letter or character, enter it in the Ticker Story Delimiter 
textbox. You can also use character mapping on your CG 
to insert a station logo between headlines. Refer to your 
CG manual for more information.  

3. Click Go.  

4. In the Rundown select Rundown rover → Layout → Add columns → Ticker 
Category. When you select a cell in this column, you will be able to pick from a 
category list that has been set up by your System Administrator.  

If you double click the “TICKER” story slug, a box appears displaying the 
headlines from the AP wire feed.  
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You can add your own local headlines before or after the national headlines by 
adding a separate entry in the Rundown. Add a row to your Rundown with a story 
containing a list of local news headlines. You might call this story “Local 
Headlines.”  

You cannot delete individual headlines from the AP ticker feed. You must select 
an entire category or leave it out completely. 

A Rundown entry’s ticker content will not be sent until its Final Approval flag is 
selected. To start sending content to the CG through a serial connection, select 
Rundown rover → Ticker Active.   
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Chapter 11 

Printing Rundown Report Layouts 
The creation and editing process for Rundown layouts follows the same rules as 
story layouts covered in 0. The only significant difference is in the Body section.  

 

The Autosize option will automatically adjust the column width to the largest 
amount of text in any of that column's rows. The Wordwrap option adjusts the 
row height so that all field material fits in the column, even if multiple lines are 
necessary. 

Click the Minimum row height checkbox to define the smallest possible row 
height. You may define this value in terms of inches, centimeters, picas, or points 
using the drop-down menus. 

You can add or delete print fields from the report layout by dragging fields to the 
Waste Bin. You can add fields by dragging them from the Available Fields 
column. Fields above the dashed line are for use in the Header or Footer areas.  

You may only drag and drop fields that appear under the dashed line into the 
Body section. Once columns are present in the Body section, to reposition them 
in relation to one another, drag and drop them to a new place. To resize 
columns, drag and drop the right borders of the columns to new positions. 

Each column in the Body area contains Autosize and Wordwrap checkboxes. 
Using the available options, you can select different font sizes for the body, 
header, and footer sections. You can also choose bold, italics, or underline. You 
can choose whether orient the Rundown layout as portrait or landscape. You can 
also combine plain text (in black) with the available fields in a print area. 
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Chapter 12 

Exporting Rundowns to HTML 
This section will show you how to convert your Rundown to HTML format. 
Converting Rundowns to HTML allows you to share Rundown information with 
people who do not have ENPS or share it over a network.  

To export a Rundown as an HTML file with all of its stories above the Rundown’s 
black bar, select Rundown rover → Export as HTML and enter a filename. 

A master table of items and links will appear at the beginning of the file, with 
stories in the remainder of the file. By default, two HTML files are written: one 
with enhanced features and one in a text-only format and named with an “x” at 
the beginning of the filename. 

The story comes out double-spaced and in a narrow column on the left side of 
the screen if the story was not reformatted. Reformatting is not automatic to 
avoid destroying tabular information. If the story is reformatted, then it will appear 
single-spaced without the extra line feeds. 

Setting Export Options 
You can set a number of customization options for how your Rundowns are 
exported to HTML. These options can be set in the HTML.INI file in the 
C:\Documents and Settings\All Users\Application Data\ENPS 
directory of your workstation. To modify this file from the Windows taskbar select 
Start → Run and enter the following command in the textbox: 
NOTEPAD \Documents and Settings\All Users\Application Data\ 
ENPS\HTML.INI 

To enable an option, remove the semicolon from the beginning of the line or 
disable it by adding a semicolon at the beginning of the line. Each entry should 
follow the format of option name, equals sign, and the setting value. For 
example, if your station logo file is in C:\GRFX\BG.JPG modify the following 
setting in the HTML.INI file: 

Logo=C:\GRFX\BG.JPG 

The following table summarizes the export options you can set in HTML.INI: 

Setting Description 
ExportPath 

 

Path for storing HTML files 

Example: C:\ENPSHTML 

BackgroundImage Filename of graphic for background image 

Example: C:\GRFX\BG.JPG 

Logo Path and filename of the graphics file for logo 

Example: C:\GRFX\LOGO.JPG 

Header Header text 

Footer Footer text. 
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Setting Description 
Copyright Copyright text. 

HeaderAboveTitle Header text appears above the title 
(1=True,0=False) 

HeaderBelowTitle Header text appears below the title. 
(1=True,0=False) 

FooterAboveCopyright Footer text above the copyright. 
(1=True,0=False) 

FooterBelowCopyright Footer text below the copyright. 
(1=True,0=False) 

HomeLink URL for a referring home page to which this page 
should refer. The syntax is: 
<link description>!<URL>  
Example:  
ENPS homepage!http://www.enps.com/ 

HomeLinkBelowTable HomeLink appears below the table. 
(1=True,0=False) 

HomeLinkEndPage HomeLink appears at the end of the page. 
(1=True,0=False) 

Marquee Internet Explorer only: Any desired text that should 
appear as a scrolling marquee. 

MarqueeForeColor Color of marquee foreground. The default is blue.* 

MarqueeBackColor Color of marquee background. The default is white.* 

PageColor Page color; default is white.* 

TableColor Table color; default is blue.* 

TextColor Text color; default is black.* 

Transparent Page color is transparent (1=True,0=False) 

TextOnly Text-only page is also generated starting with the 
letter ‘x.’ (1=True,0=False) 

CuesInExport Production commands are included in exported 
stories. By default, this value is false and production 
commands are excluded. (1=True,0=False) 

ROImageInExport  Graphic of the Rundown is included above the 
Rundown table. The default is false. 
(1=True,0=False) 

ViewExport ENPS Web browser will load automatically in the 
lower Editing Window. (1=True,0=False) 

*Color values are in hex RGB format. Here are some common examples: 

Color  Hex RGB Format 
Blue 0000FF 

Green 00FF00 

Red FF0000 

White FFFFFF 

Black 000000 
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When you are finished making changes to the HTML.INI file save the changes 
in Notepad. You will need to restart your ENPS client for your changes to take 
effect. 

Encoding Options 
You can change the encoding type by selecting Rundown rover → HTML 
encoding and selecting the appropriate method. Character encoding refers to 
the way the HTML code is written. Different codes should be used for different 
languages.  

There are three encoding options available: Western (1252), Unicode (UCS-
2), Unicode (UTF-8). If ENPS is running on an Arabic-Enabled system then 
Arabic (1256) will also appear. UTF-8 is generally considered the most efficient 
encoding, and it is widely supported in the most recent versions of browsers. 

If you are using Thai characters, for example, and you use Western (1252) 
encoding, in the HTML version the Thai characters will be represented with 
number codes such as &#3585, &#3607, and so on. If you notice that some of 
the characters in your Rundown are not being represented correctly in the HTML 
version, you should experiment with different encoding options to see which one 
works best for the language you are using.  
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Chapter 13 

Newsgathering Grids 
Newsgathering Grids are assignment planners. Each line of the grid represents a 
separate story item or prospect. When you click on a line of the Newsgathering 
Grid you will see linked grids into which you can enter information about the 
potential story. 

These grids often include schedule information (when and where the event will 
take place), feeds, costs, and information on the story follow-up. Additional fields 
can be added to the Newsgathering Grid as needed. 

Newsgathering Grid Views 
Newsgathering Grids can be displayed in different ways, which are useful 
depending on what you are working on.  

Icon Meaning 

 Display the Newsgathering Grid in its own window. This is the same as 
clicking on the  icon on the Newsgathering Grid’s title bar.  

Once this option is selected each subsequent Newsgathering Grids 
will be displayed in its own window. By default, there is a limit of 10 
detached Newsgathering Grids and/or Newsgathering Grids allowed, 
although this value may be changed by your System Administrator. 

Click the  icon in a detached Newsgathering Grid or Newsgathering 
Grid window to return the detached windows to the ENPS desktop. 

 Switch between a tabbed view and separated Newsgathering Grid 
views. In a tabbed view, you will see the names of all open 
Newsgathering Grids above the current Newsgathering Grid. Press 
Alt + > or Alt + < to move to the next Newsgathering Grid or click 
on another Newsgathering Grid name to open it. In the separated 
Newsgathering Grid view, each Newsgathering Grid occupies a 
different window. You can open Newsgathering Grid properties by 
clicking on a Newsgathering Grid title in either mode.  

 
Full Screen view. You can find other full screen view configurations by 
selecting Newsgathering Grid rover → Layout → Full Screen. From 
this menu, you can choose a full screen single Newsgathering Grid 
view, Newsgathering Grids split horizontally or vertically on the screen, 
or a Newsgathering Grid vertically split with the story from the top 
Editing Window. 

 Switch between a vertical and horizontal Newsgathering Grid view. 

 Close the Newsgathering Grid. 

Creating a Newsgathering Grid  
Select Group Folder rover → New → Newsgathering. Enter a name for the 
Newsgathering Grid in the Program textbox. 
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Group Managers should set up templates for the station. If you want to use an 
existing template select it from the list box on the left-hand side of the window or 
select Blank Newsgathering Grid Event Sheet.  

You can change the following Newsgathering Grid properties. Some fields may 
not appear in your configuration if they have not been enabled by the System 
Administrator. Likewise, the System Administrator may create custom fields for 
your station that do not appear in the list below. 

Property Description 

Allow External 
Modification 

Allow external MOS devices to create temporary holds on 
stories for modification. This feature will only work when the 
MOS Control Active box is selected.  

Auto Archive Automatically archive the Newsgathering Grid. 

AutoCreate 
Advance Days 

Configures ENPS to automatically create a Newsgathering 
Grid every day for the number of days specified, up to 365 
days in advance of the Start Date. 

Continuous 
Content 

Set the Newsgathering Grid not to be purged after 30 days 
by the ENPS maintenance routines. This setting does not 
affect the settings for automatic archiving. 

Continuous 
Content Interval 

If Continuous Content is selected, setting a value in this 
field sets the number of days before a story is archived. For 
example, if this value is set to 5, all stories that are older 
than five days will be archived. A copy of the 
Newsgathering Grid will also be archived without the stories 
that are still current. 

Enable CTOS 
Archive 

Create a copy of the Newsgathering Grid in Central Text 
Object Storage when the Newsgathering Grid is archived. 

Story Log 
Preview Size 

Set the number of lines that are displayed in the Story Log 
Preview column of the Newsgathering Grid layout. In a 
planning item, information about the item such as summary 
information, can appear in the Newsgathering Grid by 
selecting Newsgathering Grid rover → Layout → Add 
columns → Story Log Preview. 
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MOS Block Prevent the Newsgathering Grid from sending outbound 
MOS messages. 

MOS Control 
Active 

Create a MOS connection for the Newsgathering Grid on 
the ENPS server. This connects the Newsgathering Grid to 
associated Media Object Servers. Once a Newsgathering 
Grid is MOS Active, its icon in the List Window will change 
to reflect that is MOS-enabled. 

MOS Story 
Send 

Designates the MOS device, such as a video server, to 
which MOS messages will be sent. Select devices by 
checking the box next to the appropriate MOS device. This 
sends the body of all stories and associated metadata to 
those devices. 

Publishing 
Active 

Click this entry when are satisfied with all stories and the 
Rundown is ready to be published. If you have selected 
Publishing Days, the Rundown will be published 
automatically on those days even if your ENPS client is not 
running at that time. You must have the MOS Control 
Active option selected for this option to be enabled. 

Refer to the ENPS Publishing Installation and User’s Guide 
for more information about using this feature. 

Publishing Days  Select which days of the week that publishing should take 
place. Refer to the ENPS Publishing Installation and User’s 
Guide for more information. 

Publishing 
Target 

Select one of the output locations where the Rundown 
should be published. Refer to the ENPS Publishing 
Installation and User’s Guide for more information. 

If you are planning assignments for a later date, ENPS provides you with an easy 
way to set up future planning items. From any group folder configured for 
Newsgathering Grids, select Group rover → New → Newsgathering Item. This 
opens a calendar in which you can enter a date or navigate to a date to create 
the future planning item.  

 

After you enter a title, click Open. The Newsgathering Item will open in the lower 
Editing Window. Enter text into the item as desired, either in one of the sub-grids, 
or in the story portion of the item.  
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To view all of the Newsgathering Items for future dates, select Group rover → 
Calendar. Select the date you wish to view, and then select Newsgathering 
Items.  

When you first create the future Newsgathering Item, it will appear at the top of 
the work-in-progress list in the List Window. However, when the group folder is 
refreshed, the list will not include the future items. You must access them only 
through the Calendar or a search. 

Rover Options 
Option Description 

Insert Row Create a new row in the Newsgathering Grid (Ctrl+I) . 
Double-click the new row’s story slug to edit the story. 

Layout After you have modified columns, including their sizes and 
positions, save your personal Newsgathering Grid view by 
selecting Layout → Make this my layout.  

To customize the Newsgathering Grid so that the same 
features appear every time a Newsgathering Grid is 
created, save the Newsgathering Grid as a template, 
select Layout → Save as template. If the Newsgathering 
Grid is in the group folder, other members of your group 
will also be able to use it. 

After you define a personal layout, every time you open 
Newsgathering Grid it will be displayed in your personal 
layout. You can change this behavior in your personal 
settings by selecting Personal Folder → Settings where 
you can choose the template or system layout as your 
default.  

To add a column to a Newsgathering Grid, highlight any 
cell in the column to the right of where you want the new 
column to appear. In the example below, a new column 
will be inserted between the Segment and Camera 
columns:  

Select Layout → Add column and click on the column 
you want to add. The new column will appear in your 
layout to the left of the column that was previously 
selected.  

To define a row as a break, for 
example, add the Break column to your 
layout. Then click in that column of the 
row you want to make a break. A 
checkmark appears in the Break field, 
and the entire row will have a blue background. Once you 
have made the row into a break, you can delete the 
column so you do not accidentally change break lines. 

The columns Page, Story Slug, and Segment must be the 
first three columns in the Newsgathering Grid. They can 
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be hidden but they cannot be moved or deleted. 

To remove a column, first highlight any cell in that column 
and select Layout → Remove column. You can also 
remove a column by clicking on the column header and 
dragging it to the Waste Bin. When you remove a column 
from your layout, you do not lose any of the information 
contained in that column; if you add the column back later, 
it will still contain all of the same information. 

Detach Display the Newsgathering Grid in its own window. This is 
the same as clicking on the  icon on the Newsgathering 
Grid’s title bar. 

Once this option is selected all subsequent Newsgathering 
Grids will be displayed in their window. By default, there is 
a limit of 10 detached Rundowns and/or Newsgathering 
Grids allowed although this option may be changed by 
your System Administrator. 

Click the  icon in a detached Rundown or 
Newsgathering Grid window to return them to the main 
ENPS window. 

Font Change the typeface style and size in the Newsgathering 
Grid display. 

Print Print the Newsgathering Grid. This option lets you select 
which part of the Newsgathering Grid you want to print. 
You can also select Print Setup to select the printer you 
want to use, how you want the printout to appear and 
other print options. 

You can add page breaks to long Newsgathering Grids by 
adding the “Page Break” column to the layout. On rows 
where this column is checked, the Newsgathering Grid will 
have a page break. This option will only work if the RTL 
print engine is enabled; check with your System 
Administrator for more information. 

Properties Set Newsgathering Grid properties. Refer to the beginning 
of this section for more information on Newsgathering Grid 
properties. You can also access the Newsgathering Grid 
properties by double-clicking on the title at the top of the 
Newsgathering Grid. 

Archive this 
Newsgathering 
Grid 

After a Newsgathering Grid is used in production it should 
be moved to a permanent archive location for future 
reference. Archiving ensures that there can be no further 
modification or deletion of content and that it will not be 
subject to automatic deletion along with older items in 
Group Folders.  

To archive a Newsgathering Grid, select Newsgathering 
Grid rover → Archive this Newsgathering. ENPS 
purges Newsgathering Grids that are not archived within 
30 days of their creation date. To have a Newsgathering 
Grid archive automatically select Newsgathering Grid 
rover → Properties or double-click on the Newsgathering 
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Grid’s title bar. Select the AutoArchive property. If the 
System Administrator has configured AutoArchiving to be 
triggered by the system automatically then you may want 
to save the Newsgathering Grid template with this option 
enabled. 

Refresh grid Refresh the information in the Newsgathering Grid. This 
option is used to check that the Newsgathering Grid 
reflects the most up-to-date information. 

Close Close the Newsgathering Grid. This is the same as 
clicking on the X in the top right corner of the 
Newsgathering Grid. 

Calendar Open a calendar which lets you view Newsgathering Grids 
for other dates and copy items from one date to another. 
 
When you open the calendar select the Location and Item 
Type you want to display. Select the Always on Top 
checkbox if you want to keep the calendar on top of other 
windows.  
 
To view Newsgathering objects for a particular date you 
can either type the date in the Selected date file and click 
Go To or you can click on a date in the calendar. 
Newsgathering objects for that day will appear in the List 
Window.  
 
You can move an item from a Newsgathering Grid to 
another date by dragging the onto a calendar date. If you 
want to retain a copy of the item in the current 
Newsgathering Grid hold down the Shift key while you 
are dragging the item to the target date to copy it instead 
of moving it. While you are dragging the item you can hold 
the item over the << or >> arrows to change the calendar 
month before you release the mouse button.  
 
Note the following rules when working with the calendar: 
 
• If there is only one Newsgathering Grid on the target 

date the dragged item will be moved to the 
Newsgathering Grid for the target day and placed below 
the grid’s black line. 

• If there is more than one Newsgathering Grid on the 
target date ENPS will display a dialog box that allows 
you to select the correct one to use.  

• If there is no Newsgathering Grid for the target date 
ENPS will move the item into a collection of loose 
Newsgathering Items for that day and the status 
message will indicate that it has been moved as a loose 
item. 

• It is also possible to drag a loose Newsgathering Item or 
an entire Newsgathering Grid from the List Window to a 
particular day on the calendar.  
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 • In most cases you will be moving items to a future date 
but it is also possible to move items to past dates.  

To move items to another date with thekeyboard only it is 
first necessary to mark them in the newsgathering grid 
with Alt+B. Once that is done, select Newsgathering 
Grid rover → Copy selections to target → Calendar. 
The calendar control will then open from where you can 
can select the target date and then click Move or Copy. 

Newsgathering Grid Layout 
To insert new columns, select Newsgathering Grid rover → Layout → Add 
columns and select the column you want to add to your view. You can delete a 
column by clicking on its title and dragging it to the Waste Bin, although you 
cannot delete or move the Story Slug or Segment columns. 

 

You can change the width of a column by moving your mouse cursor over the 
boundary between two columns in the header row. When the arrow changes into 
a double-sided arrow you can hold down the mouse button and drag the column 
to a different size. 

 

To change the order in which columns appear, position your mouse cursor on a 
column header and then hold down the mouse button. The cursor will change to 
a pointing hand and you can drag the column to a new position. 

 

You may also change the sort order of Newsgathering Items in the grid by 
selecting Newsgathering Grid rover → Layout → Sort by and selecting the 
criteria you want to sort by.  
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Select the Sort Order menu option to choose whether you want the list sorted in 
ascending or descending order. This is a personal layout option which can be 
applied to a template view. 

Saving Layouts as Templates 

If you are a Group Manager and you want to save your Newsgathering Grid as 
the default layout for your group, select Newsgathering Grid rover → Layout → 
Make this the system layout for the group.  

Any Group Manager with Newsgathering Grid access can save their layout so 
that other users will be able to use that template. Individual users can save a 
personal layout by selecting Newsgathering Grid rover → Layout → Make this 
my layout. 

1. Make sure you have selected a unique name for your Newsgathering Grid that 
you will recognize later. To change the program name select Newsgathering 
Grid rover → Properties and enter a name in the Program text box. Any 
properties you set in this screen will also be saved in the template. 

2. To save your Newsgathering Grid layout as a template, select Newsgathering 
Grid rover → Layout → Save as template. Users will now see that template 
listed on the left hand side of the screen when they are creating a new 
Newsgathering Grid. 

To delete a Newsgathering Grid template select Group Folder rover → Group 
maintenance → NG templates and drag the template into the Waste Bin.  

Using the Newsgathering Grid 
To add a new row, select Newsgathering Grid rover → Insert Row or press 
Ctrl+I.  

To select a cell, click on it or use the cursor keys to navigate to other cells. You 
can move to the next cell by pressing Tab. Press Shift+Tab to move to the 
previous cell. Press Ctrl+Tab to move from one sub-grid to the next, such as 
“Schedule” to “Feeds,” or press Shift+Ctrl+Tab to go to the previous sub-
grid. 

If you want to replace the contents of a cell, highlight it and then type the new 
text. If you want to edit text, press the Backspace key and then use the mouse 
or arrow keys to move the cursor to different areas of the text. You can also drag 
stories, Microsoft Word documents, Microsoft Excel spreadsheets, or Adobe 
Acrobat .PDF files into the Background or Stories columns. The maximum 
number of items that can be added before you receive a warning message is set 
by the System Administrator. The system default is 10 items. 

The black bar in the Newsgathering Grid is a distinction you can use to separate 
different kinds of information you are working on in the Newsgathering Grid. Any 
material below the black bar will not be published or sent to MOS devices.  

You can use break lines to separate stories into groups. Select Newsgathering 
Grid rover → Layout → Add Columns → Break then click in a row’s Break 
column to mark that row as a break. 
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Adding External Documents 
If you have information stored in external documents such as Rich Text Format 
.RTF, a Microsoft Word .DOC, a Microsoft Word 2007 .DOCX, a Microsoft Excel 
.XLS, Microsoft Excel 2007 .XLSX, or an Adobe .PDF you can drag them from 
the Windows folder into your Newsgathering Grid into collection fields such 
including “Assignment Info” or “Background.” The system’s maximum size limit is 
3 megabytes, but the System Administrator can set a smaller value. 

The Newsgathering Grid field into which you dragged the document will update 
with the number of documents that have been added. When you click that field, 
the List Window will update with the document list. You can then double-click on 
the document name to open it. If you see the following screen, click Open to 
open the file in the lower Editing Window: 

 

Turning Newsgathering Items into Stories 
Newsgathering Items can quickly become the basis for stories simply by 
dragging the item from the Newsgathering Grid into a Rundown. The "story" or 
story log side of the Newsgathering Item will move below the grey line in the 
Rundown story and any MOS pointers that are present in the Newsgathering 
Item will also be copied into the new Rundown story below the grey line. You can 
learn more about how MOS works in Newsgathering Grids in 0, “Using 
Newsgathering Grids with MOS.” 

Changes made in the original Newsgathering Item will only be saved in the 
Newsgathering Item, but not in Rundown story. Anyone working in a Rundown 
can view a story’s original Newsgathering Item by selecting Story rover → Show 
parent NG Grid item.  

Viewing Newsgathering Grids by Date 
To view the Newsgathering Grids or Newsgathering Items that were created on a 
particular date, click Group Folder rover → Calendar. Check the appropriate 
box for Item Type and then click on the date in the calendar area. 

Archiving Newsgathering Grids 
Newsgathering Grids may be archived automatically. System Administrators 
have the option to allow automatic archiving through a global configuration 
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setting that determines when an object is automatically archived. When the 
events on a Newsgathering Grid have passed, they are removed from the active 
Group Folder and placed in the Group Archives. 

To set a Newsgathering Grid to archive automatically, select Newsgathering 
Grid rover → Properties and select the AutoArchive option. There are two ways 
to access information once it has been archived: through a search or the 
Calendar. Items attached to the Newsgathering Grid will also be archived. 

These items can be archived manually by selecting Newsgathering Grid rover 
→ Archive this Newsgathering Grid. 

Newsgathering Grid Security Levels 
Security level settings for Newsgathering Grids apply to any items in the grid. A 
user with a security level of Read only in this field would mean that users would 
not be able to make changes in any Newsgathering Item contained in a 
Newsgathering Grid. Security levels for Newsgathering Items apply to loose 
items, such as those created from a rover, but not in a Newsgathering Grid. 

Using Newsgathering Grids with MOS 
To learn more about MOS and how to work with MOS objects in ENPS, refer to 
Introduction to MOS in this guide.  

You can use a Newsgathering Grid to automatically create media objects for the 
Newsgathering Grid entries. By making your Newsgathering Grid MOS active, 
you reserve space in your video server for the media to occupy later.  

1. Open an existing Newsgathering Grid or create a new Newsgathering Grid by 
selecting Group Folder rover → New → Newsgathering. Enable MOS Control 
Active in the Newsgathering Grid properties.  

2. If the Group Manager has not already added the “Object AutoCreate” and 
“MOS Status” columns, select Newsgathering Grid rover → Layout → Add 
columns and select the column names to add them to the Newsgathering Grid.  

3. Create a new item in the Newsgathering. In this example, assume that you 
have items that will feed into the station via ENG for air. You may want to name 
objects “RAW” to differentiate them from other MOS objects. 

4. Select the server name from the “Object AutoCreate” 
column drop-down box. A media object will be created with 
the slug of the planning object on your MOS server, and 
your MOS Status column will be updated. Once a 
Newsgathering Grid is MOS Active, its List Window icon 
changes to reflect that is MOS-enabled. 

5. Double-click a Newsgathering Item’s slug to open it. 
Click on the magnifying glass icon to switch between the item’s story planner and 
the MOS object associated with the Newsgathering Item. This story planner can 
be used to store general details about the news story and assignment editors can 
use it to write basic outlines of stories which can be cut and pasted into 
Rundowns later. When a MOS object is auto-created from the planner, the MOS 
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item reference is automatically placed into this story in the appropriate 
Newsgathering Grid line. 

When the ENG feed is ready to be taken, the media manager would route the 
incoming feed to the pre-named object on the media server. If the MOS vendor's 
application supports it, it would be possible to simultaneously log the feed, and 
that metadata would also be passed to ENPS, where it would all be instantly 
indexed and searchable. 

It is also possible to log the incoming feed on the story portion of the planning 
item from ENPS, using Ctrl-; to insert time of day logging notations. In the 
Newsgathering Grid, the MOS Status column would reflect when this feed was in 
or "Ready." Your target MOS device must support the MOS Object AutoCreate 
process for this to work. 

As with MOS pointers in all stories, you can click on the MOS Item reference and 
see the item that has been fed in. This is dependent on the capabilities of your 
MOS-enabled broadcast hardware.  

If the Newsgathering Grid will be used as a central location for daily items such 
as local stories, local feeds, satellite feeds, etc., then it will be necessary to 
create "categories" in the planner for today’s stories, tonight’s stories, feeds, etc. 
This can be accomplished by making the "break" column a NG and RO column 
as above. Use the breaks to separate groups of items in your planner: 

 

When a media manager or satellite feed manager opens ENPS to see the media 
object, they will also have access to all the feed booking information which is 
already carried on the planning item. And they will be able to use a search to 
quickly find both the assignment planning items and their associated MOS clips. 
Note that the MOS clips are returned both on the "story" portion of the NG item 
and individually in the List Window. 
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In the example shown here for "ENG or SAT,” a search returns the 
Newsgathering Grid or assignment items with embedded MOS references, along 
with the MOS objects that have been pushed to ENPS.  

Writers, reporters, and Producers are also able to use a search to return these 
planning items, see all the associated editorial information, and to click on the 
MOS item reference to see the "raw" feed, by starting the vendor-provided Active 
X module in the lower ENPS edit window. That module should also allow users to 
see any metadata created when the item was ingested. 
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Chapter 14  

Generic Grids 
Generic Grids can be used as a scratch area where you can create phone lists, 
expense sheets, and more. Group Administrators can create a Generic Grid for 
their Group by selecting Group Folder rover → New → Grid. Personal Generic 
Grids can be created by selecting Personal rover → New → Grid. 

To enter information into a grid cell, highlight the cell and start typing. If you type 
into a cell that already contains text, that text will be overwritten. If you start 
typing and want to cancel the operation and retrieve the replaced text, press the 
ESC key. To edit existing text, highlight the cell and press Backspace. Press 
Ctrl+Enter to go to a new line. 

To change the column heading of the grid, select Grid rover → Edit column 
headings. You can then type in the red column heading an appropriate title for 
the information in that column. You can move to the next cell by pressing Tab. 
Press Shift+Tab to move to the previous cell.  

Add or delete rows by clicking on the New row or Delete row buttons. Add or 
remove columns by selecting Grid rover → New column or Grid rover → 
Delete column. You can save the Generic Grid as a template by selecting Grid 
rover → Save as template to make it available to other members of your group. 

You can paste information from a Microsoft Excel spreadsheet into an ENPS 
Generic Grid. First open the spreadsheet you want to copy from in Microsoft 
Excel. Select the range of cells you want to copy and press Ctrl+C. 

 

Open ENPS and create a new Generic Grid. Press Ctrl+V to paste the 
Microsoft Excel information into ENPS. You will see the following options: 
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Paste text to grid cell: The cells of the Excel spreadsheet cells will be pasted into 
a single cell of the Generic Grid. 

 

Paste table over grid: The cells of the Excel spreadsheet will be pasted into the 
corresponding cells of the Generic Grid. 

 

Paste table to replace grid: The cells of the Excel spreadsheet will completely 
replace all of the Generic Grid. 
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Section III 
Hardware Control  
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Chapter 15 

Sending Rundowns to the Prompter 
To enable prompter control from your workstation, your station’s System 
Administrator will first need to update your local ENPS.INI with the appropriate 
settings from the ENPS Operations Guide. Your System Administrator will also 
be able to help you connect a prompter to ENPS using the MOS protocol. 

Once your ENPS.INI has been modified and ENPS 
is restarted, you will have an option from the 
Rundown rover that says Dump to [Prompter 
Name].  

The person assigned to load the supers for each program should select this 
option on the assigned workstation. As with the prompter, only one workstation at 
a time should be driving the character generator during any one program. 

The prompter will reflect changes made from any workstation, but only so long as 
there is a connection open between that Rundown and the prompting system. 
Only one workstation at a time should be driving and prompting the same 
program. The Rundown must be kept open. Closing the Rundown will prevent 
ENPS from updating the prompter with any changes. 

ENPS also controls automation and playback systems, although their features 
and usage guidelines vary by device and are documented separately. If an 
associated ENPS device such as a prompter or character generator is active, a 
lightning bolt icon at the lower left of the Rundown indicates a working 
connection.  

Using a Prompter Connected with MOS 
If your prompter is connected to ENPS via MOS you will send your newscast to 
the prompter as follows:  

Select Rundown rover → Properties and make sure that the MOS Story Send 
checkbox for your prompter is checked. Then select the MOS Control Active 
checkbox. It is recommended that you select these options in the Rundown 
template so that you will not have to select them for every new Rundown. 

You can send the newscast to multiple prompters by selecting more than one 
device in the MOS Story Send list.  
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Chapter 16  

Working with Character Generators 
Once the System Administrator has completed the CG installation and 
configuration steps in the ENPS Operations Guide, you can complete the steps 
in this chapter to start using your CG with ENPS.  

The instructions in this section are for CGs connected to ENPS through a serial 
cable. If your newsroom is using a CG that connects to ENPS using the MOS 
protocol, you will enter CGs through a separate window by clicking on the Media 
icon rover and selecting the CG device you want to use. Refer to your CG 
manufacturer’s documentation for more information. 

Step 1: Creating CG Templates 
You must have sufficient security privileges to create and edit CG templates in a 
folder. If you need Group Manager privileges, contact your System Administrator 
or Group Manager.  

If the same template is needed in multiple folders, your System Administrator can 
create copies for you on the server level by completing the steps in the 
“Character Generators” section of the ENPS Operations Guide. 

1. Select Story rover → Character Generator or press Ctrl+G to open the CG 
Templates box. 
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2. To create a new Template based on an existing Template, highlight the 
existing template, click Copy and rename the new template. Click Design to edit 
the new copy. To edit an existing Template, highlight it and click Design. 

3. To create a new Template, click New and enter a description. This description 
will also be used as the Template name. Enter the corresponding Template 
number from the CG device into the Template Number box. 

 

• On Chyron devices, except Codi, the Template Number must be a four-digit 
number (i.e. 0010).  

• For Chyron Codi, there is no Template Number since the Templates are kept 
entirely within ENPS.  

• For Type Deko machines, the Template Number can be any Windows 
filename, without the file extension (i.e. if the Template in the Deko is called 
Name CG.dko, it is entered in ENPS as “Name CG”).  

• For Aston devices, the Template Number should match the numeric page 
number in the Aston. 

Check the Program Default checkbox to make the current template the default 
CG template for the current Rundown. 

If you are using ENPS Stats to post election results to your CG you can use the 
Alternate template dropdown box to select another template to use if the primary 
template will not work. For example, if a race is sent to the “Fullscreen” template 
but contains image tags, that race can be passed to a linked template “Fullscreen 
with Headshots.”  This linking can only be done to one race, and attempts to link 
beyond that will break the original link. 

4. Click OK in the Template Definition box to open an empty CG Designer box.  

Step 2: Using the CG Designer 
The CG Designer allows you to enter two types of fields in each template: entry 
fields and label fields. White boxes are entry fields that correspond to the tab 
fields in the CG device. The gray boxes are Label fields and should only be used 
to instruct users on what type of information they should type in an entry field and 
on any special formatting information. Label fields are not displayed on screen as 
part of the CG, except in the Chyron Codi.  
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You should lay out your Template as a visual representation of what the finished 
super will actually look like on screen.  

1. To create your Template, first position the red dot where you want to place 
your Entry or Label fields by clicking anywhere in the template box. Next, click 
the Entry or Label button to place the field. Now, click and drag the field to adjust 
its position. 

2. To adjust the size of Entry and Label fields, hold down the Ctrl key and press 
the up, down, left or right arrow keys. Try to size your Entry fields so what fits in 
the box will fit on screen and vice versa. This may require some experimentation. 

3. The Delete button will remove the selected field from the CG Template.  

4. The Test button allows you to test the Template. Note: You must type test data 
into the entry fields and have a corresponding Template created in the CG for the 
test to work. 

5. The Properties button will show you either the CG Template Definition box, if 
you click anywhere in the gray area of the CG Designer box, or the Properties 
box (next page), if you click in an Entry field. 
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For CG devices other than Chyron Codi, you can assign the tab order and 
maximum number of characters allowed in the Entry field from the Properties 
box.  

For the Chyron Codi, you can assign the color, font, justification, tab order, 
maximum number of characters allowed in the Entry field, and crawl functions 
from the Properties box. 

Step 3: Using Templates 
1. To enter CGs into a story, select the Character Generator option from the 
Story rover, or press Ctrl+G. This will bring up the CG Templates box. 

2. To find the template you want, scroll down the list or type the first character of 
the template’s name. 

3. If you want to enter multiples CGs using the same template, enter the number 
of CGs desired in the Number of CG captions to insert box. Then use the left-
right arrow buttons to step through the CG templates. 
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4. Enter your CG information into the appropriate fields. Enter super times in the 
In time and Out time boxes, and then click OK. The finished CG Template will 
look like this: 
[CG in 12:05 to 12:25:3 Line Full Screen\Downtown Fire\Main 
St. Closed\5 Cities Respond\Possible Arson] 

Note for Chyron Users: The quote (“ “) key positions on a Chyron keyboard are 
different from the positions on a Microsoft keyboard. Chyron maps their quote 
keys to the < and > positions of the Microsoft keyboard. So you must use the < 
key for an open quote and the > key for a close quote. Otherwise, your quotes 
will not come up correctly in the CG. This is how CG commands will appear in 
your story: 

CG commands can only be updated or edited by double clicking the CG 
command, or pressing Alt+E, to recall the CG Template box. This is true for any 
command in red type. The finished super example would look like this: 

 

You can also build Templates to call up pre-made CGs that do not require entry 
fields. To create a CG with your anchor’s name, for example, the CG Template 
boxes would look like this: 
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Use the label fields to describe the CG being called up and the person’s name as 
the template name. It would look like this in a story: 
[CG in at 0’01’’ out at 0’08’’:Christopher LaCroix] 

Note for Chyron Users: For the above steps to work in a Chyron (iNFiNiT!, 
MAX!> or MAXINE!), you must have one tab field on the CG page in the Chyron 
for ENPS to recognize it as a CG Template. Create a tab field on the CG page in 
the Chyron (using an empty row) that does not have Template configurations. As 
an added precaution, you can move this row completely off the page. ENPS will 
then recognize this as a Template page and include it in its CG list for recall 
during your newscasts. RGB messages (Chyron graphics) can be called up by 
creating an ENPS CG template called “RGB Composite” (you cannot use a 
different name), with a four-character entry field. When you are entering these 
CGs into your Stories, enter the four-character page number of the RGB page to 
be called up in the CG device. This only works if the System Administrator has 
modified the local ENPS.INI to reflect the setting Preload=0. This setting will 
not work with the Chyron Codi. 

Sports Scores Example 
Sports scoreboards can be created in your Rundowns early in the day, then 
quickly and easily updated as the scores come in. Double click on the CG in the 
story to reopen the CG template and update your scores. 
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You can highlight the winners by character mapping an image to a rarely used 
key in the CG font set being used for the team names.  

 

For example, we character mapped a ball to the asterisk * key in this example. 
The football will be inserted wherever you type *. You can use this technique in 
other situations as well (i.e. for adding bullets to full page CGs). 

The updated CG template in the story would look like this: 
[CG :COLLEGE\Stanford Cardinals\14\Final\Cal Bears *\28\Navy 
*\17\Final\Army\10] 

The final scoreboard example would look like this: 
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Step 4: Enabling CG Control 
1. If the Preload option is set to 1 in the ENPS.INI, you can select Rundown 
rover → CG Device Control. The Preload option will load the supers into your 
CG device and generate a dynamic CG list for the operator. Press the + and -- 
keys to cycle through the rows of the CG Device Control window. 

 

2. Select CG Device Control Rover → Set CG Directory. 

 

3. Select the CG directory you wish to use from the drop down list. 

4. ENPS can also be configured to control the CG device directly. System 
Administrators can refer to the ENPS Operations Guide for more information on 
configuring CG control within ENPS. 
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Chapter 17  

Introduction to MOS  
Media Object Server Communications Protocol (MOS) and ActiveX plug-in 
controls (“Media Controls”) allow the newsroom server to communicate directly 
with Media Object Servers, such as video servers, archive devices, still store 
machines, character generators, and other equipment. 

Remember that MOS systems vary from vendor to vendor, so you will need to 
learn what works with your particular setup. Some MOS systems, for example, 
will not work with multiple playlists, and other systems will not function properly 
when you toggle the MOS Ready to Air flag. Be sure to use the information in this 
guide in conjunction with the documentation from your MOS vendor. 

Using MOS, ENPS keeps track of what media objects (video, audio, still store, 
CG, etc.) reside in a Media Server and the status of each object. Through MOS, 
the Media Server also knows the order in which to play those media objects in a 
Rundown, even if the Producer changes the Rundown during a show. Here are 
some things MOS allows you to do using your ENPS workstation: 

Search the Video Server, Still Store or CG  
Use ENPS to search a single device or create a general search in which ENPS 
searches all MOS-enabled production devices, as well as stories and 
assignments stored in ENPS. ENPS will return a list of objects that meet the 
search criteria.  

You can view any object you find by double-clicking on it or by dragging into an 
Editor Window. If there is a media device’s media plug-in available, you must 
have it installed on your workstation. Contact your System Administrator if you do 
not have the plug-in.  

Using MOS Objects to Create Sequences 
A MOS object can be dragged into stories regardless of whether it is inside or 
outside of a Rundown. Once a story is in a Rundown, ENPS creates a playlist of 
all media objects. 

When you build your Rundown, the ENPS Server uses this information to build 
the playlist in each Media Object Server. Each media device operates according 
to protocols set by its manufacturer. It can be controlled manually by a Technical 
Director, CG Operator, or Prompter Operator. It may also be controlled directly 
by an automation system. 

Because ENPS establishes a dynamic link between the Rundown and Media 
Server using MOS, a Producer can modify the sequence of the show while on 
the air and the Media Object Server operator or Director can immediately see the 
change. 

MOS devices may restrict changes to the playlist that occur too close to the time 
an object is set to air. Refer to the MOS device’s operating instructions for more 
information. 
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View the Status of Equipment During Live 
Production 
MOS also allows the Producer to see the status of all Media Objects in a 
Rundown. Producers can see whether a clip has been filed, if it is ready for air, 
and track the finished time of video or audio pieces – all from the ENPS 
Rundown. This can be done before, during, and after live production and is 
useful in situations when stories are being produced during the show.  

This diagram illustrates the structure of the MOS system: 

 

Media Controls 
Media Controls, or ActiveX Controls, allow third-party vendors add the 
functionality of their applications into ENPS. The appropriate Media Control 
software will need to be installed on your workstation before it is possible to view 
MOS Objects by double-clicking on them in the ENPS List Window. This software 
will be provided by the Media Object Server vendor. If you attempt to view a 
MOS Object on a workstation that does not have the appropriate software 
installed, ENPS will display the message “Media Control not Available”. 

Click on the Media Control rover at the bottom of the ENPS screen and choose 
from the list to run other controls. Some Media Controls are run automatically 
when you click on certain types of objects.  
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By default, the ActiveX will run in the lower Editing Window. However, you might 
want to open an ActiveX in a separate window. For example, if you have two 
monitors and you want to run ENPS on one monitor and a video editing program 
in another, you can set ENPS to run ActiveX controls in a separate window. To 
do this, follow the following instructions: 

1. Close the ENPS client if it is open.  

2. Open the file C:\Documents and Settings\All Users\Application 
Data\ENPS\ENPS.INI in Notepad. 

3. In the section labeled [ENPS], add the line DetachedActiveX=1. 

4. Save the file. 

5. Start ENPS. 

The next time you start an ActiveX control, it will appear in a separate window. 
You can open a maximum of three ActiveX controls at a time. After the first 
Active X device, the windows will be accessible by hitting the Tab key across the 
top of the ActiveX window. Here are some things you can do with ENPS and 
Media Control: 

View and Edit Material on the Desktop 

Editing Plug-Ins are provided by Video and Audio Server manufacturers much 
like printer drivers are provided by PC printer makers. When you buy a video or 
audio server the manufacturer may provide you with an ActiveX plug-in to allow 
you to view and edit material on the server from within ENPS. Some 
manufacturers provide plug-ins for free; others charge for them. Contact your 
vendor for details. 

Facility Control and Automation Systems 

Automation Vendors also supply ActiveX plug-in controls for their systems that 
enable users to insert automation commands in stories and, in some cases, 
control machines directly. Please see your vendor for more details. 

Surf the Web 

ENPS comes with a Media Control that turns the lower ENPS Editing Window 
into a simple Internet Explorer Web Browser. You can open the ENPS Web 
browser by selecting Media Control → Internet or by double-clicking on a Web 
address in a story or wire story if URL detection has been enabled by your 
System Administrator.  
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Material can be cut and pasted from a website into ENPS stories and 
assignments without needing to switch between ENPS and a separate browser 
application. 

Other Functionality 

Media Controls are “Windows” in ENPS to other applications and functions. 
Other applications can run on the journalist’s desktop as if they were a part of 
ENPS, such as WinTV. It is possible to create custom controls that provide 
desktop access to routing switchers, ENG antennas, external databases, 
archives, etc. If you have a need for such a control, please contact your System 
Administrator, equipment vendor, or AP Broadcast Technology. 
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Chapter 18  

Enabling Objects for MOS 
Your System Administrator must complete the MOS configuration steps in the 
ENPS Operations Guide before you can use MOS in ENPS. To start using MOS, 
you will need to complete the instructions in this chapter to create story and 
Rundown templates that are set up to use the protocol. The next chapter, Using 
MOS and Media Controls shows you how to use those templates for live 
productions. 

Step 1: Creating a MOS-Enabled Rundown 
Template 
Several columns are available in the ENPS Rundown for programs using MOS. 
These columns display information about each Media Object contained in every 
story in the Rundown. 

Not all MOS information available in these columns is appropriate for all users or 
installations. Please coordinate with your engineering department and ENPS 
System Administrator before using them.  

The following table contains a list of MOS columns and their descriptions. To add 
a particular column select Rundown rover → Layout → Add Columns.  

Name Description 

MOS Abstracts Short summary of the media object. 

MOS Channels Channel assigned to this particular Object for playback. 
The channel assignment is by default left blank. To 
assign a specific value click on this column to display 
an input grid. 

MOS Editorial Time  Desired running time of the MOS Object in the 
program. This value may be different than the MOS 
Object Time. For example, this may occur in Voice 
Over items or where packaged reports have extra shots 
at the beginning or end. This may be entered manually 
when a MOS Object is edited, if manual editing is 
supported by the MOS vendor. Duration is added to 
overall program time. 

MOS ID MOS device that contains the clip. This is useful to 
include in Rundowns where multiple Media Object 
Servers are in use. 

MOS Item Slug Name of this instance of the MOS Object or Clip. The 
MOS item slug is created when you drop a MOS Object 
into a story. The name given by default is the ENPS 
story name with a number appended that indicates the 
sequence of the object within the story. The number is 
added only to create a unique name. This number may 
not remain a valid indicator of the position of the Item in 
the story. The most accurate indication of sequence is 
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the order the object appears in the Rundown window. 

This column may contain entries to launch ActiveX 
controls, such as a CG modal control, without having to 
open each story and click on the MOS Item reference. 

MOS Obj Slug Name of the Object or Clip as named on the Media 
Object Server. You cannot change this column from the 
ENPS Rundown. It is generated by the Media Object 
Server. 

This column may contain entries to launch ActiveX 
controls, such as a CG modal control, without having to 
open each story and click on the MOS Item reference. 

MOS Object Time Length of video or audio media objects stored on the 
Media Object Server. As the MOS sends updated 
duration times of individual objects to ENPS the time in 
this field will be updated. For example, as an editor 
changes the duration of a package from 1:15 to :59 you 
will see the time in this ENPS Rundown column change 
by sixteen seconds. By default, this duration is not 
normally added to overall program time, unless enabled 
by your System Administrator. Refer to the MOS Timing 
section in Chapter 9, Rundown Timing. 

MOS Status Status of the Item as reported by the MOS. The MOS 
device might send messages such as “Not Filed” 
“Ready” “Playing” “Stopped” and “Not Ready” in this 
column. Producers can track the progress of production 
material during the show and make decisions to move 
or dump stories based on this real-time status. This 
information is displayed only when the Rundown has 
the MOS Control Active flag set in the Rundown 
properties. 

MOS Time Time the Media Object was last updated on the Media 
Object Server. 

MOS User Duration Click on this column to view a list of MOS item 
references in a story. You can enter the number of 
seconds you want added into the Rundown timing. For 
example, if you had a voiceover and a sound on tape, 
you might enter:  
Item 1 (vo)  00 
Item 2 (sot) 25 

The overall timing is not affected by the duration of the 
voiceover but it is affected by the time of the sound on 
tape.  For MOS-enabled systems test off-line with your 
MOS vendor to ensure proper operation. According to 
the MOS protocol the MOS device should ignore any 
tags it might not understand, but it is important to know 
your MOS device will do so before putting this into 
production. 

Object AutoCreate You can set a property of a story template so that when 
a story created from that template is created in or 
moved to a MOS-active Rundown, a media object will 
automatically be created on the target MOS (your MOS 
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vendor must provide support for this feature). Refer to 
Step 2: Creating a MOS-Enabled Story Template below 
for more information. You may use this option to create 
individual MOS objects on the MOS server. 

Object Group Displays the name of the sub-folder on the server 
where the media object is saved. This is useful to know 
in case you want to copy the clip from one location to 
another. 

Object Placeholder When you click on this column, you will get a table from 
which you may specify:  

• The MOS device in which you want to create the 
placeholder. 

•  The object type, e.g. audio, video, still. One may be 
set as a default in the global MOS configuration table.  

•  The object group tag, e.g. VO, SOT, PKG. as 
outlined above. 

• Name of the new MOS object. If no name is specified, 
the name of the placeholder is taken from the MOS 
Abstract and Segment name such as: 
[<mos>School Taxes-SOT :45</mos>] 

For instance, you may wish to place all MOS Video Clips into Stories with a 
default “blank” channel assignment. The Video Server might automatically assign 
channels in a default, or the MOS operator may wish to go back and manually 
assign channels. 

ENPS does not provide any input validation or range checks on these values. It 
is possible for a user to input a value that the Media Object Server does not 
understand. You should work with your engineering department to determine 
what values are allowed. 

A typical Rundown in a MOS environment might include the MOS Object Slug, 
MOS Status and MOS Object Time and/or MOS Editorial Time, depending on the 
configuration. The desired columns should be included in Rundown Templates. 
Additionally the Media Object Server operator may wish to have additional 
columns, such as MOS ID and MOS Channel in their personal Rundown view. 

Once you add a MOS object to a story in a Rundown, simply double-click in 
either of the MOS Object Slug or MOS Item Slug column to view the MOS item 
directly from the Rundown. This is primarily for use with modal controls. For 
example, if a CG vendor provides a modal control, it would be possible to 
preview all CGs in a newscast with the Rundown full-screen, without having to 
open each story and click on the MOS item reference. This feature is also 
enabled for special one line MOS object slug display columns of the type typically 
used to display the slugs of summary MOS objects. 

Refer to “Saving a layout” in the Layouts and Views chapter of this guide for 
instructions on saving your Rundown as a template.  
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Recurring MOS Objects 

MOS objects that will be included in multiple stories but will not otherwise change 
should be marked as Recurring MOS objects. These may include title theme 
music, a clip with a show open, or video with a bump to break. You cannot 
include the same MOS object more than once in a story. To repeatedly play back 
to back objects, create multiple sequential stories with the MOS object appearing 
once in each story. 

 

If the object is not set to Recurring, after several hundred iterations, you will see 
degradation in the server performance. Recurring MOS objects may be included 
in Rundown Templates. Select the appropriate object in the ENPS List Window, 
then select List Window rover → Set as Recurring MOS object. When set, 
ENPS will not keep track of stories in which the object appears and will not reflect 
object updates through to story item references. 

Step 2: Creating a MOS-Enabled Story Template 
This step is optional. Complete this step if you want a copy of the MOS 
information included with the story properties.  

The MOS fields available as Rundown columns are also available as story fields, 
allowing journalists to quickly view information, such as duration and status, 
about the MOS object(s) contained within their story, without needing to refer to 
the Rundown. Click on the magnifying glass (Alt+P) in the story to view the 
fields.  

Add each of the MOS fields you will need for your story. For information on how 
to add fields to your story refer to Creating Story Template chapter of this guide. 

 

Full information is displayed only in stories that are included in a MOS Active 
Rundown.  
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You can set a property of a story template so that when a story created from that 
template is created in or moved to a MOS-active Rundown, a media object will 
automatically be created on the target MOS (your MOS vendor must provide 
support for this feature). To enable this feature, complete the following steps: 

1. Select Third Folder rover → Group Maintenance → Story Templates. Open 
a story template, or create a new one and select Layout → Add/remove/move 
fields, and drag the field "Object AutoCreate" above the black bar. You can drag 
additional fields above the line as needed. Click OK when you are finished. 

2. Click on the magnifying glass on the story template to view the fields or press 
Alt+P. In the Object AutoCreate field select the name of the server you wish to 
use. These servers are designated by the System Administrator.  

3. Save and close the story template.  

4. Create a new story from the template you created above and drag it to a MOS-
active Rundown. 

When automatically creating items as outlined in the steps above, the 
AutoCreate Rundown will prompt the user to enter the story slug prior to 
completing the AutoCreate action.  

It is also possible not to have the Story AutoCreate field pre-filled in the story 
template, in which case you may create a line in the Rundown and later choose 
the MOS on which you wish have the item automatically created.  
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Chapter 19 

Using MOS and Media Controls  
After creating a MOS-enabled Rundown and MOS-enabled story, you are ready 
to add MOS objects. 

Step 1: Finding MOS Objects 
MOS objects are stored in ENPS much like stories, Rundowns, assignments and 
Wire copy. MOS objects are stored in special Folders that contain only MOS 
objects. Do not change or delete MOS objects in these folders.  

To find media objects created since 12:00 a.m. select Group Folder rover → 
Today's MOS Items in any MOS-enabled folder. You can browse the Folder to 
locate the required MOS object, or perform a search. Searches have the 
advantage of matching any descriptive metadata text attached to the MOS object 
as well as its title. 

For example, when a photographer returns from the field and loads a video clip in 
the Video Server, the server may require the photographer to enter a brief 
description of the clip before the clip is saved – such as a shot-list, location 
details or the names of interviewees. This information may then be used for 
searches. 

It is recommended that you allocate certain folders to be used only for MOS 
objects. Users should have only Read Only privileges to these locations. No one, 
including Group Managers or System Administrators, should delete objects from 
a MOS objects folder; remove them directly from the Media Object Server. Do 
not assign MOS devices to News or Desk folders. 

ENPS User Privileges control access to MOS objects in the same way as other 
items in ENPS. Users authorized to view MOS objects and add them to stories 
within ENPS should be granted “Superviewer” (or equivalent) security privileges 
in Folders containing MOS objects. 

Users should not have privileges that allow them to manually add items to this 
Folder, nor manually delete MOS objects. The Folder contents should be 
updated only by the MOS device and the Folder should not contain other ENPS 
items such as stories or Rundowns. 

Users who will need to set the MOS Control Active flag for a Rundown containing 
MOS objects will require Producer privileges or higher in the Rundown folder. 

Step 2: Adding Video, Still Store or CG Objects to 
Stories 
ENPS allows MOS objects to be included in stories via drag and drop. You can 
drag MOS objects from anywhere you find them in ENPS, including the List 
Window, from within another story, or from a vendor provided Media Control. 



 

The Associated Press  77 
 

You can drag multiple media objects into your story in two ways. To add a group 
of consecutive MOS items from the List Window click the first item, hold down the 
Shift key, click the last item, then drag the group of items into the story. To 
select non-consecutive MOS items hold down the Ctrl button while you click 
each item. 

You should drop a MOS object into a story at the point you want to play or 
execute it. Generally, MOS objects are dropped into empty lines between text in 
a story to make for neater screen displays and printed copy. 

A MOS object can be added to a story from any workstation. It is not necessary 
for any additional media control software provided by a vendor to be installed. 

You may see the MOS objects appear in the story as either a single line 
reference to the MOS object containing the MOSAbstract: 

 

If you select Story rover → Layout → Show commands you will see the full 
context of the MOS object tag: 

 

To hide the full context, select Story rover → Layout → Hide commands. 

It is possible to edit the MOS Channel when a story is open for editing. This 
allows Producers and Directors to change playout channels even when a writer is 
still working in a story by clicking in the MOS Channel column and making the 
desired change. The MOS tag change will be applied after the story is closed. 
Until then, an asterisk will appear in the MOS Channel column. In addition, some 
MOS devices can make changes to the MOS properties of a story. See your 
MOS device user’s guide for more information. 

MOS objects appear on the left side of the two-column printout when a story is 
printed in two-column format. MOS objects will not appear in the prompter. If you 
want to see the full context of MOS objects in stories, click the Printer icon and 
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select the option Show MOS commands as thumbnails. Click Save as Personal 
Defaults to save this preference for future printouts. 

ENPS will not allow you to type a clip name directly. You will not find a menu 
option from which you can enter a clip name or ID and have it included in a story. 
Users must always drag and drop the MOS object into the story. This negates 
the need to retype clip names and IDs from another list and the danger of “typos” 
that go along with manual entry. 

MOS objects can be dragged into stories already in a Rundown or placed in 
stories which are then added to the Rundown. You can also create a blank story 
that only contains a MOS object.  Each story may contain any number of Media 
objects, and objects of any type. For instance, a story may contain MOS objects 
for two video clips (VO and SOT), two CGs (locator and name), and a Still Store. 
This would be a total of five MOS objects placed in the story. When this story is 
placed in a Rundown ENPS will make sure these objects are appropriately 
sequenced in the Video Server, the CG, and the Still Store.  

You cannot include the same MOS object more than once in a story. To 
repeatedly play back to back objects, create multiple sequential stories with the 
MOS object appearing once in each story. 

If you have only one MOS video server, for example, and you are using more 
traditional control methods for your CG and Still Store, you can mix the newer 
MOS objects with the older production commands needed by the CG and Still 
Store in the same story. 

Step 3: Set the MOS Control Active Flag 
The MOS Control Active flag links the ENPS Rundown to the Media Object 
Server. This flag is set in the Rundown’s Properties Dialog, accessed from the 
Rundown rover. 

 

Click on the MOS Control Active box. This enables several things: when this flag 
is initially set, a playlist in each relevant Media Object Server is built, based on 
the objects or Clips that appear in ENPS Rundown stories. 
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Thereafter, changes made to the ENPS Rundown are immediately reflected in 
the Media Object Server playlist(s). When an object or clip is modified or 
changed in the Media Object Server an update is sent to the ENPS Rundown. 
Stories contained in the Rundown are automatically updated with the current 
duration, etc. Objects and Clips contained in the Rundown are “protected” in the 
Media Object Server, preventing them from being accidentally deleted or purged. 

Status information is sent from the Media Object Server to ENPS. Status 
messages such as “Ready” “Play” and “Stop” are reflected in the Rundown in the 
MOS Status column. Status messages are only updated in Rundowns marked as 
MOS Control Active. 

Loose stories, stories in personal storage areas, and stories in Rundowns not 
marked MOS Active are not updated with changes made to the object in the 
Media Object Server and they are not automatically protected from being purged 
from the Media Object Server. 

When the MOS Control Active flag is set ON in the Rundown Properties, a MOS 
icon is displayed in the lower-left of the Rundown as a visual indication. In 
addition, the MOS symbol appears in the Rundown icon in the List Window. 

If you have a Template you use for recurring shows, it is possible to set the MOS 
Control Active flag ON in the Template. Rundowns created from the template will 
automatically have their MOS Control Active flag set. MOS objects and clips 
included in the Rundown will automatically build playlists in the Media Object 
Servers, without requiring a Producer to remember to set the flag ON. 

Server Updates 

Media Object Servers continuously update ENPS with the most current 
information about each object or clip they store. If the duration of a clip changes, 
the Media Object Server will advise ENPS that the object has changed and 
ENPS will update stories and Rundowns with the new information. Even if a story 
is locked while being edited by a specific user it will be updated. Depending on 
site-specific configuration, ENPS can also use the duration of each object to 
automatically compute and update timing in a Rundown.  

Status information and updated MOS object information is only displayed in 
Rundowns and stories when the “MOS Control Active” Rundown Property is set. 

Status Messages 

Status information reflected in the “MOS Status” column of ENPS is received 
from the Media Object Server in near real-time. Typically, it takes less than a 
second for a message to travel from the Media Object Server to the user’s 
workstation. ENPS displays each status message exactly as it receives it from 
the Media Object Server and does not interpret this information other than to add 
highlighting and color emphasis to routine messages. The messages you see in 
this column come from the Media Object Server, not from ENPS. 

The meaning and description of each message is specific to each server type 
and server manufacturer. Users should consult their Media Object Server vendor 
for a list of messages and definitions. 
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Step 4: MOS Ready to Air  
Before the Media Object Server playlist can be executed on-air, the Producer 
may need to set the MOS Ready to Air flag. The exact behavior of this switch 
depends on the configuration used by your MOS vendor.  

This setting reflects the Producer’s approval to signal the Media Object Sever to 
air the contents of the Rundown, such as the audio, video, and still store. 

 

Select Rundown rover → MOS Ready to air.This only tells the Media Object 
Server that it may play, on air, the clips contained in the playlist created by the 
Rundown. This is a final check to make sure material played on air has been 
reviewed and approved by the Producer.  

Some Media Object Server vendors may not implement this optional feature. If 
this is the case, once the MOS Control Active flag has been set, the playlist can 
be executed to air at any time. Vendors may interpret this flag in different ways. 
Please check with the Media Object Server vendor for specifics. 

Step 5: Using MOS for Live Productions 
When an ENPS Rundown’s is set to MOS Control Active, the Rundown is 
dynamically linked to a playlist built in the Media Object Server. As stories that 
include Media objects (clips) are added to the ENPS Rundown, these media 
objects are simultaneously added to the Media Object Server playlist. As the 
order of Stories is changed in ENPS, so is the sequence of media objects in the 
playlist. 

The Media Object Server operator uses the playlist, via a control screen provided 
by the vendor, to cue and take objects to air during the show. 

When a story is moved in ENPS all of the objects contained in that story are also 
moved in their associated playlists, even if objects of more than one type are 
included in the story. For example, if a story contains still store, CG, and video 
objects and the Producer moves it from the first block to the third block, all of the 
still stores, CGs, and video clips are also moved. The playlists in all three MOS 
devices are automatically and immediately updated to reflect the new story order. 
Typically this move will take less than two seconds. 

Though ENPS will build the proper sequence of objects in each device’s playlist, 
it will not take them on air. A Media Object Server operator or Facility Automation 
and Control System must use the playlist to air or execute objects. 
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Producers and Directors may wish to change the order of objects (clips) during 
execution of the show. Some vendors place a time limit on the ability to make 
changes just before an object is played. The time limit varies from vendor to 
vendor. Please see your engineering department for specific information. The 
Status Messages displayed in the Rundown will probably give you some 
indication as to when a change is not allowed. 

If you are moving items during a show it is recommended that you first float the 
story or stories to remove them from the MOS playlists, move them, and then 
unfloat the stories to reinsert them in the playlist. 

Step 6: Breaking the MOS Link 
Only one machine can set the MOS playlist to control the order that items will 
play. Under normal circumstances this is ENPS. ENPS will create the playlist in 
the Media Object Server, update it, and eventually delete it when the show is 
complete or archived. 

Under extreme circumstances it might be necessary for a Media Object Server 
operator or other person to take direct control of a device’s playlist in order to 
immediately and directly change the order. For instance, it might be necessary 
for a MOS operator to change the order of the Video Server’s playlist if ENPS 
failed. In this unlikely event, the MOS operator would use the vendor’s control 
screen to directly sequence the Video Server’s playlist until ENPS functionality 
returned. This is a manual, failsafe operating mode, not intended to be routinely 
used. 

If this mode is used, if changes are made directly to the Media Object Server 
playlist and not through ENPS, ENPS will detect this and break the control link 
with the Media Object Server. This is to avoid having ENPS “fix” a change in the 
playlist made directly by an operator. 

The link between ENPS and the Media Object Server can be re-established 
quickly, but requires the Media Object Server be taken off line for a brief period, 
such as during a commercial break. The resynchronization procedure takes only 
a few seconds, but involves deleting the playlist and rebuilding it. In many 
systems if the playlist is deleted while an object is being played to air, the object 
will stop or be otherwise disrupted. 

Some Media Object Servers can be resynchronized without being taken offline. 
See your vendor’s instructions for details. 

CAUTION: Do not perform this procedure during a live production. It may cause 
the server to stop and take programming off the air. You will need to manually 
step through the Playlist if your MOS connection is broken during a live 
production. 

If you must manually resynchronize the ENPS Rundown with the Media Object 
Server playlist, complete these steps: 

1. Select Rundown rover → Properties and turn the MOS Control Active option 
off. Click the Apply button.  

2. Turn the MOS Control Active option on, then click Apply and close the 
Rundown properties window.  
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3. You must click Apply each time for the changes to take effect. This will delete 
and then reconstruct the playlist in the Media Object Server so that it matches 
the ENPS Rundown. 

When a show is complete the playlist will remain in the Media Object Server and 
updates will be sent to the Rundown until the Rundown is archived or the MOS 
Control Active flag is set off. Archiving automatically deletes the playlist in the 
Media Object Server and breaks the link.  

If you have a number of objects you wish to protect from automatic deletion, you 
can place these objects in Rundowns that are MOS Active. This provides a 
convenient place to organize the clips. It also creates a list of clips in the Media 
Object Server that can help with server administration and maintenance. As long 
as the objects live in a Rundown marked as MOS Active, they should not be 
automatically deleted or purged. 
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Chapter 20  

AP PrimeCuts and AP GraphicsBank 
AP GraphicsBank and PrimeCuts are ActiveX plug-ins for ENPS. For these 
features to work, your station must have a GraphicsBank or PrimeCuts license. 
In addition, your System Administrator must set up configure these utilities 
according to the steps outlined in the ENPS Operations Guide. 

AP PrimeCuts 
Open any AP wire story that includes a PrimeCuts MOS tag such as:  
[<mos>PrimeCuts Cut 234 </mos>]  

You can double-click the tag to play the audio through the PrimeCuts ActiveX.  

 

If you are writing a story and would like to include PrimeCuts audio, select Media 
icon rover → AP PrimeCuts and then select the audio file you would like to add. 

Control • Description 

 
Click the Get Cut List button (Alt+G) to grab any PrimeCuts 
MOS tags from the top Editing Window and create a Cut List. 

 
Click on the Add Cut button (Alt+A) to Open dialog window so 
you may add an audio file from your hard drive or network to the 
Cut List. 

 
Click on the Clear Cut List to clear the cut list. 

 The Previous button will play the Cut located above the current 
highlighted row in the Cut List. 

 The Play button will highlight and play the Cut located on the line 
that contains the cursor. 

 The Next button will play the Cut that is located below the current 
highlighted row in the Cut List. 

 With Loop Cut checked, the current playing cut will start over 
once it completes playing. 
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 With Auto-Advanced checked, the PrimeCuts ActiveX will 
advance to the next cut in the Cut List after the current cut is 
finished playing.  

 Loop All works in conjunction with the Auto-Advance check box. 
With this checked, when the last cut in the list is finished it will 
loop back to the top of the list. 

When you click on the Get Cut List button, a cut list view with a number of 
columns will be displayed.  

Column  Description 

Untitled The first column allows you to click and drag the cut to a story 
as a MOS tag. This will only work when you have saved the Cut. 
Once you save a cut the first column for that row will display a 
story icon . 

Title The title of the media file. 

Description The description of the PrimeCut. This field can be edited. 

Time When the Cut is playing it displays the time remaining for the 
Cut. When the Cut stops it displays the length of the Cut. 

Source The location of the media file. 

Save Save the file locally or on your network. Double-click to open the 
Save window. Once you save a cut the first column for that row 
will display a story icon . 

AP GraphicsBank 
GraphicsBank accounts are allowed a set number of downloads per month. All 
downloads after your allocated number of downloads are charged a fee. Contact 
your System Administrator to find out if your station has set up an account that 
lets you preview images and prevent unintentional downloading of images. 

Double-click on the GraphicsBank MOS tag [<mos>GraphicsBank Image 
812345 </mos>] in an AP wire story to activate the GraphicsBank ActiveX and 
display the image described in the wire story.  

If you want to search for a GraphicsBank item that is not linked to an AP story 
you can select Media icon rover → AP GraphicsBank and execute a search. 
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Search 

You can type in keywords or phrases just as you would on the GraphicsBank 
website. Once you type in a keyword or Image ID, click Go to display the results. 
You can also press Enter or Alt+G to execute your search. Notice the Add to 
Script section displays the keywords or Image ID.  

As you execute different searches, the drop-down continues to collect the 
keywords and Image IDs. This way you can return to a previous image or search 
results. 

Once the search results are displayed you can click on Preview button to the 
right of an image and the Add to Script section to display the Image ID. 

Add to Script 

This feature is used to add a MOS tag to a script. For instance, a Producer may 
want to add a number of GraphicsBank MOS tags to a script to form a graphics 
request sheet for your Graphics Department.  

There are two ways to add an image to your story. You can click the Add button 
and the MOS reference to the image will appear in the story that is currently 
visible in the Editing Window. This will place the MOS reference at the last cursor 
position in the story. Or you can you can click and drag the hand icon to 
select a position in the story where you want to place the item 
reference. 

Back and Forward Buttons 

When you execute GraphicsBank searches, the Back and Forward buttons will 
work in the same way as the Back and Forward buttons in a Web browser. You 
can also press Alt+B and Alt+F.  
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Chapter 21 

Troubleshooting MOS 
If you are still having problems with your MOS connection after you follow the 
instructions in this section, contact your System Administrator. The ENPS 
Operations Guide provides additional troubleshooting steps at the server level. 

Remember the following important points about how ENPS uses MOS: 

• Communication between the two systems is text-only TCP/IP XML.  

• No media, audio or video, comes into ENPS directly, just pointers to those 
objects. 

• ENPS has no control over what runs in the ActiveX Window, including 
keyboard shortcuts. 

What to do if the MOS connection is broken 
You will need to manually step through the Playlist if your MOS connection is 
broken during a live production. 

CAUTION: Do not perform the following step during a live production. It may 
cause the server to stop and take programming off the air. You can re-
synchronize the ENPS Rundown with the Media Object Server Playlist, open 
Rundown rover → Properties. Turn off MOS Control Active and click Apply, 
then turn it back on and click Go.  

You must click the Apply button each time for the changes to take effect. This 
action deletes and then reconstructs the playlist in the Media Object Server so 
that it matches the ENPS Rundown. 

When a show is completed, the Playlist will remain in the Media Object Server. 
Updates are sent to the Rundown until it is archived or until the MOS Control 
Active flag is set to Off. Archiving automatically deletes the Playlist in the Media 
Object Server and breaks the link.  

Each MOS device determines how long clips remain active in its system; it is 
controlled by ENPS. However, to protect objects from automatic deletion, place 
these objects in Rundowns that are MOS Control Active. This also provides a 
convenient place to organize the clips.  

ActiveX Problems 
ENPS only temporarily allows other applications to use the lower Editing Window 
or detached ActiveX window, such as video browsers and editors. ENPS does 
not directly control what happens in that window, and cannot remedy any bugs in 
the ActiveX (OCX) software. ENPS shortcut keys and macros will not work inside 
an ActiveX. 

The ActiveX control must be correctly installed, registered and configured on 
each PC Workstation to operate correctly (the “Media Control Not Available” 
dialog will warn if a user attempts to view a MOS object when the appropriate 
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ActiveX is not available). Some media controls must be licensed through the 
vendor before you can use them. 

Some media vendors may restrict access to their system by limiting concurrent 
connections or requiring a separate log-on for users. 

The only direct interaction with ENPS is where media objects are dragged and 
dropped – usually between the List Window and the ActiveX control to play/edit 
the media. Here is a simple checklist for troubleshooting: 

• Is the problem known behavior for the particular ActiveX being used? 

• Will other ActiveX controls such as the ENPS Web browser run correctly on 
the PC? This can point to a problem with the installation of that particular 
ActiveX. 

• Is the ActiveX failing to operate as expected on all workstations or just on 
one workstation? Only a failure to drag and drop correctly where this 
normally works with that particular ActiveX control and can be seen working 
on other workstations point to an ENPS problem. 

• Is the failure restricted to the internal operation of the ActiveX (e.g. opening 
or playing media) – or its interaction with ENPS (e.g. dragging and dropping 
a MOS object between the ENPS List Window and the ActiveX Control)? 

• Will the ActiveX control run standalone on a Web page on the same PC? 

• Does re-installing the ActiveX software resolve the problem? 

You or the MOS Vendor support can quickly create a test Web Page to contain 
an ActiveX installed and registered on a particular PC using Microsoft Front 
Page: Insert → Advanced → ActiveX Control. 

Users require Superviewer privileges in the ENPS Folder containing their media 
clips. Superviewer privileges allow a user to see all of the MOS tags, but it does 
not allow them to change any of them. 

Communications Problems 
MOS is a reliable communications protocol but it relies on a good network 
connection. If you experience problem, check your network connection by 
contacting your System Administrator. 

The two systems talk via TCP/IP using the MOS Protocol – a system of XML 
messages between ENPS and the MOS. You can find the latest information 
about MOS at http://www.mosprotocol.com. 

MOS objects created in the MOS Server are not displayed in 
ENPS 
• Make sure the user is using the correct Folder for viewing the material in 

ENPS. This is especially important if your system uses multiple MOS folders 
for multiple MOS devices. If you are relying on a macro to navigate to the 
folder, make sure that the macro points to the right folder. 

• Make sure the user is using the correct folder in the MOS server. Many MOS 
systems have different types of material – rushes, work in hand, finished 
items etc. Often only one of these is sent to ENPS.  

http://www.mosprotocol.com/�
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• The 200-item display limit for an ENPS Folder still applies. In busy 
environments, users may need to perform a search to find all but the latest 
material in their MOS folder. 

• Create a test clip in the MOS Server – if it appears in ENPS correctly, try re-
creating the “missing” clip in the MOS Server. In this case, you may need to 
contact the MOS vendor to resolve the problem. 

Clips (MOS objects) deleted from the MOS Server are not 
removed from ENPS. 
• Follow a similar checklist process as above. 

• Ask your System Administrator to check the communications between ENPS 
and the MOS server. If a message that a Clip has been deleted in the MOS 
Server does not pass through the Inbound Items section, the message is not 
being sent by the MOS Server. Logging can help here. 

A playlist does not appear in the MOS Server when the 
Rundown is created in ENPS. 
• Check the Rundown is MOS Active by checking that the MOS icon is 

displayed at the bottom-left, next to the Under/Over time, and confirming that 
MOS Control Active is checked in Rundown Properties. 

• If in doubt, have the user take MOS Control Active off, then turn it back on; 
this should “force” a re-build of the playlist in the MOS Server. 

• Check that the Rundown contains a Clip (MOS object) from the right MOS 
Server – the playlist won’t appear in the MOS Server until the first Clip is 
added. If users drag a MOS clip from another MOS system into a story, it will 
create playlist on that other system. The Rundown may indicate “Ready” in 
the status column (because it is) – but the clip will not appear in the MOS 
playlist as expected. Use MOS ID column in Rundown to check where the 
clip is from. 

• Ask your System Administrator to check the communications between ENPS 
and the MOS server. Messages should appear in the Outbound window 
when clips are added and/or the order of the Rundown containing several 
clips is changed. The outbound items queue is on the ENPS server in the 
MOS window inside the News Object Manager. 

Changes to the ENPS Rundown are not updated in the MOS 
Playlist 
• Check the Rundown is MOS Active, and if in doubt switch MOS Active off 

and back on (as above). 

• On some systems you may need to select the MOS Ready for Air flag. 

• Check that someone has not tried to adjust the playlist of Clips directly from 
the MOS Server’s own interface – this will intentionally break the link 
between ENPS and the MOS Server, and will require MOS Control to be 
taken off and back on. 

• Ask your System Administrator to check the communications between ENPS 
and the MOS server. Messages should appear in the Outbound window 
when clips are added and/or the order of the Rundown containing several 
clips is changed. The outbound items queue is on the ENPS server in the 
MOS window inside the News Object Manager. 
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Status of MOS Clips is not shown/updated in ENPS MOS 
Status column 
• Check the Rundown is MOS Active, and if in doubt switch MOS Active off 

and back on (as above). 

• Check that the MOS Server provides a Status update (not all do). 

• ENPS displays only the text labels provided by the MOS Server. ENPS has 
no control over what is shown, so if the status is incorrect but everything else 
is working, this may indicate a problem with your vendor’s MOS Server. 

• ENPS displays some status messages with color coding – but only if the 
message is one of a defined selection 

• Ask your System Administrator to check the communications between ENPS 
and the MOS server. Messages should appear in the Outbound window 
when clips are added and/or the order of the Rundown containing several 
clips is changed. The outbound items queue is on the ENPS server in the 
MOS window inside the News Object Manager. 
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Section IV 
Macros  
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Chapter 22 

Overview of Macros 
You can create macros to automate complex text entries or a series of tasks, 
combine multiple commands, or make frequent scripting operations faster and 
more consistent.  

Personal and Group Macros 
There are two types of macros. Personal macros you define yourself and group 
macros which are defined by the Group Manager. To access your personal 
macros, select Personal Folder rover → Settings. The Macro tab opens by 
default. It presents a list of all function keys available for macros F2-F12 and 
Ctrl + F2 through F12 and corresponding fields for entering macro 
parameters. The F1 key is reserved for opening online help. 

Group Administrators can set macros for their groups by selecting Group Folder 
rover → Group maintenance → Group macros. Group users can access these 
macros by holding down Shift or Ctrl+Shift and then pressing one of the F2 
through F12 function keys. 

Rover Macros 
Additional rover macro commands are also available. These macro commands 
may be included inside the simpler function key macro commands explained 
above. 

Format: {ROVER:module:code} 

Example: {ROVER:SCRIPT:ED_FONTArial} 

where module is one of the modules defined below, and code is a valid code for 
the module identified below. 

A rover macro will be ignored if the requested choice is not valid at the time the 
macro is executed. For example, a reporter may write a macro that invokes the 
RD_ARCHIVE code in a Rundown. However, as a reporter may not have 
sufficient privileges to display that menu choice, the macro will have no effect. 

Codes are available for the following areas: wires, Personal Folder, Home 
Program/Group Folder, folders, Newsgathering Grids, Rundowns, stories, 
printing, searches, Waste Bin, and messaging. 

Macro commands are case-sensitive and must always be entered in uppercase. 
Keystrokes may not always work in a pop-up dialog that requires an action such 
as choosing Yes, No, OK or Cancel. Macro expansion will pause until the dialog 
is cleared. As ENPS evolves, your macros will need to evolve. Menu commands 
will be changed and updated, and your older macros may not work properly. Test 
after each software upgrade. In cases where macros can perform operations on 
an item and multiple items might be open, such as Rundowns, the macro may 
include a number which refers to the order in which the Rundown was displayed. 
For example, ROVER:RUNDOWN1 would refer to the first Rundown opened. 
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Creating Macros 
While most macros excute rover menu options, other ENPS macro commands 
emulate input from the keyboard and may be interpreted as a security violation 
by the User Access Control (UAC) module in Vista and Windows 7. If you are 
having difficulty executing macros and you are running one of these operating 
systems, consult your System Administrator and/or IT staff about disabling UAC. 
This issue does not apply to Windows XP. 

The same rules apply whether you entering personal macros or group macros. 
Enter regular keyboard characters in the macro fields exactly as they are to 
appear. However, some characters have special meaning and must be enclosed 
in braces {} if you want the character to display them instead of using them to 
carry out an action. Characters which must be enclosed in braces are listed in 
the following table: 

Character Definition 
+ Plus 

^ Caret 

% Percent 

{ Open Brace 

} Close Brace 

[ Open Bracket 

] Close Bracket 

To specify commands that represent actions rather than characters such as 
Enter or Tab, use the codes shown below: 

Key Code 
Backspace {BACKSPACE}, {BS} or {BKSP} 

Delete {DELETE} or {DEL} 

End {END} 

Home {HOME} 

Left arrow {LEFT} 

Right arrow {RIGHT} 

Enter {ENTER} or ~ 

Page Up {PGUP} 

Page Down {PGDN} 

Up arrow {UP} 

Down arrow {DOWN} 

Tab {TAB} 

To have a key press repeated multiple times, enter a number inside the brace. 
For example, {ENTER 9} is equivalent to pressing the Enter key nine times. 
There must be a space between the name of the key and the number. 
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To specify an action when a combination of the Alt, Ctrl, and/or Shift key 
precede the key to be pressed, use the command shown below.  

Key Command 

Alt % 

Ctrl ^ 

Shift + 

To specify that any combination of the Alt, Ctrl, and/or Shift keys be held 
down while multiple other keys are pressed, enclose the other keys in 
parentheses. For example, to create a macro where the Shift key is held down 
while both the E and C keys are pressed, use +(EC). However, to create a 
macro where the Shift key is held down while E is pressed, followed by a C, 
use +EC. 

If a macro involves a dialog box, you must add {WAIT} after the instruction to 
open the dialog. The macro processing will continue when the dialog box is 
closed. If a macro involves the user entering information into a dialog box, use 
the {PAUSE} instruction. For example, the macro: 

^K%P{TAB}%E%E{TAB}{PAUSE}{{}---take pkg---{}} 

1. Opens the Take menu. 

2. Highlights "pkg". 

3. Moves “pkg” to the "Item" entry space. 

4. Pauses to allow the user to enter additional information such as an item time. 

5. When the dialog is closes, enters the text {---take pkg---} into the story. 

To save a story and close the window, the correct command is: ^S{Wait}%C 
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Chapter 23 

Basic Macros and Shortcuts 
The following tables contain a list of all of the built-in ENPS macros and their 
corresponding keyboard shortcuts, when available.  

General 
Macro and Description Keys 
%{LEFT} %{RIGHT} %{UP} %{DOWN} 

Move between windows. 

Alt + Left/ 
Right  
Up/Down 
Arrows 

+{LEFT} 

Highlight one character to the left. 

+{LEFT 5} 

Highlight five characters to the left. 

Shift + 
Left/right 
arrow 

%+<  %+> 

Cursor left and right through the tabs of items open in the 
Editing Window. 

Alt + <      

Alt + > 

%M 

List rover commands from active window (Editing Window, 
List Window, Rundown, Newsgathering Grid). 

Alt+M 

^R 

Display today’s Rundowns in your home group. 

Ctrl+R 

{END} 

In lists, move to the bottom. In Editing Windows, move to 
the end of the item or to the end of the current line, 
depending on your personal settings. 

End 

{ESC} 

Same as Cancel, where permitted. 

Esc 

{HOME} 

In lists, move to the top. In Editing Windows, move to the 
top of the current item or to the beginning of the current 
line, depending on personal settings. 

Home 

{PAUSE} 

Insert a pause in a macro that will allow you to enter 
information into dialog boxes. The macro commands will 
then resume.  

 

{PGDN} 

In lists, display the next page. 

PgDn 
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{PGUP} 

In lists, display the previous page. 

PgUp 

{UP} 

Move up one line. 

{UP 2} 

Move up two lines.  

Up arrow 

List Window 
Macro and Description Keys 

{ROVER:SLUGLIST:SL_FONTSystem} 

{ROVER:SLUGLIST:SL_FONTArial} 

{ROVER:SLUGLIST:SL_FONTCourier New} 

{ROVER:SLUGLIST:SL_FONTTahoma} 

Change the font in the List Window.  

 

{ROVER:SLUGLIST:SL_FS8} or FS10, FS12, 
FS14, FS18, FS24, FS36 

Change the font size in the List Window. 

 

{ROVER:SLUGLIST:SL_PRINT} 

Print all slugs in List Window. 

 

{ROVER:SLUGLIST:SL_RECENTFILES} 

Open a list of the most recently used Rundowns and 
Newsgathering Grids. 

 

{ROVER:SLUGLIST:SL_VIEW1} 
{ROVER:SLUGLIST:SL_VIEW2} 
{ROVER:SLUGLIST:SL_VIEW3} 
{ROVER:SLUGLIST:SL_VIEW4} 

Change the View of the List Window. 

 

Editing Windows 
Macro and Description Keys 

%C 

Close current open item in the Editing Window. 

Alt+C 

%D 

Delete the entire story. Be careful when using this 
command. 

Alt+D 

%X 

Close all items in the Editing Window. 

Alt+X 

^A 

Select all text. 

Ctrl+A 
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^B 

Select bold formatting. 

Ctrl+B 

^E 

Expand the size of the active Editing Window to full 
screen or reduce it if it is already expanded. This has the 
same effect as the Sizing button. 

Expand the Rundown to occupy the full area of the 
screen. Expand the Newsgathering Grid to occupy the full 
screen. 

Ctrl+E 

^I 

Select italics formatting. 

Ctrl+I 

^P 

Print the story in the selected Editing Window or the entire 
Rundown. 

Ctrl+P 

^U 

Select underline formatting. 

Ctrl+U 

{UP} 

Move to the previous line. 

Up arrow 

^{UP} 

Move cursor to the start of the previous paragraph. 

Ctrl+ Up 
arrow 

^+{UP} 

Select from the current position to the start of the 
paragraph. 

Ctrl+Shift+ 
Up arrow 

{DOWN} 

Move to the next line. 

 

Down arrow 

^{DOWN} 

Move cursor to the start of the next paragraph. 

Ctrl+Down 
arrow 

^+{DOWN} 

Select from current position to the end of the paragraph. 

Ctrl+Shift+ 
Down arrow 

{END} 

^{END} 

Move to the end of the item or to the end of the current 
line, depending on personal settings. 

Move to the end of a document. 

End 

{HOME} 

Move to the top of the current item or to the beginning of 
the current line, depending on personal settings.  

Home 
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{ROVER:SCRIPT:ED_APPROVE} 

Approve the item. 

 

{ROVER:SCRIPT:ED_CANCELCONFIRM} 

Close story without Save dialog. 

 

{ROVER:SCRIPT:ED_CASE_LOWER} 

Switch to lower case. 

 

{ROVER:SCRIPT:ED_CASE_UPPER} 

Switch to upper case. 

 

{ROVER:SCRIPT:ED_CONVERTAUDIO} 

Convert current item to an audio item. 

 

{ROVER:SCRIPT:ED_CONVERTPICTURE} 

Convert current item to a picture. 

 

{ROVER:SCRIPT:ED_CONVERTSCRIPT} 

Convert current item to a story. 

 

{ROVER:SCRIPT:ED_CONVERTVIDEO} 

Convert current item to a video item. 

 

{ROVER:SCRIPT:ED_COPYPICTURE} 

Copy picture to clipboard. 

 

{ROVER:SCRIPT:ED_EDITCOPY} 

Copy highlighted text to the clipboard. Same as Edit → 
Copy from the rover. 

Ctrl+C 

{ROVER:SCRIPT:ED_EDITCUT} 

Cut highlighted text and place it on the clipboard. Same as 
Edit → Cut from the rover. 

Ctrl+X 

{ROVER:SCRIPT:ED_EDITPASTE} 

Paste previously cut/copied text. Same as Edit → Paste 
from the rover. 

Ctrl+V 

{ROVER:SCRIPT:ED_EDITPASTE} 

Paste previously cut/copied text. Same as the Edit, Paste 
choice from the rover. 

Shift+Ins  

{ROVER:SCRIPT:ED_EDITPASTE} 

Paste from clipboard. 

 

{ROVER:SCRIPT:ED_EXPORTHTML} 

Export as HTML. 

 

{ROVER:SCRIPT:ED_EXPORTTEXT} 

Export as text file. 
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{ROVER:SCRIPT:ED_FIND} 

Find a word in text. Same as the Find/Highlight choice 
from the rover. 

Ctrl+F 

{ROVER:SCRIPT:ED_FINDREPLACE} 

Find and replace text. 

Ctrl+Shift+H 

{ROVER:SCRIPT:ED_FONTArial} 

Set font to Arial. 

 

{ROVER:SCRIPT:ED_FONTCourierNew} 

Set font to Courier. 

 

{ROVER:SCRIPT:ED_FONTSystem} 

Set font to System. 

 

{ROVER:SCRIPT:ED_FONTTahoma} 

Set font to Tahoma. 

 

{ROVER:SCRIPT:ED_FS10} 

Change font size to 10. 

 

{ROVER:SCRIPT:ED_FS12} 

Change font size to 12. 

 

{ROVER:SCRIPT:ED_FS14} 

Change font size to 14. 

 

{ROVER:SCRIPT:ED_FS18} 

Change font size to 18. 

 

{ROVER:SCRIPT:ED_FS24} 

Change font size to 24. 

 

{ROVER:SCRIPT:ED_FS36} 

Change font size to 36. 

 

{ROVER:SCRIPT:ED_FS8} 

Change font size to 8. 

 

{ROVER:SCRIPT:ED_IMPORTTEXT} 

Import text file. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_CAMERA} 

Insert automation camera. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_CG} 

Insert automation CG. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_CLIP} 

Insert automation clip. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_INSET} 

Insert automation inset. 
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{ROVER:SCRIPT:ED_INSERTAUTO_ LIVEEVENT} 

Insert automation live event. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_LOGO} 

Insert automation logo. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_MACRO} 

Insert automation macro. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_OS} 

Insert automation OS. 

 

{ROVER:SCRIPT:ED_INSERTAUTO_STILL} 

Insert automation still. 

 

{ROVER:SCRIPT:ED_INSERTCG} 

Insert the CG Character Generator command. Same as 
the CG choice from the rover. 

Ctrl+G 

{ROVER:SCRIPT:ED_INSERTCG} 

Insert CG instruction. 

 

{ROVER:SCRIPT:ED_INSERTGOTO} 

Insert the Take or GoTo command. Same as the GoTo 
choice from the rover (if your language is set to UK 
English). 

Ctrl+K 

{ROVER:SCRIPT:ED_INSERTINSERT} 

Insert the Insert command. Same as the Insert choice 
from the rover. 

Ctrl+J 

{ROVER:SCRIPT:ED_INSERTLENGTH} 

Insert the Duration command. Same as the Duration 
choice from the rover. 

Ctrl+D 

{ROVER:SCRIPT:ED_INSERTNOTE} 

Insert the Notes command. Same as the Notes choice 
from the rover. 

Ctrl+H 

{ROVER:SCRIPT:ED_INSERTREADRATE} 

Insert read rate. 

 

{ROVER:SCRIPT:ED_INSERTTECH} 

Insert the Tech command. Same as the Insert tech 
instruction choice from the rover. 

Ctrl+Shift+I 

{ROVER:SCRIPT:ED_LAYOUT_SHOWLAYOUT} 

Show layout e.g., add/remove/move story fields.  

 

{ROVER:SCRIPT:ED_LAYOUT_SHOWTEMPLATEFIELDS} 

Show template fields. 

 

{ROVER:SCRIPT:ED_LINK} 

Link to MOS resource. 
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{ROVER:SCRIPT:ED_LIVEREAD} 

Insert the Anchor command. This is the same as the Live 
Read choice from the rover if your language is set to UK 
English. 

Ctrl+L 

{ROVER:SCRIPT:ED_NEXTSTORY} 

Move ahead one story in the two column view. 

 

{ROVER:SCRIPT:ED_ONECOLUMN} 

Display story in a one column view. This option is used to 
switch back from a two-column view, which is only 
available if your System Administrator has enabled it for 
your station. 

 

{ROVER:SCRIPT:ED_PLANNING_DATE} 

Change Newsgathering Grid item date. 

 

{ROVER:SCRIPT:ED_PG_<PROGRAM NAME>} 

Move an item from an Editing Window to a folder where 
<PROGRAM NAME> is the folder’s ID, not its description; 
contact your System Administrator for this information. 

 

{ROVER:SCRIPT:ED_PREVIEW} 

Preview in two columns. 

 

{ROVER:SCRIPT:ED_PREVSTORY} 

Move back one story in the two column view. 

 

{ROVER:SCRIPT:ED_PRINT} 

Print current story. 

Ctrl+P 

{ROVER:SCRIPT:ED_PRINTOPTIONS} 

Shows printer set-up form. 

 

{ROVER:SCRIPT:ED_PRIOR} 

Show prior versions; public stories only. 

 

{ROVER:SCRIPT:ED_PUBLISH_ WireGroupID} 

Publish the current story. The group you are publishing 
from must be set to the type “Wire” by the System 
Administrator. “WireGroupID” is the group ID, which you 
can find out from your System Administrator. 

 

{ROVER:SCRIPT:ED_REFORMAT} 

Reformat text. 

 

{ROVER:SCRIPT:ED_SAVE} 

Save the current in-progress story in the active Editing 
Window in the Personal Folder without closing it.  

Ctrl+S 

{ROVER:SCRIPT:ED_SCR_BLARROW} 

Toggle the position of the story black line. 
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{ROVER:SCRIPT:ED_SCR_PROTECT} 

Protect text. 

 

{ROVER:SCRIPT:ED_SCR_SAVETEMPLATE} 

Save the story template. 

 

{ROVER:SCRIPT:ED_SCR_SHOWMEDIAABL} 

Set the Story Media Viewer to preview MOS items above 
the black line. 

 

{ROVER:SCRIPT:ED_SCR_SHOWMEDIAABL} 

Set the Story Media Viewer to preview MOS items below 
the black line. 

 

{ROVER:SCRIPT:ED_SCR_UNPROTECT} 

Unprotect text. 

 

{ROVER:SCRIPT:ED_SCRIPTLOCK} 

{ROVER:SCRIPT:ED_SCRIPTUNLOCK} 

Locks/unlock the story lock while you are editing. 

 

{ROVER:SCRIPT:ED_TIMEBLOCK} 

Time the selected text. 

 

{ROVER:SCRIPT:ED_TOOLSPRON} 

Launch Pronouncer. 

 

{ROVER:SCRIPT:ED_TOOLSSPELL} 

Spell check. 

Ctrl+Shift+U 

{ROVER:SCRIPT:ED_TOOLSTHES} 

Launch Thesaurus. 

 

{ROVER:SCRIPT:ED_TWOCOLUMN} 

Display story in two column view.  

This option is only available if your System Administrator 
has enabled it for your station. 

 

{ROVER:SCRIPT:ED_UNDO} 

Undo. Same as the Undo choice from the rover. 

Ctrl+Z 

Wires Folder 
Macro and Description Keys 

%1 

Rover for Wires Folder. 

Alt+1 

^W  

Display a list of news wire stories. Same as clicking on the 
Wires folder. 

Ctrl+W 



 

102 ENPS Advanced User’s Guide 
 

{ROVER:FOLDER1:NEWS_CATEGORYx}  

Where X is a numerical category, show news from that 
category. 

 

{ROVER:FOLDER1:NEWS_PROVIDERx}  

Where X represents a provider code, show news from that 
category. 

 

{ROVER:FOLDER1:NEWS_URGENT} 

Shows news from the combined Urgents List. 

 

Personal Folder 
Macro and Description Keys 

%2 

Rover for my Work Folder. 

Alt+2 

^Y 

Display a list of items in your Personal Folder first folder. 
Same as clicking on your Personal Folder. 

Ctrl+Y 

{ROVER:FOLDER2:MF_NEWAUDIO}  

Create new audio item. 

 

{ROVER:FOLDER2:MF_NEWCONTACTGROUP}  

Create a new contact for your group folder. 

 

{ROVER:FOLDER2:MF_NEWCONTACTPERSONAL}  

Create new personal contact. 

 

{ROVER:FOLDER2:MF_NEWCONTACTSERVER}  

Create new contact which will be public to everyone. 

 

{ROVER:FOLDER2:MF_NEWFOLDER} 

Create new folder. 

 

{ROVER:FOLDER2:MF_NEWGRID}  

Create a new generic grid. 

 

{ROVER:FOLDER2:MF_NEWPICTURE}  

Create new picture. 

 

{ROVER:FOLDER2:MF_NEWRUNDOWN}  

Open a new Rundown. You will still need to select which 
Rundown to create. 

 

{ROVER:FOLDER2:MF_NEWSCRIPT}  

Start a new story in the bottom window. Same as the New 
Story choice from the Personal Folder rover. 

Ctrl+N 

{ROVER:FOLDER2:MF_NEWVIDEO} 

Create new video item. 
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{ROVER:FOLDER2:MF_OPTIONS}  

Open Personal Folder → Settings where you can create 
macros, forward searches, and change personal settings. 

 

{ROVER:FOLDER2:MF_PG_MYWORK}  

Change back to main folder if currently in a sub-folder. 

 

{ROVER:FOLDER2:MF_SHOWASCENDING} 

Show oldest items in personal folder. 

 

{ROVER:FOLDER2:MF_PG_subfolderID}  

Change folder to specific sub-folder. 

 

{ROVER:FOLDER2:MW_FINISHED}  

Quit ENPS.  

Ctrl+Q 

{ROVER:FOLDER2:MW_LAYOUTMY}  

Make the current layout your own layout. 

 

{ROVER:FOLDER2:MW_LAYOUTRESTORE}  

Restore the layout to its previous settings. 

 

{ROVER:FOLDER2:MW_LAYOUTSYSTEM}  

View with system layout. 

 

{ROVER:FOLDER2:MW_LOCAL}  

Change to local storage. 

 

{ROVER:FOLDER2:MW_LOGON}  

Logon to ENPS if in off-line mode. 

 

Third Folder  
Macro and Description Keys 

%3 

Rover for Third Folder. 

Alt+3 

^R 

Displays a list of today’s Rundowns. Same as choosing 
Today’s Rundowns from the third folder’s rover. 

Ctrl+R 

{ROVER:FOLDER3:MF_CALENDAR} 

Show calendar. 

 

{ROVER:FOLDER3:MF_GROUPFAVADD} 

Adds to group favorites. 

 

{ROVER:FOLDER3:MF_NEWAUDIO} 

Create new  audio item. 

 

{ROVER:FOLDER3:MF_NEWFOLDER} 

Create new  folder. 
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{ROVER:FOLDER3:MF_NEWGRID} 

Create new generic grid. 

 

{ROVER:FOLDER3:MF_NEWNGPROSPECT} 

Create new  Newsgathering Item. 

 

{ROVER:FOLDER3:MF_NEWPICTURE} 

Create new  picture. 

 

{ROVER:FOLDER3:MF_NEWREADIN} 

Create new  read-in script. 

 

{ROVER:FOLDER3:MF_NEWRUNDOWN} 

Create new  Rundown. 

 

{ROVER:FOLDER3:MF_NEWSCRIPT} 

Create new  script. 

 

{ROVER:FOLDER3:MF_NEWVIDEO} 

Create new  video item. 

 

{ROVER:FOLDER3:MF_PERSFAVADD} 

Adds to personal favorites. 

 

{ROVER:FOLDER3:MF_PG_folderID} 

Change program/group to indicated group ID (not the 
folder description). Check with your System Administrator 
for the correct name. This field is case-sensitive.  

 

{ROVER:FOLDER3:MF_SHOWASCENDING} 

Show oldest items first. 

 

{ROVER:FOLDER3:MF_SUP_GRTEMPLATES} 

Open a list of generic grid templates. 

 

{ROVER:FOLDER3:MF_SUP_ LOADGROUPBRIEFINGS} 

Load group Search queries. 

 

{ROVER:FOLDER3:MF_SUP_LOADGROUPMACROS} 

Load group macros. 

 

{ROVER:FOLDER3:MF_SUP_NGTEMPLATES} 

Open a list of Newsgathering Grid templates. 

 

{ROVER:FOLDER3:MF_PROGRAMMESSAGES} 

Read or open group messages. 

 

{ROVER:FOLDER3:MF_SUP_SCTEMPLATES} 

Open a list of story templates. 

 

{ROVER:FOLDER3:MF_SUP_TEMPLATES} 

Rundown templates. 

 



 

The Associated Press  105 
 

{ROVER:FOLDER3:MF_TODAYMOS} 

Display MOS objects created today. 

 

{ROVER:FOLDER3:MF_TODAYNG} 

Open a list of today's Newsgathering Grid. 

 

{ROVER:FOLDER3:MF_TODAYREADIN} 

Open a list of today's read-ins. 

 

{ROVER:FOLDER3:MF_TODAYRUNDOWN} 

Open a list of today's Rundowns. 

 

{ROVER:FOLDER3:MG_HOME} 

Return to home program. 

 

{ROVER:FOLDER3:MW_LOCAL} 

Open local storage. 

 

Fourth Folder  
Macro and Description Keys 

%4 

Open fourth folder rover. 

Alt+4 

{ROVER:FOLDER4:MF_CALENDAR} 

Show calendar. 

 

{ROVER:FOLDER4:MF_GROUPFAVADD} 

Adds to group favorites. 

 

{ROVER:FOLDER4:MF_HOME} 

Return to the fourth folder. 

 

{ROVER:FOLDER4:MF_NEWAUDIO} 

Create new  audio item. 

 

{ROVER:FOLDER4:MF_NEWFOLDER} 

Create new  sub-folder. 

 

{ROVER:FOLDER4:MF_NEWGRID} 

Create new generic grid. 

 

{ROVER:FOLDER4:MF_NEWPICTURE} 

Create new  picture. 

 

{ROVER:FOLDER4:MF_NEWREADIN} 

Create new read-in story. 

 

{ROVER:FOLDER4:MF_NEWRUNDOWN} 

Create new  Rundown. 

 



 

106 ENPS Advanced User’s Guide 
 

{ROVER:FOLDER4:MF_NEWSCRIPT} 

Create new  script. 

 

{ROVER:FOLDER4:MF_NEWVIDEO} 

Create new  video item. 

 

{ROVER:FOLDER4:MF_PERSFAVADD} 

Adds to personal favorites. 

 

{ROVER:FOLDER4:MF_PG_groupID} 

Change program/group to indicated group ID (not the 
folder description). Check with your System Administrator 
for the correct name. This field is case-sensitive. 

 

{ROVER:FOLDER4:MF_PG_MainFolderID} 

{ROVER:FOLDER4:MF_FOLDER_SubFolderName} 

Navigate to a program and its subfolder. Both macros 
must appear.  

 

{ROVER:FOLDER4:MF_PRIV} 

Access staff privileges. 

 

{ROVER:FOLDER4:MF_PROGRAMMESSAGES} 

List group messages. 

 

{ROVER:FOLDER4:MF_SHOWASCENDING} 

Show oldest items first. 

 

{ROVER:FOLDER4:MF_SUP_GRTEMPLATES} 

Show generic grid templates. 

 

{ROVER:FOLDER4:MF_SUP_LOADGROUPBRIEFINGS} 

Load group search queries for the folder you are working 
in. 

 

{ROVER:FOLDER4:MF_SUP_LOADGROUPMACROS} 

Load group macros. 

 

{ROVER:FOLDER4:MF_SUP_NGTEMPLATES 

Show Newsgathering Grid templates. 

 

{ROVER:FOLDER4:MF_SUP_SCTEMPLATES} 

Show story templates. 

 

{ROVER:FOLDER4:MF_SUP_TEMPLATES} 

Show Rundown templates. 

 

{ROVER:FOLDER4:MF_TODAYMOS} 

Display MOS objects that were created today. 

 

{ROVER:FOLDER4:MF_TODAYNG} 

Show today's Newsgathering Grid. 
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{ROVER:FOLDER4:MF_TODAYREADIN} 

Show today's read-ins. 

 

{ROVER:FOLDER4:MF_TODAYRUNDOWN} 

Show today's Rundowns. 

 

{ROVER:FOLDER4:MG_HOME} 

Return to home program. 

 

{ROVER:FOLDER4:MW_LOCAL} 

Open local storage in the fourth folder. 

 

Search 
Macro and Description Keys 

%5 

Open the Search Bar rover. 

Alt+5 

%C 

Toggle Search Bar ENPS content search. 

Alt+C 

%G 

Start a search for terms in the search text box. If the text 
box is empty, ENPS will use the text currently highlighted. 

Alt+G 

%N 

Toggle Search Bar wire search. 

Alt+N 

%W 

Toggle Search Bar Web search. 

Alt+W 

^+B 

Move the cursor to the search text entry box. If the 
Search button is displayed, then the extended search 
options w ill appear. 

Ctrl+ 

Shift+B 

{ROVER:BRIEFING:BRIEFING_GROUP_name} 

Invoke Group Brief ing of given name. 

 

{ROVER:BRIEFING:BRIEFING_SAVED_name} 

Invoke Briefing of given name. 

 

My ENPS 
Macro and Description Keys 

^+M 

Launch My ENPS. 

Ctrl+Shift+M 

Printing 
Macro and Description Keys 
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%6 

Open the Print rover. 

Alt+6 

^P 

Print the story in the selected Editing Window or the 
selected item in a Rundown. 

Ctrl+P 

{ROVER:PRINTER:PRINTER_SETUP} 

Invoke the printer set-up dialog. 

 

{ROVER:PRINTER:PRN_x} 

Changes selected printer. X is the number of the printer in 
the workstation’s printer collection, counting up from the 
bottom of the list. 

 

Messaging 
Macro and Description Keys 

%7 

Open the Messaging rover. 

Alt+7 

%T 

Open the Top Line Message w indow so you can send a 
message w ith an attachment. 

Alt+T 

^1 

Open the latest Top Line Message. Same as clicking on 
the messages line in the Top Line Message area. 

Ctrl+1 

^2 

Open the latest Top Line Message news wire alert. Same 
as clicking on the Urgents line in the Top Line Message 
Area. 

Ctrl+2 

^M 

Display a list of received Top Line Messages. Same as 
clicking on the Messaging icon. 

Ctrl+M 

{ROVER:MAIL:MAIL_CHAT} 

Launch chat session. 

 

{ROVER:MAIL:MAIL_FIND} 

Find mail messages containing the selected word. 

 

{ROVER:MAIL:MAIL_SEND}  

Starts a Top Line Message. Same as the Send choice 
from the Messaging icon. 

Ctrl+T 
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Waste Bin 
Macro and Description Keys 

%8 

Open the Waste Bin rover. 

Alt+8 

{ROVER:TRASH:TRASH_FIND}  

Find Waste Bin items containing the currently selected 
word. 

 

{ROVER:TRASH:TRASH_PROGRAM_2} 

Show the Group Waste Bin for your third folder. 

 

{ROVER:TRASH:TRASH_PROGRAM_3} 

Show Fourth Folder's Waste Bin. 

 

{ROVER:TRASH:TRASH_PROGRAM_LOCAL} 

Show Local Waste Bin. 

 

Generic Grid 
Macro and Description Keys 

{ROVER:SCRIPT:GRID_HEADINGS} 

Edit generic grid headings. 

 

{ROVER:SCRIPT:GRID_NEWCOLUMN} 

Add generic grid column. 

 

{ROVER:SCRIPT:GRID_PASTETEXT} 

{ROVER:SCRIPT:GRID_PASTETABLEINSERT} 

{ROVER:SCRIPT:GRID_PASTETABLEREPLACE} 

Paste, insert, or replace information in a generic grid.  

 

{ROVER:SCRIPT:GRID_REFRESH} 

Refresh latest information for generic grid. 

 

{ROVER:SCRIPT:GRID_REMOVECOLUMN} 

Remove generic grid column. 

 

Rundowns 
Macro and Description Keys 

^+U 

Update the MOS Editorial Start to match the updated start 
date and start time of the Rundown, by highlighting the old 
Editorial Start date and time and pressing these keys. 

Ctrl+ 
Shift+U 

^O 

Open the selected item for editing and put the cursor in the 
Editing Window. 

Ctrl+O 
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{ROVER:RUNDOWN:RD_ARCHIVE_ABOVE} 

Archive Rundown but only material above black bar. 

 

{ROVER:RUNDOWN:RD_ARCHIVE} 

Archive Rundown. 

 

{ROVER:RUNDOWN:RD_ARCHIVECOPY_ABOVE} 

Archive a copy of Rundown but only material above black 
bar. 

 

{ROVER:RUNDOWN:RD_ARCHIVECOPY} 

Archive a copy of Rundown. 

 

{ROVER:RUNDOWN:RD_ATTACH} 

Reattach a Rundown to the main interface. 

 

{ROVER:RUNDOWN:RD_AUTOMATION_CLEAR} 

{ROVER:RUNDOWN:RD_AUTOMATION_OUTPUT} 

Used by automation machines to send output and clear 
current data. 

 

{ROVER:RUNDOWN:RD_CG} 

Open the CG Device Control w indow. 

 

{ROVER:RUNDOWN:RD_CLOSE} 

Close Rundown. 

 

{ROVER:RUNDOWN:RD_COPYROWSTOALLTODAYS} 

Copies marked rows to all of today's Rundowns. 

 

{ROVER:RUNDOWN:RD_COPYROWSTOSELTODAYS} 

Copy marked rows to opened or selected Rundowns. 

 

{ROVER:RUNDOWN:RD_DETACH} 

Detach a Rundown from the main interface. 

 

{ROVER:RUNDOWN:RD_EXPORT} 

Export Rundown. 

 

{ROVER:RUNDOWN:RD_EXPORTHTML} 

Export Rundown as HTML. 

 

{ROVER:RUNDOWN:RD_FONTTahoma} 

Set the Rundown font to Tahoma. 

 

{ROVER:RUNDOWN:RD_FULLSCREEN} 

Maximize Rundown to full screen. 

 

{ROVER:RUNDOWN1:RD_FULLSCREENHORIZONTAL} 

Horizontal view  of Rundown. 

 

{ROVER:RUNDOWN1:RD_FULLSCREENVERTICAL} 

Vertical view  of Rundown. 
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{ROVER:RUNDOWN1:RD_FULLSCREENVERTICALSCRIPT} 

Display a Rundown in a full screen vertical split with an 
ENPS story. The story from the TOP edit window will be 
displayed. 

 

{ROVER:RUNDOWN:RD_INSERTROW} 

Insert a new row. Same as the Insert Row choice from the 
rover. 

 

{ROVER:RUNDOWN:RD_LAYOUTCOLUMN_name} 

Add the given column name (must use ID of column, not its 
caption). 

 

{ROVER:RUNDOWN:RD_LAYOUTMY} 

Make this your layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTPROGRAM} 

Save as program layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTRESTORE} 

View with normal layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTSAVE} 

Save this layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTSTORED_ name} 

View Rundown with a stored layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTSYSTEM} 

View with system layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTTEMPLATE} 

View with template layout. 

 

{ROVER:RUNDOWN:RD_LOCK} 

Locks/unlocks current active Rundown. 

 

{ROVER:RUNDOWN:RD_LOCKSCRIPTS} 

Lock all stories. 

 

{ROVER:RUNDOWN:RD_LOCKTIMINGBAR} 

Lock the timing bar.  

 

{ROVER:RUNDOWN:RD_MAKETEMPLATE} 

Save Newsgathering Grid as template. 

 

{ROVER:RUNDOWN:RD_MAXIMIZE} 

Maximize Rundown to top half of screen. 

 

{ROVER:RUNDOWN:RD_MAXRODUALVIEWERS} 

Toggle the Dual Script Viewer menu option. 

 

{ROVER:RUNDOWN:RD_MOSAIR} 

Set the Rundown MOS Ready to Air flag. 
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{ROVER:RUNDOWN1:RD_MOSCONTROL} 

Toggle MOS Control Active in Rundown properties. 

 

{ROVER:RUNDOWN1:RD_ONAIR} 

Toggle On Air checkbox in Rundown properties. 

 

{ROVER:RUNDOWN:RD_PRINT} 

Print Rundown only (as displayed). 

 

{ROVER:RUNDOWN:RD_PRINTALL} 

Print Rundown (as displayed) and stories. 

 

{ROVER:RUNDOWN:RD_PRINTALLMARKED} 

Print Rundown as displayed and all marked stories. 

 

{ROVER:RUNDOWN:RD_PRINTALLUNMARKED} 

Print Rundown as displayed and all unmarked stories. 

 

{ROVER:RUNDOWN:RD_PRINTRW} 

Print Rundown only (using report layout selections). 

 

{ROVER:RUNDOWN:RD_PRINTRWALL} 

Print Rundown (using report layout selections) and stories. 

 

{ROVER:RUNDOWN:RD_PRINTRWALLMARKED} 

Print Rundown using report layout selection and all marked 
stories. 

 

{ROVER:RUNDOWN:RD_PRINTRWALLUNMARKED} 

Print Rundown using report layout selection and all 
unmarked stories. 

 

{ROVER:RUNDOWN:RD_PRINTSETUP} 

Setup dialog for printing. 

 

{ROVER:RUNDOWN:RD_PROMPTER} 

Drive prompter. 

 

{ROVER:RUNDOWN:RD_PROPERTIES} 

Open the Rundown properties dialog. 

 

{ROVER:RUNDOWN:RD_PROPORTIONAL} 

Toggle Rundown between proportional and fixed view  of 
Rundown. 

 

{ROVER:RUNDOWN:RD_PUBLISH} 

Publish Rundown. 

 

{ROVER:RUNDOWN:RD_REFRESH} 

Force Rundown to refresh. 

 

{ROVER:RUNDOWN:RD_REFRESH} 

Refresh Rundown. 
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{ROVER:RUNDOWN1:RD_TABBEDVIEW} 

Tabbed view  of Rundown. 

 

{ROVER:RUNDOWN:RD_UNLOCKSCRIPTS} 

Unlock all stories. 

 

Newsgathering Grids 
Macro and Description Keys 

{ROVER:RUNDOWN:NG_ARCHIVE}  

Archive Newsgathering Grid. 

 

{ROVER:RUNDOWN:NG_PRINT}  

Print Newsgathering Grid. 

 

{ROVER:RUNDOWN:NG_PRINTALL} 

Print all rows and content of the Newsgathering Grid. 

 

{ROVER:RUNDOWN:NG_PRINTCURRENT} 

Print the current row and its contents in a Newsgathering 
Grid. 

 

{ROVER:RUNDOWN:RD_CLOSE}  

Close Rundown. 

 

{ROVER:RUNDOWN:RD_INSERTROW}  

Insert a row . 

Ctrl+I 

{ROVER:RUNDOWN:RD_LAYOUTCOLUMN_name}  

Add the given column name. Must use ID of column, 
not its caption. Check w ith the System Administrator 
for the column ID. 

 

{ROVER:RUNDOWN:RD_LAYOUTMY}  

Make this user' s layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTPROGRAM}  

Save as program layout 

 

{ROVER:RUNDOWN:RD_LAYOUTRESTORE}  

View with normal layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTSAVE}  

Save this layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTSYSTEM}  

View  w ith system layout. 

 

{ROVER:RUNDOWN:RD_LAYOUTTEMPLATE}  

View with template layout. 
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{ROVER:RUNDOWN:RD_MAKETEMPLATE}  

Save as template. 

 

{ROVER:RUNDOWN:RD_PROPERTIES}  

Rundown properties dialog. 
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Chapter 24 

Advanced Macros 
This section contains advanced macros that show how you can build on the 
functionality of the built-in ENPS macros to perform a variety of useful 
operations. Many of these macros will require customization to meet the specific 
needs of your newsroom. 

Stories  
Insert a CG into a story and add a reporter’s name and location. Change 
{DOWN 6} so that it will pick the appropriate template. You can use the first 
letter of the template name here instead. Use TABs to move through the fields 
in the CG template. Substitute the reporter’s actual name and location in the 
macro text.  

X{WAIT}{BACKSPACE}^G{WAIT}{DOWN 6}{WAIT}%O{WAIT} 
***Reporter Name***{TAB}Location%O  

Insert the anchor’s name and read-rate in a story. The following example also 
inserts Prompter instructions with braces {EXAMPLE}. If preferred, substitute 
round brackets (EXAMPLE) by replacing {{} and {}} with {(} and {)}.  

{ENTER}{BS}{WAIT}^LNAME~{{}***NAME***{}}~%MCC~18~  

Insert Over the Shoulder (OTS)/Inset details.  

{ENTER}{BS}{WAIT}^J%H{TAB}OTS: {WAIT} 

Take VO and open CG Template section.  

{ENTER}{BS}{WAIT}^K%V{TAB 9}{ENTER}{{}***VO***{}}~^G 

Take Package and open CG Template section. 

{ENTER}{BS}{WAIT}^K%P{TAB 9}{ENTER}{{}***PKG***{}}~^G 

Take Sound on Tape (SOT) Full, add brackets for transcript and open CG 
Template section. 

{ENTER}{BS}{WAIT}^K%S{TAB 9}{ENTER}{{}***SOT FULL***{}}~~ 
<>{UP}^G  

Take Sound on Tape (SOT) Full At…, add brackets for transcript and open CG 
Template section. 

{ENTER}{BS}{WAIT}^K%H{TAB}SOT FULL%A{PAUSE}{{}***SOT 
FULL***{}}~~<>{UP}^G 
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Take natural SOT Full, continued VO At…, and open CG Template section. 

{ENTER}{BS}{WAIT}^K%H{TAB}NAT SOT FULL{TAB 9}{ENTER} 
{{}***NAT SOT FULL***{}}~<Natural Sound>~{WAIT}^K%H 
{TAB}CONT VO%A{PAUSE}{{}***CONT VO***{}}~{UP 4}^G 

Take natural SOT Full At…, continued VO At… and open CG Template 
section. 

{ENTER}{BS}{WAIT}^K%H{TAB}NAT SOT FULL%A{PAUSE}{{}***NAT 
SOT FULL***{}}~<Natural Sound>~{WAIT}^K%H{TAB}CONT 
VO%A{PAUSE}{{}***CONT VO***{}}~{UP 3}^G 

Set up Take command. 

{ENTER}{BS}{WAIT}^K%H{TAB 10}~{UP}%E{TAB} 

Set up Take example. 

{ENTER}{BS}{WAIT}^K%H{TAB}EXAMPLE{TAB 9}{ENTER}{{} 
***EXAMPLE***{}} 

Set up Insert other command  

{ENTER}{BS}{WAIT}<>{LEFT}  

Sets up Insert command. 

{ENTER}{BS}{WAIT}^J%H{TAB 10}~{UP}%E{TAB}  

Insert text and production commands for a typical headlines/teasers sequence  

^L ?/?{ENTER} {(}***?***{)}{ENTER}I'M -- TONIGHT ON  
...{ENTER 1}^K%V{ENTER 1}VTR #1-{ENTER 9}{(}***? 
VO***{)}{ENTER 2}^K%I{ENTER}VTR #2-{ENTER 
9}{(}***WIPE/VO***{)}{ENTER 2}^K%I{ENTER}VTR #3-{ENTER 
9}{(}***WIPE/VO***{)}{ENTER 2}^K%I{ENTER}VTR #4-{ENTER 
9}{(}***WIPE/VO***{)}  

Display wire stories, and make fonts in both the List Window and the upper 
story window bigger for use by an anchor/ presenter on air. A story must be 
open in the upper story window and the cursor located within the story.  

^W{WAIT}{ROVER:SLUGLIST:SL_FS14}{WAIT}%{RIGHT}{WAIT}{ROVER
:SCRIPT:ED_FS18}  

Return font sizes to normal. A story must be open in the upper story window 
and the cursor located within the story.  

^W{WAIT}{ROVER:SLUGLIST:SL_FS8}{WAIT}%{RIGHT}{WAIT}{ROVER:
SCRIPT:ED_FS12} 

Open a story from a Rundown, print it and close it again, return to the 
Rundown. 

^O{WAIT}^P{WAIT}%C{WAIT}%{LEFT}  

Save, approve, print and close the current open story.  
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^S{WAIT}^P{WAIT}{ROVER:SCRIPT:ED_APPROVE}{WAIT}%C 

Copy a series of stories into contacts. This is useful when contacts have been 
transferred from another system and are stored in ENPS as stories – either in 
a Rundown or a Hold folder. For these to work, the user must have the home 
folder required for the contacts to be created in, must have Editor privileges or 
above in the folder and must not have any other items open in ENPS. First for 
contacts stored as stories in a Rundown, open the Rundown, highlight the first 
item and use this macro then run it again as necessary.  

{ENTER}{WAIT}%{RIGHT 2}{WAIT}^A{WAIT}^C{WAIT}{ROVER: 
FOLDER2:MF_NEWCONTACTSERVER}{WAIT}{TAB}^V%{LEFT}%S^C{ESC}%
{RIGHT}%C~^V~{WAIT}%C{WAIT}%{LEFT}{DOWN}  

Contacts stored as individual stories. 

{ENTER}^A{WAIT}^C{WAIT}{ROVER:FOLDER2:MF_NEWCONTACTSERVER}
{WAIT}{TAB}^V%{LEFT}%S^C{ESC}%{RIGHT}%C~^V~{WAIT}%C{WAIT}{
DOWN}  

Same as above, but deletes the original item from the folder. 

{ENTER}^A{WAIT}^C{WAIT}{ROVER:FOLDER2:MF_NEWCONTACTSERVER}
{WAIT}{TAB}^V%{LEFT}%S^C{ESC}%{RIGHT}%C~^V~{WAIT}%C{WAIT}%
DY  

Take full page. 

{ENTER}{BS}{WAIT}^K%H{Tab}FULL PAGE{Tab 9} 
{ENTER}{{}***FULL PAGE***{}}~ 

Take VO and open CG template selection. 

{ENTER}{BS}{WAIT}^K%V{Tab 9}{Enter}{{}***VO***{}}~^G 

Take Double Box. 

{ENTER}{BS}{WAIT}{{}**LIVE**{}}~^K%H~LIVE DBL BOX{TAB 9}~ 

Take PKG. 

{ENTER}{BS}{WAIT}{{}**PKG**{}}~^K%P{TAB 9}~ 

Take PKG and open CG template selection. 

{ENTER}{BS}{WAIT}^K%P{Tab 9} {Enter}{{}***PKG***{}}~^G 

Take SOT. 

{ENTER}{BS}{WAIT}{{}**SOT**{}}~^K%S{TAB 9}~ 

Take SOT/VO: 

{ENTER}{BS}{WAIT}{{}**SOT/VO**{}}~^K%H~SOT/VO{TAB 9}~ 

Take VO/SOT/VO: 

{ENTER}{BS}{WAIT}{{}**VO/SOT/VO**{}}~^K%H~VO/SOT/VO{TAB 
9}~ 

Take SOT full, set transcription brackets and open CG template selection: 

{ENTER}{BS}{WAIT}^K%S{Tab 9} {Enter}{{}***SOT 
FULL***{}}~~<>{UP}^G 
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Take SOT full at, set transcription brackets and open CG template selection: 

{ENTER}{BS}{WAIT}^K%H{Tab}SOT FULL AT : {WAIT}{{}***SOT 
FULL***{}}~~<>{UP}^G 

Take natural SOT full, continued VO at and open CG template selection: 

{ENTER}{BS}{WAIT}^K%H{Tab}NAT SOT FULL{Tab 
9}{ENTER}{{}***NAT SOT FULL***{}}~<Natural 
Sound>~{WAIT}^K%H{Tab}CONT VO AT :{WAIT} {{}***CONT 
VO***{}}~{UP 4}^G 

Take natural SOT full at, continued VO at and open CG template selection: 

{ENTER}{BS}{WAIT}^K%H{Tab}NAT SOT FULL AT :{WAIT}{{}***NAT 
SOT FULL***{}}~<Natural Sound>~{WAIT}^K%H{Tab}CONT VO AT 
:{WAIT}{{}***CONT VO***{}}~{UP 3}^G 

Take VO. 
{ENTER}{BS}{WAIT}{{}**VO**{}}~^K%V{TAB 9}~ 

Take Continued VO. 

{ENTER}{BS}{WAIT}^K%H{Tab}CONT VO{Tab 9} {ENTER}{{}***CONT 
VO***{}}~ 

Take Continued VO at. 

{ENTER}{BS}{WAIT}^K%H{Tab}CONT VO AT :{WAIT}{{}***CONT 
VO***{}}~ 

Take On Cam tag. 

{ENTER}{BS}{WAIT}^K%H{Tab}ON CAM TAG{Tab 9}{ENTER}{{}***ON 
CAM TAG***{}}~ 

Tech Wipe. 

{ENTER}{BS}{WAIT}^I%W{Tab 7}{Enter}{{}***WIPE***{}}~ 

Tech Mix (Dissolve). 

{ENTER}{BS}{WAIT}^I%I{Tab 7}{Enter}{{}***DISSOLVE***{}}~ 

Set transcription brackets. 

{ENTER}{BS}{WAIT}<>{LEFT} 

Search 
Call up your list of Group Searches, ready to select using the cursor: 

%5G{RIGHT} 

Find tomorrow’s active items in Folder 3. This does not work on Fridays or the 
end of a month.  

%3C{ENTER}%T{RIGHT}%V{WAIT}{ESC} 

To change Folder 4 and load its group Macros and Group Searches  

{ROVER:FOLDER4:MF_PG_folderid}{ROVER:FOLDER4:MF_SUP_LOADGR
OUPMACROS}{ROVER:FOLDER4:MF_SUP_LOADGROUPBRIEFINGS} 
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Printing 
Print a story from a Rundown. 

^O{WAIT}^P{WAIT}%C{WAIT}%{LEFT}{DOWN}{BS 8}PRINTED~{WAIT} 
^o^p{WAIT}%x^e{DOWN} 

Print one story from the Rundown and advance to the next story. 

^O{WAIT}^P{WAIT}%C{WAIT}%{LEFT}{DOWN} 

Print all stories in a selected Rundown. 

%m{WAIT}ppp{RIGHT}a~ 

Print marked stories in a selected Rundown. 

%m{WAIT}ppp{RIGHT}m~ 

Rundowns 
Press Space on the timing bar, open the on-air story in view mode and move 
down the Rundown. The first story must be opened by double clicking on its 
Segment or page number. The show timing must be started by clicking On Air 
in Rundown properties and manually pressing space to start the program, then 
click inside onto the story and use this macro. It leaves the focus on the story 
after each change to allow easy scrolling through the story on screen. There is 
a space between {LEFT 2} and {WAIT}.  

%{LEFT 2} {WAIT}{DOWN}^O 

Float stories by moving them beneath the black bar. You must first mark the 
item(s) to be moved. 
^{PGDN}{WAIT}%a 

Same as above, but leaves the focus on the Rundown, not the story.  

{WAIT}{DOWN}{WAIT}{ENTER} 

Program start macro can be used for the first item in the program before using 
the above macro to step through the Rundown. You must click on the first 
Segment in the program first. Note that there is a space between {ENTER} 
and {WAIT}.  

{ENTER} {WAIT}%{RIGHT 2} 

Same as above, but leaves the focus on the Rundown, not the story.  

{ENTER}{SPACE} 

Where program timing is not necessary, this macro will open the first story in a 
Rundown and display in full screen mode  

^O{WAIT}^E 

And this macro will close the first story and open subsequent stories in full 
screen mode, moving down the Rundown  

^E%C{WAIT}{DOWN}{WAIT}^O{WAIT}^E 
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To enable CG output for Rundown 1, and select View with personal layout (so 
as to allow the List Window to change to a wider view to show all the CG 
details).  

{ROVER:FOLDER2:MW_LAYOUTRESTORE}{ROVER:RUNDOWN1:RD_CG} 

To enable CG output for Rundown 1 and preload the CGs.  

{ROVER:RUNDOWN:RD_CG}{WAIT}%{RIGHT}{WAIT}%MP{ENTER} 

Close CG output for the active Rundown. The Rundown must be active 
(highlighted in red) and the layout returns to system default.  

%{RIGHT}{TAB 4}{ENTER}{ROVER:FOLDER2:MW_LAYOUTSYSTEM} 

Change Rundowns in a continuous news program, close the CG control, 
highlight the next Rundown in the List Window, then use this macro.  

{ENTER}{WAIT}{ROVER:RUNDOWN1:RD_CLOSE}{WAIT}{ROVER:RUNDOWN
2:RD_CG} 

Open Rundown highlighted in List Window, print it using current report layout 
and printer settings, close it and move one down the list.  

{ENTER}{ROVER:RUNDOWN1:RD_PRINTRW}{WAIT}{ROVER:RUNDOWN1:RD
_CLOSE}{WAIT}{DOWN} 

Same as above, but print the Rundown and all of the stories above the black 
line within the Rundown.  

{ENTER}{ROVER:RUNDOWN1:RD_PRINTRWALL}{WAIT}{ROVER:RUNDOWN1
:RD_CLOSE}{WAIT}{DOWN} 

Open the Rundown highlighted in the List Window and archive all rows above 
the black line. Manual confirmation of archive is still required.  

{ENTER}{WAIT}{ROVER:RUNDOWN1:RD_ARCHIVE_ABOVE} 

Drop the current story in a Rundown below the black bar. The letters “a” and 
“b” must be in lower case.  

%b{WAIT}^{PGDN}{WAIT}%a 

Rapidly approve stories in a Rundown, click the first one you wish to approve 
(it will turn green) then run this macro to approve the next 10. Re-run it until all 
stories are approved. This macro will remove approval from any stories in the 
Rundown that are already approved. 

{DOWN}x{WAIT}{DOWN}x{WAIT}{DOWN}x{WAIT}{DOWN}x{WAIT}{DOWN}
x{WAIT}{DOWN}x{WAIT}{DOWN}x{WAIT}{DOWN}x{WAIT}{DOWN}x{WAIT
}{DOWN}x{WAIT} 
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Copy stories in the same Rundown. 

%MI~{WAIT}{down}^o^a^c%c{ROVER:RUNDOWN1:RD_FULLSCREEN}{UP} 
^O {WAIT}^V %CY {ROVER:RUNDOWN1:RD_FULLSCREEN}{DOWN} 
^C{UP}{WAIT}^V.{ENTER}{WAIT}{DOWN}{RIGHT 
2}^C{UP}{WAIT}^V{ENTER}{WAIT}{LEFT 2} 

 Newsgathering Grids 
Allow the structure of a Newsgathering Grid to be transferred to a Rundown, 
for stations whose Newsgathering Grids closely reflect the order of their show.  

First open the Newsgathering Grid on the left side of the screen, then 
create/open a blank Rundown to the right of the Newsgathering Grid. Click on 
the slug in the Rundown above where you want the new rows to be created, or 
on the black bar if it is empty. Then make the first slug in the Newsgathering 
Grid active by clicking on it and run the following macro once for each row you 
wish to copy.  

{ROVER:RUNDOWN1:RD_FULLSCREEN}^C{WAIT}{DOWN}{ROVER:RUNDOWN
1:RD_FULLSCREEN}{WAIT}{ROVER:RUNDOWN2:RD_INSERTROW}{WAIT}{
HOME}{RIGHT 2}^V{WAIT}{ENTER}{WAIT}{DOWN} 

The previous macro copies slugs only. To copy slugs and segments, use the 
following macro. Both of the above Macros assume the Page Number column 
is included in the Rundown layout.  

{ROVER:RUNDOWN1:RD_FULLSCREEN}{HOME}^C{WAIT}{ROVER:RUNDOWN
1:RD_FULLSCREEN}{WAIT}{ROVER:RUNDOWN2:RD_INSERTROW}{WAIT}{
HOME}{RIGHT 2}^V{WAIT}{ENTER}{WAIT}{ROVER:RUNDOWN1: 
RD_FULLSCREEN}{RIGHT 2}{WAIT}^C{WAIT}{DOWN} 
{ROVER:RUNDOWN1:RD_FULLSCREEN}{WAIT}{ROVER:RUNDOWN2:RD_FUL
LSCREEN}{RIGHT 2}^V{WAIT}{ENTER}{WAIT}{DOWN} 
{ROVER:RUNDOWN2:RD_FULLSCREEN} 

Create new Newsgathering Grids for a month ahead. Set the month as 
required (replace mm in the macro) and enter in the day manually each time the 
Newsgathering Grid is created. The macro will need to be adapted for different 
international date formats (this version assumes mm/dd/yyyy). It also 
assumes the desired template is the first to appear in the alphabetical list and 
that Folder 3 is set to the folder containing the Newsgathering Grids and 
template. 

{ROVER:FOLDER3:MF_NEWNGPROSPECT}{WAIT}{TAB 2}{DOWN}{WAIT} 
%T{DEL 2}mm{RIGHT}+{RIGHT 2} 

 

Favorites 
Call up the list of personal folder favorites on Folder 3. This macro leaves the 
user ready to make their choice: 

%3P{RIGHT} 
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Same as above, but with Folder 4. 

%4P{RIGHT} 

Same as above, but for the Group Favorites. 

%3G{RIGHT} 

Add the current Folder 3 to the Personal Favorites.  

%3P{RIGHT}{DOWN 22}{ENTER} 

Add the current Folder 3 to Group Favorites. 

%3G{RIGHT}{DOWN 22}{ENTER} 

 

Miscellaneous 
Create a graphics request. 

{ROVER:FOLDER3:MF_NEWSCRIPT}{DOWN 2}{TAB}Untitled{TAB} 
~{WAIT}%P{WAIT}{DOWN 3} 

Save, approve and close a Generic Grid whether it is newly created or pre-
existing in a folder.  

%MA~~{WAIT}%C 
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