
Last updated: January 3, 2012 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 
 
 
Operations Guide 
Version 6.0 

 

 

 

 

 

 
 
 



2 ENPS Operations Guide 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Copyright © 2012 Associated Press. All rights reserved. 
 
This manual (the “Manual”) and the ENPS software (the “Software”) are 
copyrighted and all rights are reserved by the Associated Press. No part of the 
Manual or the Software may be reproduced or transmitted in any form or by any 
means, electronic or mechanical, including photocopying, recording, or any 
information storage and retrieval system, without permission in writing from the 
Associated Press. 
 
The Software described in the manual is furnished under a license agreement 
and can be used or copied only in accordance with the terms of the license 
agreement. 
 
The information in the Manual is subject to change without notice. No part of the 
Manual may be reproduced or transmitted in any form or by any means, 
electronic or mechanical, for any purpose, without prior express written 
permission of the Associated Press. 
 
THE MANUAL AND THE INFORMATION CONTAINED WITHIN IS PROVIDED 
“AS IS” AND ALL EXPRESS OR IMPLIED CONDITIONS, REPRESENTATIONS 
AND WARRANTIES, INCLUDING ANY IMPLIED WARRANTY OF 
MERCHANTIBILITY, FITNESS FOR A PARTICULAR PURPOSE OR NON-
INFRINGEMENT, ARE DISCLAIMED. 
 
The Associated Press may have patents or pending patent applications, 
trademarks, copyrights or other intellectual property rights covering subject 
matter in this document. The furnishing of this document does not give you any 
license to these patents, trademarks, copyrights or other intellectual property 
rights except as expressly provided in any written license agreement from the 
Associated Press. 
 
The terms ENPS, Associated Press and AP are registered trademarks of the 
Associated Press. Windows is a trademark of the Microsoft Corporation. Other 
products and company names mentioned herein may be the trademarks of their 
respective owners.



The Associated Press 3 
 

Contents 
Preface 6 

Technical Support 6 
Typographical Conventions in this Guide 6 

Chapter 1 7 
Hardware and Software Requirements 7 

Antivirus Software Recommendations 9 
Chapter 2 11 
Primary Server Installation 11 

Central Server and CTOS 11 
Installing on Windows 2008 Server 11 
Installing on Windows 2003 Server 18 
Connecting to Servers with Remote Desktop 22 
Enabling Automatic Logon 22 

Chapter 3 24 
Upgrading and Migrating Servers 24 

Using the Upgrade Installer 24 
Using the Full Installer 25 
Migrating Servers to New Hardware 27 
Migrating the CTOS 29 

Chapter 4 31 
Server Applications 31 

News Object Manager 31 
NOM Maintenance 34 
NOM Watcher 34 
News Wire Profiler 35 

Chapter 5 37 
Installing the Client 37 

Chapter 6 40 
Installing the Buddy Server 40 

Chapter 7 42 
Managing Servers 42 

Chapter 8 44 
Configuration Settings 44 

Global Configuration Options 44 
NOM Configuration Settings 59 
NWP Configuration Settings 65 

Chapter 9 69 
Compound Storage 69 

Chapter 10 71 
Client Configuration Settings 71 

Chapter 11 83 
Custom Fields 83 

Frequently Used Fields 87 
Chapter 12 90 
User and Group Administration 90 

Staff Table 90 
Groups 91 
Security Roles 94 
Default Settings Profiles 96 



4 ENPS Operations Guide 
 

Security Profiles 97 
Verify Clients with MAC Addresses 97 

Chapter 13 100 
Client Features 100 

My ENPS 100 
Web Searches 101 
News Tickers 101 
Follow-Me Messaging 103 
Launch External Applications 105 
Enabling Clients to Publish to Social Media 106 

Chapter 14 109 
Network Settings 109 

Port Assignments 109 
Multicasting 109 
Reflectors 110 
Private Channels 112 
Dial-up Users 113 

Chapter 15 114 
Sending and Receiving Wires 114 

Basic Serial Wire 114 
Wires via FTP 115 
Wires via E-Mail 116 
Wires via AP WebFeeds 117 
Wires in XML Format 120 
Wires via OPENS 120 
Wires via Twitter 121 
Wires via YouTube Feeds 123 
Custom Wire Categories 125 
Dependent Wires 126 
Opening a Wire with an ActiveX Plug-In 127 
Publishing Wires 127 

Chapter 16 130 
MOS Configuration 130 

Add a MOS Device or an ActiveX Plug-in 130 
Configuring ENPS Plug-Ins 133 
Read-Only Rundowns 136 
Setting Up a MOS Repeater 136 

Chapter 17 139 
Character Generators 139 

Supported Character Generators 139 
Configuration Settings 139 
Copying Templates 140 
Considerations for Specific Character Generators 141 

Chapter 18 147 
Peripherals 147 

Prompters 147 
OmniBus Automation System 148 
Hauppauge’s WinTV Card 149 

Chapter 19 151 
Routine Maintenance 151 

Daily Checks 151 
Weekly Checks 151 



The Associated Press 5 
 

Chapter 20 153 
Language Support 153 

Keyboard Support 153 
Setting the Local Language 153 
Considerations for Specific Languages 156 
Mapping International Characters with the CG 160 

Chapter 21 162 
Troubleshooting 162 

Authentication 162 
MOS 163 
Network 164 
Performance 166 
Prompters 166 
Rundowns 166 
Search 167 
Server Synchronization 170 
Stories 171 
Wires 172 

Appendix A 173 
Import and Export Data 173 

Import NewsCenter Archives 173 
Generic Import Facility 174 
Exporting ENPS Data 175 

Appendix B 177 
File Structure 177 

System Tables 177 
User Folders 178 
Program/Group Folders 178 

Appendix C 179 
Registry Settings 179 

Index 180 



Preface 
This guide is designed to be used by technical staff who will install, configure and 
support ENPS. It contains confidential and proprietary information. Your site’s 
users should refer to the ENPS Basic User’s Guide and ENPS Advanced User’s 
Guide for information about how to use ENPS in the newsroom. 

ENPS was designed to be easy to use. For System Administrators, ENPS 
provides reliable operation and a "future-proof" design that grows with your 
enterprise. 

To view the latest version of the documentation or to download ENPS software 
updates visit the ENPS website at http://www.enps.com. 

Technical Support  
Users can press the F1 key for online help while they are using ENPS. 

If you have a technical question about ENPS you can post it on the ENPS 
support forum at http://support.enps.com. You must register to receive a 
username and password. 

If you require additional technical assistance you can reach the AP at the 
following phone numbers: 

ENPS Support 
• If you are in the Americas call +1-866-ENPS-911 or +1-202-641-9641 
• If you are outside of the Americas call +44 (0) 20 8225 8685. 

AP Wires or Radio Network Delivery  
• Contact your local AP bureau. If you are not sure which department to 

contact call +1-800-821-4747 or +1-202-641-9000. 
• Call +1-800-232-7241 or +1-202-641-9880. 

Typographical Conventions in this Guide 
The following table lists the typographic conventions used in this guide: 

Typeface Meaning Example 
SAMPLE 
TEXT 

Text to be to be typed, 
keystrokes, filenames or 
directories. 

Run C:\Program 
Files\ENPS\ENPS.EXE to start 
ENPS. 

Sample 
→Text 

Navigation from one 
menu to another 

To create a new contact select 
Personal Folder rover → New→ 
Contact → Personal. 

Sample text Button names Click Close to close the current 
window. 
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Chapter 1 
Hardware and Software Requirements 

This chapter lists the minimum hardware and software required to run ENPS. 
Keep in mind the following notes about these requirements: 

• You should consult with ENPS Support before you purchase new hardware. 

• Server requirements vary based on the number of users at your site and 
other factors. You may need to add additional servers as your organization 
grows. 

• All hardware must have the appropriate drivers. Refer to “Primary Server” on 
page 11 to find out when to install drivers during the ENPS installation 
process. 

Minimum Server Requirements 

CPU Two servers are required: a Primary Server and a 
backup Buddy Server. Each server must have at least 
two Intel Xeon 2 GHz processors. Having a dual-core 
processor does not take the place of multiple 
processors. 

RAM 2 GB minimum; 4 GB or more is recommended.  

Operating Systems Windows Server 2003 or Windows Server 2008. The 
operating system must be 32-bit; 64-bit operating 
systems are not supported. The operating system you 
are using must have the latest Microsoft service packs 
and security patches installed. 
Microsoft .NET Framework 4.0 must be installed. 

Wire Ingestion Multi-port serial card such as Comtrol Rocketport or 
Digi Board with one port for each incoming wire feed. 
PCI or PCI Express connectors for the multi-port serial 
cards are recommended. USB connectors are not 
recommended. 

Hard Disk Storage Hardware RAID yielding a minimum of 146 GB. This 
can be configured as a RAID 1 or RAID 5 using 
10kRPM SCSI or SAS drives. This must be a 
hardware-based RAID; software-based RAID arrays 
are not supported. For configuration questions please 
contact ENPS Support. 

Network Interface 
Card 

10/100BASE-T minimum; 10/100/1000BASE-T 
recommended. The card must support TCP/IP in a 
Windows networking environment. 

Backup System A locally-attached external media backup for ENPS 
files is strongly recommended. 
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Additional Software Microsoft Internet Explorer 7.0 or later. 
Adobe IFilter 6.0 to index PDF files. This tool is 
available as a free download from the Adobe website at 
the following URL:  
http://www.adobe.com/support/downloads/detail
.jsp?ftpID=2611 

Remote access to server is required such as VNC, 
PCAnywhere or Remote Desktop. 
Diskeeper Server 6.0 or higher is recommended. 
Real-time antivirus software is not recommended. 
Refer to “Antivirus Software Recommendations” in this 
chapter for more information. 

The following table lists minimum hardware and software requirements for the 
client workstation: 

Minimum Client Requirements 

CPU Pentium IV 1GHz minimum; faster workstations are 
recommended for sites using ActiveX plug-ins. 

Supported 
Operating Systems 

Windows XP Professional, Windows Vista Professional 
or Windows 7 Professional. The operating system must 
have the latest Service Packs from Microsoft installed. 
Home editions are not supported.  
Microsoft .NET Framework 4.0 must be installed. 
The workstation must have a Server Client Access 
License and it must be a member of your site’s 
Windows domain. 

RAM 1 GB minimum; 2 GB or more is recommended. 

Video Card Minimum display resolution of 1024x768x16 is 
required; 1024x768x32 is recommended. 

Hard Disk 2 GB 

Browser Microsoft Internet Explorer 7.0 or later. 

Printer Laser printers such as the Hewlett Packard LaserJet 
series are recommended. Dot matrix printers have 
limited support under ENPS and are not 
recommended. 

Network Interface 
Card 

10/100BASE-T minimum; 10/100/1000BASE-T 
recommended. The card must support TCP/IP in a 
Windows networking environment. 
If you are using multimedia ActiveX plug-ins consult 
with the vendor for their networking requirements.  

Additional Hardware Audio card and speakers 

Refer to your prompter or captioning manual for information about the hardware 
requirements for your setup. You can use the following requirements as general 
guidelines: 

http://www.adobe.com/support/downloads/detail.jsp?ftpID=2611
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2611


The Associated Press 9 
 

Prompter/Captioning Workstation Requirements 

CPU Pentium IV 1 GHz or faster is recommended 

Supported 
Operating Systems 

Windows XP Professional, Windows Vista Professional 
or Windows 7 Professional. Home editions are not 
supported. The operating system must be installed with 
the latest Service Pack from Microsoft.  
The workstation must have a Server Client Access 
License and it must be a member of your site’s 
Windows domain. 

Prompter  It is recommended that you use +WinPlus+ as the 
primary or backup prompter. The +WinPlus+ prompter 
is an ISA/PCI hardware board with NTSC/PAL outputs. 
It comes with a hand controller and can be genlocked. 

RAM 1 GB minimum; 2 GB or more is recommended 

Video Card Memory 128 MB minimum 

Hard Disk  2 GB  

Network Interface 
Card 

10/100BASE-T minimum; 10/100/1000BASE-T 
recommended. The card must support TCP/IP in a 
Windows networking environment. 

Other Hardware Serial (RS-232) port for optional hand controller. 
VGA10-to-NTSC converter such as Black Box VGA to 
Video Portable Pro Videoing Inc.  
Print-To-Video Standard Mouse and/or Trackball for 
controlling prompter. 

Antivirus Software Recommendations 
AP recommends against using realtime anti-virus software on ENPS servers. 
Doing so may result in the following issues: 

• The antivirus software may have kernel-level conflicts with Microsoft's Index 
Server which ENPS uses for its Search functionality.  

• When new material is added to the server it may take significantly longer to 
add it to the index and therefore will not be available through Search as 
quickly. 

• The index may be corrupted frequently. If it is corrupted, re-indexing will 
take significantly longer to complete. The Index Server may attempt to 
repair itself from a conflict by rescanning the indexed drives which can 
significantly degrade server speed. 

• Unscheduled Master Merges may occur several times a day. This can also 
decrease server performance. 

These risks can be severe but they do not always occur. If you accept the 
potential consequences of running anti-virus software on an ENPS server 
following these steps to reduce the likelihood of encountering problems: 

• Set the antivirus software to perform scheduled scans instead of real-time 
scans. 
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• If you must do real-time scans exclude the ENPS data drive(s), which are 
usually D: on a single-partition system and F:, G: and H: on a multi-partition 
system. Also exclude the ENPS index folder Catalog.WCI. 

If you experience frequent Search or indexing problems while running anti-virus 
software you may need to disable or uninstall the antivirus software while you 
troubleshoot.  

To reduce your servers’ vulnerability to viruses and spyware you should take the 
following precautions: 

• Keep servers updated with all of the critical updates from Microsoft. 
• Do not allow access to e-mail or the Internet from the servers. 
• Make sure there are no open file shares on the servers. The only exception 

is the ENPS client installation folder which must be shared but should be set 
to read-only.  

• These steps eliminate many server vulnerabilities and reduce the need to 
run anti-virus software. 
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Chapter 2 
Primary Server Installation 

This section describes how to install a Primary Server on Windows 2008 Server 
and Windows 2003 Server. If you already have ENPS installed and you want to 
update it to the latest version refer to “Upgrading ENPS” on page 24. 

Central Server and CTOS  
The Central Server is the main repository for your ENPS system maintenance 
files including staff lists, field definitions, MOS configurations and other global 
settings. Every site must have a Central Server. There are several options for 
choosing which server will be the Central Server in your enterprise: 

• If you have only one ENPS Primary Server and one Buddy Server then one 
of these servers, typically the Primary Server, must be the Central Server.  

• If your site has multiple pairs of ENPS servers, which may be across 
multiple physical locations, any of the Primary Servers can be designated as 
the Central Server. 

• A separate, standalone server that does not function as either a Primary or 
a Buddy server may be designated as a Central Server. This standalone 
Central Server may only host the master copies of ENPS system files. It 
would not host any program groups or user data. 

The hardware requirements and installation steps for building a standalone 
Central Server are the same as those for building the Primary Server. To 
designate a server as your Central Server use set the Global Configuration 
Option CentralServer. Refer to “Global Configuration Options” on page 44 for 
more information on this setting. 

If you use a standalone Central Server you also have the option to configure it as 
a Central Text Object Server (CTOS). A CTOS is typically used by large 
organizations to store and index archive data from other ENPS servers. A CTOS 
allows users to perform a single, integrated search of archives from any client in 
the enterprise.  

The storage requirements for a CTOS depend on how many archives will be 
stored on the server. You can set a Central Server as a CTOS using the CTOS 
Global Configuration Option. Refer to “Global Configuration Options” on page 44 
for more information on this setting. 

Installing on Windows 2008 Server 
Note the following important points before you start the installation: 

• Refer to “Hardware and Software Requirements” on page 7 to make sure 
your equipment meets all of the prerequisites. Refer to “Part 5: Partition 
Drives” below for information about the partition sizes you will need for your 
operating system. 

• ENPS servers require static IP addresses, not reserved DHCP IP 
addresses. 

• Server Network Interface Cards (NICs) and the ports to which they connect 
are both set to identical settings and do not have auto-negotiate or auto-
sense functions enabled. 
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• ENPS servers may not run any other services. The only extra service that is 
allowed is the SNMP service. 

• ENPS servers cannot be Active Directory Domain Controllers. 
Part 1: Install the Operating System 
1.  Install Windows 2008 with Service Pack 2. Make sure you remember the 

System Administrator password that you provide during the installation. The 
ENPS installer will prompt you for it later.  

2.  Install hardware drivers, third party SNMP agents, Diskeeper and backup 
software.  

Part 2: Modify Windows Components 
1.  Open the Control Panel and select Windows Firewall. Make sure the firewall 

is set to Off then click OK. 

2.  Right-click on your computer’s desktop icon and select Manage to open the 
Server Manager. Under Security Information click Configure IE ESC in the 
top right corner and make sure it is set to Off for both Administrators and 
Users. 

3.  Open the command prompt and run MSCONFIG to open the System 
Configuration utility. On the Tools tab select Disable UAC then click Launch. 
Click OK to close the System Configuration window. 

 
4.  Reboot your system. 

5.  Re-open the Server Manager by right-clicking on your computer’s desktop 
icon and selecting Manage. In the Server Manager pane select Features. 

6.  In the Features Summary window select Add Features. Make sure the 
following features are selected: 

• Telnet Client 
• Telnet Server 
• .NET Framework 3.0 Features  
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Expand .NET Framework 3.0 Features. Make sure the following sub-entries 
are selected: 

• .NET Framework 3.0 
• XPS Viewer  
• WCF Activation 

When you select .NET Framework 3.0 Features the Add Roles Wizard will 
prompt you to add roles services.  

 
 Click the Add Required Role Services button. 

 Click Next through the wizard until you can click Install. Click Close when 
installation is complete. 

7.  Click Roles on the navigation pane. Under Roles Summary click Add Roles.  

 
Select the following options if they are not already installed: 

• File Services 
• Web Server (IIS) 
• Application Server 
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After you select Application Server another Add Roles Wizard will appear.  

 
Select the following options if they are not already installed: 

• COM+ Network Access 
• Web Server IIS Support 

 When the Add Roles Wizard appears click Add Required Role Services 
then click Next.  

 In the Web Server IIS Pane make sure Management Tools and its sub-
entries are selected. Make sure IIS 6 Compatibility is selected then click 
Next. 

Expand Application Development and select the ASP checkbox. 

 
Expand Windows 2003 Server File Services and select Indexing Service 
then click Next.  

Click Install to install the selected services. Reboot the server if necessary. 

Part 3: Modify Registry Settings 
1.  Run REGEDT32 from the command prompt. Navigate to the following key: 

HKEY_LOCAL_MACHINE 
\System\CurrentControlSet\Control\FileSystem 

2.  Select Edit → New → DWORD Value and enter 
NtfsMftZoneReservation as the name. 

3.  Select Edit → Modify and in the Value Data field enter the number 3. 

4.  Reboot the server for the registry changes to take effect. 

Part 4: Back Up Configuration Data 
1.  Create the C:\BACKUPS folder. 

2.  Run REGEDT32 from the command prompt. Navigate to the following key: 

HKEY_LOCAL_MACHINE 
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\SYSTEM\CurrentControlSet\Control\ContentIndex 

3.  Select File → Export and save the file as C:\BACKUPS\Index Server 
Default Settings.reg 

4. Close the registry editor. 

Part 5: Partition Drives 
The partition sizes listed below are based on an average ENPS site 
configuration. If your organization retains wires for more than 100 hours, if your 
server ingests more than six wires or if you have more than 150 users per server 
you should consult with ENPS Support for the recommend partition sizes for your 
site. 

Use the following general rules for calculating the total working size for the 
drives: 

• RAID-1: Two identical drives which yield a space equal to the size of one of 
the drives. One drive can be lost and the server will continue to run. 

• RAID-5: A minimum of three identical drives which yield space equal to the 
sum of all drives minus the size of one drive. For example, 3 x 36 GB drives 
will yield a working size of 72 GB. One drive could fail and the server would 
continue to run. 

For systems with multiple RAID arrays it is recommended that you have two 
physical disks in a RAID-1 mirror configuration with two NTFS partitions: 

• 6 GB C: System volume 
• 4 GB D: Swap file/Index Catalog for the remainder of the volume.  

The second array should be a minimum of 3 x 9 GB drives in RAID-5 
configuration. Do not partition this array. 

If you are using a RAID-1 array it is recommended that you use 2 x 72 GB 10k 
RPM SCSI or larger drives to form the RAID-1 array. 

Partition Sizes 

Drive 

Letter 

Volume  

Name 

Minimum 

Size 

Recommended  

Size 

File Allocation  

Unit Size 

C:  System  20 GB  50 GB 4096 (default)  

D:  CD-ROM    
E: Indexes 6 GB* 10 GB 4096 (default)  

F:  ENPS Work 10 GB  40 GB 1024  

G:  Wires  2 GB 5 GB 1024  

H: Archives  30 GB 50+ GB** 1024  

*On configurations with more space it is recommended that indexes are placed 
on a separate volume. However, if you have limited drive space you may place 
Indexes on the same volume as your Archives (H:). 
**Any extra space in your partitions should be allocated to the Archives 
volume. 

To set the partition letters complete the following steps:  
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1. Open Computer Management by double-clicking on the Computer 
Management shortcut on your desktop. You can also open Computer 
Management by opening a command prompt and entering the following 
command: 

C:\Windows\System32\compmgmt.msc /s  

2. Expand Storage → Disk Management. If the drive letter of your CD-ROM 
drive is F:, G: or H: you must assign it to D: or another available drive letter 
since these letters will be used by ENPS partitions. To change a drive letter 
right-click on the drive and select Change Drive Letter and Paths. 

Windows permits logical disks to have a maximum of four partitions. To 
increase this number right-click on the disk name and select Convert to 
dynamic disk. You will not be able to revert to a logical disk once you format 
the partitions. 

3.  Right-click on the unformatted partition and select Format. When you are 
prompted for Volume Type select Primary Partition or select Simple Volume 
if you are using a dynamic disk. 

4.  Format each drive according to the volume name, partition size and file 
allocation sizes listed in the Partition Sizes table above. 

Part 6: Install Server Components 
1. Download Microsoft .NET Framework 4.0 from the Microsoft website and 

install it. 

2.  Download the ENPS installer from the ENPS download site or insert the 
ENPS Setup CD-ROM. If you need a link to the download site send an e-mail 
to info@enps.com. Be sure to include your name and the name of your 
organization along with your request. 

3. Run the ENPS installer from the root directory of the ENPS WORK drive. 

• When you are prompted to enter the drive letters for Data, Wires, 
Archives and Indexes refer to the partition table above for the suggested 
drive letters. Archives and Indexes may have the same drive letter. 

• When you are prompted for the server name enter a name that 
corresponds to your site name such as station call letters. Do not name 
your server ENPS. 

• Enter the NetBIOS machine name of the Buddy Server. If this server will 
not have a Buddy Server, or you are configuring it as a CTOS, enter 
NONE. 

• Enter the NetBIOS machine name of the Central Server. If you do not 
have a separate Central Server the Primary Server will be the Central 
Server. 

• Enter the system password so that the system can login automatically. 
This is helpful in the event of a power failure or when the server area is 
unattended. If you do not enable this feature now you can manually 
enable it later by completing the instructions in “Enabling Automatic 
Logon” on page 22. 

4.  After you fill out the ENPS registration form reboot the server. ENPS server 
applications will start automatically. Minimize them before you proceed to the 
next step. 



The Associated Press 17 
 

Part 7: Set Configuration Settings 
1.  Right-click on the Recycling Bin and select Properties.  

2.  Select the ENPS volumes F:, G: and H: and select the Do not move files to 
the Recycling Bin option. Click Apply to save your settings. 

Part 8: Verify IIS Settings  
1.  Open Computer Management and expand Services and Applications then 

select Internet Information Services. Click on the server name in the 
Connections pane to expand it. Select the ENPS Web website. 

3.  Under ENPS Web Home double-click Handler Mappings to display a list of 
extensions. Make sure that the following extensions are displayed: 

  
4.  Double-click the first extension so that the Edit Story Map box appears. 

Click Request Restrictions, select the Verbs tab and verify that the verbs 
GET, HEAD, and POST appear in each. Repeat this step for each of the 
other extensions. 

  

Part 9: Install Adobe IFilter  
For users to search the contents of PDF files in Newsgathering Grids you need to 
install Adobe PDF IFilter 6.0 on the ENPS Primary Server. IFilter 6.0 is available 
for free from the Adobe website at the following URL: 
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2611 

Part 10: Enter the License Key 
Call ENPS Support to obtain a license key. You will not be able to obtain a 
license key via e-mail. 

• If you are in North America call +1-866-ENPS-911 or +1-202-641-9641. 
• If you are outside North America call +44 (0) 20 8225 7272. 

To enter your license key open the NOM and select File → Update license.  

Proceed to “Installing the Client” on page 37 to to install the ENPS client and 
complete additional server installation steps. 
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Installing on Windows 2003 Server  
Note the following important points before you start the installation: 

• Refer to “Hardware and Software Requirements” on page 7 to make sure 
your equipment meets all of the prerequisites. Refer to “Part 5: Partition 
Drives” below for information about the partition sizes you will need for your 
operating system. 

• ENPS servers require static IP addresses, not reserved DHCP IP 
addresses. 

• Server Network Interface Cards (NICs) and the ports to which they connect 
are both set to identical settings and do not have auto-negotiate or auto-
sense functions enabled. 

• ENPS servers may not run any other services. The only extra service that is 
allowed is the SNMP service.  

• ENPS servers cannot be Active Directory Domain Controllers. 
Part 1: Install the Operating System 
1.  Install Windows 2003 Server with the latest Service Pack from Microsoft. 

IMPORTANT: If you are using a Compaq, HP, Dell or IBM server do not use 
the manufacturer’s startup disk. Use the Windows boot CD instead. If you 
have to install the vendor’s utilities install the operating system then install 
vendor utilities before you install the latest Microsoft Service Pack. 

During Windows 2003 Server installation you will be prompted to install 
additional Windows components. Do not select any other options or services. 
The only service that is allowed is the SNMP service.  

Make sure you remember the System Administrator password that you enter 
during the installation process. The ENPS installer will prompt you for it later.  

2.  Install hardware drivers, third-party SNMP agents, Diskeeper and backup 
software.  

Part 2: Modify Windows Components 
1.  Open the Control Panel and select Add/Remove Programs then select 

Add/Remove Windows Components. 

• Enable the Indexing Service.  
• Disable Internet Explorer Enhanced Security Configuration.  
• Make sure Terminal Server is not installed.  

2.  Select Application Server and click Details. Enable the following features: 

• Application Server Console 
• ASP.NET 
• Network COM+ Access 

3.  Select Internet Information Services and click Details. Enable the following 
features: 

• Common Files 
• Internet Information Services Manager 
• World Wide Web Service 
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4.  Click OK until you return to the main Windows Components screen then click 
Next. When the new components are finished installing close the Add or 
Remove Programs window. 

Part 3: Modify Registry Settings 
1.  Open the command prompt and run REGEDT32. Navigate to the following 

key: 

HKEY_LOCAL_MACHINE 
\System\CurrentControlSet\Control\FileSystem 

2.  Select Edit → New → DWORD Value. Enter the name 
NtfsMftZoneReservation  

3.  Select Edit → Modify. In the Value Data field enter the number 3. 

4.  Reboot the server for the registry changes to take effect. 

Part 4: Back Up Configuration Data 
1.  Create the C:\BACKUPS folder. 

2.  Open the command prompt and run REGEDT32. Navigate to the following 
key: 

HKEY_LOCAL_MACHINE 
\SYSTEM\CurrentControlSet\Control\ContentIndex 

  Select File → Export. Save the file as C:\BACKUPS\Index Server 
Default Settings.reg then close the registry editor. 

Part 5: Partition Drives 
The recommended partition sizes below are based on an average ENPS 
configuration. If your organization retains wires for more than 100 hours, if your 
server ingests more than six wires or if you have more than 150 users per server 
you should consult with ENPS Support for the recommend partition sizes for your 
site. 

Use the following general rules for calculating the total working size of the drives: 

• RAID-1: Two identical drives which yield a space equal to the size of one of 
the drives. One drive can be lost and the server will continue to run. 

• RAID-5: A minimum of three identical drives which yield drive space equal 
to the sum of all drives minus the size of one drive. For example, 3 x 36 GB 
drives will yield a working size of 72 GB. If one drive fails the server will 
continue to run. 

For systems with multiple RAID arrays it is recommended that you have two 
physical disks in a RAID-1 mirror configuration with two NTFS partitions: 

• 6 GB C: System volume 
• 4 GB D: Swap file/Index Catalog for the remainder of the volume.  

The second array should be a minimum of 3 x 9 GB drives in RAID-5 
configuration. Do not partition this array. 

If you are using a RAID-1 array it is recommended that you use 2 x 72 GB 10k 
RPM SCSI or larger drives to form the RAID-1 array. 
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Partition Sizes 

Drive 

Letter 

Volume  

Name 

Minimum 

Size 

Recommended  

Size 

File Allocation  

Unit Size 

C:  System  20 GB  50 GB 4096 (default)  

D:  CD-ROM    
E: Indexes 6 GB* 10 GB 4096 (default)  

F:  ENPS Work 10 GB  40 GB 1024  

G:  Wires  2 GB 5 GB 1024  

H: Archives  30 GB 50+ GB** 1024  

*On configurations with more space it is recommended that indexes are placed 
on a separate volume. However, if you have limited drive space you may place 
Indexes on the same volume as your Archives (H:). 
**Any extra space in your partitions should be allocated to the Archives 
volume. 

To set the partition letters for your setup complete the following steps:  

1. Right-click the My Computer icon and click Manage to open Computer 
Management. Expand Storage → Disk Management. If the drive letter of 
your CD-ROM drive is F:, G: or H: you must assign it to D: or another 
available drive letter since these letters will be used by ENPS partitions. 
Right-click on the drive and select Change Drive Letter and Paths. 

Windows permits logical disks to have a maximum of four partitions. To 
increase this number right-click on the disk name and select Convert to 
dynamic disk. You will not be able to revert to a standard logical disk once 
you format the partitions. 

2.  Right-click on the unformatted partition area and select Format. When you 
are prompted for Volume Type select Primary Partition or select Simple 
Volume if you are using a dynamic disk. 

3.  Format each drive according to the volume name, partition size, and file 
allocation sizes listed in the Partition Sizes table above.  

4.  Close the Computer Management utility. 

Part 6: Install Server Components 
1. Download Microsoft .NET Framework 4.0 from the Microsoft website and 

install it. 

2.  Download the ENPS installer from the download site or insert the ENPS 
Setup CD-ROM. If you need a link to the download site send an e-mail to 
info@enps.com. 

3. Run the ENPS installer from the root directory of the ENPS WORK drive. 

• You will be prompted to enter the drive letters for Data, Wires, Archives 
and Indexes. Refer to the partition table in the previous step for the 
suggested drive letters. Archives and Indexes may have the same drive 
letter. 
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• When you are prompted for the server name enter a name that 
corresponds to your site name such as station call letters. Do not name 
your server ENPS. 

• Enter the NetBIOS machine name of the Buddy Server. If this server will 
not have a Buddy Server, or you are configuring it as a CTOS, enter 
NONE. 

• Enter the NetBIOS machine name of the Central Server. If you do not 
have a separate Central Server the Primary Server will be the Central 
Server. 

• Enter the system password so that the system can login automatically. 
This is helpful in the event of a power failure or when the server area is 
unattended. If you do not enable this feature now you can manually 
enable it later by completing the instructions in “Enabling Automatic 
Logon” on page 22. 

After you reboot the ENPS server applications will start automatically. Minimize 
them before you proceed to the next step. 

Part 7: Set Configuration Settings 
1.  Right-click on the Recycling Bin and select Properties.  

2.  Select the ENPS volumes (F:, G:, H:) and select the Do not move files to the 
Recycling Bin option. Click Apply to save your settings. 

Part 8: Verify IIS Settings  
Right-click the My Computer icon and click Manage to open the Computer 
Management utility. Expand Services and Applications and select Internet 
Information Services (IIS) Manager → Web Sites. Right-click on the ENPS 
Web website and select Properties. Select the Home Directory tab and click the 
Configuration button.  

You will see a list of Application Mappings. If the extensions .ida, .htw and 
.idq are not listed with the mappings shown below you will need to add them to 
the list.  

Extension Executable Path Verbs (Limit To) 

.ida C:\WINDOWS\SYSTEM32\IDQ.DLL GET, HEAD, POST 

.htw C:\WINDOWS\SYSTEM32\WEBHITS.DLL GET, HEAD, POST 

.idq C:\WINDOWS\SYSTEM32\IDQ.DLL GET, HEAD, POST 

Part 9: Install Adobe IFilter  
For users to search the contents of PDF files in Newsgathering Grids you need to 
install Adobe PDF IFilter 6.0 on the ENPS Primary Server. IFilter 6.0 is available 
for free from the Adobe website at the following URL: 
http://www.adobe.com/support/downloads/detail.jsp?ftpID=2611 

Part 10: Enter the License Key 
Call ENPS Support to obtain a license key. You will not be able to obtain a 
license key via e-mail. 

• If you are in North America call +1-866-ENPS-911 or +1-202-641-9641. 
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• If you are outside North America call +44 (0) 20 8225 7272 to obtain a 
license.  

Enter your license key by opening the NOM. Select File → Update license.  

Proceed to “Installing the Client” on page 37 to to install the ENPS client and 
complete additional server installation steps. 

Connecting to Servers with Remote Desktop 
Remote Desktop is a convenient way to administer ENPS servers from other 
workstations. However, when it is opened with its default settings Remote 
Desktop will create a new session and create additional instances of the ENPS 
server applications. This will cause problems on the server. 

To prevent this from happening you must run Remote Desktop with parameters 
that have it join the session already running. From the command prompt enter 
the following command: 

%WINDIR%\SYSTEM32\MSTSC.EXE -V:<SERVER NAME> /F /ADMIN  

where <SERVER NAME> is the server’s NetBIOS name or IP address. Earlier 
versions of Windows may require the /console switch instead of the /admin 
switch. 

You can also use remote viewing clients such as RealVNC to connect to your 
ENPS servers. 

Enabling Automatic Logon 
If you did not choose to enable automatic server logon during the installation you 
can perform the following steps to enable it: 

1.  Open the command prompt and run REGEDT32. Navigate to the following 
key: 

HKEY_LOCAL_MACHINE 
\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon  

2.  Locate the DefaultDomainName key. Right-click on the key and select 
Modify. In the Value Data field enter the domain of the Primary Server. 

3.  Locate the DefaultUserName key. Right-click on the key and select 
Modify. In the Value Data field enter the username used to log in to the 
Primary Server. 

4.  Check to see if the DefaultPassword key exists. If the key does not exist 
select Edit → New → String Value to create the key. Enter 
DefaultPassword as the string name. Right-click on the key and select 
Modify. In the String field enter the account password.  

5.  Select Edit → New → String Value to create a new key. Enter 
AutoAdminLogon as the string name. Right-click on the key and select 
Modify. In the String field enter 1. 

6.  Save your changes and exit the registry editor. 

When you restart your computer the server will log in automatically. 
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Chapter 3 
Upgrading and Migrating Servers 

Complete the steps in this chapter to upgrade ENPS to a newer version. This 
chapter includes instructions for two installers: the upgrade installer and the full 
installer. You can use the upgrade installer if the newer version has the same 
major build number as the one you are using. For example, if you are upgrading 
from 5.0.0053 to 5.0.0087 you can use the upgrade installer. If you are upgrading 
between major builds such as 4.05 to 5.0 use the full installer. 

Keep in mind the following notes before you perform the upgrade: 

• Do not perform the upgrade during or immediately prior to a newscast.  
• Perform the upgrade when there is the lowest resource load on the system.  
• Give users prior notice that the Primary Server will be unavailable. 
• If you have multiple Primary Servers upgrade the Central Server first.  

Using the Upgrade Installer 
Part 1: Download the Installer 
1.  Download the upgrade installer from the ENPS website or FTP site. If you 

need a link for the ENPS download site send an e-mail to info@enps.com. 
Be sure to include your name and the name of your organization with your 
request. 

2.  Extract the upgrade installer to the root of the ENPS WORK drive, then copy 
those files to the root folder of the Buddy Server.  

Part 2: Upgrade the Buddy Server 
Perform the following steps on your ENPS Buddy Server: 

1.  Perform the steps in “Routine Maintenance” on page 151. 

2.  Close the Watch, NOM Maint, NWP and NOM applications. You should also 
shut down Extract, WalkCS and Publish if they are running. 

3.  Run the upgrade installer.  

4.  Run the Watch shortcut on the desktop to launch the ENPS server 
applications. 

Part 3: Upgrade the Primary Server 
Perform the following steps on your ENPS Primary Server: 

1.  Open the NOM and select NOM Maintenance → Buddy Process to view 
the Buddy Server queue. Wait until the queue is empty before you proceed to 
the next step.  

2.  If your primary language is English (US) you may skip this step. Validate the 
local language file by completing the steps in “Language Support” on page 
153.  

3.  In the NOM select the NOM Configuration/Status window and select the 
Block Primary Access checkbox. Users will see the window below notifying 
them that the Primary Server is unavailable: 
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Users should select the option Switch to a backup system.  

4.  Verify that users are able to connect to the Buddy Server then shut down the 
ENPS applications on the Primary Server by closing Watch, NOM Maint, 
NWP and NOM. You should also close Extract, WalkCS and Publish if they 
are running. 

5.  Perform the steps in “Routine Maintenance” on page 151. 

6.  Run the upgrade installer on the Primary Server.  

7.  Open the command prompt. Go to the ENPS WORK drive and enter 
\NOM\NOM.EXE /BLOCK to start the NOM in Block mode. Click OK. The 
NOM will launch on the Primary Server. 

8.  Run the Watch shortcut on the desktop to launch the ENPS server 
applications. 

Part 4: Bring the Primary Server Back Online 
1. Open the Buddy Server’s NOM and select NOM Maintenance → Buddy 

Process to view its queue. Proceed to the next step once the queue is 
empty. 

2. On the Primary Server open the NOM and select the Configuration/Status 
window. Uncheck the Block Primary Access checkbox. 

Users will now see a message notifying them that the Primary Server is 
available.  

 
Users should select the option Switch back to my normal system. The upgrade 
is complete. 

Using the Full Installer 
Part 1: Download the Installer 
1.  Download the full installer from the ENPS website or FTP site. If you need a 

link for the ENPS download site send an e-mail to info@enps.com. Be sure 
to include your name and the name of your organization with your request. 

2.  Extract the full installer to the root of the ENPS WORK drive, then copy those 
files to the root folder of the Buddy Server. 
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Part 2: Upgrade the Buddy Server 
These steps should be performed on the ENPS Buddy Server: 

1.  Complete the instructions in “Routine Maintenance” on page 151. 

2.  Shut down ENPS by closing Watch, Extract, Maint, NWP and NOM. If 
WalkCS and Publish are running they should be closed.  

3.  Run the full installer. Refer to the “Installing the Buddy Server” section on 
page 40 for information on using the installer. During installation you should 
select your language dictionary, even if you already have one installed, to 
ensure that the spell checker runs correctly. Restart the server when you are 
prompted to do so. 

Part 3: Upgrade the Primary Server 
Perform the following steps on your ENPS Primary Server: 

1.  Open the NOM and select Maintenance → Buddy Process. Proceed to the 
next step once the queue is empty. 

2.  In the NOM select the Window → NOM Configuration/Status . Select the 
Block Primary Access checkbox.  

Users will see the window below notifying them that the Primary Server is 
unavailable: 

 
Users should select the option Switch to a backup system. 

3.  Verify that users are able to work on the Buddy Server then shut down the 
ENPS applications by closing Watch, NOM Maint, NWP and NOM. You 
should also close Extract, WalkCS and Publish if they are running. 

4.  Complete the instructions in “Routine Maintenance” on page 151. 

5.  Remove the shortcut to Watch from the Windows Startup folder. This allows 
you to restart the server without the server applications opening 
automatically. 

6.  Run the full installer and follow the prompts. Refer to “Part 6: Install Server 
Components” on page 16 for more information. If your site does not use 
English (US) as its primary language note that the installation process may 
overwrite your G_LANGEN file during the installation process. You can find 
the language file with your site’s customizations in 
\COMMON\G_SUPPORT\MASTERS on the ENPS WORK drive. 

7.  Open the command prompt. Go to the ENPS WORK drive and enter 
\NOM\NOM.EXE /BLOCK to start the NOM in Block mode. 

8.  Click OK. The NOM will launch on the Primary Server. 

9.  Add the shortcut to Watch back into the Startup folder. Run the Watch 
shortcut on the desktop to launch the ENPS server applications. 
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Part 4: Bring the Primary Server Back Online 
1.  Open the NOM and select NOM Maintenance → Buddy Process to view 

the Buddy queue. Proceed to the next step once the queue is empty. 

2.  Open the NOM and select Window → Configuration/Status. Uncheck the 
Block Primary Access checkbox. Users will now see the following message: 

 
Users should select the option Switch back to my normal system. The upgrade 
is complete. 

Migrating Servers to New Hardware 
The following steps will show you how to migrate your existing ENPS Primary 
and Buddy Servers  to new hardware.  

Keep in mind the following before you perform the migration: 

• Do not perform the upgrade during or immediately prior to a newscast. 
• Do not upgrade your ENPS version number when you are migrating 

servers. 
• Perform the upgrade when there is the lowest resource load on the system. 
• Give users prior notice that the Primary Server will be unavailable. 
• Your current Primary and Buddy Servers should be running when you begin 

this process. 
Part 1: Install ENPS on the New Servers 
1. Build a new Primary Server and a new Buddy Server by completing the 

instructions in “Installing on Windows 2008 Server” on page 11 and 
“Installing the Buddy Server” on page 40.  

Make sure you are using the ENPS installer that matches the ENPS version 
number that is currently installed at your site. During the installation assign 
the new servers temporary names that differ from the names of your site’s 
current servers. 

2. On both of the new servers close NOM Watcher then close the other ENPS 
server applications. 

3. Copy the following folders from your site’s current Primary Server’s WORK 
drive to the same locations on both the new Primary Server and the new 
Buddy Server: 

• All of the folders on the ARCHIVES drive. 
• The following folders on the WORK drive:  

\<PRIMARY SERVER NAME> except for the S_ARCHIVE sub-folder 
\<PRIMARY SERVER NAME>_H 
\<PRIMARY SERVER NAME>_Inactive 
\<BUDDY SERVER NAME>_H 
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\NWS 
\COMMON\G_SUPPORT 
\NOM\NOM.INI 
\NWP\NWP.INI 
\NWP\TABLES.APN 

Part 2: Configure the New Buddy Server 
1. Note the current Buddy Server’s machine name and IP address then 

disconnect it from the network.  

2. Disconnect cables from the old Buddy Server and attach them to the new 
Buddy Server. 

3. Change the new Buddy Server’s machine name from the temporary name 
you assigned earlier to the machine name of the original Buddy Server. 
Assign it the same IP address as the original Buddy Server. 

4. Run the Watch shortcut on the desktop to launch the ENPS server 
applications.  

5. On the Primary Server open NOM Maintenance and select Window → 
Buddy Process. Make sure the Queue window is empty before you proceed 
to the next step. 

6. Run \NOM\INDEXDEL.EXE on the Buddy Server’s WORK drive to rebuild the 
index. This process may take several hours.  

7. Open the NOM on your site’s current Primary Server. Select Window → 
NOM Configuration/Status. Select the Block Primary Access checkbox. 

Users will see the window below notifying them that the Primary Server is 
unavailable: 

 
Make sure that users can open Rundowns and perform Searches on the new 
Buddy Server. If users encounter problems you should uncheck the Block 
Primary Access checkbox to allow them to return to the Primary Server then 
contact ENPS Support by calling the number on page 6 for help 
troubleshooting the new Buddy Server. 

Part 3: Configure the New Primary Server 
1. Note the current Primary Server’s machine name and IP address then 

disconnect it from the network.  

2. Disconnect cables from the old Primary Server and attach them to the new 
Primary Server. 

3. Change the new Primary Server’s machine name from the temporary name 
you assigned earlier to the machine name of the original Primary Server. 
Assign it the same IP address as the original Primary Server. 

4. On the Primary Server open a command prompt. Go to the ENPS WORK drive 
and enter \NOM\NOM.EXE /BLOCK to start the NOM in Block mode. 
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5. Open NOM Maintenance and select Window → Buddy Process. Make sure 
the Queue window is empty before you proceed to the next step. 

6. Run \NOM\INDEXDEL.EXE on the Primary Server’s WORK drive to rebuild 
the index. This process may take several hours. 

7.  Open the NOM and select Window → Configuration/Status. Uncheck the 
Block Primary Access checkbox. Users will now see the following message: 

 
Users should select the option Switch back to my normal system. The 
migration is complete. 

Migrating the CTOS 
This section will show you how to migrate your CTOS to a newer operating 
system and hardware while maintaining your site’s ENPS data.  

Keep in mind the following before you perform the migration: 

• Do not perform the upgrade during or immediately prior to a newscast. 
• Do not upgrade your ENPS version number when you are migrating 

servers. 
• Perform the upgrade when there is the lowest resource load on the system. 
• Your current CTOS should be running when you begin this process. 

1. Build a Primary Server by completing the instructions in “Installing on 
Windows 2008 Server” on page 11.  

Make sure you are using the ENPS installer that matches the version number 
that your site is using. During the installation assign the new server a  
temporary machine name that differs from your site’s current CTOS. 

2. Configure the new server to be a CTOS by enabling the CTOS Global 
Configuration Option. Refer to “Global Configuration Options” on page 44 for 
more information on this setting. 

3. Close Watch first then close all ENPS server components on the new server. 

4.  Copy the following folders from your site’s current CTOS WORK drive to the 
new CTOS: 

\<PRIMARY SERVER NAME> except for the S_ARCHIVE sub-folder 
\<PRIMARY SERVER NAME>_H 
\<PRIMARY SERVER NAME>_Inactive 
\<BUDDY SERVER NAME>_H 
\NWS 
\COMMON\G_SUPPORT 
\NOM\NOM.INI 
\NWP\NWP.INI 
\NWP\TABLES.APN 
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5. Note the machine name and IP address of the current CTOS then disconnect 
it from the network.  

6. Disconnect cables from the old CTOS and attach them to the new CTOS. 

7. Rename the new CTOS with the original server’s name and assign it the IP 
address of the previous CTOS. 

8. Run \NOM\INDEXDEL.EXE on the WORK drive of the new CTOS to rebuild 
the index. This process may take several hours. 



The Associated Press 31 
 

Chapter 4 
Server Applications 

This section describes the function and usage of the applications on your ENPS 
servers. 

News Object Manager 
The News Object Manager (NOM) controls communication between the client 
and the ENPS server. Capable of processing several hundred simultaneous 
connections per user, the NOM was designed to minimize network traffic and the 
server’s resource load.  

The NOM on the Primary Server communicates with the NOM of its Buddy 
Server. It ensures that all transactions are duplicated on both servers. 

 
File Menu Options 

• Update license. Enter a new ENPS license key. Users will see an alert 
message appear 30 days before it is set to expire. To obtain a new license 
key call ENPS Support at the phone number on page 6. Be sure to have 
your site’s NID number when you call. Your NID number can be founding in 
the Global Configuration Options by selecting Fourth Folder Rover → 
System Maintenance → Global Configuration Options in the ENPS 
client. 

• Set common files’ timestamps to current date/time. If you are 
troubleshooting and you are trying to determine when a change is made to a 
file in the common folder. By setting all of the files’ timestamps to one time it 
will be easy to tell when one of the timestamps changed.  

• Reload global tables. is used when you manually edit one of the global 
tables using a text editor such as Notepad. ENPS may not detect your 
change until you select this option. 

Window Menu Options 

1. NOM Status displays status messages about ENPS communications, 
including statistics for UDP traffic, memory usage, logged in users, private 
channels and more.  

2. Basys Message Exchange is used by sites to monitor the exchange of 
message data with Basys legacy systems. The Cap checkbox is used to 
capture any messages that received error messages. 

3.  Basys Story Exchange is used by sites to monitor the exchange of story 
data with Basys legacy systems. The Cap checkbox is used to capture any 
messages that received error messages. 
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4. Archive Queue displays data when ENPS is moving data into the archives 
according to the AutoArchive settings in the Rundowns. A log of archive 
activity is displayed at the bottom of the screen.  

5. MOS is divided into two panes: Outbound Items and Inbound Items. 

 
Outbound Items lists messages that are being transmitted to MOS devices. 

Inbound Items lists messages that have been received from the MOS 
devices such as an acknowledgement message that the device received a 
query from ENPS.  

Click Special to manually send a mosReqAll message to a specific MOS 
device. The MOS device should respond by sending a message with a list of 
its MOS objects.  

The option Number roConstruction Messages is generally only used to set up 
a MOS repeater for an Avid Newscutter. 

While messages are being sent to and from MOS devices you should see 
them appear in the Queue column momentarily. If there are a large number 
of messages at one time once you may see a short list appear in either or 
both of the queues. These are messages that have not yet been sent or to 
which ENPS has not yet responded. The queues should only have messages 
that appear for a few seconds. If you see a long list of items in the queue 
there may be a communications problem between your ENPS server and the 
MOS device. If the problem persists you may see one of the following 
message in the Status column: 

• Host Not Found 
• Timeout on Connect 
• Connection is Forcibly Rejected 
• Waiting for Reply 
• Disconnected 

Refer to the MOS troubleshooting steps on page 163 for more information. If 
you are troubleshooting a communications problem between ENPS and a 
MOS device you can select the Log checkboxes to store a list of all of the 
transactions that appear in Inbound and Outbound item queues. The logs are 
saved in \NOM\LOGS on your ENPS WORK drive. You can select the Cap 
checkbox to capture any MOS messages that return errors. 
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6. NOM Configuration/Status window is where you can set NOM configuration 
settings. Consult ENPS Support before you change any of these options. 

 
Trace log file creates a log of all of the communications that take place 
between the NOM and the client workstations. The log is stored in 
\NOM\LOGS\TRACE.LOG on the ENPS WORK drive. Because the NOM 
handles a large number of transactions it is recommended that you keep this 
option selected for troubleshooting purposes only as it will degrade server 
performance. 

Block Primary Access prevents users from connecting to the Primary 
Server, forcing them switch over to the Buddy Server. This option is used 
when you are upgrading ENPS or performing routine maintenance. 

Accept buddy mode requests is used only in specific troubleshooting 
circumstances. Consult with ENPS support before you use this setting. 

Process Top Stories should be selected if you are using the server as a 
Top Story Server for the My ENPS feature. Refer to “My ENPS” on page 100 
for more information. 

7. Election Processing. If you are using Stats to process election results this 
window will display the data generated from wire data. If and you are building 
races automatically select this window and select Build races from wire data 
to generate races from wire data. Refer to ENPS Stats Guide for more 
information. 

8. AutoCreation Window gives you an overview of which Rundowns are set to 
AutoCreate and which Rundowns have already created. To view this window 
open the NOM on the ENPS Primary Server and select Window → 
Rundown AutoCreation.  
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The top pane shows you which Rundowns are configured for AutoCreation. 
Expand the Server entry to display a list of groups. If a group contains a 
Rundown that is scheduled to be AutoCreated its entry will be displayed in 
the following format: 

 
 

 

 

The bottom pane shows displays a list of Rundowns that have already been 
created. Those entries will be displayed in the following format: 

 
 

 

 

NOM Maintenance 
The Maint application purges expired data and synchronizes global tables with 
the CTOS. It also manages the Buddy process. NOM Maint resides on the same 
physical server as the NOM. 

NOM Watcher 
Ensures that required server processes are running and restarts them if they are 
closed or are terminated in error. NOM Watcher resides on the same physical 
server as the NOM. 

Rundown 
name 

Date and time 
Rundown will be 
AutoCreated 

Show’s 
start time 
(24 hour 
format) 

Rundown 
name 

Date and time 
Rundown was 
AutoCreated 

Show’s 
start time 
(24 hour 
format) 

Show’s start date and time 
(12 hour format) 
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News Wire Profiler  
The News Wire Profiler (NWP) ingests news wire feeds and writes incoming 
stories to the news database. It then forwards news agency data and urgent 
news wire alerts to users.  

The News Wire Profiler (NWP) ingests, categorizes and stores incoming serial 
data feeds. It can also forward or receive stories from another NWP server via a 
network socket connection. The NWP supports only eight-bit wires. 

The NWP runs in either of two modes: concentrator or non-concentrator. In 
concentrator mode, it receives news wire copy from multiple serial ports and 
relays a single stream to other NWP systems via TCP/IP. In non-concentrator 
mode, it receives news wire copy from multiple serial ports and/or a concentrated 
socket stream. Usually resides on the same physical server as the NOM.  

File Menu Options 

• New wire, Delete Wire options are used to configure the wires you have in 
ENPS. You can set up the wires from a variety of sources including serial 
wires, wires via FTP, wires via e-mail and others. Refer to “Sending and 
Receiving Wires” on page 114 for instructions on how to create wires. 

• View Programming Tables displays the wires data that your site is coded 
to receive from the wire provider. If this table displays ntest your site is 
correctly receiving wires. Refer to “AP Wires or Radio Network Delivery” on 
page 6 for a list of phone numbers you can call for help receiving wires. 

• Log Messages stores NWP activity in \NWP\NWP.LOG on the ENPS WORK 
drive. 

Windows 

Select the window with the name of the wire or the functionality: 

• Messages displays the number of datagrams in queue as well as any error 
messages. The maximum acceptable backlog is 1000 items. Each 
datagram is given three chances to be sent to each address where the 
recipient list is composed of the general broadcast address and reflectors. 
On the third attempt an error is logged with the IP address of the recipient. If 
multiple errors are logged for the same recipient you should check for 
network issues. 

• Sockets displays actively connected sockets and subscribers to various 
wires. 

• Configuration  

Statistics: Length of time the NWP has been running. 

Expiration: Set the length of time before news wires are removed from the 
server. Select a category name and then enter the expiration time in the 
Hours textbox. The values will be updated in the [KillClock] section of 
NWP.INI. If this field is blank, the default time of eight hours will be used. 
The maximum value is 168 hours which is one week.   

Delete Schedule: Display when expired times were deleted; schedule when 
they should be deleted past the top of the hour. 

General:  Select the Process top stories checkbox to start the Top Stories 
Server. Refer to the “My ENPS” on page 100 for more information. 
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For sites ingesting Internet-based wire feeds (i.e. AP WebFeeds, YouTube, 
Twitter, etc.) and who must connect via a proxy server, the NWP can now 
piggyback off the proxy settings in Internet Explorer.  

To enable, first configure your proxy server in Internet Explorer on your 
ENPS server, then check the Use IE Proxy Settings for web based wires 
checkbox. 

 
• Wires Feed by Socket displays incoming wires, the date and time they 

were received and the socket they originated from. Upon connection, a 
receiver registers its IP address to receive data. Any previous sockets from 
that IP address are closed. 

• Wires via E-mail allows you to set up an e-mail address that will act as a 
wire feed. Refer to “Wires via E-Mail” on page 116 for more information. 
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Chapter 5 
Installing the Client 

This chapter will show you how to install the ENPS client on your site’s 
workstations. Before you begin make sure the client workstation has all of the 
pre-requesite hardware and software in “Hardware and Software Requirements” 
on page 7.  

1. The client installer copies files from the \ENPS folder on the Primary Server’s 
ENPS WORK drive to the client workstation. You can customize the following 
files in this folder before you begin the installation to transfer your custom 
settings to your site’s client workstations. 

• Use a text editor such as Notepad to open \ENPS\ENPS.INI on the 
Primary Server. The settings in this file will be distributed as the default 
settings to all of the client workstations at your site so it is recommended 
that you review these settings before you install the client. You can find a 
complete list of these settings in “Client Configuration” on page 71. 

• Use a text editor such as Notepad to modify the master custom 
dictionary  in \ENPS\DICT\SUPP.DICT on the ENPS WORK drive . This 
file should have only one entry per line. 

• Optional. You can replace \ENPS\BITMAPS\LOGO.JPG with your site’s 
logo. This image will appear in the top left corner of the ENPS desktop. 
This file must be in JPEG format and have the same dimensions as the 
default version. 

2.  Make sure the ENPS server components are running on the Primary Server. 
If they are not, double-click the Watch shortcut to launch them. Make sure 
the shortcut to Watch is in the Windows Startup folder. 

3.  Log in to a client workstation as Administrator on the ENPS domain. 
ENPS authenticates users by their Windows login. The Windows 
Administrator account is configured with a special ENPS group called 
“System.” This account lets you configure user settings and set up other 
groups for your site. 

4. Make sure all users have local administrator privileges. Every user account 
must be able to write to the system registry and have read/write access to 
the following folders on their workstation: 

\Program Files\ENPS 
\%SYSTEMROOT%\ 
\%SYSTEMROOT%\SYSTEM 
\%SYSTEMROOT%\SYSTEM32 

ENPS periodically synchronizes users’ system clocks to the clock on the 
Primary Server so users must also have sufficient access to adjust the 
system clock on their workstation.  

If you cannot assign these privileges to the user account on the client 
workstation you must run the SETADMIN.EXE application in the \NOM folder 
on the ENPS WORK drive. 
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In this utility you can provide the login for an administrator account that 
ENPS can use to access the settings and folders that may not be available 
through user accounts. 

5. Use a text editor such as Notepad to open \ENPS\SETUP.INI on the 
Primary Server. This file is used to configure where ENPS shortcuts will 
appear on the user’s workstation. To enable a setting set it equal to 1. 

Setting Description 

Desktop Place a shortcut to ENPS on the client workstation’s 
desktop. 

StartMenu Place a shortcut to ENPS on the client workstation’s 
Start menu. 

QuickLaunch Place a shortcut to ENPS on the client workstation’s 
Quick Launch toolbar. 

Do not change any settings in the [Files] section of SETUP.INI. 

6. If you are performing the installation on a client workstation with an earlier 
version of the ENPS client make a backup copy of C:\DOCUMENTS AND 
SETTINGS\ALL USERS\APPLICATION DATA\ENPS\ENPS.INI before 
you continue with the installation. It may contain workstation-specific CG and 
prompter settings. 

7.  If you are installing the ENPS client on Windows Vista or Windows 7 you will 
need to download and install the DHTML Editing Control for Applications 
Redistributable Package from the following Microsoft website:  
http://www.microsoft.com/downloads/details.aspx?FamilyID=b769a4
b8-48ed-41a1-8095-5a086d1937cb 

If you are installing the ENPS client on Windows Vista or Windows 7 the 
User Access Control (UAC) feature may interfere with the macro functionality 
in ENPS. Some ENPS macros emulate input from the keyboard which the 
UAC may interpret as a security violation. Refer to the Microsoft website or 
your Windows documentation for information on how to disable UAC. 

8.  If you are installing the client on a drive other than the C: drive use a text 
editor such as Notepad to create the file C:\WINDOWS\SETENPS.INI with 
the following text: 

[Location] 
Drive=X: 

where X: is the drive letter where the client will be installed. 

9. On the client workstation open a command prompt and enter the command 
\\<PRIMARY SERVER NAME>\ENPS\SETUP.EXE where <PRIMARY 
SERVER NAME> is the NetBIOS machine name of your Primary Server.  

http://www.microsoft.com/downloads/details.aspx?FamilyID=b769a4b8-48ed-41a1-8095-5a086d1937cb&displaylang=en
http://www.microsoft.com/downloads/details.aspx?FamilyID=b769a4b8-48ed-41a1-8095-5a086d1937cb&displaylang=en
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ENPS will be installed to the C:\Program Files\ENPS folder of the client 
workstation. 

10. Users can start ENPS with a command line switch to control its initial state. 

/LOCAL Start off-line in local mode. 

/W Start in windowed mode. 

/F Start in full-screen mode. 

For example, to run the client off-line enter:  

C:\PROGRAM FILES\ENPS\ENPS.EXE /LOCAL 

11.  In the ENPS client select Fourth Folder rover → System Maintenance → 
Servers. For each ENPS Primary Server enter 3.0 in the IS Version 
column. 

If your site does not use English (US) as its primary language you should refer to 
“Language Support” on page 153 for more information about customizing ENPS 
for your local language. 
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Chapter 6 
Installing the Buddy Server  

The Buddy Server is a backup of the Primary Server. If the Primary Server goes 
offline for any reason, such as server hardware failure, the Buddy Server will 
allow the users at your site to continue using ENPS without disruption. 

The transactions handled by the Primary Server are sent via a guaranteed TCP 
stream to the Buddy Server in the same order in which they appeared on the 
Primary Server. Keep in mind the following notes about setting up the Buddy 
Server on your network: 

• If possible, the Primary and Buddy Servers should be physically separated 
but on connected to the same network subnet. Do not connect these 
servers over a WAN as this can cause communications problems between 
the servers. 

• Wire stories are not copied from the Primary Server to the Buddy Server so 
the Buddy Server will require its own separate, redundant wire feed in case 
the Primary Server fails. 

• If the Buddy Server and a client workstation are on different subnets the 
client workstation will not be able to receive updates to Rundowns unless 
you set up a reflector. Refer to “Reflectors” on page 110 for more 
information. 

The following steps use AP-ENPS1 as the Primary Server name and AP-ENPS2 
as the Buddy Server name. You will need to modify these instructions with the 
names of your site’s Primary and Buddy Servers.  

1.  On the Primary Server copy the folders with the server’s name and the 
server’s name with the _H suffix to the Buddy Server, e.g. \AP-ENPS1 and 
\AP-ENPS1_H.  

2.  In the ENPS client select Fourth Folder rover → System Maintenance → 
Servers. 

a. Click New. In the Buddy Server ID column enter the Buddy Server’s 
machine name such as  AP-ENPS2 then enter a short description of the 
server. The MOS column should have the same value as the ID column 
unless a separate MOS server is used. Enter the server’s IP address in 
the IP column.  

b. In the row for the Primary Server select the Buddy Server field and enter 
the Buddy Server machine ID such as AP-ENPS2.  

c. In the row for the Buddy Server highlight the Buddy Server column and 
enter the name of your Primary Server such as AP-ENPS1. 

d. Set the IS Version to 3.0. 

e. Click Save and restart the client. 

3.  Use a text editor such as Notepad to open \NOM\NOM.INI on the Primary 
Server’s ENPS WORK drive. Make sure the setting Buddy=1 is listed in the 
[NOM] section.  

Repeat this step on the Buddy Server.  
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4.  Open NOM Maintenance on the Buddy Server. Select Window → 
Synchronization and click Sync Now. Restart both the NOM and NOM 
Maintenance programs. The Buddy Server is now configured to duplicate the 
content of the Primary Server. 

5.  Open the NOM on the Primary Server and select File → Reload Global 
Tables. 

6. From the Primary Server’s NOM Maintenance program select Window → 
Buddy Process to view the transactions between your Primary Server and 
Buddy Server. After the transaction is posted on the Buddy Server will it be 
deleted from the Primary Server's log queue. The NOM provides visual 
status and a log of this process. 

If users cannot connect to the Primary Server for any reason the following 
window will appear. Users should always select Switch to a backup system. 

 
When the Primary Server is back online users will see a message them that the 
Primary Server is available.  

 
Users should select Switch back to my normal system.  
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Chapter 7 
Managing Servers 

If your organization is spread over multiple locations or you have more than 150 
users at one site it is recommended that you add additional servers to reduce the 
server resource load. 

The Servers table can be used to add or remove servers. It is also used to 
change server-specific configuration settings. To open the Servers table select 
Fourth Folder rover → System Maintenance → Servers.  

After you change one of the options in this table restart both the ENPS client and 
the NOM on the Primary Server for your changes to take effect.  

Field Description 

ID  Server name which can be up to 15 characters long. 
Spaces are not allowed. 

Description A short description which may include the server’s 
physical location such as a building name, room number 
or any other information that may be useful to identify the 
server to support staff. 

MOS Unique name used to identify the server to MOS devices. 
This may be the same as the ID. 

Buddy ID of the Buddy Server. 

IP IP address of the server. 

Broadcast Mask IP address where the server will send broadcast UDP 
datagrams. If this field is blank the default address 
255.255.255.255 will be used. 
On Windows 2003 servers the address must be the 
broadcast address of the network. For example, if the 
server's IP address is 192.168.100.5 and the subnet mask 
is 255.255.255.0 the broadcast address for the network 
would be 192.168.100.255.  
Use an IP subnet calculator, which is available on the 
Web, to calculate the broadcast address for a given 
subnet. 

Server Group Group to which the server belongs. This entry typically 
includes a physical location or department name. 

IS Version Microsoft Index Server version. This should be set to 3.0 
unless you are using an older version of Index Server, 
which is not recommended. 

MOS Repeater  Select this field if the server is a MOS repeater. Refer to 
“Setting Up a MOS Repeater” on page 136 for more 
information. 

MOS Server Name of the ENPS server providing MOS messages to a 
MOS repeater. Refer to “Setting Up a MOS Repeater” on 
page 136 for more information. 
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MOS Active Days Number of days after the Rundown’s End Time that the 
Rundown’s  MOS Control Active property will be disabled. 
Users will not be able to make a Rundown MOS-active for 
a number of days greater than this value this setting.  
The MOS Control Active property will be deactivated when 
NOM Maintenance runs. By default this occurs at 2:00 AM  
although this time can be changed by opening NOM 
Maintenance and selecting Window → Folder Info. 
If users configure Rundowns to archive automatically they 
should make sure that archiving takes place after this  
setting takes effect.  
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Chapter 8 
Configuration Settings 

This section shows you how to customize ENPS for your site by setting options in 
Global Configuration Options, NOM.INI and NWP.INI. It is recommended that 
you review all of these options to see which ones apply to your site. 

Global Configuration Options 
These options control the way ENPS works at your site. Select Fourth Folder 
rover → System Maintenance → Global Configuration Options. If the desired 
configuration setting is not listed in the window click New and enter the ID from 
the table below. To change a setting click in the Value column and enter the new 
value.  

After you change one of these options restart both the ENPS client and the NOM 
on the Primary Server for your changes to take effect. 

ID and Description Value 
AddMosObjDuration 

Determines whether the duration of MOS objects is 
used in calculating a story’s actual time. By default,  
MOSObjectTime is not included in the calculation of a 
story’s actual time. If this setting is enabled the actual 
time reflects the sum of the following values: 
• Text time 
• Manually entered durations of media objects in the 

story 
• The length of a clip which can be found in the MOS 

Object Time column in the Rundown. 
• MOS Editorial Time for a MOS object if the vendor 

lets users specify it. For voiceovers, the MOS 
Editorial Time should be set to :00 to reflect correct 
total time. 

0=Disabled (default) 
1=Enabled  
 

AllowTwoColumnScript  

Give users the option to view stories in two column 
mode. 

0=Disabled (default) 
1=Enabled 

AutoArchiveDays  

Number of days after a broadcast when Rundowns and 
Newsgathering Grids are archived according to their 
AutoArchive settings. By default archiving occurs at 2:00 
AM  although this time can be changed by opening 
NOM Maintenance and selecting Window → Folder 
Info. 
Since ENPS automatically deletes Rundowns that are 
more than 30 days old this setting must be set to a 
value less than 30. 

0=Disabled (default) 
1 to 29 
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BaseDialect 

Four letter dialect code. Local dialects take precedence 
over the BaseLanguage setting. Refer to “ENPS 
Language Support” on page 153 to find the dialect code 
for your local language. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

Four letter dialect 
code, such as ENUS 
for American English.  

BaseLanguage 

Two letter language code for ENPS labels, menus and 
fields. Refer to “ENPS Language Support” on page 153 
to find your local language code. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

Two letter language 
code such as EN for 
English.  

BrowseFullRecords  

When enabled the List Window displays four lines per 
item by default. When this setting is disabled it defaults 
to displaying only one line. 
If you enable this setting you will also need to modify the 
Global Configuration Option ListTextFormat to 
format how the information is displayed.  

0=Disabled (default) 
1=Enabled 

CaseSensitiveMOS  

Control whether ENPS uses case-sensitive MOS IDs. 
You can disable this setting for backward compatibility. 

0=Disabled 
1=Enabled (default) 
 

CentralPriv 

Enable Security Profiles. Refer to “Groups” on page 91 
for more information. 

0=Disabled (default) 
1=Enabled 

ChineseCILocale 

Sites that use Chinese as their primary language should 
set this to NEUTRAL to ensure that Forward Search and 
highlighting work correctly. 

NEUTRAL at Chinese 
language sites. 

CmdDurationColon 

Use a colon in the duration length in stories. Durations 
would be displayed as 1:30 instead of 1'30". 

0=Disabled (default) 
1=Enabled 

CorpID 

An identifier that appears on the fourth folder icon in the 
ENPS client. It is displayed in various menus and forms. 

Site identifier. Default 
value is ENPS 

CTOS 

Configure the server to be a Central Text Object Server 
(CTOS). For a description of the CTOS refer to “Central 
Server and CTOS” on page 11. If the server is set to be 
a CTOS it cannot be used for broadcasting.  

0=Disabled (default) 
1=Enabled  
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CVS 

Used to generate the license key.  Do not modify this 
field. 

DefaultMOSVersion 

Version of the MOS protocol to use by default. 2.5 

DefaultReadRate 

Default number of characters per second to use as a 
read rate for timing stories.  

Default is 18. 

DetachedActiveX 

Specify whether the Media Control icon has a rover 
option to open an ActiveX plug-in in a separate window. 
This feature is useful for viewing plug-in controls on a 
second monitor. A maximum of three detached plug-ins 
may be open at any one time. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

0 – Disabled (default) 
1 – Enabled  
 

DetachedROMax 

Maximum number of Rundowns and/or Newsgathering 
Grids for detached windows. In the main window there 
is a limit of four open Rundowns and/or Newsgathering 
Grids at any time. If a user tries to open an additional 
one they will be prompted to detach it.  

Default is 10. 
 

EnableChat 

Determines whether the Chat option is enabled from the 
client’s Messaging icon. For chat to work port 10509 
must be open on the client workstations. 

0=Disabled (default) 
1=Enabled 

EnableOfficeDocs 

Allow users to open documents from network locations. 
Files with extensions TXT, DOC and RTF can be 
imported into ENPS as new stories. Files with other 
extensions, such as PDF, DOCX, XLS, XLSX, etc., can be 
opened but not imported. See also the Office 
Document Path setting on page 93. 

0=Disabled (default) 
1=Enabled 

EnforceSecurityLevels 

Enables use of Approval Extensions. Refer to page 84 
for more information. 

0=Disabled  
1=Enabled (default) 

ExternalDocuments 

Allow users to store Word DOC or Adobe PDF 
documents in the Newsgathering Grid’s Background or 
Collection fields. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

0 – Disabled  
1 – Enabled (default) 
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FarsiTextBoxFont 

Font to use if ENPS is unable to render a Farsi 
language character with the current font. This value can 
be set to either Tahoma or Arial, either of which work 
with all Farsi characters. This setting also takes effect if 
the font specified in a story is not available on the client 
workstation. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

Tahoma or Arial 

FastHighlight 

Highlighting matches for search criteria is done on the 
client rather than the server. Disabling this option may 
slow performance. This option is not available in all 
languages. 

0=Disabled 
1=Enabled (default) 

FileDetect 

Determines whether FTP paths are supported in stories, 
Rundowns and Newsgathering Grids. In a story users 
will then be able to open paths such as 
file://c:\temp  
See also FTPDetect and UNCDetect settings. 

0=Disabled (default) 
1=Enabled 

FolderSort 

Arrange wires and agencies in the Search dialog box 
and the list of groups in the Third Folder rover 
→ Locations in alphabetical order. 

0=Disabled (default) 
1=Enabled 

FormatSubFieldValues 

Controls how fields in a Newsgathering Grid are 
formatted when they are exported to a MOS device. If 
this setting is enabled the field’s value will be exported 
using the MOS protocol’s date and time format.  
Note that the field’s Validation column must be set to 
MOSDateTime to enable exporting the field to a MOS 
device. Refer to “Creating Custom Fields” on page 55 
for more information. 

0=Disabled (default) 
1=Enabled 

FTPDetect 

Determines whether FTP paths are supported in stories, 
Rundowns and Newsgathering Grids. If this setting is 
enabled users will be able to open paths with the format: 
ftp://ftp.sitename.com 

See also FileDetect and UNCDetect settings. 

0=Disabled (default) 
1=Enabled 
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GridCellHighlightColor 

Sets the highlighting color for selected cells in 
Rundowns and Newsgathering Grids. This option only 
takes effect if the GridCellHighlightEnable setting 
is enabled in the client’s ENPS.INI. Users can change 
this value for individual workstations in their Personal 
Settings.  

Select from color 
picker. 

HardwareLayout 

Semicolon-delimited list of fields to be used with the 
Broadcast Hardware interface on legacy systems. The 
special field Default includes the fields 
GUID;PageNum;Version;Title 
Functionality is identical to prior versions of ENPS 
unless these settings are specified. 

Examples: 
Default:Presenter 
exports the same 
fields as prior 
versions but would 
includes Presenter 
as a new column to 
the far right. 
 GUID;Slug; 
Segment; 
Presenter would 
export only those four 
columns. 

InternetOutLogFiles   

Number of log files per account for tracking users’ 
Twitter and Facebook activity. Log files are stored in the 
\COMMON\INTERNETOUT folder on the ENPS WORK 
drive. 

1-999 
Default is 99. 

InternetOutLogSize 

Maximum size for users’ Twitter and Facebook activity 
logs in the \COMMON\INTERNETOUT folder on the 
ENPS WORK drive. When a log file exceeds this size the 
oldest content in the file automatically rolls over into 
another, sequentially-numbered file.  

1024-65536 
Default is 32768. 

ListTextFormat 

Controls which fields are displayed in the List Window if 
the BrowseFullRecords global configuration option is 
enabled.  
For example {Title}{CrLf}Tape:{TapeNumber} 
displays the title on the first line, adds a carriage return, 
then displays “Tape:” and the TapeNumber field on the 
next line. 
To view these changes, users have their client set to 
display at least two lines per item by selecting List 
Window rover → Lines Displayed per Item → 2. 

Any standard or local 
field  may be used in 
curly braces. The field 
is case-sensitive. 
{CrLf}  may be 
used for a carriage 
return-line feed 
combination. 

ListTextFormatNews 

Set the fields to be displayed for wires when Browse 
mode is used. This entry should be set to: 
{Title}{CRLF}{Text} 

Any standard or 
custom field. 
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ListTextFormatMOS 

Configure the content of any XML tag in a MOS object 
to be viewed using a Browse mode. This configuration 
for this option uses a similar format to 
ListTextFormat. Here are some examples: 

{/mos/mosObj/mosID} 
{mosID} 

{/mos/mosObj/mosExternalMetadata/Owner} 

{Owner} 
{/mos/mosObj/mosAbstract} 

{mosAbstract} 

This Browse format may be set separately for MOS 
object folders.  

Instead of property 
fields enclosed in { } 
enter an XML tag or 
path in the { } 
characters. It is 
assumed that the 
expression begins 
with “//” which means 
the first instance of 
the element specified 
will be found 
regardless of its level 
in the XML. 

ListTextFormatSMV 
Configure how metadata fields in the Story Media 
Viewer are displayed. For example:  
{Title}{CRLF}{Text} 

Any standard or local 
fields will work. 

LocalStaff 

Controls whether the ENPS client retrieves the entire 
staff list when it starts. If you have a large staff list and 
want to save server resources you can disable this 
option. 

0=Disabled 
1=Enabled (default) 

LowerCaseMacroKeys 

By default, ENPS interprets capital letters in a macro to 
mean that a user is holding down the Shift key. This 
may cause the following letters to be capitalized in some 
macros. If this setting is enabled it forces the letters 
following the capitalized letter to lower case. 

0=Disabled (default) 
1=Enabled 

MaxBriefingTerms 

If the number of logical operators in a Search query 
exceed the value of this setting users will see a warning 
that results will take longer than normal to process. 
Logical operators include AND, OR, and NOT. 

Default value is 20. 

MaxExternalDocSize 

Restrict the size of Word DOC and Adobe PDF files that 
can be added to the Collection field in Newsgathering 
Grids. 

This value, in bytes, 
defaults to 500000, 
approximately half a 
megabyte. The 
maximum value is 
nearly three 
megabytes or 
2999999. 

MaxMOSLinks 

MOS Item References have a property called Recurring 
which means that the referenced MOS object appears in 
multiple locations. This setting determines the maximum 
number of stories with duplicate MOS Item References 
to track when the Recurring flag is not set.  

Default is 500. 
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MessageGateway 

Specifies whether the Message Gateway is enabled. 
This option is required by Follow-Me Messaging. Refer 
to “Follow-Me Messaging” on page 103 for more 
information. 

0=Disabled (default) 
1=Enabled 

MIRXMLTree 

View MOS Item Reference tooltips in an XML tree view.  
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

0=Disabled (default) 
1=Enabled 

MOSActiveDays 

Number of days after a show’s Start Date when the 
Rundown or Newsgathering Grid’s MOS Control Active 
property will be deactivated. 

Number of days. 

MOSBrowseMediaExtensions 

Comma-delimited list of the media types that can be 
displayed in the Script Media Viewer. Any extensions 
that are supported by Windows Media Player or 
QuickTime are valid for this setting. If an extension is 
not in this list it will not be possible to preview it in the 
Story Media Viewer. 
If JPG is the first item in the list then you will only be 
able to view JPG proxies in the Script Media Viewer 
regardless of what other proxy formats exist in the item 
reference. If you want to be able to view additional 
formats when you click the play button you should list 
those formats before JPG in the list. 

Example: 
WMV,MOV,JPG 
 

MOSChannelLockOverride 

Allow users to make changes to MOS channels in the 
Rundown when a story is locked for editing. If this option 
is enabled and a channel is assigned to a MOS Item 
Reference a buffered channel will be assigned as soon 
as the story is saved. 

0=Disabled (default) 
1=Enabled 

MOSItemRefColor 

MOS Item References appear in a different color in 
stories. This is designed to make the MOS references 
easier to see alongside other red production commands.  

Select the color from 
the color palette. 

MOSItemThreshold 

Number of item references a user may add to a story 
before the client displays a warning message. Users will 
not be prevented from going over this threshold.  

Number of item 
references. The 
default is 10. 

MOSItemLengthLogThreshold 

MOS Item References in a story that are longer than the 
specified number of characters will be logged to 
C:\DOCUMENTS AND SETTINGS\ALL USERS\ 
APPLICATION DATA\ENPS\MOSITEMREF.LOG on the 
client workstation. 

Number of 
characters. The 
default is 1500. 
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MOSItemReplaceChange 

Specify this option if MOS Item References in ENPS are 
corrupted by Unicode characters from certain 
international character sets when ActiveX plug-ins 
update MOS Item References.  
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

0 – Disabled (default) 
1 – Enabled 

MOSJPGProxyPath 

See MOSBrowseMediaExtensions.  
 

MOSLeaseLockMax 

Default amount of time after a Rundown’s MOS Control 
Active property is selected that ENPS allows external 
MOS devices to place a temporary “lease” on stories to 
create new material or update existing material. This 
option requires MOS version 2.82 or higher. 

Number of seconds. 
The default is 60 and 
maximum value is 
1200. 

MOSROAllow 

Allow users to limit which MOS devices can be used 
from a Rundown. Once this setting is enabled a user 
with sufficient privileges can select which MOS devices 
a Rundown can use from the MOS Allow list in the 
Rundown’s properties. MOS Item References for 
devices which are not selected will be grayed out.  
If no entries are selected in the MOS Allow list all MOS 
devices will be allowed. If a new MOS device is installed 
at your site it will have to be manually added to the MOS 
Allow list in every Rundown. 
If MOSROAllow is disabled all MOS Allow settings will 
be ignored and any Rundown will be able to use any 
MOS device. 

0=Disabled (default) 
1=Enabled 

Multicast 

Controls whether the NOM will use multicasting to send 
packets to clients. Refer to “Multicasting” on page 109 
for more information. 

0 – Disabled (default) 
1 – Enabled 

MulticastBaseIP 

If the Multicast setting is enabled this setting 
identifies the base IP address to use during the 
automatic population of the Servers table. Addresses 
are assigned starting with this value and incremented, 
skipping previously used values. Refer to “Multicasting” 
on page 109 for more information. 

Default IP address is 
239.0.0.1 
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MulticastBasePort 

If the Multicast setting is enabled this setting 
identifies the base port to use during the automatic 
population of the Servers table. Ports are assigned 
starting with this value and incremented, skipping 
previously used values. Refer to “Multicasting” on page 
109 for more information. 

Port number. Default 
port is 10601. 

MulticastTTL 

If the Multicast setting is enabled this setting 
identifies the Time To Live value for datagrams. This 
value sets the number of “hops” a packet can take 
before it is discarded. Refer to “Multicasting” on page 
109 for more information. 

Default is 16. 

MulticastAlsoBroadcast 

If the Multicast setting is enabled you should use this 
setting during rollout if some systems are using 
Multicasting and others are not. If this setting is enabled 
the NOM and NWP will send both broadcast and 
multicast datagrams. This option should be disabled as 
soon as the rollout is complete. Refer to “Multicasting” 
on page 109 for more information. 

0 – Disabled (default) 
1 – Enabled 

MyENPS 

Controls whether the My ENPS feature is enabled. My 
ENPS gives users an overview of important wire stories, 
daily Rundowns, and assignments and more. The Top 
Story Server (TSS) must be started on the NOM for this 
feature to work. Refer to “My ENPS” on page 100 for 
more information. 

0=Disabled (default) 
1=Enabled 

MyENPSRefreshMin 

Users can configure My ENPS to automatically refresh 
content at a set interval. This value sets the minimum 
number of minutes that users may enter in the auto-
refresh field. 

Number of minutes. 
Minimum value is 1. 

NewMsgDays 

Determine the number of days that unread group 
messages will be displayed in users’ List Windows at 
startup. By default, this option is disabled so all new 
group messages will be displayed regardless of the date 
they were posted. This value is also used for unread 
group messages in My ENPS. 

0=Disabled (default) 
To enable, set the 
number of days to a 
value between 1 and 
999. 

NGCollectionThreshold 

Number of items that can be added to a Newsgathering 
Grid’s Collection field before a warning appears. 

Default is 10. 
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NGItemThreshold 

Maximum number of items that can be added to a 
Newsgathering Grid before a warning appears. Although 
there is no limit for the number of items allowed in 
Newsgathering Grids, grids that contain extremely large 
numbers of items can be difficult to open and maintain. 
The warning message appears after the user inserts a 
new item or copies lines from another Newsgathering 
Grid.  

Default is 70. 

NGTimeOffset  

Time for the server to add to the time in the 
Newsgathering Grids. This is useful if the server is 
located in a different time zone than the users. Using a 
setting of 12:00 PM users can be +/- 12 hours away 
from the server hosting the data and still see the grids 
set to the same date. 

Default for existing 
installations is 01:00 
AM. The suggested 
value and default for 
new installations is 
12:00 PM. 

NID 

Number used by ENPS Support to generate your 
license key. 

Do NOT modify this 
field. 

NoMyENPSROScript 

Determines whether Rundown stories are allowed in My 
ENPS. Enable this option to disallow them. 

0=Disabled (default) 
1=Enabled 

OnAirDragDropProtection 

If your site uses an automation system and it is 
advancing the timing bar in a Rundown you can 
“protect” a number of seconds at the end of the item. 
During this time items cannot be dragged immediately 
below the item with the PLAYING status. 
If OnAirDragDropProtection is set to its default 
value of 10 if a clip is 1:00 long once it has been playing 
for 50 seconds it will not be possible to drag an item 
immediately below it. This setting is only applicable if 
the Prevent Manual Bar Rundown property has been 
set. 

Number of seconds. 
Default value is 10. 

PadROGrid 

If Rundown text is clipped in printouts this option enable 
this option to add extra padding to the print margins. 

0=Disabled (default) 
1=Enabled 
 

PersonalCountThreshold 

Limit the number of items users can keep in their 
personal folders. If a user exceeds the number of items 
set in this option a warning message will be displayed.  
See also PersonalSpaceThreshold. 

0=Disabled (default) 
1=Enabled 

PersonalSpaceThreshold 

Number of kilobytes users can keep in their personal 
folder. If a user exceeds the specified amount a warning 
message will be displayed.  
See also PersonalCountThreshold. 

0=Disabled (default) 
or number of 
kilobytes  
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PrompterMOSLines 

Add line feeds to prompter output wherever MOS Item 
References are listed in Rundowns and Newsgathering 
Grids. 

0=Disabled 
1=Enabled (default) 

Pronouncer 

Controls whether the Pronouncer is enabled. You may 
wish to disable it if the Pronouncer is not available for 
your local language. 

0=Disabled 
1=Enabled (default) 

ReadRateIgnoredChars 

Characters that should be ignored during a story’s read-
time calculation. By default spaces, carriage returns, 
line feeds and other punctuation characters are 
excluded. The characters must be listed in hex format 
with character ranges indicated by hyphens. Ranges 
must be separated by commas.  

The suggested 
default is:  
0A-2F,3A-40,5B-
60,7B-7E 
This eliminates 
standard punctuation 
characters. 

RenumberSummaryMIR 

If a MOS Item Reference is created in a Rundown by 
the Object Autocreate function then moved below the 
story black line another Object Autocreate message will 
be issued. Enable this setting to override this behavior. 
The itemID of a summary item, normally 1, will 
automatically be changed to the next-highest available 
item ID when the item is moved below the black line. 

0 – Disabled (default) 
1 – Enabled 
 

ReportItemNo 

Default first column for Rundown layouts: Page Number 
or Item Number. 

0=PageNumber 
(default) 
1=ItemNumber 

ROItemThreshold 

Number of lines in a Rundown for ENPS before a size 
warning is displayed. This message appears when an 
applicable Rundown is opened, a user inserts a new line 
or lines from another Rundown are added. 

Default is 125. 

RTLPrint 

Use alternate print engine. Enabling this setting may 
resolve issues with printing on some systems. It also 
enables print options not available by default such as 
the ability to add page breaks to long Rundowns or 
Newsgathering Grids using the Page Break column. 
You must enable this option for right-to-left for 
languages such as Arabic. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

0 – Disabled (default) 
1 – Enabled 
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RundownAlphaPages 

Specify whether Rundown pages are numbered 
sequentially (1,2,3…)  or with alphabetic prefixes (A1, 
A2, A3...). Users can override the Global Configuration 
setting in a Rundown by selecting the Rundown 
Numeric Pages option in the Rundown properties. 

0=Pages numbered 
sequentially  
1=Page numbered 
with alphabetic 
prefixes (default) 

RundownPageNumbers 

Force the system default layout to contain the fields 
Page Number and Break. This setting makes it 
impossible to remove the Page field from the Rundown.  

0=Disabled  
1=Enabled (default) 

RundownTimeElapsed 

Adds the Elapsed Time column to Rundowns. As a 
producer times a program the Elapsed column reflects 
the total time the timing bar stays on each line, allowing 
producers to see how long a section actually runs as 
opposed to the Estimated time. If the producer fails to 
hit the space bar at the beginning of each Rundown 
item the reflected "elapsed" time will be inaccurate. 

0=Disabled (default) 
1=Enabled 

RundownTimeEstimated 

Configure Rundown timing to use the Estimated time 
rather than the actual time. If disabled, the Rundown will 
be timed based on Estimated time until the user saves a 
story or enters a time in the Actual column. 

0=Disabled (default) 
1=Enabled  

ScriptMediaViewer 

Add a pane to preview MOS Item References in a story. 
The MOS Item Reference must have a path to the 
media in the format specified by the MOS Protocol. The 
story pane can be toggled on or off from the story rover 
or the icon on the story toolbar.  
The following are sample paths: 
http://<server>/proxy/clip328cd20s0e.wmv 

ftp://<server>/proxy/clip328cd20s0e.wmv 
\\<server>\media\clip328cd20s0e.mxf 

If MOS Item References do not have a valid path ENPS 
displays a generic graphic. 
■  For more information on the MOS Protocol refer to 

http://www.mosprotocol.com. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

0 – Disabled 
1 – Enabled (default) 
 

SecureArchive 

Retain security settings for archived Rundowns. If this 
setting is disabled all users will have access to 
everything in archived Rundowns. If this setting is 
enabled users who lack rights to non-approved stories 
in an in-progress Rundown will also be denied access to 
it when the Rundown is archived. 

0=Disabled (default) 
1=Enabled 

http://www.mosprotocol.com/
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SendChecklistIndexValues 

Controls how ENPS sends checklist fields to MOS 
devices. If this setting is disabled the text is sent as the 
value of the relevant MOS tag in a semicolon-delimited 
list such as: 
<test>red;blue;white</test> 

If this setting is enabled checklist fields will be sent as 
an attribute of the MOS tag with the checklist positions 
in the tag's value, such as: 
<test DisplayValue="red;blue;white"> 
1;2;3</test> 

This format was used in earlier version of ENPS and 
may be required by some MOS devices. 

0=Disabled (default) 
1=Enabled 

SK 

Your ENPS license key. Do not modify 

Speller 

Specify whether the Speller is available as a menu 
option. This may be important if there is no local version 
of the Speller in your local language. 

0=Disabled 
1=Enabled (default) 

SpellCheckerPluginID 

Use approved third-party ActiveX spell check plug-ins 
instead of the default spell check tool included with 
ENPS. This option is used primarily by Portuguese sites 
who need a specialized spellchecker to support the 
Portuguese Language Orthographic Agreement.  
The spell check option will appear from the story rover 
menu or the spell-check option on the story toolbar. 
Use of a third-party speller replaces all built-in spelling 
functionality in ENPS including the standard 
configuration options. All configuration and dictionary 
management must be done through the third-party tool, 
not from the ENPS rover menu. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

To enable enter the 
string provided by the 
ActiveX provider. 
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StdActiveXRemove 

Used by ActiveX plug-in developers to specify an 
alternate sequence for how instances of ActiveX plug-
ins are terminated. 
Enable this option in situations in which the plug-in does 
not receive the command to terminate. This may occur 
with plug-ins that use the Windows Media Player 
control. 
When this setting is disabled: 
Set MyForm.ctrlGuest = Nothing 
MyForm.Controls.Remove 

When this setting is enabled: 
MyForm.Controls.Remove 

Set MyForm.ctrlGuest = Nothing 

0=Disabled (Default) 
1=Enabled  

TerminateOnExit 

Shut down third party processes down when the client 
closes. For example, the Hewlett Packard Universal 
PostScript driver must be shut down before the client 
can be restarted. In that case this setting would be set 
to the HP driver file HPMUP081.BIN.  
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

Name of the process 
to shut down. 

Thesaurus 

Controls whether the thesaurus is available as a menu 
option. This may be important if there is no local version 
of the Thesaurus in your local language. 

0=Disabled 
1=Enabled (default) 

TimeFormat 

Express time in formats for frame-accurate automation 
systems. Users may also set this value in the Rundown 
properties. 

PAL, NTSCDF, 
NTSCNDF, or 
THOUSANDTHS 

TitleSeparator 

Set the character used to separate Rundown Slugs and 
Segments. This can be changed by setting 
TitleSeparator to one or more characters. 

Any character(s) 
except for the 
following: 
_ < > : / \ | * ? " 

TrashDays 

Number of days to retain items in the Waste Bin. This 
does not apply to Top Line Messages which may be 
retained for 24 hours. 

Default value is 10 
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UNCDetect 

Determines whether UNC paths are supported in 
stories, Rundowns, and Newsgathering Grids. Once this 
setting is enabled the client must be restarted for this 
change to take effect. In a story users will be able to 
open paths with the format of:  
\\{machinename} or \\{IP address} 
See also FTPDetect and FileDetect global 
configuration settings. 

0=Disabled (default) 
1=Enabled 

UnescapeAttributes 

Controls how the > character is sent in the MOS 
element tags of outbound MOS messages. By default if 
there is a greater-than symbol inside of the MOS 
message’s start and end tags ENPS will send it as &gt; 
such as: 
<fieldname attribute="&lt;test&gt; 
VALUE&lt;/test&gt;">UP&gt;DOWN 
</fieldname> 

If this option is enabled ENPS will send the actual > 
character such as:  
<fieldname attribute="&lt;test> 
VALUE&lt;/test>;">UP&gt;DOWN</fieldname> 

The behavior of other characters in MOS messages will 
not be affected. This setting may also be enabled in the 
\NOM\NOM.INI on the ENPS WORK drive. If the setting 
does not exist in either location the option will be 
disabled. 

0=Disabled (default) 
1=Enabled 

UnicodeForwardSearch 

Set whether ENPS should use Unicode. This is 
necessary in languages like Chinese to ensure that 
Forward Searching and highlighting are enabled in 
agency wires. 

0=Disabled (default) 
1=Enabled 

URLDetect 

Automatically launch the Web browser control when a 
user clicks on HTTP hyperlinks appearing in news wire 
stories or stories. 

0=Disabled (default) 
1=Enabled 

UseMOSStartTime 

Display a table in the Rundown properties that allows 
users to define when ENPS can start sending messages 
to specific MOS devices. 

0=Disabled (default) 
1=Enabled 
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UseRoReqAllID 

Controls how ENPS responds to <roReqAll> 
messages from MOS devices. By default, ENPS 
responds to <roReqAll> message with an 
<roListAll> message which list all MOS-active 
Rundowns on the ENPS server.  
If this option is enabled the <roListAll> will only 
contain MOS-active Rundowns for the device which is 
requesting it.  
■  For more information on MOS Protocol messages 

refer to http://www.mosprotocol.com. 

0 – Disabled (default) 
1 – Enabled 

UseRTFtext  

Enhanced formatting options on story toolbars such as 
bold, italics, underline, and font colors. To enable this 
option you must also enable the XMLstorage option in 
the [NOM] section of the NOM.INI. 
► You can configure this setting on an individual 

workstation by adding it to the [ENPS] section of 
the workstation’s ENPS.INI. The setting in the 
ENPS.INI overrides the value in the Global 
Configuration Options. 

0 – Disabled (default) 
1 – Enabled  
 

UseSingleFont 

Optimize the appearance of stories which Turkish or  
Russian codepages. 

0=Disabled (default) 
1=Enabled 

ValidateMOSObjects 

Allow users to see when a MOS Item Reference in a 
story refers to a MOS Object that was deleted from the 
associated MOS folder.  
If you enable this setting open the MOS Configuration 
table and check the ValidateMOSObject column for 
each MOS device to which this setting should be 
applied.  
Once this setting is enabled ENPS checks for the MOS 
Object when an archived story is dragged and dropped 
into an active Rundown or a Rundown’s MOS Control 
Active property is selected. If the object is not found 
ENPS will “grey out” the MOS Item Reference in the 
story.  
This setting should only be enabled for MOS devices 
that send object messages to ENPS. It should not be 
used with devices, such as the majority of character 
generators, that do not send MOS objects to ENPS.  

0=Disabled (default) 
1=Enabled 

NOM Configuration Settings 
Use a text editor such as Notepad to open \NOM\NOM.INI on the ENPS WORK 
drive. This file lets you customize News Object Manager settings in ENPS. It is 
recommended that you contact ENPS Support before you changes to these 
settings.  

http://www.mosprotocol.com/
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Once you make a change to this file you must restart the NOM for changes to 
take effect.  

Some of the settings in the NOM.INI can be changed directly from the NOM 
application by selecting Window → NOM/Configuration Status. If you change 
settings from this window you will not have to restart the NOM for your changes 
to take effect. 

 
The following table describes the settings in this file: 

Setting Description 

[TCPIP]  
PacketVersion 

Incoming wires are in English. 

0=English news wires 
(default) 
1=Non-English news 
wires 

BroadcastMail 

Send Top Line Messages as UDP broadcasts instead 
of point-to-point messages provided that this option is 
supported by your site’s router. This allows users to 
see their Top Line Messages on each machine if they 
are logged into multiple client workstations. 

0=Disabled (default) 
1=Enabled 

BroadcastPrivate 

Specify whether changes to a user’s personal folder 
are broadcast to other workstations. This is desirable if 
a user is working on multiple machines. If this setting is 
enabled it will be enabled for all of the users on the 
server. 

0=Disabled (default) 
1=Enabled 

BreakUDPPackets  

Send a larger or smaller number of UDP packets than 
the NOM’s default value of 1024. The MaxUDPSize 
setting is used to set the specific number of packets. 

0=Disabled (default) 
1=Enabled 
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MaxUDPSize  

Maximum number of UDP packets for the NOM to send 
at one time. If you set this value too high your site may 
lose updates to Rundowns, especially for Rundowns 
longer than 200 lines.  
The setting BreakUDPPackets must be enabled for 
this setting to take effect. If the number of UDP packets 
is increased from the default ENPS may open port 
10517 in addition to the regular UDP ports 10512 and 
10513. 

Number of packets. 
Default is 2000. 

UDPRepeats 

Number of times for the NOM to re-send UDP 
packages to ensure that they are received by the client. 
The client will ignore redundant messages. This option 
will increase network traffic.  

Value from 1 to 10. 
Default is 0. 
Consult ENPS 
Support before you 
enable this option. 

[NOM]  

AutoCreateDelay 

Specify the number of minutes for the Buddy Server to 
delay AutoCreate actions. This allows the Buddy 
Server queue to clear before it starts to AutoCreate 
Rundowns. 

0=Disabled (default) 
1=Enabled 

AutoCreateTimerInterval 

Number of seconds to wait between creating Grids and 
Rundowns for the AutoCreate process. 

Maximum is 60, 
default is 20 

Broadcast 

Prevent the NOM from sending UDP broadcast 
messages into the local subnet. Use this setting if 
clients are not receiving Rundown and wire updates 
properly. 

0=Disabled (default) 
1=Enabled 

Buddy 

Specifies whether to use the Buddy Server. The Buddy 
Server should be disabled when maintenance is being 
performed on it. 

0=Disabled  
1=Enabled (default) 

CentralServer 

Name of your Central Server. Refer to “Central Server 
and CTOS” on page 11 for more information. 

Example: 
ENPSTEST01 

FastSortList 

Instructs the NOM to sort folder items more quickly 
when there are large number of items such as MOS 
object folders. The NOM uses this method 
automatically if a folder contains more than 32,000 
items. 

0=Disabled (default) 
1=Enabled 
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ListenOnBlock 

Specify whether the NOM should continues to monitor 
messages from MOS devices when it is in Block mode. 

0=Disabled  
1=Enabled (default) 

MaxSocketsClosed  
Maximum number of running Winsock controls with 
closed connections. If this limit is reached a warning is 
logged and excess controls are unloaded. 

Default is 1000 

MessageExpiration 

Number of days to preserve Top Line group or personal 
messages before they are deleted during maintenance.  

Default is 7 for short 
messages, 30 for 
longer messages 

MOSRepeater 

Configure a server to operate as a MOS Repeater. For 
more information refer to “Setting Up a MOS Repeater” 
on page 136. 

0=Disabled (default) 
1=Enabled 

RemotePortTSS 

Port to which the NOM and NWP send UDP updates to 
the Top Story Server.  

Default is 11800 

roReqRefreshMOSRefs 

Instructs the NOM to ignore roReq messages for 
Rundowns which have the MOS Control Active 
checkbox selected since MOS object updates will be 
sent automatically.  
■  For more information on MOS Protocol messages 

refer to http://www.mosprotocol.com. 

0=Disabled  
1=Enabled (default) 

SocketTimeout 

Number of minutes before the NOM closes 
unresponsive connections.  

Default is 2 

WarnSocketsConnected 

Number of simultaneous connections before a warning 
is logged. If a MOS device creates too many 
connections it may indicate a problem with the device. 

Default is 20 

XMLstorage 

Advanced formatting options on story toolbars including 
bold, italics, underline, and font colors. Clients using 
these additional formatting features must also enable 
UseRTFtext in the [ENPS] section of their ENPS.INI 
file. 
This setting must be enabled in both the NOM and 
NWP configuration settings if you want to enable 
mobile client users to edit scripts and add new lines to 
Rundowns. 

0=Disabled (default) 
1=Enabled  

http://www.mosprotocol.com/
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[Watch]  
NOM, NWP, Maint, WalkCS, Publish, 
TopStories 

Controls whether the NOM Watch starts an ENPS 
server component automatically. Do not modify this 
field unless instructed to do so by ENPS Support. 

0=Disabled  
1=Enabled (default for 
all components) 

[TopStories] 
 

RefreshMax 

Number of stories before the Top Story Server stops 
refreshing the list of top stories. If you set this value to 
25 and there are 26 stories the Top Story Server will 
not refresh the list.  

Set to 1 to disable 
refreshing. Default is 
500. 

[Maint]  

DeleteTimerInterval 

Delay between Maint operations.  
Default is 200 ms 

SyncExclude 

ENPS creates noise words lists for your for local 
language automatically. These lists cause Searches to 
exclude terms like “a,” “an” or “the.”  To exclude the 
noise word list set the value of this setting to G_NOISE. 

Set this value to  
G_NOISE to exclude 
the local noise word 
list. 

[MOS]  

<MOS Device Name> 

Number of seconds before a connection times out for a 
specific MOS device. If a timeout occurs the 
Rundown’s MOS Status column will display 
DISCONNECTED. The Rundown will refresh when the 
connection is re-established.  
Refer to the Timeout setting to select a default timeout 
value for MOS devices. 

Example: 
MOSPROMPTER=10 
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EdStartLocal 

Determines whether ENPS adjusts the roEdStart tag 
in an roCreate message based on Daylight Savings 
Time.  
By default, ENPS adjusts roEdStart to reflect the 
local time automatically. For example, if a newscast’s 
Editorial Start Time is 17:00 and the local server is in 
Eastern Standard Time ENPS would send the MOS 
device an roEdStart of 22:00. During Daylight 
Savings Time the server would send the MOS device 
an roEdStart of 21:00. 
You can also set ENPS to not adjust the time 
automatically. This may be necessary for backward 
compatibility with some MOS systems that are set to 
receive an unadjusted time in roEdStart.  
■  For more information on MOS Protocol messages 

refer to http://www.mosprotocol.com. 

0=Adjust time 
automatically (default) 
1=Do not adjust time 
automatically 

DisconnectWait 

Interval for the NOM to attempt to contact a non-
responsive MOS device.  

Default is 30 

StrictXMLValidate 

Enforce rigorous XML validity checking on incoming 
MOS messages. This option is disabled by default for 
compatibility with devices that use older versions of the 
MOS protocol. 

0=Disabled (default) 
1=Enabled 

Timeout 

Number of seconds for the connection to a MOS device 
to time out if no value is specified for a particular MOS 
device the global timeout will default to this value. 
Timeouts cannot be less than 1 second and no longer 
than 60 seconds. Shift+Del can be used on the 
server to delete the currently selected MOS message 
from the outbound queue on the NOM without 
confirmation. Ctrl+Shift+D deletes all items in the 
queue. 

Default is 6 

Version 

Default MOS version for ENPS to use if one is not 
specified for a particular device.  

Default is 2.6 

[Reflectors]  

Reflectors’ IP addresses for which you want the server 
to transmit packets directly. For more information refer 
to “Reflectors” on page 110. 

IP addresses for 
reflectors 

[Publish]   

For detailed information on Publishing refer to the 
ENPS Publishing Guide.  

http://www.mosprotocol.com/
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ConnectRetryInterval 

Number of seconds before Publishing attempts to re-
establish a lost connection to the server.  

Default is 5, maximum 
is 60 

ConnectTimeout 

Number of seconds before a connection to the 
Publishing database times out. 

Default is 5, maximum 
is 60 

Provider 

Set this value to SQLOLEDB if Publishing is configured 
to use a database.  

SQLOLEDB if 
Publishing uses a 
database. 

PublishEnabled,PublishDBEnabled 

Both of these settings must be enabled to use 
Publishing. 

0=Disabled (default) 
1=Enabled 

PublishROs 

Maximum number of Rundowns or Newsgathering 
Grids that can used for Publishing. 

Default is 50, 
maximum is 100 

[WalkCS]  

MaxDATFileSize 

Maximum size for WALKCS.DAT. This file is used by the 
WalkCS application to track which files have been 
compounded. 

Value in bytes.  
The minimum is 
4000000 or 4 MB.  
The default and 
maximum value is 
100000000 or 100 
MB. 

UseDATFile 

Controls whether WalkCS maintains a file tracking 
previously-compounded content. By default, WalkCS 
will examine each file in the archive whenever WalkCS 
runs. This reduces the memory required by WalkCS 
and the length of time it takes to compare each 
individual filename to the WalkCS tracking file. It is 
recommended that larger sites keep this option 
disabled as it can slow down server performance. 

0=Disabled (default) 
1=Enabled 

NWP Configuration Settings 
Section/Description Value 

[TCPIP]  

DatagramsPerSecond 

Number of UDP messages transmitted per second to 
the NWP. 

Default is 20 

PacketVersion 

Specifies whether incoming wires are in English. 
1=English news wires 
(default) 
2=Non-English news 
wires 
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[NWP]  
Broadcast 

Determines whether the NWP sends UDP broadcast 
messages to the local subnet. This option should be 
enabled to ensure clients receive Rundown and wire 
updates properly. 

0=Disabled (default) 
1=Enabled 

CustomXSLFiles 

Determines whether the NWP can ingest custom XML 
wires. Refer to “For diagnostic purposes, you can 
configure the NWP to re-ingest previously captured 
Webfeeds data from a text file. Open a WebFeeds wire, 
clear the Active checkbox, and press Ctrl+T. This can 
also be used for pre-election testing with ENPS Stats. 
Wires in XML Format” on page 120 for more 
information. 

0=Disabled (default) 
1=Enabled 

Discard 

Semi-colon delimited list of category codes to discard. 
Three digit category 
codes separated by 
semi-colons. For 
example:  
021;033;504 

DupeStoryThreshold 

Specifies how many of the most-recent incoming wires 
will be checked for duplicates. Duplicates are defined as 
stories which have identical slugs and the same text 
after the wire header. Any duplicates identified within 
the threshold will be discarded (only the first story 
received is retained). 
When ingesting wires via AP WebFeeds without this 
setting enables a separate version of the story is saved 
for each included category in a single WebFeeds entry 
(e.g. sports, business, general news). If this setting is 
set to a value of 2 or higher then only the version for the 
first referenced category will be saved.  

0=Disabled (default) 
 

FTPPollInterval 

Number of minutes the NWP polls FTP wire files.  
Minimum is 1. 
Maximum is 2000. 
Default is 5. 

MaxFTPCaptureFiles 

Maximum number of files that can be saved in the 
capture directory when the Create capture file option is 
selected for an FTP wire. Refer to “Wires via FTP” on 
page 115 for more information. 

Default is 9999 

MaxSocketPacket 

Maximum packet size in characters for UDP messages 
when Unicode is enabled.  

Default is 1024 

NID 

ID number for the wire programming tables.  
ID number 
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NNTP  

Specify whether to use the News Ticker feature. For 
more information refer to “News Tickers” on page 101. 

0=Disabled (default) 
1=Enabled 

PreventUrgent 

Semicolon-delimited list of category codes for which you 
want wire stories with “urgent” priority to appear as non-
urgent stories.  

Wires’ three digit 
category codes, 
separated by semi-
colons. 

TwitterFeeds 

Ingest a feed from Twitter. Refer to “Wires via Twitter” 
on page 121 for more information. 

0=Disabled (default) 
1=Enabled 

Unicode 

Unicode formatting. If this option is enabled you also 
need to change MaxSocketPacket to 1024. 

0=Disabled (default) 
1=Enabled 

UnicodeViewer 

Preview wires that contain Unicode characters beyond 
&h58F in the NWP window. 

0=Disabled (default) 
1=Enabled 

Webfeeds 

Ingest WebFeeds wires. Refer to “Wires via AP 
WebFeeds” on page 117 for more information.  

0=Disabled (default) 
1=Enabled 

XMLstorage 

Advanced formatting options on story toolbars including 
bold, italics, underline, and font colors. Clients using 
these additional formatting features must also enable 
UseRTFtext in the [ENPS] section of their ENPS.INI 
file. 
This setting must be enabled in both the NOM and 
NWP configuration settings if you want to enable 
mobile client users to edit scripts and add new lines to 
Rundowns. 

0=Disabled (default) 
1=Enabled  

YouTubeFeeds 

Ingest YouTube feeds. Refer to “Wires via YouTube 
Feeds” on page 123 for more information. 

0=Disabled (default) 
1=Enabled 

[NNTP]  

NNTPFaultRestartInterval  

Number of minutes before the NWP restarts the NNTP 
process if it stops. It is recommended that you set this 
value at 10 then change it as needed.  

Number of minutes 
 

[KillClock]  

Number of hours before wires are removed from the 
server.  

Maximum is 168 (1 
week) 
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[Reflectors]  

Reflectors’ IP addresses for which you want the server 
to transmit packets directly. For more information on 
reflectors refer to “Reflectors” on page 110. 

IP addresses to 
reflectors 

[ReflectUrgents]  

IP addresses for workstations that should receive real-
time urgent wires only. This is useful for dial-in users or 
with  a slow connection. Forward Search alerts will not 
be available to those users. 

IP addresses for 
workstations 

[Providers]  

Wire provider codes. 

 
Examples: 
APX=AP Express 
APD=AP Datafeature 
APJ=AP-Dow Jones 

[TopStories]  
ExcludedCategories 

Category codes to exclude from the Top Stories Server. 
These categories will be excluded even if the news wire 
is configured for processing on the Top Stories Server.  

NWP category 
numbers separated 
by semi-colons 

[Wire#] sections for specific wires  
AllowExtendedWireSave 

Number of hours to save wire copy. 
Number of hours. 
Maximum is 8784 or 
366 days.  

AllowedExtension 

File extensions that may be sent via FTP.  
By default all file 
types are allowed. 

AssumeUTF8XML 

In some cases XML wires in may be sent without a byte 
order mark indicating they are UTF-8. Once this setting 
is enabled the NWP will be able to ingest those wires 
properly. 

0=Disabled (default) 
1=Enabled 
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Chapter 9 
Compound Storage 

Compound Storage is a method for storing ENPS archive data. It lets you store 
archived Rundowns and Newsgathering Grids, along with their associated 
stories, as a single delimited file rather than as separate records. Using 
Compound Storage reduces the number of files on servers by as much as 97% 
and significantly reduces the number of files to be indexed. This is especially 
important for sites that have millions of records in their archives.  

If you opt to use the Compound Storage at your site, users will continue be able 
to access archived material. The only difference they will see is in how Search 
results are returned for archived data. When a Search finds an uncompressed 
item it will be displayed as an individual item in the List Window. When a 
compressed item is found the Rundown or Newsgathering Grid to which it 
belongs will be displayed. When the user opens the Rundown or Newsgathering 
Grid the search term will be highlighted in red. 

Compound Storage is configured through an application on the ENPS server 
called WALKCS.EXE. This application reviews archive folders and converts 
Rundowns and Newsgathering Grids older than a certain number of days to the 
Compound Storage model.  

It is recommended that you implement WalkCS when there is the lowest possible 
resource load on the ENPS server.  

To implement Compound Storage complete the following steps: 

 1.  Open the \NOM  folder on the ENPS WORK drive and run WALKCS.EXE.  

 

2.  In the box Convert items more than __ days old enter the number of days 
before items should be converted to Compound Storage. The recommended 
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value is 365; the maximum is 730. Lower volume sites may want to increase 
the number of days in this setting.  

3. You can also select the day of the week, and the time that the Compound 
Storage utility runs. Once you click Run now! the application will review all 
files in the archive folder and compress those which are older than the 
configured time frame. The application write a log to the WALKCS.LOG file in 
\NOM\LOGS on the ENPS WORK drive. 

4. Repeat this process on the Buddy Server. 
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Chapter 10 
Client Configuration Settings 

The configuration settings for a client workstation can be found in 
C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI. You can use a text editor such as Notepad to modify 
this file. To disable a setting add a semi-colon in front of it. 

Some of the settings in this file are identical to settings in the Global 
Configuration Options: the setting in ENPS.INI will always override the global 
option. This allows you to set up configuration settings for the majority of users at 
your site but set workstation-specific settings on a case-by-case basis. 

Once you make a change to the ENPS.INI restart the client for your changes to 
take effect. The following table describes the settings in this file: 

Option and Description Settings/Examples 

[ENPS]  
BaseDialect  

Dialect code. Local dialects take precedence over the 
setting for BaseLanguage. A complete list of base 
dialect codes may be found in “Language Support” on 
page 153. 
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

Four letter dialect code, 
such as ENUS for 
American English. 

BaseLanguage  

Language for ENPS labels, menus and fields. A 
complete list of language codes may be found in 
“Language Support” on page 153. 
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

Two letter language 
code such as EN for 
English. 

CG 

Determines whether the character generator can be 
used from the client workstation. Refer to “Character 
Generators” on page 139 for more information. 

0 – Disabled (default) 
1 – Enabled 
 

CGMacro  

Determines whether the CG operator can create CG 
macros to trigger events and transforms. This setting 
must be enabled in both the [ENPS]section and the 
[CG] section.  
CG macros replace the personal macros controlled by 
the F2-F12 keys. The CG operator will see macros 
available from Rundown rover → CG Device 
Control. The CG macro keys on the right of the list 
window next to the CG text. On the Group rover of 
the client logged into the CG workstation there will be 
an entry called CG Macros. The CG operator can 

0 – Disabled (default) 
1 – Enabled  
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enter macros which will be sent when the 
corresponding function key is pressed. These macros 
can include {Pause} so that a portion of the macro 
will execute and the remainder will be executed when 
the button is pressed again. 

ChatDateTime  

Format of the date and time prefixed on messages if 
the Include date/time option from the Chat rover is 
selected. The date/time format defaults to “dd-mmm 
hh:nn”.  

Example 
“mmm-dd hh:nn” 
displays month, day, 
hours and minutes  

ChatHoldTime 

Seconds of hold time allowed during a chat session. Default is 240 seconds, 
or four minutes. 

ChatStatusDelay 

Delay in seconds for flashing status messages.  Default is 3. 

CreateRCFiles 

Sites that are upgrading from ENPS 4.5 should 
enable this option prior to performing the upgrade. It 
enables  functionality which will allow users to select 
story text and change it to upper, lower or mixed case.  

0 – Disabled (default) 
1 – Enabled 
 

CtrlAlt 

Determines whether modifier key combinations may 
be used. For example this setting enables Ctrl+Alt 
key combinations on US keyboard or Alt+Gr in the 
UK. 

0 – Disabled (default) 
1 – Enabled 
 

DebugSocket 

Used by ENPS Support for troubleshooting purposes. Do not modify. 

DefSettings 

Determine whether a user can select security profiles 
which specify different user security levels across 
different servers and/or groups. This setting requires 
that Global Configuration Option CENTRALPRIV is 
enabled. Refer to “Default Settings Profiles” on page 
96 for more information. 

0 – Disabled (default) 
1 – Enabled 
 

DetachedActiveX 

Specify whether the Media Control icon has a rover 
option to open an ActiveX plug-in in a separate 
window. This feature is useful for viewing controls on 
a second monitor. A maximum of three detached plug-
ins may be open at any one time. 
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

0 – Disabled (default) 
1 – Enabled  
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DraftPrintCharsPerLine, 
DraftPrintLinesPerPage 

Standard story printing functions were designed for 
laser printers and are often too rich in detail for most 
dot matrix printers. User can print in “draft” format was 
from Editing Window and Rundown rovers. These 
settings take precedence over the margins in 
determining when a page or line ends. When printing 
in draft mode a small progress bar may appear in the 
upper left corner of the screen. 

Number of characters or 
number of lines  

ExternalDocuments 

Allow users to store Word DOC or Adobe PDF 
documents in the Newsgathering Grid’s Background 
or Collection fields. 
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

0– Disabled (default) 
1 – Enabled  
 

ExportPath 

Default folder in which items are saved when a user 
exports a Rundown. 

Folder path. The default 
is the root folder. 

FarsiTextBoxFont 

Font to use if ENPS is unable to render a Farsi 
language character with the current font. This value 
can be set to either Tahoma or Arial, either of which 
work with all Farsi characters. This setting also takes 
effect if the font specified in a story is not available on 
the client workstation.  
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

Tahoma or Arial 

GridCellHighlightEnable 

Specify whether ENPS should use the default dark 
gray color for cell highlighting in Rundowns and 
Newsgathering Grids. If this setting is enabled cell 
highlighting color specified by the Global 
Configuration Option GridCellHighlightColor 
will be used as the cell highlighting color. This setting 
enables the Workstation grid cell highlight color option 
in a user’s Personal Settings.  

0 – Disabled (default) 
1 – Enabled 

GridRptFontSize 

Font size in twips for printing generic grids. 
Note that 1 twip = 1/20 of point, 1440 twips = 1 inch 
and 567 twips = 1 centimeter. 

Default is 200 twips. 

GridRptHMargin 

Width of the margins in twips for printing generic grids.  
Note that 1 twip = 1/20 of point, 1440 twips = 1 inch 
and 567 twips = 1 centimeter. 

Default for top margin is 
360 twips and default 
for left and right margins 
is 240 twips. 
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LeftZoneWidth, CenterZoneWidth, 
RightZoneWidth 

When printing in two column mode it is possible to 
define the percentage of screen space occupied by 
the left column, the center spacing and the right 
column using these settings. For example if you set 
these settings as follows: 
LeftZoneWidth=40 

CenterZoneWidth=20 
RightZoneWidth=40 

the left zone will occupy 40 percent, the center zone 
will occupy 20 percent and the right zone will occupy 
40 percent. 

 

LoadPrintersOnDemand 

By default ENPS validates all available printers when the 
client starts. If this option is enabled ENPS will only validate 
the printer list when a user creates a print job. This option 
should be enabled on remote workstations that connect over 
low-bandwidth connections.  

0 – Disabled (default) 
1 – Enabled  
 

LogMOSActiveXMessages 

Create the a log of the ActiveX plug-in MOS activity. 
The XML log will be created in the C:\Documents 
and Settings\All Users\Application 
Data\ENPS folder. The filename will be the plug-in’s 
MOS ID. 

0 – Disabled (default) 
1 – Enabled 

LocalSort 

Specify whether to sort Search results on the 
workstation instead of the server. You should enable 
this option if your search results are not displayed in 
the correct chronological order. 

0 – Disabled (default) 
1 – Enabled 

MIRXMLTree 
View MOS Item Reference tooltips in an XML tree 
view.  
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

0 – Disabled (default) 
1 – Enabled 

MOSItemReplaceChange 

Specify this option if MOS Item References in ENPS 
are corrupted by Unicode characters from certain 
international character sets when ActiveX plug-ins 
update MOS Item References. 
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

0 – Disabled (default) 
1 – Enabled 
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PollClockInterval 

Interval at which the client polls the server to 
synchronize clocks. In Active Directory environments 
clock synchronization is automatic so ENPS clock is 
unnecessary. To disable server synchronization 
disable the SyncToNOMTime setting in the [ENPS] 
section. 

Number of minutes 

PrintJobDelay 

A delay for print jobs. This is necessary for some 
printing stories from Rundowns in right-to-left 
languages such as Arabic. If users are using a macro 
for their print jobs they may also need to add {WAIT} 
commands to their macro code. 

Number of seconds 

PublishDBEnabled 

Specify whether Publishing features are available in 
the client. For more information about Publishing refer 
to the ENPS Publishing Guide. 

0 – Disabled (default) 
1 – Enabled  

PublishEnabled  

Display Publishing tables and columns in System 
Maintenance. 

0 – Disabled (default) 
1 – Enabled 

QTMediaExtensions 

QuickTime player extensions that may be played in 
the script media viewer. 

Example: 
.mov,.qt,.qti,.m4p,.mp3,.
qtif,.qif,.3gp,.mp4 

ROStorySendOnFreeze 

Send MOS roStorySend messages for all stories in 
a Rundown whenever the page is frozen or unfrozen. 
This setting will slow server performance. 
■  For more information on the MOS Protocol refer to 

http://www.mosprotocol.com. 

0 – Disabled (default) 
1 – Enabled 

RTFFarEastFontFix 

Controls how a MOS Item Reference’s <itemSlug> 
tag is interpreted when an item is dragged from a 
story or ActiveX plug-in into a story with a Chinese 
language slug.  By default, ENPS will attempt to 
automatically correct the reference’s  value. If you 
want to keep the tag’s value unchanged you can 
disable this setting. 

0 – Disabled  
1 – Enabled (default) 

RTLPrint 

Specify whether to use alternate print engine. 
Enabling this setting may resolve issues with printing 
on some systems. It also enables print options not 
available by default such as the ability to add page 
breaks to long Rundowns or Newsgathering Grids 
using the Page Break column. You must enable this 
option for right-to-left for languages such as Arabic.  
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

0 – Disabled (default) 
1 – Enabled 

http://www.mosprotocol.com/
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ScriptMediaViewer 

Add a pane to preview MOS Item References in a 
story. The story pane can be toggled on or off from 
the story rover or from the toolbar in the story window.  
The MOS Item Reference must have a path to the 
media in the format specified by the MOS Protocol. 
The following are sample paths: 
http://<server>/proxy/clip328cd20s0e.wmv 
ftp://<server>/proxy/clip328cd20s0e.wmv 

\\<server>\media\clip328cd20s0e.mxf 

If MOS Item References do not have a valid path 
ENPS will display a generic graphic. 
■  For more information on the MOS Protocol refer to 

http://www.mosprotocol.com. 
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

0 – Disabled (default) 
1 – Enabled 
 

UseSendInput 
On client workstations running Windows Vista or 
Windows 7 it is recommend that you disable User 
Access Control (UAC). On machines where UAC is 
active this option, which is enabled by default, allows 
macros to continue working as expected. Disabling 
this setting switches macro execution to an alternate 
method, but should only be done on an as-needed 
basis in consultation with ENPS support. Using the 
default value has no effect on workstations running 
Windows XP or on Windows Vista or Windows 7 
machines where UAC is disabled. 

0 – Disabled  
1 – Enabled (default) 

SpellCheckerPluginID 

Use approved third-party ActiveX spell check plug-ins in 
place of the default spell check tool included with ENPS. 
This option is used primarily by Portuguese sites who 
need a specialized spellchecker to support the 
Portuguese Language Orthographic Agreement.  
The spell check option will appear from the story rover 
menu or the spell-check option on the story toolbar. 
Use of a third-party speller replaces all built-in spelling 
functionality in ENPS, including the standard 
configuration options. All configuration and dictionary 
management must be done through the third-party tool, 
not from the ENPS rover menu. 
►  This setting is also available as a Global 

Configuration Option. The value specified here takes 
precedence over the global setting. 

To enable enter the 
string provided by the 
ActiveX provider. 

SetupRestart 

Prompt users to restart workstations after clients are 
updated from the server.  

0 – Disabled  
1 – Enabled (default) 

http://www.mosprotocol.com/
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SystemEdit 

Allow users with sufficient privileges to edit system 
fields. 

0 – Disabled (default) 
1 – Enabled  

SyncToNOMTime 

In Windows Active Directory environments scheduled 
clock synchronization occurs automatically and ENPS 
synchronization is unnecessary. Use this setting to 
disable server synchronization. 

0 – Disabled 
1 – Enabled (default) 

TerminateOnExit 

Specify which external processes should 
automatically stop when the client is shut down. The 
HP Universal PS driver, for example, must be shut 
down before the client can be restarted so this setting 
would be set to the driver filename HPMUP081.BIN.  
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

Name of the process to 
shut down. 

UnicodeFontSubst 

Enable a substitute Unicode font for the ENPS 
interface. If this setting is enabled a font must be 
specified using UnicodeFontName. 

0 – Disabled (default) 
1 – Enabled  

UnicodeFontName 

Default Unicode font that will be used for the ENPS 
interface  if UnicodeFontSubst is enabled. This font 
must be installed through Windows and the name 
specified here must match the font name exactly. 

Name of the Unicode 
font. 

UserIDSpace 

ENPS does not allow login names containing spaces 
and certain reserved characters. To work with legacy 
systems where spaces are used in names set this 
setting to a replacement character such as a hyphen 
or underscore. Spaces in user names will be 
converted to the specified character for internal ENPS 
use. A hyphen is recommended.  

Windows account name 
of John_Doe would be 
converted to (and 
should be created in the 
ENPS staff database) 
as John-Doe using this 
setting. If no setting is 
specified the name 
would become 
JohnDoe. 

UseRTFtext  

Enhanced formatting options on story toolbars such 
as bold, italics, underline and font colors. This option 
is enabled by default. This option also requires 
XMLstorage is enabled in the [NOM] section of the 
NOM.INI. 
►  This setting is also available as a Global 

Configuration Option. The value specified here 
takes precedence over the global setting. 

0 – Disabled 
1 – Enabled (default) 
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WireRptHMargin, WireRptFontSize 

Set the width of the left and right margins for wire 
story printouts or the font size. The default margin is 
.25 inches and the default font size is 12 pt. The value 
is given in twips (a twentieth of a point) where 1440 
twips = 1 inch. 

Default for x is 360 
twips and the default 
value for y is 240 twips. 

[TCPIP]  

ConnectTimeout 

Length of time the client will use to attempt to connect 
to the ENPS server. 

Default is 20 seconds. 

LocalServer  

Name of the Primary Server. Example: APENPS01 

PacketVersion 

Allow support for non-English feeds. Port 10517 may 
be automatically used in addition to 10512 and 10513 
for UDP datagrams. Make sure this setting is the 
same for both the client’s ENPS.INI and in the 
\NWP\NWP.INI on the ENPS WORK drive. 

1 – English wire feeds 
(default) 
2 – Non-English wire 
feeds 

ReceiveTimeout 

Number of seconds before a timeout to receive 
information back from the ENPS server. 

Default is 20 seconds. 

ReceiveTimeoutBriefing  

Number of seconds the client will wait for Search 
results. 

Default is 20 seconds. 

ReceiveTimeoutMOSQuery  

Number of seconds the client will wait for MOS  
search results. This setting applies to MOS version 
2.8.1 or higher. 

Default is 5 seconds. 

ReceiveTimeoutWebHits  

Amount of time the client will wait when the Count 
button is pressed from the Search dialog box’s 
Advanced Options tab. 

Default value is 4 
seconds. 

SearchAutoKeyboard 

When using ENPS in any RTL language locale such 
as Arabic an operating system conflict may switch the 
keyboard language in some textboxes like the Search 
box. This setting controls whether ENPS should 
prevent the language switching. By default, this option 
will be enabled only if the default locale uses a RTL 
language but you can enable this setting to ensure 
that switching is prevented regardless of your locale. 

0 – Disabled 
1 – Enabled (default) 

SelectRows 

Number of entries to store in the List Window. Default is 250. 
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UDPInfo  

When this setting is enabled, UDP packets received 
by the workstation will be recorded and the command 
Ctrl+Alt+U will display a table of servers, packets 
received, and a reliability measure.  
Only NOM UDP packets (not NWP packets) are 
tracked and UDPs are only sent only when non-
private data is manipulated such as a story is saved or 
a Rundown is re-ordered. UDPs from servers on 
different subnets will not be received unless they are 
explicitly "reflected" and if private channels are active 
the UDPs will still be tracked even though they are not 
processed because the packets are duplicated in the 
private channel. 
The CtrlAlt setting in the [ENPS] section must be 
enabled for this feature to work. 

0 – Disabled (default) 
1 – Enabled  

[Prompter]  

Driver 

Name of the prompter driver. Once the driver is 
specified here you the user can select Rundown 
rover → Dump to the corresponding prompter.  

AutoCue 
WinCue 
WinPlus 
Simplicity 
AP Prompter 

Log  

Create a log of prompting activity for troubleshooting 
purposes. Enabling this option generates 
C:\DOCUMENTS AND SETTINGS\ALL 
USERS\APPLICATION DATA\ENPS\PROMPTER.LOG 
with overflow into C:\DOCUMENTS AND 
SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\PROMPTER.000.  
The following are logged: 
• *.DAT control file updates, text writes, and file 

removals from the prompter share. 
• Failed writes of *.DAT files or text files. The word 
FAILED! will be in the log for any write failures. 

0 – Disabled (default) 
1 – Enabled  

Path 

If you are using WinCue, WinPlus, or AP Prompter 
and you prompter data to be written to disk, specify a 
drive letter and directory name or UNC name and 
path. 

Examples: 
C:\PROMPTDATA 

\\APENPS1\PRMPT 

Port  

Prompter port for AutoCue prompters. Default is 1. 
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Settings  

Serial port settings including baud rate, parity, packet 
size and stop bits. AutoCue is the only serial prompter 
supported; it requires the following serial port settings 
in the [Prompter] section: 
; Prompter port (for AutoCue only) 
; Port=1 
; Serial port (defaults to 9600,n, 8,1) 
; Settings=9600,n,8,1 

9600,N,8,1 

[CG]  

AstonAnimation  
Any AstonCopyPreviewToDisplay command 
sent to an Aston will be followed by an 
AstonWaitForDynamicEnd command. 

0 – Disabled (default) 
1 – Enabled  

AutoPreview  

First item to be automatically previewed when grid is 
first opened, and the next item to be previewed when 
an item is rendered. 

0 – Disabled (default) 
1 – Enabled  

BigEndian  

When the Unicode setting is enabled, this settings 
causes the byte order of Unicode data to conform to 
the Java binary standard instead of the Intel binary 
standard. 

0 – Disabled (default) 
1 – Enabled  

CGMacro  

Determines whether the user can create CG macros 
to trigger events and transforms. This setting must be 
enabled in both the [ENPS]section and the [CG] 
section. 

0 – Disabled (default) 
1 – Enabled 

CharMap  

Refer to “Mapping International Characters with the 
CG” on page 160 more information. 

 

Directories  

Specifies all available message directories on the 
Chyron or drives on the Dubner. This setting is not 
valid for the Codi. Each entry must include the full 
drive and path name and exactly match the message 
directories on the Chyron.  
All messages in these directories must be built using 
machine fonts, not converted fonts. All tab fields must 
be set to auto-erase, and all tab stops must match the 
order of the AP ENPS templates as built by the ENPS 
operator. Each message directory must have 
sufficient clear space above the defined starting 
location to handle large newscasts. 

Chyron/ TypeDeko 
example: 
DIRECTORIES= 
C/AM;C/NOON;C/5PM;
C/6PM;C/10PM 
 
Dubner example: 
DIRECTORIES= 
1;2;3 
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GlobalCommand  

When disabled, CG commands will utilize the Chyron 
machine ID code and the proper syntax to address a 
unique machine on a multi-drop serial cable. When 
enabled, CG commands will use a global command 
structure to address all Chyron CGs on a multi-drop 
serial cable. 

0 – Disabled (default) 
1 – Enabled  

LeadingTab  

When enabled, a Tab command is sent when 
beginning communication with the character 
generator, sometimes necessary to position the CGs 
cursor in the proper starting field. 

0 – Disabled (default) 
1 – Enabled  

Preload  

Preload all CG instructions for show to the character 
generator. Changes will be transmitted to the CG in 
real-time and subject to control by the CG keyboard. 
When disabled, the ENPS PC is in control. This 
setting is not valid for the Codi. 

0 – Disabled (default) 
1 – Enabled  

PrimaryUser  

In some situations, multiple users can work with the 
Chyron CG at the same time and it may be desirable 
to specify which user's commands will be given 
priority processing. If this option is disabled “X” 
commands will be used and if enabled “Y” commands 
will be used. 

0 – Disabled (default) 
1 – Enabled  
 

Retries  

Number of times to retry transmission to the CG 
device after a timeout.  

Default is 3. 

RTS  

When enabled, the Request to Send signal on the CG 
is respected. This feature may be required for 
arbitrating flow control between ports on serial port 
sharing devices. Many such devices have different 
operational characteristics and may, or may not, be 
suitable for use with ENPS. Generally, a CG-enabled 
PC should have exclusive control of the CG to prevent 
arbitration problems. 

0 – Disabled (default) 
1 – Enabled  

Test 

When enabled, the ENPS character generator driver 
is in “test mode” and does not respect the settings for 
CGTimeout or CGRetries. 

0 – Disabled (default) 
1 – Enabled  

Timeout  

Milliseconds the ENPS character generator driver will 
wait to hear from the CG device before timing out (500 
ms is half a second; 1000 ms is one second). 

Default is 3000 (three 
seconds). 

Trace  

CG operations are logged to a temporary file named 
CGTRACE.LOG for review. 

0 – Disabled (default) 
1 – Enabled  
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Unicode  

Data to be sent in Unicode rather than ANSI in the 
default code page. 

0 – Disabled (default) 
1 – Enabled 

UserAccount  

User account name for an Aston model character 
generator. If specified, a command instructs the Aston 
to change to that user account. 

Example: JOHNSMITH 

UseSBCGOutput  

Use this setting if you are not using a double-byte 
character language and output is sent to the CG 
incorrectly.  

0 – Disabled (default) 
1 – Enabled  

UTF-8 

Force UTF-8 encoding for the output to the CG 
device. This setting will output to Unicode UTF-8 
regardless of whether the Unicode setting is enabled 
or not. 

0 – Disabled (default) 
1 – Enabled  

[Reflect]  

Servers, NOM, NWP 

Run the standalone reflector REFLECT.EXE on a 
workstation that is dedicated to being a reflector. This 
option is enabled by adding a list of servers, delimited 
by semicolons, as a Servers setting. This section 
might also be placed in a file called REFLECT.INI.  
For more information to “Reflectors” on page 110. 

For example: 
APENPS01; 
APENPS02 

[Update]  

Defer 

Number of days to defer minor client updates for dial-
up users. Major updates cannot be deferred. 

Default value is 10. 

[StatsCG]  

Refer to the ENPS Stats Guide for information on the 
settings in this section.  

[TickerCG]  

CG information for News Tickers. Refer to “News 
Tickers” on page 101 for more information.  

[Automation]  

This section applies to the OmniBus serial interface. 
Refer to Using the OmniBus System on page 125 for 
more information. 
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Chapter 11 
Custom Fields 

In addition to the standard fields that come with ENPS you can add your custom 
fields which may appear in stories, contacts, Rundowns and Newsgathering 
Grids. 

Open the ENPS client and select Fourth Folder rover → System Maintenance 
→ [Site name] fields. If you want to change the parameters of a standard 
system field create a custom field with the same name and assign the desired 
parameters. You must restart the NOM on the Primary Server and the ENPS 
client for your changes to take effect. 

The following table describes the parameters used to create a custom field: 

Field Description 

ID  System identifier for the custom field. This name is not Use 
letters and numbers only. Users will not be able to locate 
the ID using Search if this ID contains any of the following 
characters: ~ ! @ # $ % ^ & * ( ) - = + _’  

Read Only Specify whether the field allows input. 

Default Caption  Field name to display to users. A translation in the 
Languages table will override this value.  

Just Left, center or right text justification.  

Validation Determines how to verify that information was entered in 
the correct format. Refer to “Validation Fields” on page 84 
for more information. 

List Choices to appear in a pull-down list delimited by pipe 
“|“ characters for example: VO|VOSOT|RDR|PKG|LIVE 

Reqd  Specify whether the field is required. 

Width  Width in pixels for the default column display. 

MaxLen  Maximum number of characters that may be entered in the 
field. 

Upper  Force text to uppercase. 

MinVal, MaxVal Minimum and maximum values for a numeric entry. 

Merge Not used. 

Type Determines which ENPS components will display the field 
such as Rundowns, Newsgathering Grids, Scripts, etc. 
Refer to “Type Fields” on page 86 for more information. 

Protected  Protect field’s value from changes after an initial value is 
entered. 
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Sequence  Order number for a fields to appear in the ENPS 
component such as the story property fields. When you 
have a group of related fields you can assign sequential 
numbering so that these fields remain in a consistent order.  

Parent  ID of a parent field. Fields with this entry are indented 
under their parent field. 

Briefable  Allow the field to be located through a Search. Selecting 
this option adds the field to the Search box’s Corporate 
Content tab.  
The first word entered in these fields can be found using 
the field search box under <Site name> Content tab of the 
Search window. Anything after the first space can be found 
using “Words in Text.” For example, if a user’s Search 
string is “Acme Hotel Fire” you could find this story by doing 
a field search for “Acme” or a Words in Text search for 
“hotel” or “fire.”  

Set Lock  Do not use. 

Word Wrap  Specify whether text should wrap around to the next line 
when a word reaches the edge of a column. 

Extract Target  Extract information from Anchor, CG and Notes columns. 
The fields Take Other and Insert Other can extract data 
from the TAKE and INSERT commands, respectively. 

Approval 
Extension 

Determines whether multiple approvals will be required 
before an item is cleared for broadcast. You can create 
multiple fields set as Rundown columns and set this 
property for each field. Once those fields are created the 
Final Approval column becomes read-only. It will be 
automatically selected only when all of the Approval 
Extension fields have been checked. If any of the fields are 
not selected, or if story contents change, the Final 
Approval column will be automatically de-selected. The 
ability to select specific Approval Extension fields can be 
associated with specific security levels after you enable the 
Global Configuration Option EnforceSecurityLevels. 
Refer to page 46 for more information. 

Autosize Width  Automatically adjust the width if the field is a Rundown 
column. 

MOS Send  Send the field via MOS roStorySend messages when the 
Rundown’s MOS Control Active property is enabled.  

MOS Tag  Specify whether the user can add MOS tags to a summary 
MOS item or to a MOS item in a story from the Rundown 
level. 

Validation Fields 
The following table describes each of the options in the Validation field. These 
options define the type of control that appears in the custom field. 
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Option Description 

Text Text input from user. 

ComboBox Drop-down list of choices. The user can either leave this 
entry blank select one of the choices in the menu. By 
default, the top line is blank to clear a previously selected 
choice. 

CheckBox Checkbox that can be selected or unselected.  

CheckList Drop-down checklist that allows users to select multiple 
options. 

CheckListEdit Drop-down checklist that allows users to enter a field 
manually. 

Duration Converts a numerical entry to a duration. If the user enters 
2 is converted to :02.  

Number Specify whether the field requires a numerical value. 

Date Require a date. If a user types 12-23-10 it is converted to 
12/23/10. Entering 122310 would cause an error.  

Time Time entry. 7:00 will be converted to 7:00:00 AM. 
Entering 700 produces an error. 

Collection Newsgathering Grid column into which users may drag 
items such as Microsoft Word DOC and Adobe PDF files. 
Background and Assign Info are examples of Collection 
fields.  

Form A form with multiple rows. Each row may have its own 
unique parameters, labels and validation. To define a row 
enter:  
label, validation, length, extract column  
Each entry must be separated by commas. Values may be 
left empty but a comma  must be still be added as a 
placeholder for the field parameter.  
Add the pipe character | to mark the beginning of a new 
row. For example:  
Who,Text,10|What,Text,10|Date,Date,10,Date 
|Length,Duration,10,EstDuration 

 
If you want to create a form for an Event Sheet  refer to the 
Validation field type Special below. 

Special Used the same way as the Form type above but used only 
for Event Sheets which display grids when double-clicked 
from Newsgathering Grids. The validation is case-sensitive. 
When this field is exported via MOS StorySend and/or 
Publishing, XML-based formatting will be applied. Fields 
with the validation type of Special appear as repeating 
elements named after the field. Each will contain child 
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elements named after the subfield column headings as in 
the following example for two rows of "Costs" data: 
<Costs><Date>11/11/2002</Date><Amount>44 
</Amount><Other>333</Other></Costs><Costs><
Date>11/22/2002</Date><Amount>55</Amount><O
ther>667</Other> 

Tree Provides nested options, with parent and child choices. 
Once Tree is selected in the Validation column click in the 
List field then press Enter or the Space bar to display a 
new window to configure the tree view.  

  
The bottom of the window displays a number of options 
that will help you configure the options on the tree. 

Dual Allows the user to select two choices from a drop-down list. 
Choices are specified in the List separated by pipe  
characters “|” such as:  
Choice1|Choice2|Choice3 

Table Display a table when the user clicks on the column. The 
table is defined by the List entries. List entries of "Tape 
Name|Tape Number" will result in a two-column, two-row 
table with rows "Tape Name" and "Tape Number.” 

 
MOS DateTime, 
Duration, 
Automation, 
Automation 
Duration 

Allow user to add custom tags which can be read by MOS 
devices.  

StaffIDList Prompts the user to type the username of an ENPS user or 
multiple usernames separated by commas. 

Type Fields 

Field Value 

Story Story property.  

RO Column Rundown column.  

RO Property Rundown properties field. For example the On Air 
checkbox is a Rundown Property. 
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NG Column Newsgathering Grid column 

NG Property Newsgathering Grid property 

Event Sheet Newsgathering Grid column that displays information in a 
grid. 

Contacts Contact field 

Story Header Appears at the top of stories 

Story Front Appears just below the story header 

Frequently Used Fields 
This section describes custom fields that may be useful for your site. Each field 
includes a description of how the field is used and its configuration settings in the 
Fields table. 

Rundown Column to Display MOS Objects 
Rundown and Newsgathering Grid fields can display objects from MOS devices. 
For example, directors could have a field that displays video items instead of 
MOS placeholders.  

To see a list of MOS Item References that come from the MOS ID MYVIDEOMOS 
create the following field: 

Field Value 

ID MyVideo 

Default Caption My Video 

Just Left 

Validation MOS Automation 

List Item’s MOS ID 

Type RO Column 

MOS Send  
MOS Tag objSlug 

Restart ENPS and add the column to a Rundown. When you add MOS Item 
References to the story this MOS column will extract IDs for MYVIDEOMOS and 
display them. 

Using this feature you could display any tag from the MOS Item Reference by 
specifying it in the MOS Tag field. You could also configure this field to allow the 
user to enter information in the MOS Item Reference specified by the MOS ID.  

To create a column to set the video playout channels for MYVIDEOMOS you could 
add the following entry into the list box in field definitions:  

Channel, MYVIDEOMOS 

This would present the user with a table for channel entry only for the MOS Item 
References that have MYVIDEOMOS as the MOS ID. 

You can also create Rundown field that lists MOS Item References in the Source 
Content Area, the area below the black line, in stories. To create this field, enter 
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a MOS-related field name with the letters BBL appended to it. For example, you 
could create a column MOSSlugsBBL that would only display MOS Slugs for 
items in the Source Content Area. 

Rundown Column to Send Status Messages Alerts 
ENPS can send users a Top Line Message when an item’s status changes in a 
Rundown. Complete the following steps to enable this feature: 

1. Select Fourth Folder rover → System Maintenance → Groups. Select the 
Parent/Child column for the group that will host the Rundown. 

2. The Rundown will send alerts according to the text in the Status column in 
the Rundown. By default this column contains the following options to display 
status: OK, ADDED, CHANGED, EP, ANC, HOLD, KILL and 
EMBARGOED. 

If you want to change one of these status messages you need to re-define 
the Status field in the Fields table. To do this select Fourth Folder → 
System Maintenance → [Site] Fields. Click New and create a field with the 
following options: 

Field Value 

ID DocStatus 

Default Caption Status 

Just Left 

List Options separated by the | character such as: 
NEW | DELETE | REVIEWED 

Width Column width in picas, e.g. 1000 

Validation ComboBox 

Type RO Column 

3. Navigate to the group. Select Group Folder rover → Group Maintenance 
→ Group Settings. 

In the textbox Status codes that trigger top line messages enter the status 
value that will send a Top Line Message. This value must match one of the 
values you entered in the List column; this field is case-sensitive. 

 
In the second textbox enter the full name of the user who will receive a Top 
Line Message when the Status column you specified in the top textbox is 
selected. You can enter multiple names by separating them with a semi-
colon. 
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Prevent MOS Items from Changing Approvals 
When MOS Item References update they can change story approvals in 
Rundowns. To override this behavior create a custom field for the Rundown.  

Select Fourth Folder rover → System Maintenance and select the fields for 
your enterprise. Add a field with the following parameters: 

Setting Value 

ID KeepApproveOnMOSChg 

Default Caption Prevent Approval Reset 

Justification Left 

Validation CheckBox 

Type RO Property 

Click Save then restart the NOM. Users will see a checkbox called Prevent 
Approval Reset. 
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Chapter 12 
User and Group Administration 

This chapter will show you how to administer user accounts in ENPS including 
adding or deactivating user accounts and assigning security privileges. You will 
also create user groups and assign privileges to Folder Managers to manage 
those groups. 

This section also describes how you can create Performance Monitoring and 
audit logs to keep track of how the system is being used. 

Staff Table 
To modify user accounts select Fourth Folder rover → System Maintenance 
→ Staff.  To add a new user click New and then enter the following information. 

Field Description 

ID  User’s Windows login name. 

Program User’s home group. This is the group that opens when the 
user clicks on the Third Folder. 

Active  This box must be checked for the user to be able to use 
ENPS. If a user is no longer working at your site uncheck 
this box.  
Important: Do not delete the user from the system since 
any templates or stories created by that user will not be 
attributed to any owner, and this can cause instability in the 
system. 

Supervisor Make the user a System Administrator. 

Surname User’s last name. 

Given Name User’s first name. 

BasysID Not used. 

Department Description of the user’s department and/or position. 

Notes Notes about this user. 

ServerManager User may add, delete, and edit Read-ins on the server. 

SNAPfeed User may access SNAPfeed functionality. 

Physical 
Location 

User’s desk location or office number. 

Internet 
Accounts 

Authorize the user’s account for sending messages via 
Twitter. Refer to “Enabling Clients to ” on page 106 for more 
information. 
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Blocked Clients If you are using ENPS 
6.00.0048 or later you can 
control users’ access to 
specific mobile clients. By 
default all users can access 
all ENPS clients. To block a 
user from using a specific 
client open the ENPS client on the Primary Server and 
select Forth Folder Rover → System Maintenance → 
Staff. In the Blocked Clients column you can select the 
client type to block: Desktop, Outlook, Smartphone, WAP or 
Web.  

Changing a User’s ID 
If a user’s legal name changes you must complete the following steps to transfer 
the user’s personal folder contents and personal settings to a new account ID:  

1.  Create a new Windows domain account for the user. 

2. Open the Staff table described above and create an account for the new 
Windows user ID. Locate the user’s old Windows ID and uncheck the Active 
checkbox. 

3. On the Primary Server open the ENPS WORK drive and open the folder with 
the Primary Server name. Locate the folder with user’s old user ID preceded 
by “U_” such as  U_JOHNDOE. Rename the folder to reflect the user’s new 
Windows username.  

4.  From the folder with the name of your Primary Server open the S_SUPPORT  
sub-folder and repeat the previous step, renaming the user’s old U_ folder to 
the new Windows user ID. 

The user may now use ENPS with the new Windows username. 

Groups 
Groups are used in parallel to how your enterprise works. At sites with a small 
number of users this may be as simple as one group for News and another for 
the Desk; large enterprises may have dozens or even hundreds of groups.  

The following types of items can be customized for each group: 

• Group Searches 
• Macros 
• Templates for CGs, Rundowns, and Newsgathering Grids 
• Report layouts for stories and Rundowns  

To create a new group, select Fourth Folder rover → System Maintenance → 
Groups. Click New to add groups/programs to the server.  

Parameter Definition 

ID Unique identifier. Spaces are not allowed. 

Description Group name that will appear to users. 

Server Local or remote Primary Server that will host the 
group.  
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Type Configure the folder group as an internal or external 
publishing folder. For information on how to configure 
a group for publishing refer to “Groups” on page 91. 

Newsgathering Do not use. 

Private Do not use. 

Parent/Child If selected, Group Managers will be able to set the 
Status column in Rundowns so that when the status 
has changed, certain users will be notified if a change 
is made in a Rundown. 

Gateway Queue Used by sites with legacy system gateways. 

WarnApproved Display a warning message if a user attempts to edit 
an approved story.  

ForceEnglish Force the keyboard layout to English in text entry 
fields if another language’s keyboard layout is in use. 
This option applies to text entry fields in story titles, 
Rundown property fields, Rundown cells, and input 
windows such as the prompt to save changes.  
This setting also takes effect during macro playback. 
The original keyboard layout will be restored when 
macro playback is done. 

Allowed Wires Semicolon-delimited list of wire Provider codes as 
defined in \NWP\NWP.INI on the ENPS WORK drive. 
These will be the only wires available to the group. If 
this column is left blank, all Providers will be allowed. 
You may enter up to 255 characters in this field. 

Enable CTOS By default, Rundowns and Newsgathering Grids are 
not sent to the Central Text Object Server. 
By selecting this box, Rundowns and Newsgathering 
Grids can be sent to the CTOS but Group Managers 
will also have to select the Allow CTOS checkbox.  
It is recommended that only important Rundowns and 
Newsgathering Grids are sent to the CTOS. Enabling 
this setting does not change local archive behavior. 
For more information on the CTOS refer to “Central 
Server and CTOS” on page 11. 

Election Create and view election items. Refer to ENPS Stats 
Guide for more information. 

AutoCreate Enable the Group Manager to set the days of the 
week on which Rundowns will be automatically 
created.  

WriteEnable Archives Allow the group to write to archives. 

WarnRODelete Display a warning when a user tries to delete a 
Rundown or a Newsgathering Grid. 
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MOS Redirection Redirect the MOS messages for all of the Rundowns 
that are dragged into the Group by specifying the 
device to which MOS messages should be sent. For 
example: 
<family>=<family>.<machine>.<location>. 
<enterprise>.<mos> 

To redirect to multiple devices separate entries with a 
semicolon. For example: 

SNAPFEEDDC=SNAPFEED.WASHINGTON.AP.MOS; 
SNAPFEEDNY=SNAPFEED.NEWYORK.AP.MOS 

MOS Include Double-click to display a list of current MOS devices 
and ActiveX controls. Select the checkboxes of the 
MOS devices and ActiveX controls that you want to be 
visible from the group’s Media icon rover.  

MOS Exclude Double-click to display a list of current MOS devices 
and ActiveX controls. Select the checkboxes of the 
MOS devices and ActiveX controls that you do not 
want to be visible from the group’s Media icon rover. 

Office Document 
Path 

Network folder where users can view non-ENPS 
documents and import selected files into ENPS as 
new stories. Files with extensions TXT, DOC and RTF 
can be imported into ENPS as new stories. Files with 
other extensions, such as PDF, DOCX, XLS, XLSX, 
etc., can be opened but not imported. To use this 
setting you must first enable the EnableOfficeDocs 
setting in the Global Configuration Options and restart 
the ENPS NOM.  
For a folder where this is enabled a new subfolder 
called Office Documents will appear on the folder's 
rover menu. Selecting this entry lists the files stored in 
the network location. Double-clicking a file will open it 
in the appropriate application such as Microsoft Word,  
Notepad, etc. For TXT, RTF, and DOC files you can 
click once to highlight a file then choose Import as 
story from the List Window rover menu to import the 
file contents as a new ENPS story. Generally this 
feature preserves Word formatting but some 
information such as graphics may not be imported.  
If a document is dragged to the ENPS trash can it will 
also be deleted from the network location. 

Default Security Default privilege level for a group. All users not 
specifically assigned a privilege level in a folder will 
assume the folder’s default privilege level. If no default 
level is assigned to a folder then the default level of 
Viewer will be used. 

Physical Location Internal note for the location of the group’s users. 

After you set the group options click Save. Exit the ENPS client and restart it to 
see the new group. 
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Security Roles 
Security roles define privileges for what users with different responsibilities can 
view and modify in ENPS. A number of these roles, such as Assistant and 
Director, come pre-defined in ENPS. You can modify the pre-defined roles and 
you can create new roles to fit the needs of your organization. 

Group Managers can assign these settings to common roles in their groups such 
as Producer, Director or Production Assistant. Security levels can also vary from 
one group to another: for example, a user may be an Editor in one group and a 
Producer in another. Group Managers may perform additional fine-tuning for how 
these roles will act in their groups. Refer to the ENPS Advanced User’s Guide for 
more information. 

To view security roles select Fourth Folder rover → System Maintenance → 
Security. Many of the options offer the following four levels of security: 

Security Level Privileges 

0 - None  No access to the item. 

1- Read Approved  Read approved items only; cannot change or delete 
items. 

2 - Read Any  Read approved and unapproved items; cannot change or 
delete items. 

3 - Read/Write  Read, create, delete and change items. 

To create a new security level click New. The table below describes each of 
options you can set for the security profiles: 

Field Description 

ID Unique identifier. Spaces are not allowed. 

Description Name of the security role that will be seen by Group 
Managers. 

Running Order  Add, delete and move stories in a Rundown. Able to 
delete items from a Newsgathering Grid. 

Script Create and write stories outside of Rundowns and edit 
story properties. 

RO Stories Edit Rundown stories and their properties, stories outside 
of Rundowns and their properties, Rundown fields and 
story slugs.  

Approve Enter final approval for a story, float stories, freeze page 
numbers, create and lock Rundowns, use on-air timing 
functions, choose MOS Story Send devices and set the 
Rundown’s MOS Control Active property. 

Staff View and modify staff privileges. 

NG Grids Create and move new Newsgathering Grid items. 

NG Items Create new Newsgathering Grid items, edit existing 
Newsgathering items and their properties such as grid 
fields, story slug, forms and Story Log data. 
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NG Approve Select MOS Story Send devices and make a 
Newsgathering Grid MOS Control Active. 

Maint View and modify group templates, macros, report 
layouts, and saved Searches. Can also create standard 
Rundown and Newsgathering Grid views for other users. 

Election Create races, edit races and enter election results into 
ENPS Stats. 

Write Archives Write to archives in Rundowns and Newsgathering Grids. 

Approval 
Extensions 

Specifies which Approval Extension fields users with this 
level of access can select/deselect. Use of this feature 
requires enabling EnforceSecurityLevels in the 
Global Configuration Options. Refer to page 84 for more 
information. 

If the Primary Server you are working on is not your organization’s Central Server 
open NOM Maintenance at select Window → Synchronization. Click Sync 
Now. Then open the NOM and select File → Reload Global tables. 

Pre-Set Roles 
The following table provides a summary of each of the security profiles and 
description of each one: 

Role Description 

Guest Create stories outside of Rundowns only. 

Viewer  

Create stories outside of Rundowns.  
Read Rundown items but cannot change or delete items 
in Rundowns or Newsgathering Grids.  
This is the default setting for all users until another 
setting is specified. 

Superviewer Read items in Rundowns and Newsgathering Grids but 
unable to change them.  

Intern 
Create and modify stories outside of Rundowns but 
cannot modify items in Rundowns or Newsgathering 
Grids. 

Desk Ideas 
Modify stories outside of Rundowns but not stories listed 
in a Rundown. Create and modify items in 
Newsgathering Grids.  

Writer Modify stories in Rundowns. Can create and modify 
items in Newsgathering Grids. 

Desk 
Create Rundowns and Newsgathering Grids; read and 
modify any story in either. Approve items in 
Newsgathering Grids but not in Rundowns. 

Assistant 
Read any loose stories but can only modify stories in a 
Rundown; can read Newsgathering Grid items but 
cannot modify them. 

CGMaint 
Modify stories in a Rundown but cannot modify 
Newsgathering Grid items; can read any items in both, 
provides folder maintenance privileges like creating 
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report templates. 

Director 
Cannot create Rundowns or Newsgathering Grids, can 
read any item in both but can only modify items in a 
Newsgathering Grid.  

Producer Create Rundowns and Newsgathering Grids, modify any 
items in either, and approve items in either one. 

Manager 

Highest group security level with all of the Producer 
privileges plus folder maintenance options like modifying 
report templates, and ability to modify staff privileges 
within the group. Only a small number of users in the 
group should have this privilege level. This level is 
required to complete many of the tasks described in this 
guide. 

Default Settings Profiles 
Once you have completed the instructions above to create or modify the security 
roles at your site you can set the default settings for those security levels. You 
can use Default Settings Profiles to pre-set the personal, print, macro and Search 
settings for those profiles. If you want to select certain settings for those users, 
Default Settings Profiles saves you the work of defining a number of settings on a 
user-by-user basis. Users can still change their settings to suit their individual 
needs. 

Group Managers can also use this feature at group level by following the 
instructions in the ENPS Advanced User’s Guide.  

Complete the following settings to create and apply Default Settings Profiles: 

1. To enable the site-wide User Profiles enable the settings DefSettings in 
ENPS.INI and the Global Configuration option CENTRALPRIV, then restart 
the ENPS client.  

2.  To modify user profiles select Fourth Folder rover → Default Settings 
Profiles.  

 
3. To set your preferences highlight a profile such as "Guest" then click Select. 

Make any changes to the preferences, including fonts, fourth folder choice, 
default ActiveX control, macros, forward searches, or regular searches. Click 
Save when you are finished making your selections. 
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4.  Click Save then restart ENPS for your changes to take effect. 

Security Profiles 
Once you have defined security roles and created groups for your site you may 
want to define Security Profiles which define different security roles for different 
groups such as Guest in one group, Viewer in another group and so on. 

Complete the following steps to define a Security Profile: 

1.  Select Fourth Folder rover → Security Profiles. 

 
2.  To start a new profile click in the Profile column and click New. The new 

entry will be displayed at the bottom of the column. Enter a Profile name and 
Server name. The first  Program entry should reflect the user’s most often-
used, or “home”, group. Then in the Security column select the Security role 
that the user should have in that group. 

To define another group for the profile click in the Server column and click 
New. Once you have defined all of the security roles for the appropriate 
groups click Save to store your changes. 

3. To apply a security profile to a user select Fourth Folder rover → System 
Maintenance → Staff. Select a user name then click Show security. 

 
The Profile column lists the Security Profiles that were defined in the Security 
Profiles screen. To add an additional Profile click New. When you select a 
Profile, Program and Security entries will be filled in automatically. 

You can also create an Ad-hoc entry to manually define the Security role that 
you want to define for a particular Program group.  

Verify Clients with MAC Addresses 
You may opt to maintain a list of MAC addresses for workstations and devices 
which are eligible to connect to ENPS. This provides an extra layer of security 
apart from the authentication through a Windows username and password.  

You can use two methods to build the MAC address table: 

• Build your MAC address list automatically by first installing ENPS on all of 
the workstations and devices at your site. Each time an ENPS client 
connects to the Primary Server the G_MACS.NEW  file is updated with the 
MAC address of that workstation or device. This file is located in 
\COMMON\G_SUPPORT on the ENPS WORK drive. To use the MAC 
addresses stored in this file replace the contents of the file G_MACS with 
G_MACS.NEW.  

• You can manually create an entry for each entry in the MAC address table 
described below. 
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Regardless of which method you choose, remember that any time a network card 
is added or removed from a workstation you must manually change that entry in 
the MAC address table. If a workstation or device is not listed in the MAC 
Address table it will be denied access to ENPS. 

To view the MAC address table open the ENPS client. Open Fourth Folder 
rover → System Maintenance → MAC Addresses.  

Property Definition 

ID 
This is a required field. 

MAC Address of the network adapter, e.g. 
000123A2BCDE. 
To obtain a workstation’s MAC address click on 
the ENPS logo in the upper left-hand corner of the 
ENPS client on that workstation or open the 
command prompt and enter IPCONFIG -ALL 

Server 
This is a required field. 

Primary or Server name such as APENPS01.  
 

AcctCode 
This is a required field. 

Internal accounting code. If you are not using this 
field enter 0001.  
 

Active Checkbox to indicate whether this network 
address has access to ENPS. If this box is not 
checked the workstation is explicitly prohibited 
from accessing ENPS. 

Free, Property ID, 
Location, Charge Code, 
Department, Notes 

Fields used to store descriptive information about 
the device or workstation. 

Monitor Monitor information on client workstation. To 
enable monitoring for the selected MAC address. 
Make sure the Active box is checked. You will 
have to enter something in the "AcctCode" box 
before you will be allowed to save this file. This 
can be anything.  
Restart the NOM on the ENPS server. Use a text 
editor such as Notepad to open C:\DOCUMENTS 
AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI. In the [ENPS] section 
add the setting CtrlAlt=1 then restart the client 
on the designated workstation. Press 
Ctrl+Alt+M to open a window displaying 
statistics with an option to print a summary. 
date/time, action, details, and elapsed time (in 
seconds, accurate to .001 seconds) are shown. 
The following functions are monitored: 
• Logins 
• Opening a story 
• Opening an agency news wire item 
• Displaying an audio/video object 
• Opening a folder list 
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• Searches 
• Updating a Rundown 
• Messaging 
The log will be cleared each time the ENPS client 
is restarted. 

StartDate Date when access begins. 

Private Channels Semicolon delimited list of ENPS servers for 
which the client should open private channels. 
Refer to “Private Channels” on page 112  for 
instructions on how to set up private channels. 

Expires Date on which access will be terminated. 
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Chapter 13 
Client Features 

This section will show you how to set up important features in ENPS including: 

• My ENPS provides users with an overview of wires and local content. 
• Web Searches extends searches to the Web. 
• News Ticker creates a scrolling ticker from the Rundown. 
• Follow Me Messaging lets users forward their top-line messages to a cell 

phone or wireless device while they are away from their desk. 

My ENPS 
My ENPS gives users an overview of wire stories and local content by adding an 
icon to the ENPS desktop. Refer to the ENPS Basic User’s Guide for more 
information. To enable My ENPS complete the following steps: 

1.  Select Fourth Folder rover  → System Maintenance → Global 
Configuration Options. Add the setting MyENPS=1. 

2.  Restart the ENPS client. 

3.  To allow My ENPS to launch automatically on startup you need to enable the 
Top Story Server. Use a text editor such as Notepad to open 
\NOM\NOM.INI on the ENPS WORK drive. In the [Watch] section add the 
line TopStories=1. 

4.  Open the NWP. Select the Configuration window and select the General tab. 
Check Process Top Stories. The NOM send updates to the Top Story Server 
through direct UDP packets on port 11800. This port can be changed by 
adding the RemotePortTSS setting to the [NOM] section of the 
\NOM\NOM.INI on the ENPS WORK drive.  

5. Complete this step for each wire you want to appear in user’s My ENPS Top 
Stories list. Select the wire from the Window menu. At the bottom of the 
window uncheck the Active checkbox if it is selected, select the Process top 
stories checkbox then check the Active checkbox to re-activate the wire.  

6.  Restart the NOM. 

Excluding Categories 
It is possible to exclude certain categories of stories from being sent to the Top 
Stories Server, even if the news wire is configured for Top Stories Server 
processing. To set the exclusion, add the following entry to \NWP\NWP.INI on 
the ENPS WORK drive: 

[TOPSTORIES] 
ExcludedCategories=1;9;10;13;91;92;101;102;104 

with the numbers representing NWP category numbers. Stories you might 
consider not sending to Top Story Server would be routine weather stories, 
lottery results or non-news advisories. 
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Web Searches 
Web Searches enable users to extend the capability of ENPS Search to the 
Internet. To set up these features, select Fourth Folder rover → System 
Maintenance → Web Search Engines. 

 
A URL you use must allow you to enter your query text at the end of the string. 
For example, to create a Yahoo search string you would enter: 

http://search.yahoo.com/search?ei=UTF-8&fr=fp-tab-web-
t&n=20&fl=0&x=wrt&p= 

You can test a URL to see if it will works as a Web Search. Paste the URL into 
your Web browser then enter search terms at the end of the string. If the Website 
is able to process your query successfully the query string will work in ENPS. 

News Tickers 
Users create a scrolling news ticker directly from an ENPS Rundown if your site 
uses one of the following CGs: 

• Pinnacle's Deko family 
• Chyron Codi 
• Chyron iNFiNiT! family including MAX! and MAXINE! with Chyron serial 

crawl enabled 

To use this functionality your site must subscribe to the AP Network News 
Transfer Protocol (NNTP) headlines feed. Complete the following steps to enable 
Rundowns to generate news tickers.  

1. On the ENPS WORK drive use a text editor such as Notepad to open \NWP\ 
NWP.INI. Add the line NNTP=1 to the [NWP] section. 

2.  Restart the NWP. When it opens you will see the NNTP Ticker Feed window. 
You may enter a news server name or IP address, a username and 
password. You can also select whether the target server requires a logon.  
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3.  Select the Active checkbox. The application will download a list of available 

news groups such as ap.online.headlines.us. Select the categories 
you want to add then click the Add button to add them to the category list. 
You may also add a shorter, easier to recognize name for each category. 

4.  Once the NWP configuration is complete, click Active, and the application will 
begin downloading headline content. 

5.  Use a text editor such as Notepad to open \NOM\NOM.INI on the ENPS 
WORK drive and add the setting RefreshMax=X to the [TopStories] 
section where X is the number of stories at which the TSS will stop refreshing 
the Top Stories List (the default is 500). For example, if you set 
RefreshMax=25 and the total number of stories is 26, the TSS will not 
refresh the list. If you do not want to refresh the list at all, set 
RefreshMax=1. 

6.  Because tickers use crawls which are different than normal ENPS CG 
templates, you must use a text editor such as Notepad to enter the CG 
information directly into the C:\DOCUMENTS AND SETTINGS\ALL 
USERS\APPLICATION DATA\ENPS\ENPS.INI on the ENPS client.  

Add the following section to the ENPS.INI: 

[TickerCG] 
;for CG output (if CG=1 in ENPS section above) 
;for Chyron serial crawl 
;CG=Infinit!;NTSC;COM1:9600,n,8,1;0; 
;for Pinnacle Deko Intelligent Interface commands 
;CG=Deko;NTSC;COM1:9600,n,8,1;0;5000 
;for Chyron Codi commands 
;CG=Codi;NTSC;COM3:9600,n,8,1;1000 
Timeout=5000 
Test=0 
Retries=1 
Trace=0 
DateFormat=h:nn am/pm 
 
;Pinnacle Deko specific 
;CG Directories 
;CGCurrentDir=C:\DEKO 
;CG BasePage 
;BasePage=C:\DEKO\CRAWL.DKO 
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;Chyron Codi specific 
CodiPosition=400 
CodiSpeed=2 
CodiFont=1 
CodiFontColor=1 
CodiBackgroundTopColor=200,200,200 
CodiBackgroundBottomColor=50,50,50 
CodiBackgroundTopPosition=200 
CodiBackgroundBottomPosition=256 

Locate the section of lines for the CG you are using and remove the semi-colon 
from the beginning of each line that contains an “=” to make that line active. 
Make sure that all of the settings are correct for your CG, including BasePage 
and CGCurrentDir for Pinnacle Deko and communications parameters such as 
baud rates, stop bits, and parity. Refer to “Character Generators” on page 139 for 
more information on how these parameters are formatted.  

Users should refer to ENPS Advanced User’s Guide for instructions on how to 
create news tickers. 

Follow-Me Messaging 
Follow-Me Messaging gives users the ability to forward their incoming top-line 
messages to a cell phone or wireless device while they are away from their desk.  

Part 1: Set up the Server 
The Follow-Me Messaging server must be a different machine than the ENPS 
server. You must install the Follow-Me server application on a POP mail server 
machine, running Windows 2003 Server. Install all Windows Updates and 
security patches before you begin the installation process. 

1.  Download the latest the latest version of the .NET Framework Redistributable 
Package from  http://msdn.microsoft.com/netframework/ 
downloads. Install the .NET Framework on the server that will host the 
Messaging Gateway. Reboot the machine when the installation is complete. 

2.  Check to see if the SMTP service is installed. To do this open the Control 
Panel and select Add/Remove Programs. On the left hand side of the 
window, click Add/Remove Windows Components. Click Application 
Server and then click Details. Click Internet Information Services (IIS) and 
then click Details. The SMTP Service checkbox should be selected. Also 
make sure ASP.net is installed 

3.  Open Computer Management and verify that ASP.net State Service is 
running set to startup automatically. Expand the menu below Services and 
Applications, click on Services and then double-click ASP.net State 
Service. The dropdown box for Startup type should be set to “Automatic.” 

 Expand the menu underneath Services and Applications. Check to make 
sure that Default SMTP Virtual Server is selected under Internet Information 
Services. If you want to make sure your SMTP server is listening, go to the 
command line and enter netstat –an. At the beginning of list that appears 
you should see 0.0.0.0:25 with a status of “listening”.”  

4.  Download and install MDAC v2.8. This package can be found at the 
Microsoft download site http://www.microsoft.com/downloads. 

5. Make sure ASP is installed. It is also recommended that you verify ASP is 
running in Computer Management.  

http://www.microsoft.com/downloads
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6.  Download and install ENPSMsgGatewayInstaller.msi. If you need 
access to the ENPS download page send an e-mail to info@enps.com. 

 The installation program will prompt you for the following information:  

• Number of hours the Messaging Gateway should wait for reply from an 
e-mail. If an email message does not arrive within this number of hours 
after it was sent then it will be purged. 

• Domain of the e-mail address used for your Messaging Gateway. Enter 
the domain name of the ENPS Messaging Gateway e-mail address, e.g. 
ENPSMsgGateway.com. 

• ENPS Central Server. If you are only using one Primary Server that is 
your Central Server. 

7. Reboot when you are finished running the installer. 

8.  From the Control Panel open Administrative Tools and click Services. 
Locate the ENPS Messaging Gateway and make sure its status is set to 
Started.  

9.  From the \NOM directory, run MAINT.EXE and synchronize with the Central 
Server, or Primary Server, depending on your network configuration. 

Part 2: Configuration Settings  
1.  Start ENPS. Select Fourth Folder rover → System Maintenance → Global 

Configuration Options. Add the value MessageGateway=1.  

2.  Select Fourth Folder rover → System Maintenance → MOS 
Configuration. Click New and create an entry with the ID 
ENPSMsgGateway.MOS and the IP address for the Applications Server 
where the MsgGateway resides. The ID is case-sensitive. 

Restart the NOM and the ENPS client for changes to take effect. 

3.  Select Fourth Folder rover → System Maintenance → Messaging 
Gateway Devices. This table lets you configure a list of mobile device 
names and descriptions that will be supported by your enterprise. Your table 
may have the following settings:  

Device Description 

MOB Mobile phone 

PDA Personal digital assistant 

4.  For ENPS top line messages to be properly interpreted by the devices you 
have configured, ENPS ships with XSL transforms that converts a user 
message to a format that is readable by the device. Select Fourth Folder 
rover → System Maintenance → Messaging Gateway Transforms. Select 
the ID of the device you want to configure, the Message Type (Assignment, 
Contact, Story, or Topline) and then the name of the transform you wish to 
use: 

Mobile Phone Transforms Description 

Assignments mobAssignments.xsl 

Contacts mobContact.xsl 
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Stories mobScript.xsl 

Topline mobTopLine.xsl 

PDA Transforms Description 

Assignments pdaAssignments.xsl 

Contacts pdaContact.xsl 

Stories pdaScript.xsl 

Topline pdaTopLine.xsl 

All of the ENPS fields called in standard transforms are marked as Rundown 
Story Send fields in the ENPS Fields. To check this, select Fourth Folder 
Rover → System Maintenance → {Enterprise} Fields. If additional fields 
are required, they must be added in this screen and they must be designated 
for MOS Story Send output. Note that custom transforms may be required to 
add these fields to the standard output provided by AP, and writing and 
support of those transforms is the responsibility of the news organization.  

5.  Select Fourth Folder rover → System Maintenance → Staff and highlight 
a user name. Click the Show devices button. From this screen you can select 
a device and its unique address for messages to get forwarded. This can be 
an e-mail address or a mobile phone’s unique identifying text messaging 
address, such as John_Smith@555.1212. ENPS users will be able to 
configure which devices to send messages, and the time ranges in which to 
send them to those devices. 

Part 3: Send a Test Message to a Mobile Device 
Once you have configured a user’s Follow-Me messaging settings, make sure 
that user is not logged in. Then, in the ENPS client, select Mail rover → Send 
and send a Top Line Message to that user. If the message is transmitted to that 
user’s device, you have properly configured Follow-Me messaging.  

Launch External Applications 
Create a workstation-specific.INI file with your user ID such as JOHNDOE.INI 
and place it in the Windows directory. To launch other applications, add the 
following lines to the .INI, replacing the paths listed below with paths to the 
desired applications. This will determine which external applications may be 
launched from within the ENPS client. 

The text to the left of each equal sign appears to the user from Personal Folder 
rover, and the executable command follows to the right: 

[Shell] 
Word="C:\PROGRAM FILES\OFFICE\WINWORD\WINWORD.EXE" 
Excel="C:\PROGRAM FILES\OFFICE\EXCEL\EXCEL.EXE" 
Calculator="C:\WINDOWS\SYSTEM32\CALC.EXE" 

The macro to launch an application: %2o{Right}~ 

This will launch the first application in your list,  WINWORD.EXE. To launch the 
second application in the list, add {DOWN 1} before the ~ character, such as: 
%2o{Right}{DOWN 1}~ To launch the third application, add {DOWN 2}, and so 
on. 
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Enabling Clients to Publish to Social Media 
ENPS clients can be permissioned to publish updates to social media. This 
functionality is enabled individually by workstation by completing the steps below. 
Users should refer to the ENPS Basic User’s Guide for information on how to use 
social media features. 

1. Download the Social Media installation files from the ENPS download site. If 
you need a link for the ENPS download site send a request to 
info@enps.com with your name and the name of your organization. 

2. Copy the ENPSIO executable to the client workstation where you want to 
install the functionality. Make sure ENPS is closed on the client workstation 
then run the .EXE. 

3. On the Primary Server open the ENPS client and select Fourth folder rover 
→ System Maintenance → Internet Output Accounts.  

 

Enter the details for the social media accounts as follows: 

Field Description 

Service ID Login name for the social media account. If there 
are spaces or punctuation in the account name, 
omit them here. 

Service Type TWITTER or FACEBOOK in upper-case. 

Username For Twitter accounts enter the user ID for the 
account.  
For Facebook accounts, enter the name of the page 
including any spaces that might exist in the name, 
e.g. News Watch 17. 

Password Leave this entry blank. You will get a  security token 
to enter in this field once you complete the  
authentication process. 

Log Server ENPS server to which the account's history logs will 
be written. This is usually the Primary Server. 

Repeat these steps for each account you wish to enable, then click Save to 
apply your changes. Shut down your ENPS client. 
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4. If the Primary Server you are working on is not your organization’s Central 
Server you must synchronize the servers. Open NOM Maintenance and 
select Window → Synchronization. Click Sync Now. 

5.  To authorize  ENPS users to publish to social media, re-launch the ENPS 
client and select Fourth folder rover → System Maintenance → Staff. In 
the Internet Accounts column, grant each user publishing rights to the 
appropriate accounts. The first time you perform this step you must also 
enable access for your System Administrator account. Click Save to apply 
your changes.  

6. If the Primary Server you are working on is not your organization’s Central 
Server you need to synchronize the servers again. Open NOM Maintenance 
and select Window → Synchronization. Click Sync Now. 

7. Restart the ENPS client. 

Authorizing ENPS to Publish to Twitter 
a. Select Messaging rover → Social Media. Click on a Twitter account name, 

enter an update into the message box, and click Send. Note that this update 
will be published to your Twitter feed. An authorization window will appear 
with a Twitter URL in it.  

  
b. Copy the URL and paste it into your browser. Log in to Twitter and confirm 

that you want to give ENPS access to your Twitter account. Twitter will then 
provide a pass code. Paste that code into the field that displays the 
authentication URL.  

c. A second window will appear with a security token. Copy the token. 

d. Select  Fourth folder rover → System Maintenance → Internet Output 
Accounts. Paste the token in the Account Password field for the 
appropriate Service ID. You only need to perform this authorization once for 
each Twitter account, even if the account’s password changes. 

Authorizing ENPS to Publish to Facebook 
a Restart the ENPS client on the Primary Server and select Messaging → 

Social Media. Click on a  Facebook page, enter an update into the Status 
box, and click Share. Note that this update will be published to the Facebook 
page. 

b. A Facebook login page will appear in the lower-half of the control; you may 
need to display the control full-screen within ENPS to see it. Log in using an 
account authorized to manage your Facebook page and confirm that you 
want to give your ENPS system authorization to publish to your page.  

c. A pop-up window will appear with an authorization token. Copy the token to 
the clipboard. 
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d. Select Fourth folder rover → System Maintenance → Internet Output 
Accounts and paste the token into the Password field. You only need to 
perform this authorization once for each Facebook account, even if the 
account’s password changes. Click Save and close the ENPS client. 

7.  Once authorization is complete once again open NOM Maintenance. Select 
Window → Synchronization and click Sync Now. Restart both the NOM 
and NOM Maintenance programs. 

8. If your site does not use English as its primary language, the text labels in 
the social media  window can be localized in the ENPS language file. To 
modify these settings select Fourth Folder rover → System Maintenance 
→ Language Resources. Select the proper language file for your clients 
and make any changes necessary to the Internet Output section. 

Social Media Activity and Error Logs 
• All social media updates sent via ENPS are stored on the server specified in 

the Internet Output Accounts table for each individual account. These logs 
can be found in the \COMMON\INTERNETOUT folder on the server’s ENPS 
WORK drive and can also be viewed by selecting a particular account within 
the social media control in the ENPS client 

• If Facebook returns an error during the user’s upload process it will be 
logged to the file SOCIALMEDIA.LOG on the client workstation. In Windows 
XP this file is located in C:\DOCUMENTS AND SETTINGS\ALL 
USERS\ENPS and in Windows 7 it can be found in 
C:\PROGRAMDATA\ENPS. 

• Two Global Configuration Settings, InternetOutLogFiles and 
InternetOutLogSize, control the number and size of the log files. Refer 
to “Global Configuration Options” on page 44 for more information about 
these settings. 
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Chapter 14 
Network Settings 

This section will show you how to configure networking options for the ENPS 
servers to communicate with client workstations.  

ENPS requires a TCP/IP network to links all of the clients and servers. Client-
server requests are carried via TCP streams using User Datagram Protocol 
(UDP). The NOM uses a UDP application-layer protocol to update client records. 
ENPS communicate with the NOM via an application-layer protocol on top of 
TCP/IP and UDP to communicate with the NOM. 

Port Assignments 
ENPS uses a range of ports beginning with 10501 for TCP and/or UDP 
messaging. The following ports are used by ENPS: 

Port Number Purpose 

10505/10506 Client TCP requests 

10507/10508 NOM UDP datagrams 

10509 Chat 

10510 Private channel TCP 

10511  NWP-to-NWP TCP  

10512/10513/10517 NWP UDP datagrams  

10540, 10541, 10542 MOS communication 

10543-10549 Reserved for future MOS use 

The NOM sets the remote port to 10507 and then binds 10508. The client sets 
local port to 10508 and binds 10507. 

The NWP sets remote port to 10512 or 10517 and binds 10513. The client sets 
local port to 10513 and binds 10512. The ENPS client must do a directory scan 
on the read-only \ENPS share on all ENPS servers. If the client has permission 
to read files on the \ENPS share then they have domain authentication. The 
client makes a request via TCP port 139 to the ENPS servers. 

Multicasting 
By default, the ENPS server uses UDP broadcasts to communicate updates to 
client workstations. Multicasting is an alternative method of distributing data 
updates. Multicasting makes communication between the server and clients 
more efficient by using the network infrastructure to deliver updates only to those 
client workstations that need them, not to every workstation in a particular 
subnet. Multicasting eliminates the need for reflectors to individual subnets. 

As an added benefit, dial-up and VPN users can now receive dynamic updates 
from both the NOM and the NWP provided the dial-up or VPN system supports 
multicasting.  

To enable multicasting complete the following steps:  
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1.  Make sure that all of the hardware on the network between the ENPS server 
and the client workstations is compatible with multicasting.  

2.  Open the server’s NOM.INI. In the [TCPIP] section verify the setting 
Broadcast=1.  

3.  Open the server’s NWP.INI. In the [NWP] section verify the setting 
Broadcast=1.  

4.  Set the Multicast and MulticastAlsoBroadcast Global Configuration 
Options. Refer to “Global Configuration Options” on page 44 for a description 
of these settings. 

5.  Open the Servers table by selecting Fourth Folder rover → System 
Maintenance → Servers. Enter the Multicast IP and Multicast Port values 
for each server. 

6.  Restart the NOM of the Central Server. This will assign the new 
MulticastIP and MulticastPort values to all of the servers across the 
enterprise as in the example below:  

Server Name MulticastIP MulticastPort 

Server 1 239.0.0.1 10601 

Server 2  239.0.0.2 10602 

Server 3 239.0.0.3 10603 

Although these values are inserted automatically you can use the Global 
Configuration Options to set different values for individual servers.  

Reflectors 
If your site does not use multicasting and your ENPS server is on a different 
subnet than its client workstations you will need to use reflectors to relay 
information from the server to the client workstations. Reflectors allow users to 
view real-time updates to wires, Rundowns, Newsgathering Grids and top-line 
messages. 

Typically ENPS servers support at least 10 reflectors. Setting up too many 
reflectors will cause a delay in real-time updates reaching client workstations. 
The maximum number of reflectors that can be configured on a server varies with 
the server’s processing speed and workload.  

You have two options for setting up reflectors: configure your site’s router for 
directed broadcasts or set up a standalone workstation to run REFLECT.EXE. 

Option 1: Configure Your Router for Directed Broadcasts 
You can configure your site’s router to allow directed broadcasts to another 
network. This is the preferred method for setting up reflectors.  

1.  The following instructions show you how to set up directed broadcasting on 
the Cisco IOS. These instructions use Ethernet interface 0 as the LAN 
interface; you should adjust these steps to fit your site’s configuration. 

conf t  
int e0  
ip directed-broadcast  
end  
save 



The Associated Press 111 
 

2. By default, ENPS sends a maximum socket packet size of 8192. If your site’s 
router requires a different setting use a text editor such as Notepad to open 
\NWP\NWP.INI on your ENPS Work Drive and change the 
MaxSocketPacket setting to the correct value. This value should be set to 
1024 when the  Unicode setting is enabled in \NWP\NWP.INI on the ENPS 
Work Drive. 

3. Use a text editor such as Notepad to open \NOM\NOM.INI on the ENPS 
WORK drive. Enter the reflector’s broadcast IP address on its own line to the 
[Reflectors] section. If the subnet’s IP begins with 192.168.1.1 the 
broadcast IP is 192.168.1.255.  

Option 2: Use a Standalone Workstation as a Reflector 
The workstation you designate can only be used as a reflector but it is not 
necessary to use server class hardware. To configure the workstation to be a 
reflector complete the following steps: 

1. Set up a Windows workstation with a TCP/IP connection. The workstation 
must have static IP address. Log in with an Administrator account. 

2. Download SETUPREF.EXE from the ENPS download site. If you need a link 
for the ENPS download site send a request to info@enps.com with your 
name and the name of your organization. When you run the installer it will 
add the files REFLECT.EXE and REFLECT.INI to your C:\Program 
Files\ENPS folder.  

Run REFLECT.EXE to start the reflector.  

3. By default, all data will be reflected. If you want to specify which servers will 
have their data reflected by you can use the Servers setting in the 
[Reflect] section of REFLECT.INI as follows: 

[Reflect] 
Servers=ENPSDESK01;ENPSNEWS01 

In this example only traffic received from servers ENPSDESK01 and 
ENPSNEWS01 will be reflected.  

4.  Use a text editor such as Notepad to open \NOM\NOM.INI on the ENPS 
WORK drive. Add the reflector’s IP addresses to the [Reflectors] section, 
for example: 

[Reflectors] 
; Standalone reflector PC in Building A 
10.141.8.15 
; ENPS client as a UDP reflector 
132.185.158.136 

5.  Repeat the previous step with the \NWP\NWP.INI on the ENPS WORK drive. 

To prevent message duplication only one reflector should be active on a given 
subnet.  

If necessary, you can also use this capability to reflect packets directly to 
machines on certain IP addresses in another subnet. However, serving too many 
workstations in this manner may degrade server performance.  
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Dial-up Workstations 
Do not add dial-up workstation addresses to the [Reflectors] section of 
NWP.INI. Instead, you can enable real-time urgent news wire updates only for 
dial-up users by adding the IP address of each dial-in workstation to the 
[ReflectUrgents] sections of NWP.INI. With this setting urgent items will be 
transmitted to those workstations but Forward Search alerts will not be available. 

VPN Support 
There are two types of VPN systems. One is a site to site VPN in which 
information is transmitted by VPN routers. This is typically used when a branch 
office or bureau connects to a central office. In this situation reflectors are 
supported because there is a broadcast address available for the site. 

The other type of VPN is a client to server VPN. This is used on laptops in the 
field. Users connect to a wireless network, dial in and make a point-to-point 
connection to the main office. In this situation reflectors are not supported. 

Datagram Optimization 
The NWP uses a queue system for UDP messages. By default, a maximum of 20 
UDP datagrams per second are transmitted. To change this value use a text 
editor such as Notepad to open \NWP\NWP.INI on the ENPS Work Drive and 
enter a new value for DatagramsPerSecond. 

To optimize this setting for the number of reflectors you are using use following 
formula:  DatagramsPerSecond  = rate of stories received at peak * (Number of 
active reflectors+1). For example, if you expect to receive five stories per second 
at peak and you have four reflectors this formula would be 5 * (1 + 4) = 25 so you 
would set the DatagramsPerSecond value to 25. If this value is not set high 
enough UDPs may be delayed.  

Private Channels  
A workstation with a private channel receives updates from the NOM via 
guaranteed TCP instead of UDP packets. You can use private channels if a site 
has trouble connecting to the Primary Server or if you want to have extra 
assurance that mission-critical workstations such as CG or prompter machines 
receive updates. 

Complete the following steps to create a private channel: 

1.  Find the MAC address for the workstation you want to connect via private 
channel by opening the ENPS client and double-clicking the ENPS icon on 
the top left corner of the screen.  

2.  Select Fourth Folder rover → System Maintenance → MAC Addresses. 
Click New to create a new entry. Enter the following information: 

Field Description 

ID Workstation’s MAC address. Because MAC addresses 
vary for computers accessing via dial-up PPP this field 
may also contain a list of pre-authorized dial-up IP 
addresses or IP ranges separated by semicolons. 

Server NetBIOS machine name for the server to which the 
workstation will connect. 

Private Re-enter the NetBIOS server name. In rare cases when 
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Channels updates from multiple servers are required you can 
enter multiple server names separated by a semicolon. 
There should be no more than five Private Channels for 
each pair of Primary and Buddy Servers.  

AcctCode The field cannot be left blank. You can enter a single 
character such as a period “.” or enter a unique number 
in this field that will help you identify the channel later. 

Active  

3.  Click Save and close the table. 

4.  If the Primary Server you are working on is not your organization’s Central 
Server open NOM Maintenance at select Window → Synchronization. 
Click Sync Now. Then open the NOM and select File → Reload Global 
tables. 

5.  Restart the ENPS client on the private channel workstation. 

Workstations set up to work with private channels ignore standard UDP 
messages. If workstations have IP addresses in ranges also covered by 
reflectors the reflected messages will be ignored. 

If a private channel connection is lost it will be re-established automatically. A 
dialog box will appear in the client stating that the connection was lost and 
suggesting that the open items (e.g., Rundowns, stories) be manually refreshed 
in case updates arrived during the connection loss.  

Dial-up Users 
ENPS works through most types of network connections including dial-in 
connections through a 28.8k modem. Full connection access is attained through 
any TCP/IP compatible transport including dial-up PPP. 

Before users connect to the server via dial-up you should make sure the DNS 
setting for the TCP/IP dial-up adapter is disabled. Open the Control Panel and 
open the Networking options. Select TCP/IP Dial-Up Adapter and click 
Properties. Click the DNS Configuration tab then click Disable DNS. Disabling 
DNS for the Dial-Up Adapter will disable it for all other TCP/IP adapters on the 
workstation. If another user requires DNS (e.g. when connected directly to the 
network while on-site), the DNS setting must be re-enabled. 

If the Remote Access Service is in the same subnet as the ENPS server, users 
will not be able to receive Top Line Messages or Urgent wire alerts through a 
dial-up connection.  
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Chapter 15  
Sending and Receiving Wires 

This chapter describes how to set up your ENPS to send and receive wires. Wire 
configuration is done in the News Wire Profiler (NWP) on the Primary Server.  

Categories, Providers, and other wire parameters are set in two places: the NWP 
application on the Primary Server and in the \NWP\NWP.INI on the ENPS WORK 
drive.  

Basic Serial Wire 
To create a new serial wire open the NWP and select File → New Wire.  

Choose the appropriate COM port and click OK. A new wire window appears. 
Click More for the wire configuration options. 

 
Complete the following fields to create the serial wire: 

Field Description 

Provider Select the name of the wire provider from the pull-down 
menu. 

Baud, Parity, Data 
and Stop bits 

Enter these specifications according to the port 
specifications. 

Buffer Use the default value of 3174. 
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Category Map, 
Format 

Settings provided by the wire provider. Non-standard 
formats are supported via the Custom option. 

Use default slug Assign a standard slug for wire stories. To enable this 
feature select the checkbox then enter the slug in the 
textbox. This feature is useful if your site ingests wires in 
a language for which Windows does not have a system 
codepage.  

Wires via FTP 
Before you create the wire via FTP follow the instructions in the previous section 
to create a category for the new wire in \NWP\NWP.INI on the ENPS Work 
Drive. 

1.  Create a new section for the category in the format of [Category_???] 
with a three letter designation for the wire such as [Category_PRN]. In this 
section you will create mappings for the wire’s category codes to the three 
digit category codes you created in the [Category] section, for example: 

[Category_STO] 
; Default to PR Other Stories 
Default=400 
; ST Advisories 
r=400 
t=401 
; PR Domestic/Washington 
a=401 
b=401 

2.  Restart the NWP then select File → New Wire and select FTP. When the 
new wire window appears click More to view additional options. 
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The following table provides an overview of these fields: 

Field Description 

Server NetBIOS name of the FTP server such as 
ftp1.prnewswire.com 

Port Port number specified by the wire provider, usually 21. 

PASV Select this checkbox if Passive transfers should be 
enabled. 

Username, 
password 

FTP server login credentials. In some cases, you may 
have to enter this in the format of 
username@servername such as 
UserID@ftp1.prnewswire.com.  

Directory In most cases this setting may be left blank. If you are 
downloading wires from an FTP site with multiple story 
directories you can optimize this process by creating 
multiple wires with different target directories. First 
create one FTP with all of the wire details and select the 
first directory that you want to capture. Then restart the 
NWP, and create a new wire using the first FTP wire as 
the wire source. The new wire will inherit the server and 
login settings from the first wire. 

Codepage Set the default codepage for your region. 

Category Map Select the Category Map code you created in the 
NWP.INI. 

Use default 
slug 

Assign a standard slug for wire stories. To enable this 
feature select the checkbox then enter the slug in the 
textbox. This feature is useful if your site ingests wires 
in a language for which Windows does not have a 
system codepage.  

Extract slug 
from keyword 
field 

  

3.  Make sure your NWP settings are only active on the Primary Server. If both 
the Primary and Buddy Servers are attempting to download wire data, it will 
only be saved to one of them. Since many wires via FTP also have a backup 
FTP site, you can set the Buddy Server to download wires from the backup. 

4. Select the Active checkbox to start using the wire. 

Wires via E-Mail 
The NWP can ingest POP e-mail as a wire feed. This allows reporters without 
access to an ENPS client to send story text to an e-mail address designated for 
wires. Incoming e-mail messages will be formatted as if they are regular news 
wire stories with the text added to each item’s slug for easy identification.  

The NWP will not ingest e-mail wires when the recipient is part of a CC or BCC 
address list or one of multiple addresses on the To: line; those messages will be 
deleted. 
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To enable wires via e-mail open the News Wire Profiler and select Window → 
Wires via e-mail. Click the More button then click New to create a new entry. 
Complete the following fields: 

Field Description 

POP3 Server NetBIOS name of the POP3 mail server. Do not attempt 
to access mail servers requiring connections through 
firewalls, SOCKS servers or dial-up connections. 

User ID, Password POP3 mail server’s login credentials. 

E-mail address E-mail address that will receive wires via-email. 

Provider EM 

Use default slug Assign a standard slug for wire stories. To enable this 
feature select the checkbox then enter the slug in the 
textbox. This feature is useful if your site ingests wires 
in a language for which Windows does not have a 
system codepage.  

Category, Priority Assign a category and priority for the e-mail wire. 

TopStories Select if the e-mail wire should appear as part of the 
Top Story Server in the My ENPS feature. Refer to “My 
ENPS” on page 100 for more information. 

Msgs, Junk Tracks the total number of messages received and the 
number of messages marked as “Junk” by the Junk 
Filter described below. 

Junk Filter E-mail addresses which should have their messages 
deleted. 

Category-based 
kill,  
wire-based kill 

Select Category-based to purge wires according to the 
wire’s Kill setting in the \NWP\NWP.INI on the ENPS 
WORK drive. 
Select Wire-based to enter a specific number of hours 
and/or days before the wire data is purged from the 
server.  

Select the Active checkbox to use the wire. 

Wires via AP WebFeeds 
Complete the following steps to configure AP WebFeeds as a wire in ENPS: 

1.  Use a text editor such as Notepad to open \NWP\NWP.INI on the ENPS 
WORK drive. In the [NWP] section add the entry Webfeeds=1. Save and 
close the file. 

2.  Close the News Wire Profiler. It will re-open automatically. 

3. In the News Wire Profiler select File → New Wire. Select WebFeeds and 
click OK. Click the More button to view the wire’s configuration settings. 
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If the Active checkbox is selected it must be unchecked before changes can 
be made to the wire settings. 

4.  Enter the following information to configure the wire: 

Field/Option Description 

Get Member Content If selected, AP WebFeeds will include content 
published by your organization.  

Username, password AP WebFeeds login credentials provided by AP. 

Provider Set to AP or other custom setting as needed. 

Cat Map Set to NAA or other custom setting as needed. 

5.  Select Click to Refresh to update the listing in the Product column. To 
include a product click on it then click ADD. The feed will appear in the 
Products to Display column.  

ENPS will display a warning message if too many products are included in a 
single WebFeeds wire. This is done to avoid URL length restrictions in the 
query that the NWP sends to the AP WebFeeds server. If you see the 
warning message, you will either need to remove some products or create a 
second WebFeeds wire in the NWP. There is no specific limit to the number 
of products you can add to the WebFeeds wire since the length of the 
request URL is determined by several variables including the length of the 
WebFeeds account name and password, certain optional settings in the 
NWP, and the length of the product codes that were selected. 

Sites that use AP Exchange can save their searches online and they will 
appear in WebFeeds alongside other WebFeeds content.  Note that it may 
take several minutes between the time the search is configured in AP 
Exchange and when it is available in the NWP. 



The Associated Press 119 
 

6. To create an entry for the product on the Wires rover menu in ENPS select 
the Custom Category checkbox next to the product name. AP WebFeeds 
content will always be displayed in the appropriate standard categories 
whether this box is selected or not. 

Individual stories delivered via AP WebFeeds may include multiple category 
codes. By default a separate version of the story is saved for each included 
category (e.g. sports, business, general news)  in addition to the WebFeeds 
Custom Category above, if enabled. This behavior can be changed using 
the DupeStoryThreshold setting in the [NWP] section of the NWP.INI. 
For more information on this setting refer to “NWP Configuration Settings” on 
page 65. 

7.  The settings at the bottom of the window control how the feed is processed 
by the News Wire Profiler. 

Field/Option Description 

Check For Updates 
Every 

Interval at which the ENPS will check for 
updated data from the AP WebFeeds server. 

Timeout Length of time ENPS will wait for a response 
from the AP WebFeeds server before it 
closes the connection. 

Max. Entries Per 
Request 

Largest number of stories that may be 
downloaded at one time. The maximum is 
500. 

Suppress notification 
of  duplicate stories 

By default, ENPS deletes duplicate wires. If 
this box is checked the News Wire Profiler 
will not create an entry in \NWP\NWP.LOG on 
the ENPS WORK drive when duplicate stories 
are detected.  

Autoflatten Headlines For AP WebFeeds that contains packages of 
headlines, such as “Top U.S. Headlines,” 
ENPS can request both the headlines and 
the individual stories referenced in the 
package. Enabling this option will increase 
the amount of network traffic. 
If unchecked, ENPS will only request the 
headline package, not the referenced stories 
which are contained in other feeds. This is 
the default behavior.  

Capture Save AP WebFeeds XML data to the server. 
This is useful for troubleshooting problems 
with the wire. 

Category-based kill,  
wire-based kill 

Select Category-based to purge wires 
according to the wire’s Kill setting in the 
\NWP\NWP.INI on the ENPS WORK drive. 
Select Wire-based to enter a specific number 
of hours and/or days before the wire data is 
purged from the server. 

Refer to the ENPS Stats Guide section on configuring the election wire for 
information on how to set the values for the election fields. 
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8. Click the Active checkbox to enable the feed.  

Once the feed is enabled users will have the following story property fields 
available in AP WebFeeds stories:  

Property Field Description 

Story Entities People, places and organizations related to the 
story, e.g. “Jon Stewart; Helen Mirren; Jennifer 
Aniston” 

Story Subjects Topics related to the story, e.g. “Award shows; Arts 
and Entertainment” 

Wire Status Whether the story is usable or unusable. 

Wire Release 
Time 

If a story is listed as unusable, the time when a 
story can be used.  

For diagnostic purposes, you can configure the NWP to re-ingest previously 
captured Webfeeds data from a text file. Open a WebFeeds wire, clear the Active 
checkbox, and press Ctrl+T. This can also be used for pre-election testing with 
ENPS Stats. 

Wires in XML Format 
To receive wires in XML format you need to create an XSL transform. Complete 
the following steps: 

1. Make a copy of one of the sample XSL transforms in the \NWP\XSL folder on 
the ENPS WORK drive. Rename the file with the name of the wire to be 
ingested. 

2. Use a text editor such as Notepad to modify the settings in the XSL 
according to the formatting of the XML wire.  

3. Open \NWP\NWP.INI in a text editor. Add the setting CustomXSLFiles=1 
to the [NWP] section.  

4. Restart the NWP. Select File → New Wire. In the Story Format menu select 
the name of the XSL filename that you modified.  

Set the Story Start and Story Stop codes to match the root tag of the XML 
file. The root tag is the first tag in the file after the XML header. In the 
following example the Start Code is <NewsML and Story Stop code is 
/NewsML>. Note that the close bracket > and open bracket < are omitted 
from the Start and Stop codes, respectively. 

<?xml version="1.0" encoding="utf-8"?> 
<NewsML Version="1.2"> 
  <NewsEnvelope> 
    <TransmissionId>1025</TransmissionId> 
    <DateAndTime>20090927T103318Z</DateAndTime> 
  . . .  
 </NewsML> 

Wires via OPENS 
If you are using OPENS you can use the OPENSCG application to output the 
closings data in XML format to an FTP server. The News Wire Profiler can then 
import that information into ENPS as a wire. Refer to “For diagnostic purposes, 
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you can configure the NWP to re-ingest previously captured Webfeeds data from 
a text file. Open a WebFeeds wire, clear the Active checkbox, and press 
Ctrl+T. This can also be used for pre-election testing with ENPS Stats. 

Wires in XML Format” above and “Wires via FTP” on page 115 for more 
information. 

Open the NWP and select File → New Wire. Select FTP and click OK. Enter 
information into the appropriate fields as detailed on page 115. Make sure that 
you point it to the server that the OPENSCG application is sending information to 
via FTP. In the Story Format select the OPENS XSL transform. 

Wires via Twitter 
This section will show you how to set up the NWP to ingest Twitter content.  

1.  Set up a Twitter account for your site. Select the Twitter users you want to 
follow. You can select additional users later. 

2.  Use a text editor such as Notepad to open \NWP\NWP.INI on the ENPS 
WORK drive. 

a.  In the [NWP] section add the setting TwitterFeeds=1 

b. Optional. You may want to create a custom category for your Twitterfeed, 
especially if your site has multiple Twitter accounts. To create a custom 
category for the Twitterfeed select a three digit number above 300 equal 
to the category name in the [Categories] section such as: 

301 = Twitter 

 There is a 30-character limit on the category length. 

c. In the [Providers] section add the following entry: 

 TWT=TwitterFeed 

d. Save and close NWP.INI. 

3.  Close the NWP. It will restart automatically.  

4. Select New → Wire. For the wire type select TWITTER.  

 
5. Complete the following fields on the Twitterfeeds Wire window: 

Field Description 

Username Twitter login name. 
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Default Category If you created a custom category in the NWP.INI 
you can select it here. Otherwise you can select a 
standard category. 

Provider Code Select TWITTER. 

Use default slug Assign a standard slug for wire stories. To enable 
this feature select the checkbox then enter the slug 
in the textbox. This feature is useful if your site 
ingests wires in a language for which Windows does 
not have a system codepage. 

Check for Updates 
Every 

Frequency with which the NWP requests updates 
from Twitter. Twitter may limit the number of update 
requests that can be made in an hour from third-
party applications like ENPS. This limit is based on 
the Twitter account used to make the request. 
Twitter may change the value without warning. You 
can find more information on Twitter's rate-limiting 
policies here: 
http://dev.twitter.com/pages/rate_limiting_faq 
If your ENPS Twitter account is over the limit for the 
current hour it will be logged in the NWP's 
Messages window. The NWP will not receive new 
updates from Twitter until the next hour begins. 

Timeout Number of seconds ENPS will wait for a response 
from the Twitterfeeds server before it closes the 
connection. 

Max. Entries Per 
Request 

Maximum number of wire stories to download when 
connected. 

Capture Save data to the server. This is useful for 
troubleshooting problems with the wire. Capture files 
are saved to the \NWP folder on the ENPS WORK 
drive. The filename will be the name of the wire. 

Category-based 
kill, wire-based kill 

Select Category-based to purge wires according to 
the wire’s Kill setting in the \NWP\NWP.INI on the 
ENPS WORK drive. Select Wire-based to enter a 
specific number of hours and/or days before the wire 
data is purged from the server. 

6.  Select the Active checkbox. 

7. An authorization window will appear with a Twitter URL in it.  

a. Copy the URL and paste it into your browser.  

b. Log in to Twitter and confirm that you want to give ENPS access to your 
Twitter account. Copy the authorization code.  

c. Paste the code into the authorization window in the NWP. You only need 
to perform this authorization once for each Twitter account, even if the 
account’s password changes. 
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Wires via YouTube Feeds 
You can configure the NWP to search YouTube for video on selected topics. A 
YouTube account is not required to use this feature. Complete the following 
steps to receive YouTube feeds as a wire:  

1.  Use a text editor such as Notepad to open \NWP\NWP.INI on the ENPS 
WORK drive. 

a.  In the [NWP] section add the setting YouTubeFeeds=1 

b. Optional. You may want to create a custom category for your YouTube 
feed. To create a custom category for the Twitterfeed select a three digit 
number above 300 equal to the category name in the [Categories] 
section such as: 

302 = YouTube  

 There is a 30-character limit on the category length. 

c. In the [Providers] section add the following entry: 

 YTB=YouTube 

d. Save and close NWP.INI. 

2.  Close the NWP. It will restart automatically.  

3.  In the NWP select New → Wire and select the YouTube wire.  

 
Complete the following fields: 

Field Description 

Search Search terms for videos. This may be a topic local 
interest or a story that one of your users is following. 
Audience members can submit videos to your site 
by adding a unique keyword, e.g. “News7Now” to 
the metadata for their YouTube videos. To create a 
wire that displays audience content enter that 
keyword in this field.  

Use default slug Assign a standard slug for wire stories. To enable 
this feature select the checkbox then enter the slug 
in the textbox. This feature is useful if your site 
ingests wires in a language for which Windows does 
not have a system codepage.  
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Safe search 
options 

Level for filtering content that YouTube flagged as 
explicit.  

Default Category  If you created a category mapping for the wire in the 
NWP.INI you can select it here. 

Provider Code Select YOUTUBE. 

Check for Updates 
Every 

Frequency with which the NWP requests updates 
from YouTube. 

Timeout Number of seconds ENPS will wait for a response 
from the YouTube server before it closes the 
connection. 

Max. Entries Per 
Request 

Maximum number of wire stories to download when 
connected. 

Capture Save data to the server. This is useful for 
troubleshooting problems with the wire. Capture 
files are saved to the \NWP folder on the ENPS 
WORK drive. The filename will be the name of the 
wire. 

Category-based 
kill, wire-based kill 

Select Category-based to purge wires according to 
the wire’s Kill setting in the \NWP\NWP.INI on the 
ENPS WORK drive. Select Wire-based to enter a 
specific number of hours and/or days before the 
wire data is purged from the server. 

Select the Active checkbox to start using the new wire. 

YouTube wires include a MOS Item Reference to the video. By default, users will 
see a JPG preview image in the ENPS media viewer. You can enable an option 
that will let users double-click the MOS Item Reference to open the YouTube 
video in a Web browser in the ENPS Editing Window. 

To enable this select Fourth Folder rover → System Maintenance → MOS 
Configuration and click New. Enter the following settings: 

Field Value 

MOS ID internet.youtube.mos 

Description                       YouTube 

ActiveX                    NCWeb.ctrlBrowse 

Default Settings              URL=http://www.youtube.com/watch?v=<objID> 

MOS Version                                                               2.8.3           

LocalDragDrop                 Off 

Read Only  

Click Save to apply changes. 
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Custom Wire Categories 
You can create wire categories on a per-server basis that will be displayed from 
the Wires folder rover. Categories are defined in the \NWP\NWP.INI on the 
ENPS WORK drive at the bottom of the [Categories] section. Here is a 
breakdown of category numbers from the NWP.INI: 

[Categories] 
1=Advisories 
2=International Stories;National/International News 
4=National Newsminutes/Newswatches;National/International 
News 
6=Business/Financial News 
7=Features/Entertainment 
9=Sports Stories;Sports 
12=State/Regional Stories;State/Regional News 
13=State Newsminutes/Newswatches;State/Regional News 
; The following are hard-coded internally and cannot be 
changed here. 
3=Domestic/Washington Stories;National/International News 
5=Politics 
10=Farm/Agricultural News 
91=Sports Scores;Sports 
92=Lottery Results;State/Regional News 
102=State/Zone Forecasts;Weather 
105=Local/Metro Forecasts;Weather 
104=Tropical Weather;Weather 
108=Hourly Temperatures;Weather 
107=Radar Summaries;Weather 
101=Agricultural Weather;Weather 
106=Marine/Boating Forecasts;Weather 
103=Weather Advisories;Weather 

You can assign a custom category a code number greater than 400.. The 
example below creates a category called “Special” with sub-categories for Stocks 
and Baseball. Note that "S" should appear in the third position and the fifth 
position is reserved for a semi-colon delimiter. 

[Categories] 
400=Stocks;Special;S;;Stock or Dow 
401=Baseball;Special;S;;World Series 

Move Copy with a Keyword to Wires 
If an incoming news wire has a predictable structure you can move stories that 
contain a specific keyword to its own custom category. To do this complete the 
following steps: 

1.  Use a text editor such as Notepad to open \NWP\NWP.INI on the ENPS 
WORK drive. Create a custom category mapping for the wire such as:  

[Category_test] 
<<SPORT>>=9 

There is a 30-character limit on the category length.  

2. Open the NWP and select File → New. Complete the following fields: 



126 ENPS Operations Guide 
 

Field Value 

Story Format Custom 

Category Code Search  

Tag, Delimiter, Position Refer to the example in the following 
string: ?!?<<SPORT >>?!? 

Tag is ?!?  
Delimiter is ?!? 
Position is 2 because the category name 
SPORT is the second field after the tag. 

Dependent Wires 
Dependent wires are “virtual” wires created from existing serial wires or FTP 
feeds. To create a dependent wire open the NWP and select File → New. When 
the wire parameters window appears select Dependent-Selector Codes or 
Dependent-FTP Directory from the Type dropdown menu. These types are 
described below. 

Dependent-Selector Codes 
This option lets you create a virtual wire based on selector codes from another 
wire. In the Parent Feed dropdown menu select the wire from which you want to 
create a dependent wire. The dependent wire will automatically inherit the 
connection settings from the parent wire. 

Next, enter one or more selector codes separated by commas to specify what will 
be included in the dependent wire. These can either be entered manually or from 
a dropdown menu of AP selector codes. A selector code can be added manually 
even if it is not already in the list. Enter the selector codes in the (Duplicate) field 
to retain the items in the parent wire. If you enter the selector codes in the 
(Extract) field the items will be removed from the parent wire. 

If the parent wire contains AP selector codes you may also route dependent wire 
items to specific categories by mapping selector codes to categories. Use a text 
editor such as Notepad to open \NWP\NWP.INI on the ENPS Work Drive. The 
example below shows a sample mapping: 

[SIDCategory_SAMPLE] 
; Radio Advisories 1 
1rad-=1 
; Television Advisories 1 
1tel-=1 
; General Advisories 1 
anr--=1 
; International 2 
1tv--=2 

This selector code to category mapping can then be selected from the dependent 
wire from the Selector Category Map dropdown menu.  

Dependent-FTP Directory 
Use this dependent wire type when you want to create two FTP wires that 
originate from different folders on the same FTP server and can be accessed 
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with the same credentials. This will allow the NWP to pull content for both wires 
without having to disconnect and reconnect to the same server unnecessarily.  

Once you have created an NWP wire entry for the first FTP wire create the 
Dependent-FTP Directory wire. Specify the first FTP wire in the Parent Feed 
dropdown then enter the directory path for the dependent wire. Complete the 
other fields as you would for any other type of wire. 

Opening a Wire with an ActiveX Plug-In 
You can configure a wire to open in an ActiveX plug-in rather than an Editing 
Window by completing the following steps: 

1.  Select Fourth Folder Rover → System Maintenance → MOS 
Configuration. 

2.  Create an entry in the format of name.xxx where name is any name you 
assign and xxx matches the wire provider code in the \NWP\NWP.INI on 
the ENPS WORK drive. For example, the AP Global MOSID would be 
GlobalWire.APG.  

3. In the ActiveX column enter the name of the plug-in that you want to 
associate with this wire.  

4.  Click Save to store your changes and restart the ENPS client. 

Publishing Wires 
Users can publish stories within your organization as a wire or they may publish 
stories to an external wire. Internal publishing features can be used to make 
content like stories available to other users at the site through a category 
available from the Wires folder rover. External publishing makes your site’s 
content available to outside organizations in the same way news agencies like 
the AP publish news wires.  

Note that wire publishing described here is separate from ENPS Publishing 
which is used to publish stories to cell phones and the Web. Refer to the ENPS 
Publishing Guide for more information. 

Complete the following steps to configure a group that can publish wires: 

1. Use a text editor such as Notepad to open \NWP\NWP.INI on the ENPS 
WORK drive. You first need to create a category for the wire to be published. 
Add an entry in the [Categories] section with the category information 
with the following format: 

300=Publish Test;Publishing;I;v  

• This entry consists of the following parameters separated by semi-
colons: 

• A category number between 300 and 400 
• Name of the wire 
• The word Publishing 
• I to indicate internal publishing and X for external publishing. The letter 

must be upper-case. 
• v for the final parameter. In NAA/ANPA format v is an advisory.  

2. Copy your changes from the NWP.INI to the NWP.INI on the Buddy Server. 
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3. In the ENPS client select Fourth Folder rover → System Maintenance → 
Groups. Complete the instructions in the “Groups” section on page 91 to 
create a new group. Do not call the new group “Wires.” This new group can 
only be used for publishing. 

To enable the group to publish wires select the group’s Type column and 
select Wire from the dropdown list. 

4.  Restart the NWP on the Primary and Buddy Servers. 

5. In the NWP on the Primary Server select Window → Publishing 
Subsystem.  

 
This window contains a list of groups that are enabled for publishing and a 
number of properties for each. If your wire is published externally you can 
select the External checkbox and set the wire parameters and Format in the 
lower half of this window. 

Users can publish to the new wire-enabled group by dragging stories into the 
group folder. Once the item is transmitted it will be removed from the folder.  

Internal Publishing Features 
You can configure internal publishing to publish Rundowns from one group to 
another. To do this, select Fourth folder rover → System maintenance → 
Groups. Select the Parent/Child column for both the group that will create the 
Rundown and for the target group that will receive the published Rundown.  

Navigate to the group that will publish the Rundown. Select Group folder rover 
→ Group maintenance → Group settings. 

 
This screen allows you to specify who will be notified if the status of a story 
changes. You can enter the name of a user or a group. In the Publish Rundown 
to: box you can enter the name of the target group. When you open a Rundown 
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in that group users will then have the option to publish to the specified target 
group. 
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Chapter 16 
MOS Configuration 

The Media Object Server (MOS) protocol is an evolving standard for 
communication between newsroom computer systems and hardware devices. 
ENPS supports MOS versions 2.5, 2.6, 2.8, 2.8.1, 2.8.2, 2.8.3 and 3.8.3. 

Many sites create a group called MOS Objects for storing the site’s MOS 
objects. Refer to “Groups” on page 91 for instructions on how to create a new 
group. 

For the latest information about MOS including an overview of MOS messages 
refer to http://www.mosprotocol.com. 

Add a MOS Device or an ActiveX Plug-in 
This section shows you how to add MOS-enabled hardware or ActiveX plug-in to 
ENPS.  

MOS-enabled hardware includes video servers, audio servers, still stores, 
character generators and other types of broadcast hardware.  

ActiveX plug-ins are applications that can run from ENPS. They are provided by 
hardware vendors to allow users view and edit material on that device from 
ENPS and may include access to routing switchers, ENG antennas, external 
databases, archives and many other types of newsroom operations. Once 
installed, the ActiveX plug-in will appear as an option from the Media Control 
rover at the bottom of the ENPS desktop. 

To add, modify or remove MOS devices and ActiveX plug-ins select Fourth 
folder rover → System Maintenance → MOS configuration. The settings in 
this table are described below: 

Setting Description 

ID A MOS device’s unique identifier. If you are configuring 
MOS-enabled hardware, such as a video server, this ID 
should match the ID that is configured on the hardware. 
Use the following format when you create a MOS ID: 
<vendor>.<product>.<site ID>.<enterprise>. 
<mos> 

This is called a fully-qualified MOS ID. It is important to 
use fully-qualified IDs to ensure compatibility between 
ENPS and MOS devices. An example of a fully-qualified 
MOS ID is aveed.server2.camden.wtn.mos  
If you are configuring an ActiveX plug-in enter the ID 
provider by the vendor. 
By default, MOS IDs are case-sensitive although this 
behavior can be changed by disabling the Global 
Configuration Option CASESENSITIVEMOS. Refer to 
“Global Configuration Options” on page 44 for more 
information. 

Description Description of the device or ActiveX plug-in. This text will 
be displayed to users in ENPS menus. 

http://www.mosprotocol.com/
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IP For MOS versions earlier than 3.8.3 this is the IP address 
of the MOS device.  
For MOS version 3.8.3 or higher this is a URL pointing to 
the .ASMX file on the MOS device. 

ActiveX If you are configuring a hardware device this field may be 
left blank. 
If you are configuring an ActiveX plug-in this field 
specifies the name of the plug-in from the Windows 
Registry such as NCWeb.ctrlBrowse.  
Check the vendor’s documentation for more information. 

Program Name of the ENPS group in which MOS object messages 
will be stored. The default group is System.  
If you are configuring an ActiveX control that does not 
connect to a server and which only sends MOS object 
pointers to ENPS do not select a group. 

Default Settings Parameters that may be required by the ActiveX control. 
Check the vendor’s documentation for more information.  

MOS Version MOS protocol version to use with this device or plug-in: 
2.5, 2.6, 2.8, 2.8.1, 2.8.2, 2.8.3, or 3.8.3.  
For users to search MOS devices this field must be set to 
2.8.1 or higher and the ENPS server port 10542 must be 
open. 
If you are using MOS version 3.8.3 or higher you should 
configure a secure socket connection to the MOS device. 
Refer to http://support.microsoft.com/kb/ 
299875 for more information. 
If you leave this field blank ENPS will use the MOS 
version specified by the Version setting in 
\NOM\NOM.INI on the ENPS WORK drive. 

Local DragDrop In most configurations this option should be set to Off 
since it can interfere with the mouse control in the plug-in. 

Modal UI ActiveX Run a plug-in in its own window rather than the lower 
Editing Window. When using plug-ins defined by this field, 
as opposed to the Detached ActiveX column, users are 
forced to perform an action in the window before they can 
continue using ENPS. This is required for some plug-ins 
that require input before other changes are made. 
To enable this feature re-enter the control’s name from 
the ActiveX column such as NCWeb.ctrlBrowse. Users 
can open the plug-in by selecting Editing Window rover 
→ MOS Commands.  

Modal UI Default 
Settings 

If a control name is specified in Modal UI ActiveX this 
field should duplicate the contents of Default Settings. 

Auto Create Determines whether Rundowns on this device will able to 
create MOS objects and/or placeholders for MOS objects 
automatically. 

Username, 
Password 

Credentials sent to the plug-in from ENPS. These settings 
may be left blank if login authentication is not required. 

http://support.microsoft.com/kb/299875
http://support.microsoft.com/kb/299875
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Read Only Allow a device to receive messages but not to send them. 
This is useful for plug-ins like ENPS FAX which should 
not have any outgoing MOS messages. 

Alias User-friendly name for a MOS device to display instead of 
the fully-qualified MOS ID. This name will appear in the 
dropdown boxes for the Autocreate and Object 
Placeholder Create columns in Rundowns and 
Newsgathering Grids. 

Story Send Determines whether a MOS-enabled device can receive 
MOS StorySend messages. These messages send the 
entire story including text, production commands and 
pointers to MOS objects. StorySend messages are often 
required by prompters and automation systems.  
If this column is not selected only references to objects 
will be sent to the device.  
Check the vendor’s documentation to find out if this 
setting should be enabled. 

RORO Limit Limit the number of Read-Only Rundowns that can be 
created in a group. Refer to “Read-Only Rundowns” on 
page 136 for more information. 

Object Type Select Audio, Still, or Video. This field is for your 
reference only; it may be left blank. 

Object Groups Name of groups, typically for different shows, into which 
MOS objects will be sorted. The groups will appear as 
subfolders of the Program/Group that is selected in the 
MOS Configuration table for a particular device. This 
allows MOS objects to be routed to different subfolders 
automatically. Separate each entry with the pipe | 
character. Users will be able to select the group from the 
Object Placeholder Create column. 

Archive Only Include all of the MOS StorySend messages when a user 
archives a Rundown or Newsgathering Grid. These 
messages include the entire body of a story including text, 
production commands and pointers to MOS objects. This 
option is useful if organization uses a MOS-
enabled Content Management System (CMS).  
If you use this setting make sure the Story Send column 
is also selected. The user can then open the Rundown’s 
properties and select the MOS Control Active checkbox 
then select a MOS device in the StorySend column.  

Detached ActiveX To run an ActiveX in its own window copy the name from 
the ActiveX column here. If the ActiveX runs a different 
plug-in when it is in detached mode enter the control’s 
name from the Windows registry. 

Detached Default 
Settings 

Although this is typically the same parameters that are 
defined for the Default Settings column the settings may 
be different for detached plug-ins. Check the vendor’s 
documentation for more information. 
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Use Detached Displays the ActiveX plug-in in a separate window 
regardless of whether the client has selected to view 
ActiveX controls separately. 

Raw Content Send all of the content below a Rundown’s black line to 
the MOS device including pointers to MOS objects. 

Icons Select icons to display MOS objects displayed in the List 
Window. Click  for a list of choices.  
You can create your own 16x16 pixel icons in the 
\ENPS\BITMAPS\MOS directory on the server. These 
images will be copied to client workstations when the 
client is installed. You can also manually copy 16x16 pixel 
icons in the .ICO or .BMP format to C:\DOCUMENTS 
AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\BITMAPS\MOS. If this folder does not exist 
you will not be able to change the icons for the MOS 
device. 

Color Set the color used to display MOS Item References by 
clicking the  icon. The numbers displayed represent the 
color’s RGB values.  

Export Formatted 
Text 

Determine whether rich text formatting such as bold, 
underline, and italics will be sent to the device in MOS 
StorySend messages. This column has a drop-down 
menu with three choices: 
• Off: Do not include rich text formatting. 
• Basic: Include basic rich text formatting such as bold, 

italics and underline. Other formatting, such as 
strikethrough text, will be omitted.  

• Extended: Include all rich text formatting.  

Validate MOS 
Objects 

Verify that a MOS object exists when a story is opened or 
a Rundown’s MOS Control Active property is selected. If 
the object is not found the MOS Item Reference will turn 
grey. Do not enable this setting on devices such as 
character generators that typically do not send MOS 
object messages to ENPS. 

Block 
ItemChannel 

Ignore channel assignments created by the MOS device. 
If this option is selected users will need to enter a channel 
number for every MOS Item Reference in a Rundown. 

Status time local Control how ENPS processes time values in inbound 
MOS Status messages that do not have a time zone 
specified. If this option is enabled ENPS will use the 
same time zone as the ENPS server. If this option is 
disabled GMT will be used as the time zone. 

Configuring ENPS Plug-Ins 
This section shows you how to configure the basic plug-in for Internet Explorer 
and plug-ins for two subscription-based services you can access from with 
ENPS: AP GraphicsBank and AP PrimeCuts.  
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Internet Explorer 
The following example shows you how to configure the default custom Microsoft 
Internet Explorer control that ships with ENPS. It can be used as a model for how 
to implement your own ActiveX controls. These instructions assume that the 
Microsoft Internet Explorer ActiveX control is installed and registered on the 
workstation. 

To enter the configuration parameters open the ENPS client and select Fourth 
folder rover → System Maintenance → MOS Configuration and set the 
following parameters: 

Setting Value 

ID IEXPLORER 

Description Internet Explorer 

ActiveX NCWeb.ctrlBrowse 

Default 
Settings 

URL to open as the browser’s homepage in the format of  
URL=<page address>, for example: 
URL=<http://www.enps.com> 

You can hide the browser address bar and/or status bar by 
adding the following settings to the Default Settings entry, using 
pipes between settings, for example:  
URL=http://www.enps.com|ToolBar=False|StatusBar= 
False 

All other settings should be left at their default values. 

AP PrimeCuts 
You must have a subscription to AP PrimeCuts account to use this feature. 

ENPS can automatically detect links to AP PrimeCuts audio in incoming AP news 
wire stories. Such links will be converted to MOS Item References which can be 
clicked to automatically download the desired file.  

Set up the PrimeCuts ActiveX plug-in by selecting Fourth folder rover → 
System Maintenance → MOS Configuration and enter the following 
parameters: 

Setting Value 

ID APPC.MOS 

Description AP PrimeCuts 

ActiveX PrimeCuts.PrimeCutsControl 

Default Settings URL=http://apprimecuts.com/texis/sound/bank
/autodownload.bin/+/<objID>?User=<Username> 
&Pass=<Password>|URLtext=http://apprimecuts 
.com/texis/sound/bank/results.html?User= 
<Username>&Pass=<Password>&query=<Cut> 
&whatfield=F&byrank=0 

Do not enter any spaces. 

MOS Version 2.8 
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Local DragDrop Off 

Username, 
password 

Your site’s PrimeCuts username and password. 

Read Only  

All other settings should be left at their default values. 

The ENPS Advanced User’s Guide contains instructions on how to use AP 
PrimeCuts. 

To install the ActiveX, you must run the setup application SETUPPC.EXE from the 
root directory of your Primary Server. Once the installation is complete, clients 
must be reinstalled to use the ActiveX functionality. 

ActiveX Configuration: AP GraphicsBank  
You must have an AP GraphicsBank account to use this service. Remember that 
GraphicsBank accounts are allowed a set number of downloads per month. All 
downloads after your allocated number of downloads will be charged a fee. 

It is recommended that you set up a GraphicsBank account that allows users to 
only download preview images to prevent unintentional downloads and charges. 
Contact AP Member Services at 1-800-342-5127 to set up a preview only 
account. 

To install the ActiveX run SETUPGB.EXE from the root directory of your Primary 
Server. You may need to reinstall the ENPS client on workstations that will use 
this functionality. 

To enter the GraphicsBank ActiveX configuration parameters, open the ENPS 
client and select Fourth folder rover → System Maintenance → MOS 
Configuration and set the following parameters: 

Setting Value 

ID APGB.MOS 

Description AP GraphicsBank 

ActiveX Gbank.GbankControl 

Default Settings 

URL=http://gb.ap.org/texis/gb/results.html? 
&User=<Username>&Pass=<Password>&query= 
<GraphicsBankSearch> 

Do not enter any spaces.  

MOS Version 2.8 

Local DragDrop Off 

Username, 
Password Your site’s GraphicsBank username and password. 

Read Only  

The ENPS Advanced User’s Guide contains instructions on how to use the 
GraphicsBank plug-in. 
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Read-Only Rundowns 
Read-Only Rundowns are used in enterprises where Rundowns are sent via 
MOS from one ENPS system to another. Making a Rundown Read-Only 
prevents different groups from making changes to copies of a Rundown and 
having to reconcile different versions. With a Read-Only Rundown only one 
master copy of a Rundown can be changed. 

Complete the following steps to configure a Read-Only Rundown:  

1.  On the server that will host the Read-Only Rundown select Fourth folder 
rover → System Maintenance → MOS configuration. Enter the MOS ID 
and the IP address of the target server where ENPS will send the Read-Only 
Rundown. Select the Story Send column. Click Save to apply your changes. 

2. Restart the NOM on the host server. 

3. On the target server that will receive the Read-Only Rundown select Fourth 
folder rover → System Maintenance → MOS configuration. Enter 
the target server’s MOS ID and its IP address. You do not have to select 
Story Send on the target server. In the Program column select the folder 
where you want the Read-Only Rundowns to be stored. Do not use your 
site’s News or Desk folders. In the RORO Limit specify the maximum number 
of Read-Only Rundowns that can be stored on the server.  

3.  Restart the NOM of the target server. 

4.  On the client for the source NOM create a new Rundown. In the Rundown 
properties select the target server as a MOS Story Send device then select 
MOS Control Active.  

The Read-Only Rundown will appear in the folder you configured for the target 
server. 

Setting Up a MOS Repeater 
A MOS Repeater is a workstation that re-broadcasts all of the Rundowns on a 
server that have the MOS Control Active property enabled. A typical use for this 
functionality would be to provide multiple non-linear editing clients with stories 
from a Rundown that has the MOS Control Active property selected so that 
stories could be still be viewed while users are editing the media.  

Complete the following steps to configure a workstation as a MOS Repeater: 

1.  You cannot use the Primary or Buddy Server as a MOS Repeater. Designate 
the MOS Repeater workstation with the following minimum specifications: 

• 18 GB free space 
• 512 MB RAM 
• Operating system must be Windows 2000 Server, Windows 2003 Server, 

Windows 2000 Professional or Windows XP Professional. The operating 
system must have the latest Service Packs and critical updates from 
Microsoft installed. 

2. Install IIS and create a separate F: called ENPS Work to install the ENPS 
server applications. 

3. Install a copy of the ENPS server applications on the MOS Repeater 
workstation. Identify the MOS Repeater server as a Primary Server. You also 
need to enter the machine name of your site’s actual Primary Server or 
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Central Server when you are prompted to do so during the installation 
process. 

4. Use a text editor such as Notepad to open \NOM\NOM.INI  on the ENPS 
Work Drive. Add or change the following settings to the [Watch] section: 

NOM=1 
NWP=0 
Maint=1 
Extract=0 

Add or change the following settings to [Maint] section: 

Delete=0 
Sync=1 
Buddy=0 

Add or change the following setting to the [NOM] section: 

MOSRepeater=1 

Restart the Watch application and close the NWP. 

5. On a client workstation for your site’s ENPS Primary Server select Fourth 
Folder rover → System Maintenance → Servers and click Add to create a 
new entry with the following parameters: 

Setting Value 

ID MOS Repeater’s NetBIOS name. 

Description Description for the MOS Repeater. 

MOS  Re-enter the MOS Repeater’s NetBIOS name. 

IP MOS Repeater’s IP address. 

MOS Repeater  

MOS Server Primary Server name from the MOS repeater will 
receive its MOS StorySend messages 

Click Save to apply your changes. 

6.  To set up the targets for a MOS Repeater select Fourth Folder rover → 
System Maintenance → MOS Repeater Targets and enter the following 
parameters for each target: 

Setting Value 

Target ID Target machine’s NetBIOS name. 

Description Target machine description. 

IP IP address of the repeater target. 

Repeater ID Re-enter target machine name’s NetBIOS name. 

7. To ensure that the MOS Repeater stays in sync with the NOM, MOS 
StorySend messages will be numbered coming out of the parent. If the 
Repeater target receives a message out of the expected order it can request 
a re-sync for the affected Rundown. To enable this, open the NOM on the 
Primary Server and select Windows→  MOS. Check the box Number 
roConstruction Messages. From this screen you can also set the number of 
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minutes to purge the MOS Repeater’s message queue after an editing site 
logs off. 

8.  If the Primary Server you are working on is not your organization’s Central 
Server open NOM Maintenance at select Window → Synchronization. 
Click Sync Now. Then open the NOM and select File → Reload Global 
tables. 

9. Restart the NOM on both the MOS Repeater and the ENPS Primary Server. 
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Chapter 17 
Character Generators 

This chapter will show you how to setup your character generator in ENPS. The 
instructions in this chapter apply only to character generators which are 
connected to ENPS through a serial connection. Character generators that are 
controlled through a MOS connection are configured through the vendor’s 
ActiveX plug-in. 

Supported Character Generators 
ENPS CG support includes, but is not limited to, the following CGs: 

Manufacturer Models 

Aston Motif, Ethos, Moto, Red, Blue and Green 

Chyron Duet , Codi, MAX!, MAXINE!, iNFiNiT!,  

Pinnacle Deko, FX Deko (in iNFiNiT! emulation mode) 

Pixel Power Collage in iNFiNiT! emulation mode 

Grass Valley 20k, 30k, Graphics Factory and Halo 

Inscriber 
VMP Studio, CG Supreme, CG Xtreme, Inca CG and 
Inca Studio. You must have the AutoCGMax option 
enabled for Inscriber CGs to work with ENPS. 

Designate an ENPS client machine as your CG workstation. The CG operator 
must be able to log into ENPS, select the desired Rundown, and enable CG 
control from within that Rundown. 

When you are connecting the cabling for the CG be sure to follow the 
manufacturer’s instructions. Some vendors have unique cabling configurations as 
some CGs require pin signals to be reversed at one end to enable hardware flow 
control.  

Refer to “Considerations for Specific Character Generators” on page 141 for 
more information. 

Configuration Settings 
To enable a client workstation for CG support use a text editor such as Notepad 
to open C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI. In the [ENPS] section set CG=1. 

The [CG] section controls the connection parameters for the CG device. The 
setting CG requires the following information separated by semi-colons: 

Description Value 

Driver type Aston, AstonUnicode, Infinit!, Max, 
Maxine, Dubner, Codi, Duet 

Video standard NTSC, PAL 

Serial port settings <COM PORT>:<Baud>,<Parity>,<Word 
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length>,<Stop bits> 

Machine ID Optional. You can find this value in your character 
generator’s setup program.  

Default page Starting page number in the character generator's that 
will be used to begin recording. If pages will be 
preloaded into the Chyron this value will determine the 
starting page number. The default value is 5000. If 
pages are not preloaded leave this value blank 

Page number 
prefix 

Optional. Character or string to prefix before the page 
number.  

Here are sample connection strings: 

CG=Aston;PAL;COM1:19200,e,7,1 
CG=iNFiNiT!;NTSC;COM1:19200,n,8,1;16;5000 
CG=Maxine;NTSC;COM1:19200,n,8,1;16;5000 
CG=Max;NTSC;COM1:19200,n,8,1;16;5000 
CG=Codi;NTSC;COM1:19200,n,8,1 
CG=Dubner;NTSC;COM1:19200,n,8,1;16;;AP 
CG=Duet;NTSC;COM1:19200,n,8,1;16;5000 

To set the CG directory open the ENPS client and select List Window rover → 
Set CG Directory. 

There are a number of other settings in the [CG] section of the C:\DOCUMENTS 
AND SETTINGS\ALL USERS\APPLICATION DATA\ENPS\ENPS.INI file that 
control how ENPS works with character generators. Refer to “Client 
Configuration” on page 71 for more information. 

Controlling Multiple Character Generators 
There are two methods for controlling multiple CGs: 

• Set up multiple ENPS client workstations with each one connected to a 
different character generator. 

• Connect multiple character generators to one machine. The 
C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI would require multiple connection strings: one 
active string and the other connection strings would need to be commented 
out by adding a semi-colon to beginning of the entry. Every time the CG 
operator wanted to select a different character generator the ENPS.INI 
would need to be modified. 

Copying Templates 
If a Folder Manager creates a character generator template that is needed in 
other groups you can copy the template files on the Primary Server. To copy 
templates from one group to another one complete the following steps: 

1.  Open the folder on the Primary Server’s ENPS WORK drive with the Primary 
Server name. Select the subdirectory with the name of the group that has the 
template then open the \G sub-folder. 

2. Copy the templates to the target group’s \G sub-folder. If the target group 
does not have any CG templates you will need to create the \G sub-folder. 
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Considerations for Specific Character Generators 
This section lists instructions for specific character generator manufacturers. 
Check your character generator’s documentation or contact the vendor for more 
information.  

Chyron 
Keyboard Control 

For Chyron character generators that have their own keyboards there are two 
methods for controlling the device: 

• Under PC control the Chyron operator uses the PC keyboard or mouse to 
control CGs sent to the Chyron’s A channel. Once CG control is enabled the 
operator can move forward or backward through the Rundown. Each CG 
command encountered within a story will load the appropriate template, fill 
input fields, and feed the air channel using the defined buffer page. 

• Under Chyron keyboard control the Chyron operator pre-loads the entire 
Rundown using templates within the defined directory on the Chyron. The 
operator will record the entire newscast as a series of message pages 
beginning at a single pre-defined starting point. The default value is 5000. 
This enables the operator to play the CGs in either or both channels or to 
apply “transform events” to the CGs under manual control. It also allows the 
operator to use the Next key on the Chyron keyboard to move forward 
through the newscast. With this option, the operator has full control over 
fonts, color, kerning and placement. 

Tab Fields 

All tab field pages must be built using machine fonts, not converted fonts, and tab 
stops must be set to Auto-Erase. Tab field order is extremely important, and 
duplicate tab field numbers will create problems. Using the Chyron, it is possible 
to have two fields incorrectly defined as the same tab stop number, which would 
disrupt any automated input. 

International Characters 

To use international characters with the character generator use Notepad to 
modify C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS. The settings below show an example of how to use international 
characters with the Chyron. These settings may not work if they have mapped 
these accent marks to different keys on the Chyron. Refer to your Chyron 
documentation for more information.  

[CG] 
CharMap=CG_MAP 
 
[CG_MAP] 
; Chyron accents mapping for French. 
; The Ï needs to come before other letters in the table  
; because of its hex value of 0xCF. 
Î=I0x1A; 
Ï=I%CF%22; 
î=i0x1A; 
ï=i%CF%22; 
À=A0x92; 
Â=A0x1A; 
à=a0x92; 
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â=a0x1A; 
È=E0x92; 
Ê=E0x1A; 
É=E0x94; 
Ë=E%CF%22; 
è=e0x92; 
ê=e0x1A; 
é=e0x94; 
ë=e%CF%22; 
Ô=O0x1A; 
ô=o0x1A; 
ó=o0x94; 
Ù=U0x92; 
Û=U0x1A; 
Ü=U%CF%22; 
ù=u0x92; 
û=u0x1A; 
ú=u0x94; 
ü=u%CF%22; 
Ç=C%CF%3B; 
ç=c%CF%3B; 
[CG_MAP]  
 
;Chyron accents mapping, Spanish  
Í=I0x94;  
í=i0x94;  
Á=A0x94;  
á=a0x94;  
É=E0x94;  
é=e0x94;  
Ó=O0x94;  
ó=o0x94;  
Ú=U0x94;  
Ü=U%CF%22;  
ü=u%CF%22;  
ú=u0x94;  
Ñ=N0x1D;  
ñ=n0x1D;  
¿=0xBD;  
¡=0x4;  
[CG_MAP]  
 
;Chyron accents mapping, Portuguese  
Í=I0x94;  
í=i0x94;  
Á=A0x94;  
á=a0x94;  
ã=a0x1D; 
É=E0x94;  
é=e0x94;  
Ó=O0x94;  
ó=o0x94;  
õ=o0x1D; 
Ú=U0x94;  
Ü=U%CF%22;  
ü=u%CF%22;  
ú=u0x94;  
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Ñ=N0x1D;  
ñ=n0x1D;  
¿=0xBD;  
¡=0x4;  

Pinnacle 
If you are using a Pinnacle Deko, it is suggested that you use the iNFiNiT! Driver. 
However, if you want to support Unicode output on a Pinnacle Deko use a text 
editor such as Notepad to modify C:\DOCUMENTS AND SETTINGS\ALL 
USERS\APPLICATION DATA\ENPS\CG.INI on the CG workstation.  

[Deko] 
Driver=6 

In the [CG] section of the local C:\DOCUMENTS AND SETTINGS\ALL 
USERS\APPLICATION DATA\ENPS\ENPS.INI file, here is an example of how 
you would reference the Deko driver: 

[CG] 
CG=Deko;;COM3:19200,N,8,1;1;5000 
Preload=0 
Timeout=2000 
Unicode=1 
BigEndian=1  

Aston 
Unicode and ANSI Support 

To support a mix of Unicode and ANSI on a number of Aston CGs, including the 
Aston Blue use a text editor such as Notepad to add the following lines to 
C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\CG.INI on the CG workstation: 

[AstonUnicode] 
Driver=7 

Below is an example of how you would reference the driver in the [CG] section: 

[CG] 
CG=AstonUnicode;;COM3:19200,N,8,1;1;5000 
Preload=0 
Timeout=2000 
Unicode=0 

International Characters 
[CG_MAP] 
; Chyron accents mapping, German 
; Character map for inclusion in ENPS.INI for Aston CG 
; Windows NT CODE PAGE 850 + Aston Roman/Greek font set 
; There is a mapping for every char from 128 to 255 to  
; avoid loss of communication following a checksum  
; error caused by truncating 8-bit chars to 7-bit.  
; Some Unicode currency chars above 255 are included.  
; This won't work because ENPS cannot cope with comments  
; after the mapping 
&H0080=00E1 ;€ Euro. Aston font may not contain character 
&H20AC=00E1 ;€ Euro. Aston font may not contain character 
&H0081=00AD ; � - dummy map 
&H0082=00D3 ;‚ 
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&H0083=00AA ;ƒ 
&H0084=00D0 ;„ 
&H0085=00CC ;… 
&H0086=00AC ;† 
&H0087=00AD ;‡ - char for many dummy maps 
&H0088=005E ;ˆ 
&H0089=00AE ;‰ 
&H008A=013C0053 ;Š 
&H008B=00BC ;‹ 
&H008C=0082 ;Œ 
&H008D=00AD ; � - dummy map 
&H008E=013C005A ;Ž 
&H008F=00AD ; � - dummy map 
&H0090=00AD ; � - dummy map 
&H0091=00CE ;‘ - dummy map 
&H0092=00CF ;’ - dummy map 
&H0093=00CE ;“ 
&H0094=00CF ;” 
&H0095=00CA ;• 
&H0096=00D4 ;– 
&H0097=00D5 ;— 
&H0098=007E ;˜ 
&H0099=00B2 ;™ 
&H009A=013C0073 ;š 
&H009B=00BB ;› 
&H009C=0083 ;œ 
&H009D=00AD ; � - dummy map 
&H009E=013C007A ;ž 
&H009F=013B0059 ;Ÿ 
&H00A0=00AD ; - dummy map 
&H00A1=00B8 ;¡ 
&H00A2=00A8 ;¢ 
&H00A3=00A7 ;£ - Normal kbd £ sign 
&H20A4=00A7 ;£ Unicode Pound sign 
&H00A4=00AB ;¤ 
&H00A5=00A9 ;¥ 
&H00A6=007C ;¦ 
&H00A7=00CD ;§ 
&H00A8=00AD ;¨ - dummy map 
&H00A0=00B0 ;© 
&H00AA=00D8 ;ª 
&H00AB=00BA ;« 
&H00AC=00DF ;¬ 
&H00AD=00D1 ; 
&H00AE=00B1 ;® 
&H00AF=00AD ;¯ - dummy map 
&H00B0=00B4 ;° 
&H00B1=00D6 ;± 
&H00B2=00C7 ;² 
&H00B3=00C8 ;³ 
&H00B4=00OE ;´ 
&H00B5=018B ;µ 
&H00B6=00A7 ;¶ 
&H00B7=00C9 ;· 
&H00B8=00D3 ;¸ 
&H00B9=00C6 ;¹ 
&H00BA=00B4 ;º 
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&H00BB=00B9 ;» 
&H00BC=00BD ;¼ 
&H00BD=00BE ;½ 
&H00BE=00BF ;¾ 
&H00BF=00B7 ;¿ 
&H00C0=01390041 ;À 
&H00C1=01390041 ;Á 
&H00C2=013A0041 ;Â 
&H00C3=013D0041 ;Ã 
&H00C4=013B0041 ;Ä 
&H00C5=013D0041 ;Å 
&H00C6=0080 ;Æ 
&H00C7=01430043 ;Ç 
&H00C8=01390045 ;È 
&H00C9=01380045 ;É 
&H00CA=013A0045 ;Ê 
&H00CB=013B0045 ;Ë 
&H00CC=01390049 ;Ì 
&H00CD=01380049 ;Í 
&H00CE=013A0049 ;Î 
&H00CF=013B0049 ;Ï 
&H00D0=00AD ;Ð - dummy map 
&H00D1=013E004E ;Ñ 
&H00D2=0139004F ;Ò 
&H00D3=0138004F ;Ó 
&H00D4=013A004F ;Ô 
&H00D5=013E004F ;Õ 
&H00D6=013B004F ;Ö 
&H00D7=00B5 ;× 
&H00D8=0086 ;Ø 
&H00D9=01390055 ;Ù 
&H00DA=01380055 ;Ú 
&H00DB=013A0055 ;Û 
&H00DC=013B0055 ;Ü 
&H00DD=01380059 ;Ý 
&H00DE=008F ;Þ 
&H00DF=0181 ;ß 
&H00E0=01390061 ;à 
&H00E1=01380061 ;á 
&H00E2=013A0061 ;â 
&H00E3=013E0061 ;ã 
&H00E4=013B0061 ;ä 
&H00E5=013D0061 ;å 
&H00E6=0081 ;æ 
&H00E7=01430063 ;ç 
&H00E8=01390065 ;è 
&H00E9=01380065 ;é 
&H00EA=013A0065 ;ê 
&H00EB=013B0065 ;ë 
&H00EC=01390069 ;ì 
&H00ED=01380069 ;í 
&H00EE=013A0069 ;î 
&H00EF=013B0069 ;ï 
&H00F0=008D ;ð 
&H00F1=013E006E ;ñ 
&H00F2=0139006F ;ò 
&H00F3=0138006F ;ó 
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&H00F4=013A006F ;ô 
&H00F5=013E006F ;õ 
&H00F6=013B006F ;ö 
&H00F7=00B6 ;÷ 
&H00F8=0087 ;ø 
&H00F9=01390075 ;ù 
&H00FA=01380075 ;ú 
&H00FB=013A0075 ;û 
&H00FC=013B0075 ;ü 
&H00FD=01380079 ;ý 
&H00FE=008E ;þ 
&H00FF=013B0079 ;ÿ 
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Chapter 18 
Peripherals 

This chapter shows you how to interface ENPS with these other peripheral 
devices: 

• Prompters 
• Omnibus Automation System 
• Hauppauge WinTV card 

Prompters 
If you are using a prompter connected to an ENPS client workstation through a 
serial cable the setup is configured in C:\DOCUMENTS AND SETTINGS\ALL 
USERS\APPLICATION DATA\ENPS\ENPS.INI in the [Prompter] section. 
Refer to “Client Configuration” on page 71 for more information. 

+WinPlus+ AP Prompter 
To install the +WinPlus+ AP software that comes with ENPS open 
C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI.  

In the [Prompter] section remove the semicolon from the line 
Driver=Winplus. Set the Path setting to the UNC path of the published 
prompter file area.  

Save ENPS.INI and close the file. Refer to the +WinPlus+ AP Prompter User’s 
Guide for more information. 

BDL Prompter 
ENPS updates the BDL prompter by sending text files to the ENPS Primary 
Server folder. BDL polls this folder for changes so for this process to work 
properly, the default remote polling must be enabled and the Dump to WinPlus 
option must be selected at all times in ENPS. In ENPS, a lightning bolt will 
appear in the bottom left-hand corner of the active Rundown when this feature is 
activated.  

To install the BDL prompter, complete the following steps: 

1.  On the BDL workstation, create a directory where the show files will be 
dumped.  

2.  In the BDL interface, select Options → Configuration → Constants. Set 
the Remote Input Directory to the name of the shared folder. You are can 
use a UNC name if you prefer to dump show files to a folder on the ENPS 
server. 

3.  Under the PC-Card tab, set the Line Standard to NTSC or PAL.  

4.  Go to Options → Newsroom and select ENPS.  

5.  On an ENPS client workstation use a text editor such as Notepad to open 
C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI.  
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6.  In the [Prompter] section remove the semicolon from the line 
Driver=WinPlus. Remove the semicolon from Path= line and enter the 
path to the shared folder.  

7.  In the BDL client, click the ENPS icon to bring up a list of shows dumped to 
WinPlus. Double-click on the show to prompt.  

8.  Press F9 to activate prompting.  

MOS Prompters 
You can control a prompter using a MOS ActiveX plug-in. This workstation 
should not be shut down and the WinPlus application should always be running 
so that a MOS message cue does not build up. 

To configure a MOS prompter select System Maintenance → MOS 
Configuration add the following settings for each prompter at your site: 

Setting Description 

MOS ID Name of your MOS server. This name is case-sensitive and 
should follow the following naming convention: 
<family>.<location>.<site ID>.<mos> 

Description Autoscript MOS Prompter 

IP IP address of the MOS prompter 

ActiveX If you are using the Autoscript ActiveX control enter  
wpcontrol.wpremote 

Program A MOS-enabled group that is homed to the local ENPS 
server. This can be a MOS group for a video or still store 
device. This allows the MOS prompter to send a list of all 
messages to ENPS when requesting MOS-active Rundowns 
from the prompter and acts like a message cue.  

If you do not want to use an existing group create a new 
group with your site’s call letters in the ID and have it homed 
to the Primary Server. In the description enter several 
hyphens so users will know not to open or search the group. 

MOS Version 2.8 

Local DragDrop Off 

Story Send Checked  

OmniBus Automation System 
These instructions apply to the OmniBus serial interface. If your site will be using 
the MOS ActiveX plug-in to control the OmniBus system you should refer to the 
vendor’s documentation for setup and configuration information. 
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Configuration Settings 
Use a text editor such as Notepad to open  C:\DOCUMENTS AND 
SETTINGS\ALL USERS\APPLICATION DATA\ENPS\ENPS.INI. Add the 
following serial automation control settings: 

[Automation] 
Driver=OmniBus 
; Port settings 
Port=COM1:9600,e,7,1 
; Store logs to AUTOTRAC.LOG in the TEMP folder. 
Trace=1 
; Display a message box each time a command  
; is sent to the device. 
Debug=1 

Automation Fields 
ENPS allows multiple Rundowns to drive the device at the same time. The 
Rundowns are sent in the order in which automation was activated. Changes to 
the Rundown are reflected in the OmniBus system in real time. The following 
fields are required on automation dialogs: 

Clip   Name Mandatory 
Still  Name Mandatory 
CG   Template Mandatory, Page Mandatory 
Inset  Name Mandatory 
Camera Name Mandatory  
Logo  Template Mandatory 
Event  Length, Name Mandatory 
OS   Name Mandatory 

The field's entry pattern is expected to be in the format mm:ss, to which leading 
and trailing 00s are added (e.g. 00:mm:ss:00) for relaying to OmniBus. If the field 
is blank 00:00:00:00 is passed. Event Length is ignored for the purposes of 
Rundown calculations. You will see Manual and Automatic buttons along with the 
fields: "In at:[mm:ss]" and "Event Length: [mm:ss]". The latter is sent as the 
"duration" field to OmniBus. When set to Manual the fields are hidden and the 
normal CLIPM OmniBus command structure is used. When it is set to Automatic 
the fields are visible and enabled and the CG command is sent to OmniBus using 
the CLIP+ command structure to define the event.  

Syncing Automation Devices 
Automation error logging shows when the facility is activated/deactivated. 
Because OmniBus cannot be queried for status or playlist contents ENPS 
assumes the OmniBus system state does not change from ENPS session to 
ENPS session. If the devices get out of sync stop the automation control from all 
Rundowns, clear all playlists from the automation choice of the Rundown menu, 
then reactivate automation on the Rundowns. 

Hauppauge’s WinTV Card 
ENPS supports Hauppauge’s WinTV PCI products. Users can watch almost any 
video source in the lower Editing Window of an ENPS client. This can help make 
the most of limited desk space in studios, control rooms, and crowded 
newsrooms. Through external audio/video inputs, you can connect to a regular 
antenna, a cable television feed, in-house video, or a satellite receiver, each with 
up to 125 channels, or a VTR or video camera.  
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WinTV PCI boards work with most PCI VGA cards, although there are 
exceptions. For more information on the Hauppauge WinTV add-in boards go to 
http://hauppauge.com. 

The WinTV card and version 2.0 or later of its drivers should be installed. 
Additionally, the hcwWinTV.ocx file must be copied from the \ENPS\WINSYS 
folder on the server to the \WINDOWS\SYSTEM32 folder on the client. Register 
the file with the following command: REGSVR32 hcwWinTV.ocx 

Select Fourth folder rover → System Maintenance → MOS Configuration, 
and add the following settings: 

ID WinTV 

Description WinTV 

ActiveX hcwWinTVControl.hcwWinTVocx 

On workstations where the WinTV OCX is installed the Media rover → WinTV 
option will appear.  

A command strip along the left-hand side of the resizable window allows users to 
change channels, volume, and video source, or switch to full-screen video 
playback. Right-clicking will present pop-up menus to change source and 
channels, adjust the image (contrast, brightness, saturation, hue), freeze a 
frame, copy the current frame to the clipboard, print the current frame, or even 
save a frame to disk in JPEG, BMP, TIFF or GIF format.  
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Chapter 19 
Routine Maintenance 

This section lists the routine maintenance procedures that all sites should 
perform on a daily, monthly, and periodic basis to help ensure trouble-free 
operation of ENPS.  

Daily Checks 
• Make sure NOM Watcher and the other ENPS processes are running. 
• Verify that the time on the server is correct  
• Open Computer Management  select Services and Applications → 

Indexing Service. If the Docs to Index value is greater than 1000 or is not 
reducing, there may be a problem with indexing. 

• Open the NOM and select Window → MOS. Check there are no MOS 
messages in the outbound queue that are not moving to the MOS device.  

• Check the Application and System logs for errors or warnings. 
• Check the RAID array management software for errors or warnings. 
• Check that the disk is defragmented. If you are using Windows 2008 Server 

you can figure the operating system to defragment volumes daily. To enable 
this feature right-click on a drive and select the Tools tab. Select the 
volumes and the time of day when they should be defragmented. This 
should be at the point of the lowest workload on the server. If your site uses 
Windows 2000 Server or Windows 2003 Server can use DISKEEPER to 
defragment volumes daily. 

Weekly Checks 
• Back up the following folders:  

\%PRIMARY-MACHINE-NAME%  
\%PRIMARY-MACHINE-NAME%_H  
\%PRIMARY-MACHINE-NAME%_Inactive  
\%BUDDY-MACHINE-NAME%  
\%BUDDY-MACHINE-NAME%_H  
\ENPS  
\NWP  
\NOM  
\COMMON 

• Check the ENPS Support Forum for ENPS updates. 
• Check the Buddy process is working correctly by checking that the Buddy 

Process queue in Maint on the ENPS Primary Server is not filling up. Refer 
to “Buddy Process Sync” on page 141 for more information. 

• Open the command prompt and run CHKDSK if there will not be a newscast 
for at least two hours. 

• Install the latest Windows Service Pack. Service packs are available from 
http://www.microsoft.com but do not install the IIS Lockdown utility. 

• Verify that the drives have sufficient free disk space.  
• On the Primary Server check the folder with the server name. Use a text 

editor such as Notepad to open DIRSIZE.TXT and check that the number 
of files in a folder is not causing a performance problem on the server. This 
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can happen in folders not automatically maintained by NOM Maint such as 
Personal areas, and MOS folders. Generally, folders should not contain 
more than several thousand files. 

• Check the number of directories in the NWS folder. There should be one per 
hour that news wires are retained (e.g. 96). Too many directories indicates 
that wires are not purging correctly. 

• Update copies of your operating system Emergency Repair Disks. This disk 
can be used to repair an operating system if the files become corrupt. 
Create the ERD by opening the command prompt and entering RDISK /S 
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Chapter 20 
Language Support 

ENPS works with a large number of languages in countries all over the world. 
This section will help you set up ENPS to work with the needs of your site. 

Keyboard Support 
It is up to the user to select the keyboard layout for a story. For new stories, 
ENPS will use the currently active keyboard layout. Users can have multiple 
keyboard layouts, even for the same language. ENPS will attempt to find an 
installed keyboard layout for a language that is compatible with a selected story 
(rather than requiring the exact sub-language). For example, if a user selects a 
British English story but no British keyboard layout is installed, ENPS will use any 
available English keyboard layout. 

If characters for your local language such as á, è, or ü are not available on a 
standard keyboard open the Control Panel and select Keyboard. Select the 
Input Locales tab and click Add to add your language. Changes to the keyboard 
layout in the operating system will be reflected in ENPS. 

Setting the Local Language 
You can customize the text in the ENPS interface to reflect the language spoken 
at your site by translating the entries in the language file on the Primary Server 
by completing the following steps: 

1.  Locate either a two-letter base language code or a four letter dialect code 
from one of the following tables that best describes the language spoken at 
your site: 

Base Language Codes 

Language Code Language Code 

Afrikaans AF Latvian LV 

Albanian SQ Lithuanian LT 

Arabic AR Macedonian MK 

Basque EU Malay MS 

Belarusian BE Maltese MT 

Bulgarian BG Norwegian NO 

Catalan CA Polish PL 

Chinese ZH Portuguese PT 

Croatian HR Raeto-Romance RM 

Czech CS Romanian RO 

Danish DA Russian RU 

Dutch NL Serbian-Cyrillic SR 

English EN Setsuana TN 
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Estonian ET Slovenian SL 

Farsi FA Slovak SK 

Finnish FI Sorbian SB 

Faeroese FO Spanish ES 

French FR Sutu SX 

Gaelic GD Swedish SV 

German DE Thai TH 

Greek EL Turkish TR 

Hebrew HE Tsonga TS 

Hindi HI Ukrainian UK 

Hungarian HU Urdu UR 

Icelandic IS Vietnamese VI 

Indonesian IN Xhosa XH 

Italian IT Yiddish JI 

Japanese JA Zulu ZU 

Korean KO   

Base Dialect Codes 

Language/ 

Dialect 

Code Language/ Dialect Code 

Arabic-U.A.E. ARAE French-Canada FRCA 

Arabic-Bahrain ARBH French-Luxembourg FRLU  

Arabic-Algeria ARDZ French-Switzerland FRCH 

Arabic-Egypt AREQ German-Austrian DEAT 

Arabic-Iraq ARIQ  German-Lichtenstein DELI  

Arabic-Jordan ARJO German-Luxembourg DELU  

Arabic-Kuwait ARKW German-Switzerland DECH 

Arabic-Lebanon ARLB  Italian-Switzerland ITCH  

Arabic-Libya ARLY Portuguese-Brazil PTBR  

Arabic-Morocco ARMA Romanian-Moldova ROMO 

Arabic-Oman AROM Russian-Moldova RUMO 

Arabic-Qatar ARQA Sami-Norway SAMI 

Arabic-Saudi 
Arabia 

ARSA Spanish-Argentina ESAR  

Arabic-Syria ARSY Spanish-Bolivia ESBO  

Arabic-Tunisia ARTN Spanish-Chile ESCL  
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Arabic-Yemen ARYE Spanish-Columbia ESCO  

Chinese-PRC ZHCN Spanish-Costa Rica ESCR  

Chinese-Hong 
Kong 

ZHHK Spanish-Dominican 
Republic 

ESDO 

Chinese-
Singapore 

ZHSG Spanish-Ecuador ESEC 

Chinese-Taiwan ZHTW Spanish-Guatemala ESGT  

Dutch-Belgium NLBE  Spanish-Honduras ESHN  

English-
Australia 

ENAU Spanish-Mexico ESMX 

English-Belize ENBZ  Spanish-Nicaragua ESNI  
 

English-Canada ENCA Spanish-Panama ESPA 

English-Ireland ENIE  Spanish-Peru ESPE  

English-Jamaica ENJM Spanish-Puerto Rico ESPR  

English-New 
Zealand 

ENNZ Spanish-Paraguay ESPY  

English-South 
Africa 

ENZA Spanish-El Salvador ESSV  

English-Trinidad ENTT Spanish-Uruguay ESUY  

English-United 
Kingdom 

ENGB Spanish-Venezuela ESVE  

French-Belgium FRBE  Swedish-Finland SVFI 

2. Open \COMMON\G_SUPPORT\MASTERS on the ENPS WORK drive. If you see 
a file with the prefix g_lang followed by the two or four letter code for your 
local language copy that file to \COMMON\G_SUPPORT on the ENPS WORK 
drive. 

 If you do not see your local language file in the MASTERS folder open 
\COMMON\G_SUPPORT on the ENPS WORK drive. Copy G_LANGEN to a new 
file with the prefix g_lang followed by the two or four character code. For 
example, if you’re your site’s local language is Chinese call this file 
g_langzh. If the local language is Spanish and you are Mexico name this 
file g_langesmx.  

3.  Select Fourth Folder rover → System Maintenance → Language 
Resources. Highlight your language’s resource file in the list on the left. 
Click Edit.  

 You can now make changes to how text is displayed in the ENPS interface 
by translating the English text strings after the equal sign to text in your local 
language. If you need to refer to the file’s original text the masters are stored 
in \COMMON\G_SUPPORT\MASTERS on your ENPS WORK drive. 

4.  Once you are done making changes click Validate.  
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Working in Two Languages 
Complete the following steps if your site has ENPS clients that need to display 
two languages: 

1.  Open the Windows Control Panel and select Regional and Language 
Options. Click the Languages tab and then click Details. In earlier versions 
of Windows, these options can be found under Keyboards. 

2.  In the Text Services and Input Languages dialog, click Add. Select the 
language that you want to add to the current Windows language. Click Ok. 

3.  The language bar icon will appear in the Windows taskbar with a blue icon 
which you can use to switch to the other language. It is possible to switch 
between languages using left Alt+Shift although this key combination is 
configurable. 

Each language will have special its own combinations to produce characters. In 
Spanish, for example, to create an accented character press the single quote ` 
key plus a letter; plus and equal symbols generate: ¡ ¿ and the ; key produces ñ. 

In ENPS 6.00.0045 a change was made to ensure search results are consistent 
when searching for phrases with mixed English and non-English characters, e.g. 
Annika Östberg. The ENPS server must be re-indexed for this correction to take 
effect. For instructions on re-indexing your ENPS server refer to the instructions 
on using INDEXDEL.EXE on page 167. 

Considerations for Specific Languages  
• ENPS is compatible with international versions of Windows 2000 and 

Windows XP. 
• Some locale-specific story menu items (Upper/lower case, Fonts, and 

Dictionary/Thesaurus/Pronouncer) are automatically disabled and not visible 
for languages not using the ANSI (1252) code page. 

• Certain code pages may have a delay when opening stories. If this is the 
case, enable the UseSingleFont option in the Global Configuration 
Options 

• If you are using a double-byte character language and your output to the 
CG is being sent incorrectly, add the setting UseSBCGOutput=1 to the 
[CG] section of the C:\DOCUMENTS AND SETTINGS\ALL 
USERS\APPLICATION DATA\ENPS\ENPS.INI on clients connected to 
the CG device. 

Arabic and other Right-To-Left Languages 
• Right-to-left language support is available only on versions of Windows that 

support it (e.g., Arabic, Hebrew), allowing users to view/edit stories with 
Arabic and Pan-European text. 

• Users in the Arabic locale have the option to view text either left to right 
(LTR) or right to left (RTL). To override the default of RTL, select Personal 
Settings and select LTR. 

• Titles which include a number (e.g. “500 News”) may sometimes display in 
the List Window in an incorrect sequence. This is due to a limitation of the 
Windows right-to-left conversion process. 

• If your language is Farsi you should specify a font ENPS can use to display 
Farsi characters if a story’s current font cannot be found or cannot properly 
render the Farsi character. You can either set the FarsiTextBoxFont for 
all clients in the Global Configuration Options or in the C:\DOCUMENTS AND 
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SETTINGS\ALL USERS\APPLICATION DATA\ENPS\ENPS.INI to 
specify it for a particular workstation. 

• An C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI setting SearchAutoKeyboard lets RTL language 
users override or specifically enable an ENPS feature which prevents an 
operating system level conflict that can cause the keyboard language being 
switched in some ENPS text boxes, such as the Search box. 

• To fully support printing right-to-left languages such as Arabic you must add 
the following setting to the [ENPS] section for a workstation’s local 
ENPS.INI file: 
[ENPS] 
RTLPrint = 1 

If you are having trouble displaying Arabic characters correctly add the following 
character mappings to the \NWP\NWP.INI on the ENPS WORK drive: 

[StringTransEBU] 
<Restrictions>=&H0052;&H0065;&H0073;&H0074;&H0072;&H0069
;&H0063;&H0074;&H0069;&H006f;&H006e;&H0073;&H000d;&H000a
;&H000d;&H000a 
</Restrictions>= 
<Dopesheet>=&H0044;&H006f;&H0070;&H0065;&H0073;&H0068;&H
0065;&H0065;&H0074;&H000d;&H000a;&H000d;&H000a 
</Dopesheet>= 
<Shotlist>=&H0053;&H0068;&H006f;&H0074;&H006c;&H0069;&H0
073;&H0074;&H000d;&H000a;&H000d;&H000a 
</Shotlist>= 
<ItemID>=&H0049;&H0074;&H0065;&H006d;&H0049;&H0044;&H000
d;&H000a;&H000d;&H000a 
</ItemID>= 
&H000d;&H000a;&H000d;&H000a;&H000d;&H000a=&H000d;&H000a;
&H000d;&H000a 
&H003c= 
&H003d= 
&H003e= 
&H0040= 
&H005e= 
 
[StringTransAReA] 
&H064d=&H0652 
&H064c=&H0651 
&H064b=&H0650 
&H064a=&H064d 
&H0649=&H064c 
&H0645=&H0643 
&H0644=&H0641 
&H0639=&H063a 
&H0638=&H0639 
&H0637=&H0638 
&H0646=&H0644 
&H0648=&H0646 
&H0647=&H0645 
&H203a=&H0644;&H0627 
&H00ac=&H060c 
&H00bb=&H061b 
&H00d7=&H0637 
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&H00e0=&H0640 
&H00e2=&H0642 
&H00e7=&H0647 
&H00e8=&H0648 
&H00e9=&H0649 
&H00ea=&H064a 
&H00eb=&H064b 
&H00ee=&H064e 
&H00ef=&H064f 
&H003c= 
&H003d= 
&H003e= 
&H0040= 
&H005e= 
 
[StringTransTAra] 
&H0041=&H0621 
&H0042=&H0622 
&H0043=&H0623 
&H0044=&H0624 
&H0045=&H0625 
&H0046=&H0626 
&H0047=&H0627 
&H0048=&H0628 
&H0049=&H0629 
&H004a=&H062a 
&H004b=&H062b 
&H004c=&H062c 
&H004d=&H062d 
&H004e=&H062e 
&H004f=&H062f 
&H0050=&H0630 
&H0051=&H0631 
&H0052=&H0632 
&H0053=&H0633 
&H0054=&H0634 
&H0055=&H0635 
&H0056=&H0636 
&H0057=&H0637 
&H0058=&H0638 
&H0059=&H0639 
&H005a=&H063a 
&H0061=&H0641 
&H0062=&H0642 
&H0063=&H0643 
&H0064=&H0644 
&H0065=&H0645 
&H0066=&H0646 
&H0067=&H0647 
&H0068=&H0648 
&H0069=&H0649 
&H006a=&H064a 
&H003c= 
&H003d= 
&H003e= 
&H0040= 
&H005e= 
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&H000d;&H000a;&H000a= 

Eastern European Languages 
• Some characters from the ANSI 1250 codepage such as the Polish “ñ”, 

Slovak “ò” and Czech “ì”, as well as other characters following them on the 
same line, may be displayed in an incorrect font after a story containing 
such characters is saved and reopened. This is due to a Microsoft limitation 
of the presentation of these Unicode characters. 

• Windows XP is specifically required for clients using Azeri, Kazak, Uzbek 
and Kyrgyz language support. Earlier versions of Windows lack proper 
locale, codepage and character set/font support for these languages. 

Swedish 
• If you are in a Swedish locale, some instances of the date sort order of 

Search items may be displayed incorrectly. To correct this issue, add the 
entry LocalSort=1 in the [ENPS] section of the C:\DOCUMENTS AND 
SETTINGS\ALL USERS\APPLICATION DATA\ENPS\ENPS.INI. 

Chinese 
• Far East language support is available only in the Far East versions of 

Windows, without which Chinese stories cannot be viewed. With it, users 
can view/edit stories with the respective Far East glyphs and Pan-European 
text. 

• To ensure that forward search on agency copy and highlighting in Chinese 
works correctly, complete the following steps: 

1.  In the Global Configuration Settings add ChineseCILocale=NEUTRAL and 
UnicodeForwardSearch=1.Restart the ENPS client. 

2.  In the NWP.INI, ensure that the parameter Unicode=1 is included in the 
[NWP] section. 

3.  Locate the following key in the registry on the server: 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ 
ContentIndex\Language\Neutral 

If you are using Simplified Chinese, set the values for this key as follows: 

Field Value 

NoiseFile noise.chs 

StemmerClass {78fe669a-186e-4108-96e9-77b586c1332f} 

WBreakerClass {9717fc70-c1bc-11d0-9692-00a0c908146e} 

These values should be consistent with the values in this key: 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ 
ContentIndex\Language\Chinese_Simplified 

If you are using Traditional Chinese, set the values for this key as follows: 

Field Value 

NoiseFile noise.cht 

StemmerClass {78fe669a-186e-4108-96e9-77b586c1332f} 
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WBreakerClass {954F1760-C1BC-11D0-9692-00A0C908146E} 

4.  Locate the following key: 

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ 
ContentIndex 

For the DLLsToRegister value, if it contains Query.DLL, remove it from 
the value data. 

Mapping International Characters with the CG 
Character Generator character mapping supports different languages and 
character sets and general "string swapping" is available with embedded 
unprintable character support. In the C:\DOCUMENTS AND SETTINGS\ALL 
USERS\APPLICATION DATA\ENPS\ENPS.INI file on the workstation 
controlling the CG device add the following in the [CG] section: 

[CG]  
CharMap=CG_Map  

Create a new [CG_Map] section and use the following format for the new 
character map:  

[CG_Map]  
SourceString=TargetString  

For example:  

[CG_Map]  
Dog=Cat  

Swaps the string "Dog" with the string "Cat.”  

More often, however, the requirement will be to map certain foreign language or 
unprintable characters. Accordingly, source and target string formats are 
enhanced to contain the following "escape" options: 

Code Escape Option 

&Hhhhh; BASIC-style hex string; convert the hhhh value to a Unicode 
character represented by that hex value. Note that if the 
&Hhhhh is at the end of the Source or Target string, the 
semicolon is optional (thus providing backward compatibility 
with prior ENPS versions which used the Aston driver 
character mapping capability). Otherwise, the semi-colon is 
required because hhhh is a variable-length string consisting 
of from one to four hex digits. 

0xhhhh; C-style hex string; identical to &H above. 

%hh HTML-style "byte" escape string; must have two hex digits. 

%uhhhh HTML- style "word" escape string; must have four hex digits. 

\nnn Lotus-style "byte" escape string; must have three decimal 
digits. 

For example: 

• &H20=\160 maps a space into a Windows non-breakable space. 
• %20=xxx map spaces to the string "xxx". 
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• %20=ho0x21; maps all spaces to the string "ho!". 

Due to the above escapes, the "&", "%", and "\" characters if required must be 
escaped using one of the methods above. For example: 

• % = %25 
• & = %26 
• \ = %5C 

The number of characters in a mapping must agree only with the same number 
of characters in the incoming data's category field, in effect allowing wildcarding 
and shorter lists of mappings for similar category groupings.  

Operators can jump between items by recalling the first page of each story and 
easily make changes by opening the story within the Rundown, then editing the 
CG information. Once the story is saved, the updated information is sent to the 
CG. This is the safest control method, since any changes made via the CG 
keyboard are downstream of the control PC, and later changes made to the 
ENPS Rundown can overwrite the CG operator's previous changes. 

CG character mapping supports different languages and character sets. The 
MapOneToOne option handles possible "circular" mappings. For example, a map 
might include these settings: 

0xCD=0xd6 
0xD6=0x99 

In this example, the hex value CD is mapped to D6, then D6 is mapped to 99. 
Essentially, then, CD is mapped to 99, which may not have been intended. This 
behavior can be changed in the [CG] section of the C:\DOCUMENTS AND 
SETTINGS\ALL USERS\APPLICATION DATA\ENPS\ENPS.INI file. 

[CG] 
MapOneToOne=x 

When set to 1 mapping is one-to-one and any "circular" references are not 
processed. If the value is set to 0 (the default), circular mapping is allowed for 
legacy CG support and also allows mapping single character to a string or a 
string to a string. 

Double Byte Character Sets 
To support DBCS languages such as Chinese use a text editor such as Notepad 
to modify C:\DOCUMENTS AND SETTINGS\ALL USERS\APPLICATION 
DATA\ENPS\ENPS.INI to include the following: 

[CG] 
CharMap=char_map_name 
[char_map_name] 
xxx=yyyyyyyy 
xxx=yyyyyyyy 
xxx=yyyyyyyy 

In this example, char_map_name is a name given to a character map, xxx is 
the Unicode representation of the character in text, and yyyyyyyy represents 
the characters that must be sent to the CG to generate the character. The driver 
includes a linefeed to close the buffer string and will handle starting another 
buffer string for the remainder. 
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Chapter 21 
Troubleshooting 

This section contains troubleshooting steps for technical issues that you or your 
site’s users may encounter in ENPS. If you need additional help refer to the 
“Technical Support” section on page 6. 

Authentication 
User sees an incorrect warning that the license key is about to expire. 

In the Windows Control Panel check the Regional Settings on both the client 
workstation and the server to make sure their time and date formats are the 
same.  

User sees the message: “The credentials supplied to ENPS conflict with an 
existing set of credentials. Please contact your System Administrator.” 

ENPS only allows connections if the user can be authenticated in the Windows 
domain and the user does not have any other open sessions. This message may 
be displayed because the local Windows credentials conflict with the domain 
credentials supplied. This most commonly occurs when using a VPN connection. 

User sees the message “BAD_PASSWORD followed by unsuccessful 
directory scan when accessing \\SERVERNAME\ENPS.” 

• On the client workstation open a command line and enter 
\\<SERVERNAME>\ENPS where <SERVERNAME> is the NetBIOS name or 
IP address of your Primary Server. If the shared folder displays a prompt for 
the user’s login credentials it indicates that the user does not have the 
necessary permissions for the Windows domain. 

• Make sure that the user does not have an account on the server with a 
different password than the one on the local client. 

User sees the message “Socket error [10061] / Connection forcefully rejected.” 

The ENPS client cannot connect to the Primary Server. Refer to the “Network” 
troubleshooting section on page 163 for more information. 

To open ENPS in off-line mode right-click the ENPS shortcut and select 
Properties. Change the shortcut’s target to "C:\Program 
Files\ENPS\ENPS.EXE /LOCAL" and click OK.  

User sees the message “Form_load_splash_error [339] Line = 65 rich TX 
32.OCX.” 

The client workstation has the wrong version of an ENPS file. Re-install the 
ENPS client by completing the following steps: 

1.  Back up C:\Documents and Settings\All Users\Application 
Data\ENPS\ENPS.INI to a temporary folder.  

2. Delete C:\Program Files\ENPS.  



The Associated Press 163 
 

3.  At the command prompt enter \\<PRIMARY SERVER>\ENPS\SETUP.EXE 
where <PRIMARY SERVER> is the NetBIOS machine name or IP address of 
your Primary Server.  

4. Restore C:\Documents and Settings\All Users\Application 
Data\ENPS\ENPS.INI from the temporary folder. 

User sees the message “Local Administrator rights are required.” 

1. Run a virus checker on the client workstation to rule out malware affecting 
user privileges. 

2.  Confirm that the ENPS shortcut is pointing to the correct folder by right-
clicking on the shortcut and selecting Properties. 

3. Ensure that the ENPS share on the server is set to Read-only. 

4.  Make sure that the date/time formats on the server and clients match. 

User sees the message “Form_Load frmUDP [10048] Address in use. Flow 
network connection has been detected.” 

Check the server for duplicate server processes such as multiple instances of the 
NOM. 

User sees the message “Socket error [10061] Connection forcefully rejected.” 

Select Fourth Folder Rover → System Maintenance → Servers. Make sure 
that the IP address for each server is correct.  

MOS 
Before you contact ENPS Support you should check the following items: 

• Is the Rundown’s MOS Control Active property selected? 
• Are the proper MOS IDs are selected in the Rundown’s MOS Story Send 

property? 
• Was the ENPS Primary Server or the MOS server updated since the 

connection issue began? 
• What time did the issue occur? 
• Was MOS logging enabled when the issue took place? To enable MOS 

logging open the News Object Manager and select Window → MOS. Check 
to see if there is there a queue of Inbound or Outbound items then select 
the Log box for both columns. These logs will be stored in the \NOM\LOGS 
folder on the ENPS WORK drive.MOS logs are stored as XML with filenames 
that match the MOS Server name. 

• Which Rundowns are having issues? Is there a specific story in the 
Rundown that is having MOS connection problems? Is there a specific MOS 
Item Reference which is causing a problem?  

• Has any information changed recently in the MOS Configuration table? 
• Can the ENPS server successfully ping the MOS server? Can ENPS telnet 

to the ports 10540 and 10541 on the server? 
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There is a confirmed connection between the ENPS Primary Server and the 
MOS server but certain stories are not updating 

If the story has a lock symbol across the top left corner close the story and 
updates for the story will be incorporated. ENPS buffers all MOS updates while 
the story is under edit lock. 

Network 
Client workstation does not receive updates to Rundowns or wires. 

This problem can arise if a large number of UDP packets are lost on the network. 
This issue may be caused by the firewall on the client or a router that is block 
blocking TCP/UDP port updates. Check the following possible causes: 

• In the Control Panel for the client workstation open the Windows Firewall. 
Make sure that it is either turned off or that it has the necessary ports open 
for communicating with the ENPS server. For a list of ports refer to “Port 
Assignments” on page 109. If the workstation has a third-party firewall 
running you should also check to see if it has the ENPS network ports 
enabled. 

• If the updates are not reaching multiple workstations check to see if those 
computers are on a different subnet than the other workstations. If they are, 
make sure that the appropriate broadcast IP address information for the 
subnet is listed in the [Reflectors] section of both the \NOM\NOM.INI 
and the \NWP\NWP.INI on the Primary Server. Refer to “Reflectors” on 
page 110 for more information. 

There are two methods to determine if your site is losing an unusally high 
number of packets: 

Option 1: Enable Packet Table to Determine Packet Loss 

1.  Use Notepad or another text editor to open \NWP\NWP.INI on the ENPS 
WORK drive. In the [TCPIP] section set PacketVersion=2. If this value 
was set to 1 you may want to set it back to its original value when you 
complete these steps. 

2.  Close the ENPS client if it is open. Use Notepad or another text editor to 
open C:\Program Files\ENPS\ENPS.INI and change the following 
settings: 

[ENPS] 
CtrlAlt=1 
 
[TCPIP] 
UDPInfo=1 
PacketVersion=2 

3. Open the ENPS client. Open a story in a public folder, save it, then press 
Ctrl+Alt+U. Note the value on the counter then close it. Press 
Ctrl+Alt+U again and look at the counter. Each time you change the story 
and save it you should see the UDP count increase. 

Option 2: Use FlushUDP to Determine Packet Loss 

1. Use Notepad or another text editor to open C:\Program 
Files\ENPS\ENPS.INI. In the [TCPIP] section add the setting 
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FlushUDP=1 then add this setting to in the \NOM\NOM.INI on the Primary 
Server’s ENPS WORK drive. 

2. Open C:\Program Files\ENPS\UDP on the client workstation and 
\NOM\UDP on the Primary Server’s ENPS WORK drive. Each of these folders 
tracks UDP traffic. If the file count in either of this folders is substantially 
different from the other you should investigate why there is UDP packet loss 
on your network.  

Temporary Workaround for Packet Loss Issues 
If one of the methods above shows your site’s network is losing a large number 
of packets between the server and client workstations it is important for you to 
resolve the network problem as soon as possible. 

As a temporary workaround you can configure the News Object Manager to send 
all UDP packages multiple times to ensure that the client receives them; the 
client will ignore redundant messages. To enable this option open the News 
Object Manager on the Primary Server. Select Window → NOM Configuration 
Status and set UDP Repeats to a number between 1 and 10. Enabling this 
option will increase network traffic. 

Socket closes unexpectedly. 

The Primary Server checks sockets on a set time interval to check for non-
responsive ports. If a port is non-responsive the socket will be closed. To 
increase this interval use Notepad or another text editor to open \NOM\NOM.INI 
on the ENPS WORK drive. In the [NOM] section set SocketTimeout to a higher 
value. The default is 10 seconds.  

If the socket closes when there is a heavy workload on the server the error 
message may be generated because the Primary Server is busy satisfying other 
client requests. Use Notepad or another text editor to open C:\Documents and 
Settings\All Users\Application Data\ENPS\ENPS.INI on the client 
workstation. Increase the value for the ConnectTimeout setting. The default 
value is 5 seconds and the maximum is 60. 

ENPS launches in Local Storage mode when connected to the network. 

Check the following possible causes: 

• Make sure the shortcut to ENPS.EXE does not include the /LOCAL switch. 
• On the client workstation open a command line and enter 

\\<SERVERNAME>\ENPS where <SERVERNAME> is the NetBIOS name or 
IP address of your Primary Server. If the shared folder displays a prompt for 
the user’s login credentials it indicates that the user does not have proper 
permissions for the Windows domain. 

• Select Fourth Folder Rover → System Maintenance → Servers. Make 
sure that the IP address for the server is correct. 

• Select Fourth Folder rover → System Maintenance → Staff. Make sure 
the user’s ID matches the user’s Windows login name. 

• Select Fourth Folder rover → System Maintenance → Groups. Make 
sure that the user has the correct server listed in the Server column. 
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Performance 
Slow performance on the server or on client workstations. 

Performance issues can arise from a number of factors. If you experience 
slowdown on an ENPS server or its client workstations check the following: 

• If you are using ENPS 4 upgrade to ENPS 5 or later. ENPS updates often 
include changes that improve performance. 

• Check the server and the client workstations for folders that have 10,000 or 
more files in a single folder. These folders should be reduced by moving 
files to other folders or by deleting unnecessary files.  

• Make sure the server’s archives are being stored on the Archives drive 
instead of on the ENPS WORK drive. 

• Close non-essential applications on the client workstation. If you are running 
real-time antivirus software on the client temporarily disable it to see if the 
antivirus application is causing the slowdown. Refer to “Antivirus Software 
Recommendations” on page 9 for more information. 

Prompters 
AP +WinPlus+ prompter is not being updated 

This can happen if a user dumps a show to the prompter then closes the 
Rundown. The connection to the prompter has been lost but the files are still 
stored in the prompter. The user should first re-open the Rundown and select 
Dump to WinPlus to see if the prompter can be updated.  

If ENPS cannot locate the \PROMPTER folder because of a network problem it 
may cause a serious error when the user selects Dump to WinPlus. If such a 
problem occurs it is recommend that you set up a private channel between the 
workstation and the Primary Server. Refer to “Network Settings” on page 109 on 
for more information on how to set up private channels. 

Rundowns 
User sees the message “Resize column [381] Invalid property array index.” 

A custom field on your Primary Server was not properly saved to your site’s 
Central Server. On the Primary Server open the News Object Manager and 
select File → Reload global tables then restart the client.  

Rundown is missing. 

Perform a Search to locate the Rundown. Make sure the option to search the 
local Waste Bin is selected along with the Waste Bin for the group where the 
Rundown was stored. 

The TrashDays setting in the Global Configuration Options controls how long 
items are retained in the Waste Bin. For more information on this setting refer to 
“Global Configuration Settings” on page 44.  

User sees the warning message “Proceed with edits absent a lock?” 

A user attempted to make a change to a System Maintenance window that is 
open by another user. If the user selects No the user will be able to view 
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information in the window but cannot save changes. If the user selects Yes 
whoever clicks Save last will commit setting changes to the server; the other 
user’s changes will be discarded. 

table.  

Error message [9] Subscript out of Range 

There are a number of scenarios which can cause this error. Note the title of the 
blue message box and the context in which it appeared before you contact ENPS 
Support. Refer to “Technical Support” section on page 6 for the contact number. 

Rundown dates in the List Window do not appear in the local format. 

You can control how dates are displayed in the local language by selecting  
Fourth Folder rover → System Maintenance → Language Resources. Select 
the local language file on the left side of the screen then change the date format 
with the following settings: 

ENPSShortDateTime=mm/dd/yy hh:nn  
ENPSLongDateTime=mm/dd/yyyy hh:nn 

Search 
Search results are missing or incomplete. 

If users enters search parameters and see an * character in the List Window it 
indicates that no results were found. Users should adjust their Search terms or 
try other searches. 

If multiple users are not getting Search results or they receive an error message 
indicating the server is unavailable you will need to rebuild the index by 
completing the following steps: 

1.  Open Computer Management on the Primary Server. Expand Services and 
Applications then select Indexing Service. Check the Status column for 
ENPSWork to make sure it says “Started.” If it is not running right-click 
ENPSWork and select All Tasks → Start. Check to see if users can receive 
Search results.  

2. Click Directories under ENPSWork and verify that the correct folders are 
being indexed. These folders should include the drive letters that 
corresponds to the root folders of your Wires and Archives drives and the 
folder on the ENPS WORK drive with the name of your site’s Primary Server. 

3.  Expand Services and Applications and select Internet Information 
Services (IIS) Manager → Web Sites. Right-click on the ENPS Web 
website and select Properties. Select the Home Directory tab and click the 
Configuration button.  
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You will see a list of Application Mappings. If the extensions .ida, .htw 
and .idq are not listed with the mappings shown below you will need to add 
them to the list.  

Extension Executable Path Verbs (Limit To) 

.ida C:\WINDOWS\SYSTEM32\IDQ.DLL GET, HEAD, POST 

.htw C:\WINDOWS\SYSTEM32\WEBHITS.DLL GET, HEAD, POST 

.idq C:\WINDOWS\SYSTEM32\IDQ.DLL GET, HEAD, POST 

4.  Select Internet Information Services → Web Service Extensions. There 
should be an entry for Indexing Service and it should be set to Allowed.  

 
If you cannot find this entry complete the following steps: 

a. Right-click Web Service Extensions and click Add a new Web service 
extension.  

b. In the Extension name textbox enter Indexing Service.  

c. Click Add and select the following files: 

          C:\WINDOWS\SYSTEM32\IDQ.DLL 
          C:\WINDOWS\SYSTEM32\WEBHITS.DLL  

d. Select the Set extension status to Allowed checkbox. 

5. If  users still cannot receive search or you receive an error message when 
you type a query you will need to re-index the server.  
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Depending on the amount of data the re-indexing process can take as long 
as 24 hours. In the NOM select Window → NOM Configuration/Status. 
Select the Block Primary Access checkbox. Users will see the window below 
notifying them that the Primary Server is unavailable: 

 
Users should select the option Switch to a backup system.  

6.  Run \NOM\INDEXDEL.EXE  on the ENPS WORK drive. Once you click OK on 
the confirmation screen the application will start re-indexing the server. To 
check the status of the re-indexing open Computer Management and select 
Indexing Service. 

If INDEXDEL.EXE does not function correctly complete the following steps: 

a.  Open a command prompt and run REGEDIT. 

b.  Navigate to 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ 
ContentIndex 

c.  Locate the key ISAPIDefaultCatalogDirectory. Make sure that 
Value Data is set to ENPSWork. 

d. Re-run INDEXDEL.EXE. 

7.  Once the indexes are rebuilt uncheck the Block Primary Access checkbox. 
Users will be prompted to return to the Primary Server. 

8. Run \NOM\INDEXDEL.EXE  on the Buddy Server. 

User sees the message “Unpack time [6] Overflow” 

1.  Back up the files in the client workstation’s \WINDOWS\SYSTEM32 folder. 

2. Copy the files from server’s \ENPS\WINSYS folder on the ENPS WORK drive 
into the client workstation’s \WINDOWS\SYSTEM32 folder, overwriting the 
client workstation’s copies of the files. 

3.  If the user still sees the “Unpack time [6] Overflow” message you need to re-
install the ENPS client.  

a.  Back up \Documents and Settings\All Users\Application 
Data\ENPS\ENPS.INI on the client workstation to save any custom 
settings. 

b. Delete C:\Program Files\ENPS.  

c. Open a command prompt and enter the following command:  

\\<PRIMARY SERVER NAME>\ENPS\SETUP.EXE  

 where <PRIMARY SERVER NAME> is the NetBIOS machine name or IP 
address of the Primary Server. 
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d. Overwrite \Documents and Settings\All Users\Application 
Data\ENPS\ENPS.INI with the user’s original ENPS.INI. 

User sees the message “Socket unable to complete.” 

A user’s Search parameters may be so wide that the Index Server is taking too 
long to process the request and ENPS drops the connection due to a timeout.  

The user can change the Search to contain fewer search terms or you can use 
Notepad or another text editor to modify \Documents and Settings\All 
Users\Application Data\ENPS\ENPS.INI to increase the length of the 
timeout. Increase the ReceiveTimeout setting in the [TCPIP] section to a 
larger value. The default value is 20 seconds. 

User sees the message “Socket closed by host.” 

This error is typically caused by a user entering a noise word such as “so” as one 
of the Search terms. Noise words usually do not cause a problem but sometimes 
they can cause the Index Server to ignore the search and close the socket.  

Instruct users to omit the noise word from the search or enclose the search terms 
in square brackets so that ENPS will pass the term as an exact phrase. This can 
also be done by checking the Exact Phrase checkbox in the Search dialog. 

User receives the message “Your search returned too many matches. Refine 
the search term, limit the date/time range, or choose other more specific 
search parameters.” 

It is possible that your site has exceeded the default limits for the Indexing 
Server. Complete the following steps to increase this limit: 

1.  Open the command prompt on the Primary Server and run REGEDIT.  

2. Locate the following key: 
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\ 
ContentIndex 

3.  Click on CurentControlSet to see the contents of the folder. 

4.  Open MaxRestrictionNodes. Change the Base value to Decimal. Set 
Value data to 4294967295. 

5.  Reboot the Primary Server. Repeat these steps on the Buddy Server.  

Server Synchronization 
ENPS WORK drives on Primary and Buddy servers are out of sync. 

This issue can occur for a number of reasons. For example, one of the ENPS 
servers may can lose data because of a hardware failure or a network problem 
may prevent your servers from communicating with each other for an extended 
period of time. 

You can either restore data from the Primary to the Buddy or vice-versa. The 
instructions below refer to the server with the most complete data as the “Source” 
and the server you want to update as the “Target.”  

These instructions can be completed while users are still working on the Source 
server. 
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1. On the Source server map the drive letter such as X: to the root folder of the 
Target server’s ENPS WORK drive  by opening a command prompt and 
entering the following command: 

NET USE X: \\TARGET 

where TARGET is the machine name of your Target server and path to the 
ENPS WORK drive. If you opt to use a drive letter other than X: you will need 
to modify the other steps in this section accordingly. 

2.  On the Source server move the \COMMON\BUDDY folder to the root of its 
ENPS Work drive. 

3.  The NOMBACK utility duplicates Source server data on the Target server. 
This process will also delete any files on the Target server that are not 
present on the Source server.  

Open \NOM\NOMBACK.EXE on the ENPS WORK drive of the Source server to 
run NOMBACK. 

a. De-select the Common checkbox. 

b. In the Target Path enter X: 

c. Click Go to start the NOMBACK process.  

4. When the NOMBACK process is complete copy \COMMON\G_SUPPORT 
FOLDER, usually on the F: drive, from the Source server to the same 
location on the Target server.  

5. It is recommended that you re-index the Target server. For instructions on re-
indexing your ENPS server refer to the instructions on using INDEXDEL.EXE 
on page 167. 

6. You can now delete the \COMMON\BUDDY folder that you copied to the root 
of your Source machine’s data drive. 

Stories 
User sees the message “[32364] Bad Custom Dictionary.” 

The SUPP.DIC dictionary file was created incorrectly. The file should have one 
word per line with no spaces at the end of each word. There must also be a 
carriage return after the last word in the file.  

User sees the message “EditCtrl_ExtendSelOverFields [5] Invalid procedure 
call or argument’, ‘Run time error [28 Out of stack space.” 

Make sure the story does not contain a square bracket that lacks a matching 
bracket. This can happen when story text is pasted in from another document. 
Square brackets in ENPS are restricted to production commands and must 
always come in pairs.  

User sees the message “Draw Tabs can’t create auto redraw image.” 

The resources on the client PC may be low, perhaps because there are other 
applications running at the same time as ENPS. The user should reboot the PC 
and close applications they do not need. 
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Wires 
Your site is not receiving wire stories. 

1. Verify that the cable for wires is plugged into the Primary Server. 

2. Make sure that the News Wire Profiler running on the Primary Server. If it is 
not running double-click the Watch shortcut on your desktop to start the 
server applications. Make sure there is shortcut to Watch in the server’s 
Startup folder. 

3. Open the News Wire Profiler select Window and select the wire. Verify that 
the Active box is checked. If the wire is active select the Monitor checkbox. If 
you do not see incoming data in the wire window contact the wire provider for 
an update to the wire’s programming tables. If it is an AP wire you can find 
the support number in the “Technical Support” section on page 6.  

When you contact the wire provider make sure you have your site’s NID 
number. This number can be found by opening the ENPS client and selecting 
Fourth folder rover → System Maintenance → Global Configuration 
Options. 

If your site is still not receiving wires after you update the programming table 
your wire provider may need to send a technician to your site to perform 
additional troubleshooting. 

Wire stories appear in the wrong category. 

1. Contact the wire provider for an update to the wire’s programming tables. If it 
is an AP wire you can find the support number in the “Technical Support” 
section on page 6.  

When you contact the wire provider make sure you have your site’s NID 
number. This number can be found by opening the ENPS client and selecting 
Fourth folder rover → System Maintenance → Global Configuration 
Options. 

2. If you want the wire to appear in a custom category refer to “Custom Wire 
Categories” on page 125 for instructions on how to set up the custom 
category. To configure the wire to appear in either a custom category or an 
existing category complete the following steps: 

a. Open the NWP on the Primary Server. Click Window and select the name 
of the wire.  

b. Uncheck the Active checkbox.  

c. In the Category dropdown menu select the category name. 

d. Select the Active checkbox to reactivate the wire.  
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Appendix A  
Import and Export Data 

This section describes how to import data from NewsCenter into ENPS, how to 
use the Generic Import Facility to import other archives, and how to use the 
Extract utility to export data from ENPS.  

A number of archives from other newsroom computer systems can be converted 
to work with ENPS. Contact ENPS Support for questions regarding archives from 
specific systems. You can find the ENPS Support  number in the “Technical 
Support” section on page 6. 

Import NewsCenter Archives 
Rundown archives and contacts from AP NewsCenter can be converted to ENPS 
using the NCIMPORT.EXE program in the \NOM directory on the Buddy Server. 
Archives should be placed in the corresponding directory with the Buddy Server's 
computer name (i.e., BNCENPS02). Both archives and contacts should be placed 
in the directory corresponding to the Primary Server's computer name (i.e., 
BNCENPS01) on both the Primary and Buddy servers. The conversion process 
usually takes several hours. 

System performance is not affected during archive conversion to the Buddy 
Server since users should still be working on the Primary Server. System 
performance may be affected while importing the contacts on the Primary server. 
It is advisable to do the contact conversion on the Primary server at a time when 
there is the least amount of traffic on the network. 

1.  Run NCIMPORT.EXE from the \NOM directory on the ENPS Server.  

2.  Fill in three entry fields:  

NewsCenter 
Folder 

Path to the \NewsCntr directory on the Dataserver 
such as \\dataserv\data$\newscntr 

Target Path Drive on the Primary that contains the ENPS 
installation. This should be the Archive drive (typically 
H:). This cannot be a UNC path. 

Target Database Name of the server you are running the 
NCIMPORT.EXE on (e.g. BNCENPS02). 

3.  Select what you would like to convert from NewsCenter to ENPS: Rundown 
Archives and/or Contacts. 

4.  Click Go. You will see a dialog box showing the paths for the conversion. If 
they are correct, click Yes to continue. If you notice an error you may select 
No and make the appropriate changes. If you select Yes and the paths are 
incorrect you will receive an error from NCIMPORT.EXE. At this time, you will 
have to check the paths and make the appropriate changes. 

5. The conversion process creates a folder \P_NC20. Copy this folder to the 
same location on the Buddy Server. 

6. Run \NOM\INDEXDEL.EXE on the Primary Server’s WORK drive to rebuild 
the index. Repeat this step on the Buddy Server. 
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Generic Import Facility 
The ENPS Generic Import Facility allows data from Access tables to be imported 
into ENPS database structures. Install GIF by running SETUPGIF.EXE on an 
ENPS server. It will place an icon on the desktop. 

Microsoft Access is used because it can bind or import from many types of data 
such as Microsoft Excel, Lotus 1-2-3, text files, HTML, dBase, FoxPro, Paradox, 
and ODBC databases. Also, it is possible to access Oracle data via ODBC or a 
dBase table, or do an elaborate Join. 

Any number of tables or updateable queries may be used, so the possibilities are 
endless for dynamic updates from a variety of sources. Note that by being able to 
import against queries, the underlying data structure can vary, with the query 
doing filtering and cleanup, for example.  

The following fields must be in the Access table, although the first five and 
seventh need not be filled: 

ID Description Format Sample 

GUID Should be blank and will 
be automatically updated 
with the GUID of the 
resulting record. If this 
field is not blank, it is 
assumed that record was 
already imported. This 
allows an interrupted 
import to be restarted 
without duplicate data 
being posted. 

Text, 50 
characters [blank] 

Database 
 

Must match the machine 
ID of an entry in the 
server table. GIF must be 
run on the server.  

Text, 255 
characters BNCENPS01 

Path  
 

Either P_groupname or 
U_username that will be 
validated against the 
program/group or staff 
databases respectively. 

Text, 50 
characters 
 

P_WCTRIAL or 
U_MARTIM10 

Folder  
 

ID of the subfolder where 
the data should be 
stored, excluding the F_ 
prefix. If not supplied, the 
main folder is used 

Text, 50 
characters TEST 

Owner  
 

User ID, excluding the U_ 
prefix which must validate 
against the staff 
database. 

Text, 50 
characters MARTIM10 

Title 
 

The item's title/slug, for 
which there should not be 
a field in the field 
definitions tables. 

Text, 50 
characters STORYTITLE 
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Text The item’s associated 
text (optional), for which 
there should not be a field 
in the field definitions 
tables.  

Memo 
 

Sample text 

The Database, Path, Folder and Owner settings may be specified for all records 
in the database by supplying them in the on-screen form. Additional fields must 
match IDs from the field definitions tables and will be validated, and only "story"-
related fields may be used. 

The ENPS Generic Import Facility (GIF) allows data from Microsoft Access tables 
to be imported into ENPS database structures. Microsoft Access is used to bind 
or import from many types of data (e.g., Excel, Lotus 1-2-3, text files, HTML, 
dBase, FoxPro, Paradox, and ODBC databases). Also, it is possible to access 
Oracle data via ODBC or a dBase table, or perform an elaborate Join. GIF will 
import as many matching fields as are specified and makes two passes, one to 
check the rows, and one to import. The import will not be executed unless all the 
rows pass checks. 

GIF imports as many matching fields as are specified and makes two passes, 
one to check the rows, and one to import. The import will not be executed unless 
all the rows pass checks. 

Any date fields must be in the format YYYYMMDDHHNNSS, and the time portion 
must be stated in GMT. 

Exporting ENPS Data  
Extract is a server component that allows you to transfer ENPS data to other 
applications. It resides on the same physical server as the NOM.  

An Extract process runs on the server and handles requests by clients to resolve 
queries. It allows them to export archived material in a format that can be used 
by other applications. 

To perform the extraction process, complete the following steps: 

1.  In the Search window, select your organization's content, then a date range, 
entering "from" and "to" dates. 

2.  In the server list select the CTOS (or any other server) and select All content 
or Archives. 

3.  Select the Advanced tab and the Extract button becomes visible. You can 
save the Search at this point if the task is going to be reused. 

4.  Click Extract and enter a name for the output job to dispatch the request to 
the server. 

When the extraction is complete the user will receive a Top-Line Message. With 
the message in an Editing Window the first choice on the rover will allow the user 
to copy the resulting file to a local drive for use in other applications. Extract job 
files exist on the server for approximately 24 hours. 

The file format is as follows, with fields delimited by the Tab character (x09): 

First Row  
Start Date 
End Date 
Additional rows 
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Field Name/Description 
Program Name 
Start Date 
Story Slug 
Newsgathering Grid Name 
Newsgathering Grid Piece Type 
Newsgathering Grid First Use flag (0=No, 1=Yes) 
Newsgathering Grid Live flag (0=No, 1=Yes) 
Actual (duration) 
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Appendix B 
File Structure 

Each ENPS server hosts multiple tables that can be global, server-based, user-
based, and program-based. Table structures are not defined here, as such 
information cannot be manipulated outside of ENPS. 

System Tables 
Global tables are stored in the \COMMON\G_SUPPORT directory on the Central 
Server and are replicated to all other ENPS servers as part of the Maintenance 
process. All changes, no matter what server a user is accessing while making 
changes, are made on the Central Server. The replication interval is defined as a 
Maintenance process option and defaults to 30 minutes. 

Table Description 

G_AUTOMAC Automation macros table 

G_CONFIG Global configuration table 

G_FIELDDEF System field definitions table 

G_FIELDLOC Local field definitions table  

G_LANGEN Master English resource table 

G_LANG* Other language resource tables 

G_MACS 
G_MACS.NEW 

MAC address table 

G_MOS Media Object Server table 

G_NOISE* Noise word list table 

G_PROGRAMS Program/group table 

G_SECURITY Security level table 

G_SERVERS Server list table 

G_STAFF User table 

Each group has its own tables on its home server containing stories, Rundowns, 
group messages and other group data in a directory with the same name as the 
server. A directory with a "_H" suffix holds history data (i.e., previous versions of 
public stories). NWP-related tables are stored in \COMMON\C_SUPPORT on the 
ENPS Primary Server. 

Table Description 

C_CATEGORIES NWP categories table 

C_PROVIDERS  NWP providers table 

C_CATEGORIES and C_PROVIDERS are regenerated automatically at start-up, 
based on the contents of \NWP\NWP.INI. 
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ENPS clients communicate with the appropriate server. The directories displayed 
below are local to production servers and are not replicated.  

Table Description 

S_ARCHIVE Archived data 

S_PRIV  User and program/group privileges tables 

S_SUPPORT User and program/group profiles table 

U_* User data 

P_* Program/group data 

D_* News wire story tables, by category and 
provider 

User Folders 
Each ENPS user account has its own set of folders which store items such as 
current work in progress and incoming messages.  

Folder  Description 

M Received top-line messages 

W Private, work in progress data (including stories, Rundowns, and 
other items) 

T Private deleted items/trash 

Program/Group Folders 
Each program or group has its own set of folders. Table names are generated 
from a unique program or group ID such as BNCENPS01. 

Folder  Description 

C Contacts 

G Character generator templates 

L Rundown templates and Newsgathering Grid templates 

R Report layouts 

T Public deleted items/trash 

V Stored layouts for Rundowns and Newsgathering Grids 

W Public, work in progress data (including stories, 
 Rundowns, and other items)  

X Story and grid templates 
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Appendix C 
Registry Settings 

This section lists the changes that ENPS makes to the system registry on your 
Primary Server and Buddy Server.  
HKLM\SYSTEM\CurrentControlSet\Control\contentindex  
EventLogFlags=2  
FilterDelayInterval=2  
FilterFilesWithUnknownExtensions=1 
FilterRemainingThreshold=5 
FilterRetryInterval=2 
GenerateCharacterization=1 
IsapiMaxEntriesInQueryCache=0 
IsapiMaxRecordsInResultSet=5000 
MaxCharacterization=45 
MaxFilesizeFiltered=4096 
MaxFreshCount=40000 
MaxRestrictionNodes=3000 
MaxRunningWebHits=200 
MaxWebhitsCpuTime=7200 
PropertyStoreMappedCache=varies based on available RAM  
 
HKLM\SYSTEM\CurrentControlSet\Control\FileSystem  
NtfsDisable8dot3NameCreation=1 NtfsDisableLastAccessUpdate=1 
 
HKLM\SYSTEM\CurrentControlSet\Services\Browser\Parameters  
MaintainServerList=Auto 
 
HKLM\SYSTEM\CurrentControlSet\Services\EventLog\Application  
MaxSize=1048576  
Retention=0 
 
HKLM\SYSTEM\CurrentControlSet\Services\EventLog\Security  
MaxSize=1048576  
Retention=0 
 
HKLM\SYSTEM\CurrentControlSet\Services\EventLog\System  
MaxSize=1048576  
Retention=0 
 
HKLM\SYSTEM\CurrentControlSet\Control\contentindex  
DelayUsnReadOnLowResource=0  
DesiredIndexingPerf=3  
DesiredQueryingPerf=3  
LowResourceSleep=5  
MaxWordlistIo=4294967295  
MaxWordlistIoDiskPerf=100  
ScanBackoff=0  
ServiceUsage=4  
StartupDelay=60000  
UsnReadMinSize=1  
WordListUserIdle=0 
 
HKLM\SYSTEM\CurrentControlSet\Control\Services\cisvc 
Start=2 
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